# What's the cause of this problem and what's the solution?

**URL:** <https://discuss.elastic.co/t/whats-the-cause-of-this-problem-and-whats-the-solution/315641>\
**Category:** Elasticsearch\
**Created:** [October 2, 2022, 8:59pm UTC](https://discuss.elastic.co/t/whats-the-cause-of-this-problem-and-whats-the-solution/315641 "2022-10-02T20:59:57Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![morad\_della3](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/morad_della3/32/101241_2.png) [@morad\_della3](https://discuss.elastic.co/u/morad_della3)\
**Post date:** [October 2, 2022, 8:59pm UTC](https://discuss.elastic.co/t/whats-the-cause-of-this-problem-and-whats-the-solution/315641/1 "2022-10-02T20:59:57Z")

</div>

i installed elastic and kibana 8.4.1 in ubuntu 22.04  
and when i try to do

> sudo apt update

or

> sudo apt install unzip

i get this error

```auto
E: Conflicting values set for option Signed-By regarding source https://artifacts.elastic.co/packages/8.x/apt/ stable: /usr/share/keyrings/elasticsearch-keyring.gpg !=
E: The list of sources could not be read.

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 30, 2022, 9:00pm UTC](https://discuss.elastic.co/t/whats-the-cause-of-this-problem-and-whats-the-solution/315641/2 "2022-10-30T21:00:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
