# What's the solution of this error please?

**URL:** <https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485>\
**Category:** Elasticsearch\
**Created:** [October 26, 2022, 8:32am UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485 "2022-10-26T08:32:57Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![morad\_della3](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/morad_della3/32/101241_2.png) [@morad\_della3](https://discuss.elastic.co/u/morad_della3)\
**Post date:** [October 26, 2022, 8:32am UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/1 "2022-10-26T08:32:57Z")

</div>

I don't find a solution for this error anyone help me please when I try to start elasticsearch.  
[

```auto
2022-10-26T08:13:00,690][WARN][i.n.u.i.PlatformDependent] [elastic] Failed to get the temporary directory; falling back to: /tmp
[2022-10-26T08:13:06,559][ERROR][o.e.b.Elasticsearch] [elastic] fatal exception while booting Elasticsearch
java.security.AccessControlException: access denied ("java.io.FilePermission" "/tmp" "read")
        at java.security.AccessControlContext.checkPermission(AccessControlContext.java:485) ~[?:?]
        at java.security.AccessController.checkPermission(AccessController.java:1068) ~[?:?]
        at java.lang.SecurityManager.checkPermission(SecurityManager.java:411) ~[?:?]
        at java.lang.SecurityManager.checkRead(SecurityManager.java:751) ~[?:?]
        at sun.nio.fs.UnixPath.checkRead(UnixPath.java:780) ~[?:?]
        at sun.nio.fs.UnixFileSystemProvider.checkAccess(UnixFileSystemProvider.java:294) ~[?:?]
        at java.nio.file.Files.createDirectories(Files.java:772) ~[?:?]
        at org.elasticsearch.ingest.geoip.DatabaseNodeService.initialize(DatabaseNodeService.java:150) ~[?:?]
        at org.elasticsearch.ingest.geoip.IngestGeoIpPlugin.createComponents(IngestGeoIpPlugin.java:121) ~[?:?]
        at org.elasticsearch.node.Node.lambda$new$15(Node.java:696) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.plugins.PluginsService.lambda$flatMap$0(PluginsService.java:236) ~[elasticsearch-8.4.1.jar:?]
        at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:273) ~[?:?]
        at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:197) ~[?:?]
        at java.util.AbstractList$RandomAccessSpliterator.forEachRemaining(AbstractList.java:720) ~[?:?]
        at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:509) ~[?:?]
        at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:499) ~[?:?]
        at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:575) ~[?:?]
        at java.util.stream.AbstractPipeline.evaluateToArrayNode(AbstractPipeline.java:260) ~[?:?]
        at java.util.stream.ReferencePipeline.toArray(ReferencePipeline.java:616) ~[?:?]
        at java.util.stream.ReferencePipeline.toArray(ReferencePipeline.java:622) ~[?:?]
        at java.util.stream.ReferencePipeline.toList(ReferencePipeline.java:627) ~[?:?]
        at org.elasticsearch.node.Node.<init>(Node.java:710) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.node.Node.<init>(Node.java:311) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch$2.<init>(Elasticsearch.java:214) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch.initPhase3(Elasticsearch.java:214) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:67) ~[elasticsearch-8.4.1.jar:?]

```

---

<div class="post-metadata">

**Author:** ![cheshirecat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cheshirecat/32/109532_2.png) [@cheshirecat](https://discuss.elastic.co/u/cheshirecat)\
**Post date:** [October 26, 2022, 1:42pm UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/2 "2022-10-26T13:42:52Z")

</div>

> [@morad\_della3](#):
>
> `access denied ("java.io.FilePermission" "/tmp" "read")`

The answer is in your question.

---

<div class="post-metadata">

**Author:** ![morad\_della3](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/morad_della3/32/101241_2.png) [@morad\_della3](https://discuss.elastic.co/u/morad_della3)\
**Post date:** [October 26, 2022, 7:38pm UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/3 "2022-10-26T19:38:55Z")

</div>

what's the solution bro ? you don't ive me a solution  
how to let it access ?

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [October 26, 2022, 8:21pm UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/4 "2022-10-26T20:21:01Z")

</div>

We are not all bros.... 🙂

But agree should point you in the right direction.

> **[UNIX / Linux : What is the correct permission of /tmp and /var/tmp directories...](https://www.thegeekdiary.com/unix-linux-what-is-the-correct-permission-of-tmp-and-vartmp-directories/amp/)**
>
> The /tmp and /var/tmp directories requires special permissions. This directory has Sticky Bit permissions. The t at the end symbolizes that the sticky bit is set. A file created in the /tmp directory can only be removed by its owner, or the root...

Perhaps try ...

`chmod 1777 /tmp`

---

<div class="post-metadata">

**Author:** ![morad\_della3](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/morad_della3/32/101241_2.png) [@morad\_della3](https://discuss.elastic.co/u/morad_della3)\
**Post date:** [October 26, 2022, 8:29pm UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/5 "2022-10-26T20:29:35Z")

</div>

```auto
elastic@elastic:~$ sudo cat /var/log/elasticsearch/elasticsearch.log
[2022-10-26T08:05:05,405][INFO][o.e.n.Node] [elastic] version[8.4.1], pid[1078], build[deb/2bd229c8e56650b42e40992322a76e7914258f0c/2022-08-26T12:11:43.232597118Z], OS[Linux/5.15.0-52-generic/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/18.0.2/18.0.2+9-61]
[2022-10-26T08:05:05,691][INFO][o.e.n.Node] [elastic] JVM home [/usr/share/elasticsearch/jdk], using bundled JDK [true]
[2022-10-26T08:05:05,692][INFO][o.e.n.Node] [elastic] JVM arguments [-Des.networkaddress.cache.ttl=60, -Des.networkaddress.cache.negative.ttl=10, -Djava.security.manager=allow, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j2.formatMsgNoLookups=true, -Djava.locale.providers=SPI,COMPAT, --add-opens=java.base/java.io=ALL-UNNAMED, -Xms512m, -Xmx512m, -XX:+UseG1GC, -Djava.io.tmpdir=/tmp/elasticsearch-7860567220576485458, -XX:+HeapDumpOnOutOfMemoryError, -XX:+ExitOnOutOfMemoryError, -XX:HeapDumpPath=/var/lib/elasticsearch, -XX:ErrorFile=/var/log/elasticsearch/hs_err_pid%p.log, -Xlog:gc*,gc+age=trace,safepoint:file=/var/log/elasticsearch/gc.log:utctime,pid,tags:filecount=32,filesize=64m, -XX:MaxDirectMemorySize=268435456, -XX:G1HeapRegionSize=4m, -XX:InitiatingHeapOccupancyPercent=30, -XX:G1ReservePercent=15, -Des.distribution.type=deb, --module-path=/usr/share/elasticsearch/lib, --add-modules=jdk.net, -Djdk.module.main=org.elasticsearch.server]
[2022-10-26T08:05:32,077][INFO][c.a.c.i.j.JacksonVersion] [elastic] Package versions: jackson-annotations=2.13.2, jackson-core=2.13.2, jackson-databind=2.13.2.2, jackson-dataformat-xml=2.13.2, jackson-datatype-jsr310=2.13.2, azure-core=1.27.0, Troubleshooting version conflicts: https://aka.ms/azsdk/java/dependency/troubleshoot
[2022-10-26T08:05:45,139][INFO][o.e.p.PluginsService] [elastic] loaded module [aggs-matrix-stats]
[2022-10-26T08:05:45,140][INFO][o.e.p.PluginsService] [elastic] loaded module [analysis-common]
[2022-10-26T08:05:45,140][INFO][o.e.p.PluginsService] [elastic] loaded module [constant-keyword]
[2022-10-26T08:05:45,141][INFO][o.e.p.PluginsService] [elastic] loaded module [data-streams]
[2022-10-26T08:05:45,141][INFO][o.e.p.PluginsService] [elastic] loaded module [frozen-indices]
[2022-10-26T08:05:45,142][INFO][o.e.p.PluginsService] [elastic] loaded module [ingest-attachment]
[2022-10-26T08:05:45,142][INFO][o.e.p.PluginsService] [elastic] loaded module [ingest-common]
[2022-10-26T08:05:45,143][INFO][o.e.p.PluginsService] [elastic] loaded module [ingest-geoip]
[2022-10-26T08:05:45,143][INFO][o.e.p.PluginsService] [elastic] loaded module [ingest-user-agent]
[2022-10-26T08:05:45,155][INFO][o.e.p.PluginsService] [elastic] loaded module [kibana]
[2022-10-26T08:05:45,156][INFO][o.e.p.PluginsService] [elastic] loaded module [lang-expression]
[2022-10-26T08:05:45,163][INFO][o.e.p.PluginsService] [elastic] loaded module [lang-mustache]
[2022-10-26T08:05:45,164][INFO][o.e.p.PluginsService] [elastic] loaded module [lang-painless]
[2022-10-26T08:05:45,170][INFO][o.e.p.PluginsService] [elastic] loaded module [legacy-geo]
[2022-10-26T08:05:45,171][INFO][o.e.p.PluginsService] [elastic] loaded module [mapper-extras]
[2022-10-26T08:05:45,172][INFO][o.e.p.PluginsService] [elastic] loaded module [mapper-version]
[2022-10-26T08:05:45,172][INFO][o.e.p.PluginsService] [elastic] loaded module [old-lucene-versions]
[2022-10-26T08:05:45,173][INFO][o.e.p.PluginsService] [elastic] loaded module [parent-join]
[2022-10-26T08:05:45,185][INFO][o.e.p.PluginsService] [elastic] loaded module [percolator]
[2022-10-26T08:05:45,185][INFO][o.e.p.PluginsService] [elastic] loaded module [rank-eval]
[2022-10-26T08:05:45,194][INFO][o.e.p.PluginsService] [elastic] loaded module [reindex]
[2022-10-26T08:05:45,194][INFO][o.e.p.PluginsService] [elastic] loaded module [repositories-metering-api]
[2022-10-26T08:05:45,195][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-azure]
[2022-10-26T08:05:45,196][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-encrypted]
[2022-10-26T08:05:45,196][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-gcs]
[2022-10-26T08:05:45,196][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-s3]
[2022-10-26T08:05:45,196][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-url]
[2022-10-26T08:05:45,197][INFO][o.e.p.PluginsService] [elastic] loaded module [runtime-fields-common]
[2022-10-26T08:05:45,200][INFO][o.e.p.PluginsService] [elastic] loaded module [search-business-rules]
[2022-10-26T08:05:45,202][INFO][o.e.p.PluginsService] [elastic] loaded module [searchable-snapshots]
[2022-10-26T08:05:45,202][INFO][o.e.p.PluginsService] [elastic] loaded module [snapshot-based-recoveries]
[2022-10-26T08:05:45,207][INFO][o.e.p.PluginsService] [elastic] loaded module [snapshot-repo-test-kit]
[2022-10-26T08:05:45,207][INFO][o.e.p.PluginsService] [elastic] loaded module [spatial]
[2022-10-26T08:05:45,207][INFO][o.e.p.PluginsService] [elastic] loaded module [systemd]
[2022-10-26T08:05:45,210][INFO][o.e.p.PluginsService] [elastic] loaded module [transform]
[2022-10-26T08:05:45,226][INFO][o.e.p.PluginsService] [elastic] loaded module [transport-netty4]
[2022-10-26T08:05:45,226][INFO][o.e.p.PluginsService] [elastic] loaded module [unsigned-long]
[2022-10-26T08:05:45,227][INFO][o.e.p.PluginsService] [elastic] loaded module [vector-tile]
[2022-10-26T08:05:45,227][INFO][o.e.p.PluginsService] [elastic] loaded module [wildcard]
[2022-10-26T08:05:45,234][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-aggregate-metric]
[2022-10-26T08:05:45,235][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-analytics]
[2022-10-26T08:05:45,235][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-async]
[2022-10-26T08:05:45,260][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-async-search]
[2022-10-26T08:05:45,260][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-autoscaling]
[2022-10-26T08:05:45,261][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-ccr]
[2022-10-26T08:05:45,262][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-core]
[2022-10-26T08:05:45,263][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-deprecation]
[2022-10-26T08:05:45,264][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-enrich]
[2022-10-26T08:05:45,265][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-eql]
[2022-10-26T08:05:45,274][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-fleet]
[2022-10-26T08:05:45,274][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-graph]
[2022-10-26T08:05:45,274][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-identity-provider]
[2022-10-26T08:05:45,275][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-ilm]
[2022-10-26T08:05:45,282][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-logstash]
[2022-10-26T08:05:45,291][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-ml]
[2022-10-26T08:05:45,293][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-monitoring]
[2022-10-26T08:05:45,293][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-ql]
[2022-10-26T08:05:45,306][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-rollup]
[2022-10-26T08:05:45,307][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-security]
[2022-10-26T08:05:45,308][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-shutdown]
[2022-10-26T08:05:45,338][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-sql]
[2022-10-26T08:05:45,338][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-stack]
[2022-10-26T08:05:45,339][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-text-structure]
[2022-10-26T08:05:45,339][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-voting-only-node]
[2022-10-26T08:05:45,339][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-watcher]
[2022-10-26T08:05:45,339][INFO][o.e.p.PluginsService] [elastic] no plugins loaded
[2022-10-26T08:05:49,930][WARN][i.n.u.i.PlatformDependent] [elastic] Failed to get the temporary directory; falling back to: /tmp
[2022-10-26T08:06:22,216][INFO][o.e.e.NodeEnvironment] [elastic] using [1] data paths, mounts [[/ (/dev/mapper/ubuntu--vg-ubuntu--lv)]], net usable_space [3.8gb], net total_space [23.4gb], types [ext4]
[2022-10-26T08:06:22,226][INFO][o.e.e.NodeEnvironment] [elastic] heap size [512mb], compressed ordinary object pointers [true]
[2022-10-26T08:06:24,575][INFO][o.e.n.Node] [elastic] node name [elastic], node ID [qYyl0MXKRDebGnxigtquiQ], cluster name [elasticsearch], roles [ingest, data_frozen, ml, data_hot, transform, data_content, data_warm, master, remote_cluster_client, data, data_cold]
[2022-10-26T08:07:18,912][ERROR][o.e.b.Elasticsearch] [elastic] fatal exception while booting Elasticsearch
java.io.IOException: could not remove the following files (in the order of attempts):
   /tmp/elasticsearch-13601843752466320684/empty820977285015997091tmp: java.nio.file.NoSuchFileException: /tmp/elasticsearch-13601843752466320684/empty820977285015997091tmp

        at org.elasticsearch.core.IOUtils.rm(IOUtils.java:203) ~[elasticsearch-core-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.PolicyUtil.getPolicyPermissions(PolicyUtil.java:402) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.PolicyUtil.validatePolicyPermissionsForJar(PolicyUtil.java:346) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.PolicyUtil.validatePolicyPermissions(PolicyUtil.java:362) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.PolicyUtil.getModulePolicyInfo(PolicyUtil.java:380) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.Security.getPluginAndModulePermissions(Security.java:166) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.Security.configure(Security.java:124) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:186) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:66) ~[elasticsearch-8.4.1.jar:?]
[2022-10-26T08:07:24,699][WARN][i.n.u.i.PlatformDependent] [elastic] Failed to get the temporary directory; falling back to: /tmp
[2022-10-26T08:07:32,554][ERROR][o.e.b.Elasticsearch] [elastic] fatal exception while booting Elasticsearch
java.security.AccessControlException: access denied ("java.io.FilePermission" "/tmp" "read")
        at java.security.AccessControlContext.checkPermission(AccessControlContext.java:485) ~[?:?]
        at java.security.AccessController.checkPermission(AccessController.java:1068) ~[?:?]
        at java.lang.SecurityManager.checkPermission(SecurityManager.java:411) ~[?:?]
        at java.lang.SecurityManager.checkRead(SecurityManager.java:751) ~[?:?]
        at sun.nio.fs.UnixPath.checkRead(UnixPath.java:780) ~[?:?]
        at sun.nio.fs.UnixFileSystemProvider.checkAccess(UnixFileSystemProvider.java:294) ~[?:?]
        at java.nio.file.Files.createDirectories(Files.java:772) ~[?:?]
        at org.elasticsearch.ingest.geoip.DatabaseNodeService.initialize(DatabaseNodeService.java:150) ~[?:?]
        at org.elasticsearch.ingest.geoip.IngestGeoIpPlugin.createComponents(IngestGeoIpPlugin.java:121) ~[?:?]
        at org.elasticsearch.node.Node.lambda$new$15(Node.java:696) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.plugins.PluginsService.lambda$flatMap$0(PluginsService.java:236) ~[elasticsearch-8.4.1.jar:?]
        at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:273) ~[?:?]
        at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:197) ~[?:?]
        at java.util.AbstractList$RandomAccessSpliterator.forEachRemaining(AbstractList.java:720) ~[?:?]
        at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:509) ~[?:?]
        at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:499) ~[?:?]
        at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:575) ~[?:?]
        at java.util.stream.AbstractPipeline.evaluateToArrayNode(AbstractPipeline.java:260) ~[?:?]
        at java.util.stream.ReferencePipeline.toArray(ReferencePipeline.java:616) ~[?:?]
        at java.util.stream.ReferencePipeline.toArray(ReferencePipeline.java:622) ~[?:?]
        at java.util.stream.ReferencePipeline.toList(ReferencePipeline.java:627) ~[?:?]
        at org.elasticsearch.node.Node.<init>(Node.java:710) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.node.Node.<init>(Node.java:311) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch$2.<init>(Elasticsearch.java:214) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch.initPhase3(Elasticsearch.java:214) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:67) ~[elasticsearch-8.4.1.jar:?]
[2022-10-26T08:11:46,983][INFO][o.e.n.Node] [elastic] version[8.4.1], pid[1770], build[deb/2bd229c8e56650b42e40992322a76e7914258f0c/2022-08-26T12:11:43.232597118Z], OS[Linux/5.15.0-52-generic/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/18.0.2/18.0.2+9-61]
[2022-10-26T08:11:47,077][INFO][o.e.n.Node] [elastic] JVM home [/usr/share/elasticsearch/jdk], using bundled JDK [true]
[2022-10-26T08:11:47,081][INFO][o.e.n.Node] [elastic] JVM arguments [-Des.networkaddress.cache.ttl=60, -Des.networkaddress.cache.negative.ttl=10, -Djava.security.manager=allow, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j2.formatMsgNoLookups=true, -Djava.locale.providers=SPI,COMPAT, --add-opens=java.base/java.io=ALL-UNNAMED, -Xms512m, -Xmx512m, -XX:+UseG1GC, -Djava.io.tmpdir=/tmp/elasticsearch-10084986477897366141, -XX:+HeapDumpOnOutOfMemoryError, -XX:+ExitOnOutOfMemoryError, -XX:HeapDumpPath=/var/lib/elasticsearch, -XX:ErrorFile=/var/log/elasticsearch/hs_err_pid%p.log, -Xlog:gc*,gc+age=trace,safepoint:file=/var/log/elasticsearch/gc.log:utctime,pid,tags:filecount=32,filesize=64m, -XX:MaxDirectMemorySize=268435456, -XX:G1HeapRegionSize=4m, -XX:InitiatingHeapOccupancyPercent=30, -XX:G1ReservePercent=15, -Des.distribution.type=deb, --module-path=/usr/share/elasticsearch/lib, --add-modules=jdk.net, -Djdk.module.main=org.elasticsearch.server]
[2022-10-26T08:12:05,268][INFO][c.a.c.i.j.JacksonVersion] [elastic] Package versions: jackson-annotations=2.13.2, jackson-core=2.13.2, jackson-databind=2.13.2.2, jackson-dataformat-xml=2.13.2, jackson-datatype-jsr310=2.13.2, azure-core=1.27.0, Troubleshooting version conflicts: https://aka.ms/azsdk/java/dependency/troubleshoot
[2022-10-26T08:12:15,903][INFO][o.e.p.PluginsService] [elastic] loaded module [aggs-matrix-stats]
[2022-10-26T08:12:15,907][INFO][o.e.p.PluginsService] [elastic] loaded module [analysis-common]
[2022-10-26T08:12:15,908][INFO][o.e.p.PluginsService] [elastic] loaded module [constant-keyword]
[2022-10-26T08:12:15,910][INFO][o.e.p.PluginsService] [elastic] loaded module [data-streams]
[2022-10-26T08:12:15,912][INFO][o.e.p.PluginsService] [elastic] loaded module [frozen-indices]
[2022-10-26T08:12:15,914][INFO][o.e.p.PluginsService] [elastic] loaded module [ingest-attachment]
[2022-10-26T08:12:15,915][INFO][o.e.p.PluginsService] [elastic] loaded module [ingest-common]
[2022-10-26T08:12:15,916][INFO][o.e.p.PluginsService] [elastic] loaded module [ingest-geoip]
[2022-10-26T08:12:15,917][INFO][o.e.p.PluginsService] [elastic] loaded module [ingest-user-agent]
[2022-10-26T08:12:15,921][INFO][o.e.p.PluginsService] [elastic] loaded module [kibana]
[2022-10-26T08:12:15,922][INFO][o.e.p.PluginsService] [elastic] loaded module [lang-expression]
[2022-10-26T08:12:15,925][INFO][o.e.p.PluginsService] [elastic] loaded module [lang-mustache]
[2022-10-26T08:12:15,926][INFO][o.e.p.PluginsService] [elastic] loaded module [lang-painless]
[2022-10-26T08:12:15,927][INFO][o.e.p.PluginsService] [elastic] loaded module [legacy-geo]
[2022-10-26T08:12:15,927][INFO][o.e.p.PluginsService] [elastic] loaded module [mapper-extras]
[2022-10-26T08:12:15,929][INFO][o.e.p.PluginsService] [elastic] loaded module [mapper-version]
[2022-10-26T08:12:15,931][INFO][o.e.p.PluginsService] [elastic] loaded module [old-lucene-versions]
[2022-10-26T08:12:15,934][INFO][o.e.p.PluginsService] [elastic] loaded module [parent-join]
[2022-10-26T08:12:15,934][INFO][o.e.p.PluginsService] [elastic] loaded module [percolator]
[2022-10-26T08:12:15,935][INFO][o.e.p.PluginsService] [elastic] loaded module [rank-eval]
[2022-10-26T08:12:15,936][INFO][o.e.p.PluginsService] [elastic] loaded module [reindex]
[2022-10-26T08:12:15,938][INFO][o.e.p.PluginsService] [elastic] loaded module [repositories-metering-api]
[2022-10-26T08:12:15,939][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-azure]
[2022-10-26T08:12:15,940][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-encrypted]
[2022-10-26T08:12:15,940][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-gcs]
[2022-10-26T08:12:15,943][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-s3]
[2022-10-26T08:12:15,944][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-url]
[2022-10-26T08:12:15,944][INFO][o.e.p.PluginsService] [elastic] loaded module [runtime-fields-common]
[2022-10-26T08:12:15,945][INFO][o.e.p.PluginsService] [elastic] loaded module [search-business-rules]
[2022-10-26T08:12:15,946][INFO][o.e.p.PluginsService] [elastic] loaded module [searchable-snapshots]
[2022-10-26T08:12:15,947][INFO][o.e.p.PluginsService] [elastic] loaded module [snapshot-based-recoveries]
[2022-10-26T08:12:15,950][INFO][o.e.p.PluginsService] [elastic] loaded module [snapshot-repo-test-kit]
[2022-10-26T08:12:15,951][INFO][o.e.p.PluginsService] [elastic] loaded module [spatial]
[2022-10-26T08:12:15,953][INFO][o.e.p.PluginsService] [elastic] loaded module [systemd]
[2022-10-26T08:12:15,954][INFO][o.e.p.PluginsService] [elastic] loaded module [transform]
[2022-10-26T08:12:15,955][INFO][o.e.p.PluginsService] [elastic] loaded module [transport-netty4]
[2022-10-26T08:12:15,956][INFO][o.e.p.PluginsService] [elastic] loaded module [unsigned-long]
[2022-10-26T08:12:15,957][INFO][o.e.p.PluginsService] [elastic] loaded module [vector-tile]
[2022-10-26T08:12:15,957][INFO][o.e.p.PluginsService] [elastic] loaded module [wildcard]
[2022-10-26T08:12:15,964][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-aggregate-metric]
[2022-10-26T08:12:15,965][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-analytics]
[2022-10-26T08:12:15,966][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-async]
[2022-10-26T08:12:15,967][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-async-search]
[2022-10-26T08:12:15,968][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-autoscaling]
[2022-10-26T08:12:15,969][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-ccr]
[2022-10-26T08:12:15,972][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-core]
[2022-10-26T08:12:15,972][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-deprecation]
[2022-10-26T08:12:15,977][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-enrich]
[2022-10-26T08:12:15,979][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-eql]
[2022-10-26T08:12:15,979][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-fleet]
[2022-10-26T08:12:15,980][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-graph]
[2022-10-26T08:12:15,980][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-identity-provider]
[2022-10-26T08:12:15,981][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-ilm]
[2022-10-26T08:12:15,981][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-logstash]
[2022-10-26T08:12:15,983][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-ml]
[2022-10-26T08:12:15,987][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-monitoring]
[2022-10-26T08:12:15,989][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-ql]
[2022-10-26T08:12:15,990][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-rollup]
[2022-10-26T08:12:15,991][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-security]
[2022-10-26T08:12:15,993][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-shutdown]
[2022-10-26T08:12:16,017][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-sql]
[2022-10-26T08:12:16,021][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-stack]
[2022-10-26T08:12:16,023][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-text-structure]
[2022-10-26T08:12:16,024][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-voting-only-node]
[2022-10-26T08:12:16,025][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-watcher]
[2022-10-26T08:12:16,028][INFO][o.e.p.PluginsService] [elastic] no plugins loaded
[2022-10-26T08:12:42,693][INFO][o.e.e.NodeEnvironment] [elastic] using [1] data paths, mounts [[/ (/dev/mapper/ubuntu--vg-ubuntu--lv)]], net usable_space [3.8gb], net total_space [23.4gb], types [ext4]
[2022-10-26T08:12:42,696][INFO][o.e.e.NodeEnvironment] [elastic] heap size [512mb], compressed ordinary object pointers [true]
[2022-10-26T08:12:43,338][INFO][o.e.n.Node] [elastic] node name [elastic], node ID [qYyl0MXKRDebGnxigtquiQ], cluster name [elasticsearch], roles [ingest, data_frozen, ml, data_hot, transform, data_content, data_warm, master, remote_cluster_client, data, data_cold]
[2022-10-26T08:13:00,690][WARN][i.n.u.i.PlatformDependent] [elastic] Failed to get the temporary directory; falling back to: /tmp
[2022-10-26T08:13:06,559][ERROR][o.e.b.Elasticsearch] [elastic] fatal exception while booting Elasticsearch
java.security.AccessControlException: access denied ("java.io.FilePermission" "/tmp" "read")
        at java.security.AccessControlContext.checkPermission(AccessControlContext.java:485) ~[?:?]
        at java.security.AccessController.checkPermission(AccessController.java:1068) ~[?:?]
        at java.lang.SecurityManager.checkPermission(SecurityManager.java:411) ~[?:?]
        at java.lang.SecurityManager.checkRead(SecurityManager.java:751) ~[?:?]
        at sun.nio.fs.UnixPath.checkRead(UnixPath.java:780) ~[?:?]
        at sun.nio.fs.UnixFileSystemProvider.checkAccess(UnixFileSystemProvider.java:294) ~[?:?]
        at java.nio.file.Files.createDirectories(Files.java:772) ~[?:?]
        at org.elasticsearch.ingest.geoip.DatabaseNodeService.initialize(DatabaseNodeService.java:150) ~[?:?]
        at org.elasticsearch.ingest.geoip.IngestGeoIpPlugin.createComponents(IngestGeoIpPlugin.java:121) ~[?:?]
        at org.elasticsearch.node.Node.lambda$new$15(Node.java:696) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.plugins.PluginsService.lambda$flatMap$0(PluginsService.java:236) ~[elasticsearch-8.4.1.jar:?]
        at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:273) ~[?:?]
        at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:197) ~[?:?]
        at java.util.AbstractList$RandomAccessSpliterator.forEachRemaining(AbstractList.java:720) ~[?:?]
        at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:509) ~[?:?]
        at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:499) ~[?:?]
        at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:575) ~[?:?]
        at java.util.stream.AbstractPipeline.evaluateToArrayNode(AbstractPipeline.java:260) ~[?:?]
        at java.util.stream.ReferencePipeline.toArray(ReferencePipeline.java:616) ~[?:?]
        at java.util.stream.ReferencePipeline.toArray(ReferencePipeline.java:622) ~[?:?]
        at java.util.stream.ReferencePipeline.toList(ReferencePipeline.java:627) ~[?:?]
        at org.elasticsearch.node.Node.<init>(Node.java:710) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.node.Node.<init>(Node.java:311) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch$2.<init>(Elasticsearch.java:214) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch.initPhase3(Elasticsearch.java:214) ~[elasticsearch-8.4.1.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:67) ~[elasticsearch-8.4.1.jar:?]
[2022-10-26T09:20:24,539][INFO][o.e.n.Node] [elastic] version[8.4.1], pid[4906], build[deb/2bd229c8e56650b42e40992322a76e7914258f0c/2022-08-26T12:11:43.232597118Z], OS[Linux/5.15.0-52-generic/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/18.0.2/18.0.2+9-61]
[2022-10-26T09:20:24,588][INFO][o.e.n.Node] [elastic] JVM home [/usr/share/elasticsearch/jdk], using bundled JDK [true]
[2022-10-26T09:20:24,590][INFO][o.e.n.Node] [elastic] JVM arguments [-Des.networkaddress.cache.ttl=60, -Des.networkaddress.cache.negative.ttl=10, -Djava.security.manager=allow, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j2.formatMsgNoLookups=true, -Djava.locale.providers=SPI,COMPAT, --add-opens=java.base/java.io=ALL-UNNAMED, -Xms512m, -Xmx512m, -XX:+UseG1GC, -Djava.io.tmpdir=/tmp/elasticsearch-6930780148924417883, -XX:+HeapDumpOnOutOfMemoryError, -XX:+ExitOnOutOfMemoryError, -XX:HeapDumpPath=/var/lib/elasticsearch, -XX:ErrorFile=/var/log/elasticsearch/hs_err_pid%p.log, -Xlog:gc*,gc+age=trace,safepoint:file=/var/log/elasticsearch/gc.log:utctime,pid,tags:filecount=32,filesize=64m, -XX:MaxDirectMemorySize=268435456, -XX:G1HeapRegionSize=4m, -XX:InitiatingHeapOccupancyPercent=30, -XX:G1ReservePercent=15, -Des.distribution.type=deb, --module-path=/usr/share/elasticsearch/lib, --add-modules=jdk.net, -Djdk.module.main=org.elasticsearch.server]
[2022-10-26T09:20:39,960][INFO][c.a.c.i.j.JacksonVersion] [elastic] Package versions: jackson-annotations=2.13.2, jackson-core=2.13.2, jackson-databind=2.13.2.2, jackson-dataformat-xml=2.13.2, jackson-datatype-jsr310=2.13.2, azure-core=1.27.0, Troubleshooting version conflicts: https://aka.ms/azsdk/java/dependency/troubleshoot
[2022-10-26T09:20:54,655][INFO][o.e.p.PluginsService] [elastic] loaded module [aggs-matrix-stats]
[2022-10-26T09:20:54,659][INFO][o.e.p.PluginsService] [elastic] loaded module [analysis-common]
[2022-10-26T09:20:54,661][INFO][o.e.p.PluginsService] [elastic] loaded module [constant-keyword]
[2022-10-26T09:20:54,664][INFO][o.e.p.PluginsService] [elastic] loaded module [data-streams]
[2022-10-26T09:20:54,667][INFO][o.e.p.PluginsService] [elastic] loaded module [frozen-indices]
[2022-10-26T09:20:54,671][INFO][o.e.p.PluginsService] [elastic] loaded module [ingest-attachment]
[2022-10-26T09:20:54,672][INFO][o.e.p.PluginsService] [elastic] loaded module [ingest-common]
[2022-10-26T09:20:54,676][INFO][o.e.p.PluginsService] [elastic] loaded module [ingest-geoip]
[2022-10-26T09:20:54,679][INFO][o.e.p.PluginsService] [elastic] loaded module [ingest-user-agent]
[2022-10-26T09:20:54,681][INFO][o.e.p.PluginsService] [elastic] loaded module [kibana]
[2022-10-26T09:20:54,682][INFO][o.e.p.PluginsService] [elastic] loaded module [lang-expression]
[2022-10-26T09:20:54,685][INFO][o.e.p.PluginsService] [elastic] loaded module [lang-mustache]
[2022-10-26T09:20:54,689][INFO][o.e.p.PluginsService] [elastic] loaded module [lang-painless]
[2022-10-26T09:20:54,690][INFO][o.e.p.PluginsService] [elastic] loaded module [legacy-geo]
[2022-10-26T09:20:54,694][INFO][o.e.p.PluginsService] [elastic] loaded module [mapper-extras]
[2022-10-26T09:20:54,700][INFO][o.e.p.PluginsService] [elastic] loaded module [mapper-version]
[2022-10-26T09:20:54,701][INFO][o.e.p.PluginsService] [elastic] loaded module [old-lucene-versions]
[2022-10-26T09:20:54,705][INFO][o.e.p.PluginsService] [elastic] loaded module [parent-join]
[2022-10-26T09:20:54,708][INFO][o.e.p.PluginsService] [elastic] loaded module [percolator]
[2022-10-26T09:20:54,711][INFO][o.e.p.PluginsService] [elastic] loaded module [rank-eval]
[2022-10-26T09:20:54,713][INFO][o.e.p.PluginsService] [elastic] loaded module [reindex]
[2022-10-26T09:20:54,715][INFO][o.e.p.PluginsService] [elastic] loaded module [repositories-metering-api]
[2022-10-26T09:20:54,717][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-azure]
[2022-10-26T09:20:54,721][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-encrypted]
[2022-10-26T09:20:54,722][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-gcs]
[2022-10-26T09:20:54,726][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-s3]
[2022-10-26T09:20:54,729][INFO][o.e.p.PluginsService] [elastic] loaded module [repository-url]
[2022-10-26T09:20:54,730][INFO][o.e.p.PluginsService] [elastic] loaded module [runtime-fields-common]
[2022-10-26T09:20:54,733][INFO][o.e.p.PluginsService] [elastic] loaded module [search-business-rules]
[2022-10-26T09:20:54,735][INFO][o.e.p.PluginsService] [elastic] loaded module [searchable-snapshots]
[2022-10-26T09:20:54,738][INFO][o.e.p.PluginsService] [elastic] loaded module [snapshot-based-recoveries]
[2022-10-26T09:20:54,739][INFO][o.e.p.PluginsService] [elastic] loaded module [snapshot-repo-test-kit]
[2022-10-26T09:20:54,742][INFO][o.e.p.PluginsService] [elastic] loaded module [spatial]
[2022-10-26T09:20:54,744][INFO][o.e.p.PluginsService] [elastic] loaded module [systemd]
[2022-10-26T09:20:54,745][INFO][o.e.p.PluginsService] [elastic] loaded module [transform]
[2022-10-26T09:20:54,748][INFO][o.e.p.PluginsService] [elastic] loaded module [transport-netty4]
[2022-10-26T09:20:54,751][INFO][o.e.p.PluginsService] [elastic] loaded module [unsigned-long]
[2022-10-26T09:20:54,754][INFO][o.e.p.PluginsService] [elastic] loaded module [vector-tile]
[2022-10-26T09:20:54,756][INFO][o.e.p.PluginsService] [elastic] loaded module [wildcard]
[2022-10-26T09:20:54,758][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-aggregate-metric]
[2022-10-26T09:20:54,762][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-analytics]
[2022-10-26T09:20:54,763][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-async]
[2022-10-26T09:20:54,766][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-async-search]
[2022-10-26T09:20:54,769][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-autoscaling]
[2022-10-26T09:20:54,773][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-ccr]
[2022-10-26T09:20:54,776][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-core]
[2022-10-26T09:20:54,778][INFO][o.e.p.PluginsService] [elastic] loaded module [x-pack-deprecation]

```

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [October 26, 2022, 8:45pm UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/6 "2022-10-26T20:45:13Z")

</div>

Can you show the lines before that in the logs from the beginning of the start up.

In short, it's trying to use the tmp directory to download the geoip database.

Exactly How are you starting elasticsearch

How did you install a elasticsearch?

You are so might try cleaning out the /tmp If there's anything elasticsearch related

---

<div class="post-metadata">

**Author:** ![morad\_della3](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/morad_della3/32/101241_2.png) [@morad\_della3](https://discuss.elastic.co/u/morad_della3)\
**Post date:** [October 26, 2022, 8:59pm UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/7 "2022-10-26T20:59:04Z")

</div>

> [@stephenb](#):
>
> Exactly How are you starting elasticsearch

sudo systemctl start elasticsearch.service

> [@stephenb](#):
>
> How did you install a elasticsearch?

from the installing document of debian because I install it in ubuntu server 22.04 and elastic version 8.4.1

---

<div class="post-metadata">

**Author:** ![morad\_della3](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/morad_della3/32/101241_2.png) [@morad\_della3](https://discuss.elastic.co/u/morad_della3)\
**Post date:** [October 26, 2022, 9:00pm UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/8 "2022-10-26T21:00:18Z")

</div>

> [@stephenb](#):
>
> You are so might try cleaning out the /tmp If there's anything elasticsearch related

```auto
elastic@elastic:~$ cd /tmp/
elastic@elastic:/tmp$ ls
hsperfdata_logstash systemd-private-9028fdea0ed04af7975b9bb8b81f0e0e-systemd-logind.service-T50ktD
snap.lxd systemd-private-9028fdea0ed04af7975b9bb8b81f0e0e-systemd-resolved.service-eWUVc7
systemd-private-9028fdea0ed04af7975b9bb8b81f0e0e-kibana.service-v64OhX systemd-private-9028fdea0ed04af7975b9bb8b81f0e0e-systemd-timesyncd.service-fVmp0o
systemd-private-9028fdea0ed04af7975b9bb8b81f0e0e-ModemManager.service-gkVpoA vmware-root_685-4013788754

```

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [October 26, 2022, 9:00pm UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/9 "2022-10-26T21:00:22Z")

</div>

So can you show the logs from startup?

to me looks like something is not correct with your /tmp directory... perhaps consult your linux admin?

---

<div class="post-metadata">

**Author:** ![morad\_della3](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/morad_della3/32/101241_2.png) [@morad\_della3](https://discuss.elastic.co/u/morad_della3)\
**Post date:** [October 26, 2022, 9:04pm UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/10 "2022-10-26T21:04:11Z")

</div>

> [@stephenb](#):
>
> So can you show the logs from startup?

```auto
elastic@elastic:~$ journalctl -b
oct. 26 19:51:20 elastic kernel: Linux version 5.15.0-52-generic (buildd@lcy02-amd64-032) (gcc (Ubuntu 11.2.0-19ubuntu1) 11.2.0, GNU ld (GNU Binutils for Ubuntu) 2.38)>
oct. 26 19:51:20 elastic kernel: Command line: BOOT_IMAGE=/vmlinuz-5.15.0-52-generic root=/dev/mapper/ubuntu--vg-ubuntu--lv ro
oct. 26 19:51:20 elastic kernel: KERNEL supported cpus:
oct. 26 19:51:20 elastic kernel: Intel GenuineIntel
oct. 26 19:51:20 elastic kernel: AMD AuthenticAMD
oct. 26 19:51:20 elastic kernel: Hygon HygonGenuine
oct. 26 19:51:20 elastic kernel: Centaur CentaurHauls
oct. 26 19:51:20 elastic kernel: zhaoxin Shanghai
oct. 26 19:51:20 elastic kernel: Disabled fast string operations
oct. 26 19:51:20 elastic kernel: x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating point registers'
oct. 26 19:51:20 elastic kernel: x86/fpu: Supporting XSAVE feature 0x002: 'SSE registers'
oct. 26 19:51:20 elastic kernel: x86/fpu: Supporting XSAVE feature 0x004: 'AVX registers'
oct. 26 19:51:20 elastic kernel: x86/fpu: xstate_offset[2]: 576, xstate_sizes[2]: 256
oct. 26 19:51:20 elastic kernel: x86/fpu: Enabled xstate features 0x7, context size is 832 bytes, using 'standard' format.
oct. 26 19:51:20 elastic kernel: signal: max sigframe size: 1776
oct. 26 19:51:20 elastic kernel: BIOS-provided physical RAM map:
oct. 26 19:51:20 elastic kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009e7ff] usable
oct. 26 19:51:20 elastic kernel: BIOS-e820: [mem 0x000000000009e800-0x000000000009ffff] reserved
oct. 26 19:51:20 elastic kernel: BIOS-e820: [mem 0x00000000000dc000-0x00000000000fffff] reserved
oct. 26 19:51:20 elastic kernel: BIOS-e820: [mem 0x0000000000100000-0x00000000bfedffff] usable
oct. 26 19:51:20 elastic kernel: BIOS-e820: [mem 0x00000000bfee0000-0x00000000bfefefff] ACPI data
oct. 26 19:51:20 elastic kernel: BIOS-e820: [mem 0x00000000bfeff000-0x00000000bfefffff] ACPI NVS
oct. 26 19:51:20 elastic kernel: BIOS-e820: [mem 0x00000000bff00000-0x00000000bfffffff] usable
oct. 26 19:51:20 elastic kernel: BIOS-e820: [mem 0x00000000f0000000-0x00000000f7ffffff] reserved
oct. 26 19:51:20 elastic kernel: BIOS-e820: [mem 0x00000000fec00000-0x00000000fec0ffff] reserved
oct. 26 19:51:20 elastic kernel: BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
oct. 26 19:51:20 elastic kernel: BIOS-e820: [mem 0x00000000fffe0000-0x00000000ffffffff] reserved
oct. 26 19:51:20 elastic kernel: NX (Execute Disable) protection: active
oct. 26 19:51:20 elastic kernel: SMBIOS 2.7 present.
oct. 26 19:51:20 elastic kernel: DMI: VMware, Inc. VMware Virtual Platform/440BX Desktop Reference Platform, BIOS 6.00 11/12/2020
oct. 26 19:51:20 elastic kernel: vmware: hypercall mode: 0x02
oct. 26 19:51:20 elastic kernel: Hypervisor detected: VMware
oct. 26 19:51:20 elastic kernel: vmware: TSC freq read from hypervisor : 1995.380 MHz
oct. 26 19:51:20 elastic kernel: vmware: Host bus clock speed read from hypervisor : 66000000 Hz
oct. 26 19:51:20 elastic kernel: vmware: using clock offset of 17284024581 ns
oct. 26 19:51:20 elastic kernel: tsc: Detected 1995.380 MHz processor
oct. 26 19:51:20 elastic kernel: e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
oct. 26 19:51:20 elastic kernel: e820: remove [mem 0x000a0000-0x000fffff] usable
oct. 26 19:51:20 elastic kernel: last_pfn = 0xc0000 max_arch_pfn = 0x400000000
oct. 26 19:51:20 elastic kernel: x86/PAT: Configuration [0-7]: WB WC UC- UC WB WP UC- WT
oct. 26 19:51:20 elastic kernel: total RAM covered: 3072M
oct. 26 19:51:20 elastic kernel: Found optimal setting for mtrr clean up
oct. 26 19:51:20 elastic kernel: gran_size: 64K chunk_size: 64K num_reg: 2 lose cover RAM: 0G

```

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [October 26, 2022, 11:59pm UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/11 "2022-10-26T23:59:28Z")

</div>

first you should run

```auto
cd /tmp
ls -la

```

That will show the permissions

This is the correct `journalctl` command per the [docs] ([Install Elasticsearch with Debian Package | Elasticsearch Guide [8.4] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/deb.html#deb-running-systemd)) the logs you provided aren't the correct ones.  
`sudo journalctl --unit elasticsearch`

Not sure how much I will be able to help this is something to do with your `/tmp` filesystem

You might try uninstall clean everything and re-install

---

<div class="post-metadata">

**Author:** ![cheshirecat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cheshirecat/32/109532_2.png) [@cheshirecat](https://discuss.elastic.co/u/cheshirecat)\
**Post date:** [October 27, 2022, 10:40am UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/12 "2022-10-27T10:40:00Z")

</div>

> [@stephenb](#):
>
> chmod 1777 /tmp

Don't do that at any circumstances. This is the best way to blow up your system by a single user.  
Permissions for such directory should be set like this:

```auto
chmod -R 755 /tmp

```

Is your Elasticsearch instance run by root? If so you should check ownership with command:

```auto
ls -lah

```

Result shoud be like this:

```auto
-rw-r--r-- 1 krzysztof krzysztof 280 08-23 16:44 test

```

if your group/owner is not same as user that runs Elasticsearch (for example root) you should change it with a command:

```auto
chown -R root:root /tmp

```

Ps.  
We are not bros.

---

<div class="post-metadata">

**Author:** ![morad\_della3](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/morad_della3/32/101241_2.png) [@morad\_della3](https://discuss.elastic.co/u/morad_della3)\
**Post date:** [October 30, 2022, 8:59pm UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/13 "2022-10-30T20:59:42Z")

</div>

> [@cheshirecat](#):
>
> ```auto
> -rw-r--r-- 1 krzysztof krzysztof 280 08-23 16:44 test
> 
> ```

the result like that :  
elastic@elastic:/tmp$ ls -lah  
total 60K

```auto
drwxr-xr-x 15 root root 4,0K oct. 30 20:58 .
drwxr-xr-x 20 root root 4,0K oct. 3 21:08 ..
drwxr-xr-x 2 root root 4,0K oct. 26 19:51 .font-unix
drwxr-xr-x 2 998 999 4,0K oct. 26 21:06 hsperfdata_logstash
drwxr-xr-x 2 root root 4,0K oct. 26 19:51 .ICE-unix
drwxr-xr-x 3 root root 4,0K oct. 26 19:52 snap.lxd
drwx------ 3 root root 4,0K oct. 30 20:58 systemd-private-9028fdea0ed04af7975b
drwxr-xr-x 3 root root 4,0K oct. 26 19:51 systemd-private-9028fdea0ed04af7975b
drwxr-xr-x 3 root root 4,0K oct. 26 19:51 systemd-private-9028fdea0ed04af7975b
drwxr-xr-x 3 root root 4,0K oct. 26 19:51 systemd-private-9028fdea0ed04af7975b
drwxr-xr-x 3 root root 4,0K oct. 26 19:51 systemd-private-9028fdea0ed04af7975b
drwxr-xr-x 2 root root 4,0K oct. 26 19:51 .Test-unix
drwxr-xr-x 2 root root 4,0K oct. 26 19:51 vmware-root_685-4013788754
drwxr-xr-x 2 root root 4,0K oct. 26 19:51 .X11-unix
drwxr-xr-x 2 root root 4,0K oct. 26 19:51 .XIM-unix

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 27, 2022, 9:00pm UTC](https://discuss.elastic.co/t/whats-the-solution-of-this-error-please/317485/14 "2022-11-27T21:00:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
