# When Removing default path settings elasticsearch fails starting

**URL:** https://discuss.elastic.co/t/when-removing-default-path-settings-elasticsearch-fails-starting/128881
**Category:** Elasticsearch
**Created:** [April 20, 2018, 1:06pm UTC](https://discuss.elastic.co/t/when-removing-default-path-settings-elasticsearch-fails-starting/128881 "2018-04-20T13:06:28Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![souf\_el\_badraoui](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/souf_el_badraoui/32/47746_2.png) [@souf\_el\_badraoui](https://discuss.elastic.co/u/souf_el_badraoui)
#### Post date: [April 20, 2018, 1:06pm UTC](https://discuss.elastic.co/t/when-removing-default-path-settings-elasticsearch-fails-starting/128881/1 "2018-04-20T13:06:28Z")

</div>

Hello,  
I want to upgrade my 5.6.5 ES cluster to v6.2 using the Upgrade Assistant and i get an error that states

> ```
> Default path settings are removed
> This issue must be resolved to upgrade. Read Documentation
> 
> ```

but i already have path.data and path.logs set in my elasticsearch.yml file :

> ```
> path.data: /var/lib/elasticsearch
> path.logs: /var/log/elasticsearch 
> 
> ```

So i try to remove default path settings in /usr/lib/systemd/system/elasticsearch.service:

> -Edefault.path.logs=${LOG\_DIR}   
> -Edefault.path.data=${DATA\_DIR} \

but after that when i try to start ES using systemctl it fails whit the following error and no logs written:

> ```
> Exception in thread "main" org.elasticsearch.bootstrap.BootstrapException: java.nio.file.NoSuchFileException: /usr/share/elasticsearch/config
> Likely root cause: java.nio.file.NoSuchFileException: /usr/share/elasticsearch/config
> at sun.nio.fs.UnixException.translateToIOException(UnixException.java:86)
> at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)
> at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)
> at sun.nio.fs.UnixFileAttributeViews$Basic.readAttributes(UnixFileAttributeViews.java:55)
> at sun.nio.fs.UnixFileSystemProvider.readAttributes(UnixFileSystemProvider.java:144)
> at sun.nio.fs.LinuxFileSystemProvider.readAttributes(LinuxFileSystemProvider.java:99)
> at java.nio.file.Files.readAttributes(Files.java:1737)
> at java.nio.file.FileTreeWalker.getAttributes(FileTreeWalker.java:225)
> at java.nio.file.FileTreeWalker.visit(FileTreeWalker.java:276)
> at java.nio.file.FileTreeWalker.walk(FileTreeWalker.java:322)
> at java.nio.file.Files.walkFileTree(Files.java:2662)
> at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:100)
> at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:83)
> at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:299)
> at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121)
> at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112)
> at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54)
> at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)
> at org.elasticsearch.cli.Command.main(Command.java:88)
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)
> 
> ```

```
Refer to the log for complete error details.

```

Can you help please !

---

<div class="post-metadata">

### Author: ![souf\_el\_badraoui](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/souf_el_badraoui/32/47746_2.png) [@souf\_el\_badraoui](https://discuss.elastic.co/u/souf_el_badraoui)
#### Post date: [April 23, 2018, 7:06am UTC](https://discuss.elastic.co/t/when-removing-default-path-settings-elasticsearch-fails-starting/128881/2 "2018-04-23T07:06:48Z")

</div>

Hello guys,  
Any idea how to resolve this error ?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 21, 2018, 7:06am UTC](https://discuss.elastic.co/t/when-removing-default-path-settings-elasticsearch-fails-starting/128881/3 "2018-05-21T07:06:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
