# When using the graph function in kibana, the fielddata error is reported, and the fielddata needs to be changed to ture

**URL:** <https://discuss.elastic.co/t/when-using-the-graph-function-in-kibana-the-fielddata-error-is-reported-and-the-fielddata-needs-to-be-changed-to-ture/190031>\
**Category:** Kibana\
**Tags:** elastic-stack-graph\
**Created:** [July 11, 2019, 1:58pm UTC](https://discuss.elastic.co/t/when-using-the-graph-function-in-kibana-the-fielddata-error-is-reported-and-the-fielddata-needs-to-be-changed-to-ture/190031 "2019-07-11T13:58:14Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![sky810675](https://avatars.discourse-cdn.com/v4/letter/s/f19dbf/32.png) [@sky810675](https://discuss.elastic.co/u/sky810675)\
**Post date:** [July 11, 2019, 1:58pm UTC](https://discuss.elastic.co/t/when-using-the-graph-function-in-kibana-the-fielddata-error-is-reported-and-the-fielddata-needs-to-be-changed-to-ture/190031/1 "2019-07-11T13:58:14Z")

</div>

Hi guys,

I am new to Kibana, have data loaded into elasticsearch 7.1.1 and using the graph function in kibana 7.1.1 to visualize for connection graph. I want to get like this picture.

 ![kibana](https://us1.discourse-cdn.com/elastic/original/3X/a/c/acd0ff1463a8ef3358fdbfe4eb5cbda448b4da2c.png)

But I get the error message:

```
Error 400 Bad Request: Fielddata is disabled on text fields by default. Set fielddata=true on [host] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a …

```

I refer to the official website solution

```
PUT my_index/_mapping/my_type {
  "properties": {
     "my_field": { 
     "type": "text", 
    "fielddata": true 
   }
 } 
}

```

Then I got another error.

```
 {
   "error": {
         "root_cause": [
            {
          "type": "illegal_argument_exception",
          "reason": "Types cannot be provided in put mapping requests, unless the include_type_name parameter is set to true."
            }
           ],
          "type": "illegal_argument_exception",
          "reason": "Types cannot be provided in put mapping requests, unless the include_type_name parameter is set to true."
        },
    "status": 400
}

```

How can I do? Thanks.

---

<div class="post-metadata">

**Author:** ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)\
**Post date:** [July 18, 2019, 11:20am UTC](https://discuss.elastic.co/t/when-using-the-graph-function-in-kibana-the-fielddata-error-is-reported-and-the-fielddata-needs-to-be-changed-to-ture/190031/2 "2019-07-18T11:20:14Z")

</div>

Try to remove the "type" from the mapping request.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 15, 2019, 11:29am UTC](https://discuss.elastic.co/t/when-using-the-graph-function-in-kibana-the-fielddata-error-is-reported-and-the-fielddata-needs-to-be-changed-to-ture/190031/3 "2019-08-15T11:29:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
