# While configuring the elastic search cluster with two elk nodes. i am getting the error

**URL:** <https://discuss.elastic.co/t/while-configuring-the-elastic-search-cluster-with-two-elk-nodes-i-am-getting-the-error/349947>\
**Category:** Elasticsearch\
**Created:** [December 26, 2023, 11:23am UTC](https://discuss.elastic.co/t/while-configuring-the-elastic-search-cluster-with-two-elk-nodes-i-am-getting-the-error/349947 "2023-12-26T11:23:10Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jaladanki\_Varaprasad](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jaladanki_varaprasad/32/130324_2.png) [@Jaladanki\_Varaprasad](https://discuss.elastic.co/u/Jaladanki_Varaprasad)\
**Post date:** [December 26, 2023, 11:23am UTC](https://discuss.elastic.co/t/while-configuring-the-elastic-search-cluster-with-two-elk-nodes-i-am-getting-the-error/349947/1 "2023-12-26T11:23:10Z")

</div>

mote\_cluster\_client, data, data\_cold]  
[2023-12-26T11:21:03,744][ERROR][o.e.b.Elasticsearch] [elk-node-2] fatal exception while booting Elasticsearch  
org.elasticsearch.ElasticsearchSecurityException: failed to load SSL configuration [xpack.security.transport.ssl] - cannot read configured [PKCS12] keystore (as a truststore) [/etc/elasticsearch/truststore.p12] - this is usually caused by an incorrect password; (a keystore password was provided)  
at org.elasticsearch.xpack.core.ssl.SSLService.lambda$loadSslConfigurations$11(SSLService.java:620) ~[?:?]  
at java.util.HashMap.forEach(HashMap.java:1429) ~[?:?]  
at java.util.Collections$UnmodifiableMap.forEach(Collections.java:1707) ~[?:?]

---

<div class="post-metadata">

**Author:** ![yago82](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yago82/32/97755_2.png) [@yago82](https://discuss.elastic.co/u/yago82)\
**Post date:** [January 18, 2024, 11:22am UTC](https://discuss.elastic.co/t/while-configuring-the-elastic-search-cluster-with-two-elk-nodes-i-am-getting-the-error/349947/2 "2024-01-18T11:22:08Z")

</div>

> [@Jaladanki\_Varaprasad](#):
>
> mote\_cluster\_client, data, data\_cold]  
> [2023-12-26T11:21:03,744][ERROR][o.e.b.Elasticsearch] [elk-node-2] fatal exception while booting Elasticsearch  
> org.elasticsearch.ElasticsearchSecurityException: failed to load SSL configuration [xpack.security.transport.ssl] - cannot read configured [PKCS12] keystore (as a truststore) [/etc/elasticsearch/truststore.p12] - this is usually caused by an incorrect password; (a keystore password was provided)  
> at org.elasticsearch.xpack.core.ssl.SSLService.lambda$loadSslConfigurations$11(SSLService.java:620) ~[?:?]  
> at java.util.HashMap.forEach(HashMap.java:1429) ~[?:?]  
> at java.util.Collections$UnmodifiableMap.forEach(Collections.java:1707) ~[?:?]

Hi,

try to verify that the password you've provided in the Elasticsearch configuration for the keystore is correct. The password should be specified in the `xpack.security.transport.ssl.keystore.secure_password` setting in the `elasticsearch.yml` file.

> **[Security settings in Elasticsearch | Elasticsearch Guide \[8.12\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/security-settings.html)**

Regards

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 15, 2024, 11:22am UTC](https://discuss.elastic.co/t/while-configuring-the-elastic-search-cluster-with-two-elk-nodes-i-am-getting-the-error/349947/3 "2024-02-15T11:22:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
