# While making kibana to work with SearchGuard Getting Error

**URL:** <https://discuss.elastic.co/t/while-making-kibana-to-work-with-searchguard-getting-error/36938>\
**Category:** Elasticsearch\
**Created:** [December 11, 2015, 5:39am UTC](https://discuss.elastic.co/t/while-making-kibana-to-work-with-searchguard-getting-error/36938 "2015-12-11T05:39:54Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![balubollam](https://avatars.discourse-cdn.com/v4/letter/b/a587f6/32.png) [@balubollam](https://discuss.elastic.co/u/balubollam)\
**Post date:** [December 11, 2015, 5:39am UTC](https://discuss.elastic.co/t/while-making-kibana-to-work-with-searchguard-getting-error/36938/1 "2015-12-11T05:39:54Z")

</div>

```
      Hi Everyone

```

I Have Implemented “search-guard” Elasticsearch

--\>

First i have created a “SearchGuard” Index

\*Then I have Installed and Configured it in logging.yml and Elasticsearch.yml

\*In elasticsearch.yml i have given a user name:admin and password:admin

note:I have given all permissions to admin user in “searchguard” index

\*HERE is my index

curl -XPUT '[http://localhost:9200/searchguard/ac/ac](http://localhost:9200/searchguard/ac/ac)' -d '{

```
"acl": [

{

    "Comment": "By default no filters are executed 

```

and no filters a by-passed. In such a case an exception is thrown and  
access will be denied.",

```
    "filters_bypass": [],

    "filters_execute": []

 },

 {

       "Comment": "For role admin all filters are bypassed (so none will be executed). This means unrestricted access.",

       "roles": [

           "admin"

       ],

       "filters_bypass": [],

       "filters_execute": [“actionrequestfilter.kibanaUser”]

 }

 ]

```

}'

\*Here is my elasticsearch.yml

searchguard.enabled: true

searchguard.rewrite\_get\_as\_search: true

searchguard.allow\_all\_from\_loopback: true

searchguard.config\_index\_name: searchguard

searchguard.key\_path: /var/lib/elasticsearch/searchguard\_node.key

##User settings

searchguard.authentication.settingsdb.user.admin: admin

searchguard.actionrequestfilter.names: ["kibanaUser","admincopy"]

searchguard.actionrequestfilter.kibanaUser.allowed\_actions:["indices:admin/get","indices:data/read/", "monitor"]

---\>Here iam getting “timeout” Error.

As i am new to this concept.Not getting.Please someone help me out in this??

Thanks And Regards

Balaji

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:31pm UTC](https://discuss.elastic.co/t/while-making-kibana-to-work-with-searchguard-getting-error/36938/2 "2017-07-05T23:31:55Z")

</div>


