# While using httpjson input in filebeat getting error Exiting: Failed to start crawler

**URL:** https://discuss.elastic.co/t/while-using-httpjson-input-in-filebeat-getting-error-exiting-failed-to-start-crawler/374873
**Category:** Beats
**Tags:** filebeat
**Created:** [February 21, 2025, 10:15pm UTC](https://discuss.elastic.co/t/while-using-httpjson-input-in-filebeat-getting-error-exiting-failed-to-start-crawler/374873 "2025-02-21T22:15:12Z")
**Posts on this page:** 1
**Showing post:** 6

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [February 26, 2025, 9:53pm UTC](https://discuss.elastic.co/t/while-using-httpjson-input-in-filebeat-getting-error-exiting-failed-to-start-crawler/374873/6 "2025-02-26T21:53:05Z")

</div>

I have no clue, I do not use this input, but searching on the forum I found a similar [post](https://discuss.elastic.co/t/filebeat-pagination-doesnt-support-in-field-name-azure-graphapi/347621).

It seems that the `httpjson` does not suport fields with `@` in the name.

You may need a response from someone from Elastic or maybe open an issue in Github.

---

_[View the full topic](https://discuss.elastic.co/t/while-using-httpjson-input-in-filebeat-getting-error-exiting-failed-to-start-crawler/374873)._
