# Whitelisting own cloud elasticsearch instance IP

**URL:** https://discuss.elastic.co/t/whitelisting-own-cloud-elasticsearch-instance-ip/262313
**Category:** Elasticsearch
**Tags:** elastic-stack-alerting
**Created:** [January 27, 2021, 5:35am UTC](https://discuss.elastic.co/t/whitelisting-own-cloud-elasticsearch-instance-ip/262313 "2021-01-27T05:35:02Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![mkadiri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mkadiri/32/82953_2.png) [@mkadiri](https://discuss.elastic.co/u/mkadiri)
#### Post date: [January 27, 2021, 5:35am UTC](https://discuss.elastic.co/t/whitelisting-own-cloud-elasticsearch-instance-ip/262313/1 "2021-01-27T05:35:02Z")

</div>

For one our deployments we've created a traffic filter via [https://cloud.elastic.co/deployment-features/traffic-filters](https://cloud.elastic.co/deployment-features/traffic-filters) that whitelists our VPN IP addresses.

This works as expected, I can only access elasticsearch/kibana when I'm connected to my company's VPN, however recently we've tried implementing a watcher that notifies us when the cluster is unhealthy.

It seems that the watcher is prevented from hitting the healthcheck endpoint, we get a 403 error which is due to the traffic filtering rules, I assume because we've not whitelisted the elastic instance IP address?

I've tested this theory by deleting the traffic filter from our deployment, which gets rid of the 403 errors, however this is not ideal as we need to keep the whitelisted IPs filter.

My question is, is there a way of getting around this 403 error? am I able to whitelist the elasticsearch instance that is making the healthcheck requests? if so, how do I obtain the correct list of IPs to whitelist

```auto
PUT _xpack/watcher/watch/cluster_health_watch
{
  "trigger" : {
    "schedule" : { "interval" : "10s" }
  },
  "input" : {
    "http" : {
      "request" : {
       "scheme": "https",
       "host" : "....eu-west-1.aws.found.io",
       "port" : 9243,
       "path" : "/_cluster/health",
       "auth": {
          "basic": {
            "username": "...",
            "password": "..."
          }
        }
      }
    }
  },
  "actions": {
    "notify-slack": {
      "throttle_period" : "10s",
      "slack" : {
        "message" : {
          "to" : ["#elasticsearch-alerts-test"],
          "text" : "Cluster status is {{ctx.payload.status}}"
        }
      }
    }
  }
}

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 24, 2021, 5:35am UTC](https://discuss.elastic.co/t/whitelisting-own-cloud-elasticsearch-instance-ip/262313/2 "2021-02-24T05:35:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
