# Why did "some" ElasticSearch Dashboards disappeared after upgrade?

**URL:** <https://discuss.elastic.co/t/why-did-some-elasticsearch-dashboards-disappeared-after-upgrade/19192>\
**Category:** Elasticsearch\
**Created:** [August 11, 2014, 11:50am UTC](https://discuss.elastic.co/t/why-did-some-elasticsearch-dashboards-disappeared-after-upgrade/19192 "2014-08-11T11:50:58Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sabyasachi\_Ruj](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sabyasachi_ruj/32/1342_2.png) [@Sabyasachi\_Ruj](https://discuss.elastic.co/u/Sabyasachi_Ruj)\
**Post date:** [August 11, 2014, 11:50am UTC](https://discuss.elastic.co/t/why-did-some-elasticsearch-dashboards-disappeared-after-upgrade/19192/1 "2014-08-11T11:50:58Z")

</div>

I am using Elasticsearch for indexing logs. I have configured few Kibana  
dashboards to periodically check the health of the logs.

I upgraded the Elasticsearch nodes from "" to "". Some of the dashboards in  
Kibana have stopped working since the upgrade. The error following error is  
shown:

Error Could not find . If you are using a proxy, ensure it is

> configured correctly.

Strangely, many other dashboards are working fine. I also noticed if I  
search directly in Elasticsearch using query API, all dashboards are being  
listed, even those which are throwing 404. But when I try to access them  
using the get api, they throw 404.

Example query api where the dashboard is being listed:

```
curl -XPOST 'https://localhost:9200/kib-int/dashboard/_search' -d 

```

'{"query":{"bool":{"must":[{"term":{"dashboard.title":"health"}}],"must\_not":,"should":}},"from":0,"size":10,"sort":,"facets":{}}'

Example get api where the document throws 404:

```
curl -XGET 'https://localhost:9200/kibana-int/dashboard/Log health'

```

Any idea, what is going wrong?

- the version of your JVM: java version "1.7.0\_55"
- your local configuration: your operating system: Amazon Linux
- how many nodes and indices you have: 3 nodes, 15 indices
- what gateway you are using (eg local, fs, s3 etc): local

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/a568355f-9828-407f-8fc2-aa426a24ec02%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/a568355f-9828-407f-8fc2-aa426a24ec02%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Sabyasachi\_Ruj](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sabyasachi_ruj/32/1342_2.png) [@Sabyasachi\_Ruj](https://discuss.elastic.co/u/Sabyasachi_Ruj)\
**Post date:** [August 11, 2014, 12:01pm UTC](https://discuss.elastic.co/t/why-did-some-elasticsearch-dashboards-disappeared-after-upgrade/19192/2 "2014-08-11T12:01:36Z")

</div>

Sorry. Missed the versions. We upgraded from 1.2.0.1 to 1.3.1.

On Monday, August 11, 2014 5:20:58 PM UTC+5:30, Sabyasachi Ruj wrote:

> I am using Elasticsearch for indexing logs. I have configured few Kibana  
> dashboards to periodically check the health of the logs.
> 
> I upgraded the Elasticsearch nodes from "" to "". Some of the dashboards  
> in Kibana have stopped working since the upgrade. The error following error  
> is shown:
> 
> Error Could not find . If you are using a proxy, ensure it
> 
> > is configured correctly.
> 
> Strangely, many other dashboards are working fine. I also noticed if I  
> search directly in Elasticsearch using query API, all dashboards are being  
> listed, even those which are throwing 404. But when I try to access them  
> using the get api, they throw 404.
> 
> Example query api where the dashboard is being listed:
> 
> ```
> curl -XPOST 'https://localhost:9200/kib-int/dashboard/_search' -d 
> 
> ```
> 
> '{"query":{"bool":{"must":[{"term":{"dashboard.title":"health"}}],"must\_not":,"should":}},"from":0,"size":10,"sort":,"facets":{}}'
> 
> Example get api where the document throws 404:
> 
> ```
> curl -XGET 'https://localhost:9200/kibana-int/dashboard/Log health'
> 
> ```
> 
> Any idea, what is going wrong?
> 
> - the version of your JVM: java version "1.7.0\_55"
> - your local configuration: your operating system: Amazon Linux
> - how many nodes and indices you have: 3 nodes, 15 indices
> - what gateway you are using (eg local, fs, s3 etc): local

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/a383e8bd-bee9-426b-948c-5fba8651d95a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/a383e8bd-bee9-426b-948c-5fba8651d95a%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Sabyasachi\_Ruj](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sabyasachi_ruj/32/1342_2.png) [@Sabyasachi\_Ruj](https://discuss.elastic.co/u/Sabyasachi_Ruj)\
**Post date:** [August 11, 2014, 1:52pm UTC](https://discuss.elastic.co/t/why-did-some-elasticsearch-dashboards-disappeared-after-upgrade/19192/3 "2014-08-11T13:52:14Z")

</div>

I just tried  
this: [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/blog/tool-help-routing-issues-elasticsearch-1-2-0/)

This tool fails with the following error:

$ java -jar elasticsearch-fix-routing-1.0.jar localhost 9300 grafana  
copy\_if\_missing  
Aug 11, 2014 1:46:38 PM org.elasticsearch.plugins  
INFO: [Donald Pierce] loaded , sites   
Index: grafana, number of shards: 5  
Shard 1/5:  
Exception in thread "main"  
org.elasticsearch.action.search.SearchPhaseExecutionException: Failed to  
execute phase [init\_scan], all shards failed; shardFailures  
{[OOiRSfRZQweq1HGk8y8G8Q][grafana][0]:  
QueryPhaseExecutionException[[grafana][0]:  
query[ConstantScore(ScriptFilter(bad-routes))],from[0],size[200]: Query  
Failed [Failed to execute main query]]; nested:  
PropertyAccessException[[Error: unresolvable property or identifier: bad]  
[Near : {... bad-routes ....}]  
^  
[Line: 1, Column: 1]]; }  
at  
org.elasticsearch.action.search.type.TransportSearchTypeAction$BaseAsyncAction.onFirstPhaseResult(TransportSearchTypeAction.java:233)  
at  
org.elasticsearch.action.search.type.TransportSearchTypeAction$BaseAsyncAction$1.onFailure(TransportSearchTypeAction.java:179)  
at  
org.elasticsearch.search.action.SearchServiceTransportAction$23.run(SearchServiceTransportAction.java:523)  
at  
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:744)

On Monday, August 11, 2014 5:31:36 PM UTC+5:30, Sabyasachi Ruj wrote:

> Sorry. Missed the versions. We upgraded from 1.2.0.1 to 1.3.1.
> 
> On Monday, August 11, 2014 5:20:58 PM UTC+5:30, Sabyasachi Ruj wrote:
> 
> > I am using Elasticsearch for indexing logs. I have configured few Kibana  
> > dashboards to periodically check the health of the logs.
> > 
> > I upgraded the Elasticsearch nodes from "" to "". Some of the dashboards  
> > in Kibana have stopped working since the upgrade. The error following error  
> > is shown:
> > 
> > Error Could not find . If you are using a proxy, ensure it
> > 
> > > is configured correctly.
> > 
> > Strangely, many other dashboards are working fine. I also noticed if I  
> > search directly in Elasticsearch using query API, all dashboards are being  
> > listed, even those which are throwing 404. But when I try to access them  
> > using the get api, they throw 404.
> > 
> > Example query api where the dashboard is being listed:
> > 
> > ```
> > curl -XPOST 'https://localhost:9200/kib-int/dashboard/_search' -d 
> > 
> > ```
> > 
> > '{"query":{"bool":{"must":[{"term":{"dashboard.title":"health"}}],"must\_not":,"should":}},"from":0,"size":10,"sort":,"facets":{}}'
> > 
> > Example get api where the document throws 404:
> > 
> > ```
> > curl -XGET 'https://localhost:9200/kibana-int/dashboard/Log health'
> > 
> > ```
> > 
> > Any idea, what is going wrong?
> > 
> > - the version of your JVM: java version "1.7.0\_55"
> > - your local configuration: your operating system: Amazon Linux
> > - how many nodes and indices you have: 3 nodes, 15 indices
> > - what gateway you are using (eg local, fs, s3 etc): local

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/ab480ba3-5864-4d5a-8372-c410c93a089a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/ab480ba3-5864-4d5a-8372-c410c93a089a%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:09am UTC](https://discuss.elastic.co/t/why-did-some-elasticsearch-dashboards-disappeared-after-upgrade/19192/4 "2017-07-06T01:09:34Z")

</div>


