# Why does logstash not import file into elasticsearch?

**URL:** <https://discuss.elastic.co/t/why-does-logstash-not-import-file-into-elasticsearch/25397>\
**Category:** Logstash\
**Created:** [July 12, 2015, 5:56pm UTC](https://discuss.elastic.co/t/why-does-logstash-not-import-file-into-elasticsearch/25397 "2015-07-12T17:56:31Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![bhutchinson](https://avatars.discourse-cdn.com/v4/letter/b/2acd7d/32.png) [@bhutchinson](https://discuss.elastic.co/u/bhutchinson)\
**Post date:** [July 12, 2015, 5:56pm UTC](https://discuss.elastic.co/t/why-does-logstash-not-import-file-into-elasticsearch/25397/1 "2015-07-12T17:56:31Z")

</div>

**Versions**  
Windows 7  
elasticsearch v1.6.0  
logstash v1.5.2  
kibana v4.1.0

**Background**  
I am trying to import an Apache Access Log file into elasticsearch. I am finding that sometimes logstash will work as desired, other times logstash will choke when trying to import the same file.

**After an Import Fails...**  
The DOS Command window returns the following messages  
WARNING: exception caught on transport layer ..., closing connection  
java.net.SocketException: Permission denied: no further information

If I check the elasticsearch/logs/cluster.log I see the following messages  
I see the same error messages.

What I have tried to resolve import issue

1. stopped elasticsearch/started elasticsearch
2. changed import file name
3. changed logstash.conf file name
4. restarted computer

**Question**  
What is causing the issue? How do I resolve this issue so that logstash will import my Apache Access Log file into elasticsearch every time (instead of only importing the log file into elasticsearch sporadically)?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:34am UTC](https://discuss.elastic.co/t/why-does-logstash-not-import-file-into-elasticsearch/25397/2 "2017-07-06T05:34:54Z")

</div>


