# Why i am getting "1 of 3 shards failed"

**URL:** <https://discuss.elastic.co/t/why-i-am-getting-1-of-3-shards-failed/222565>\
**Category:** Beats\
**Tags:** packetbeat\
**Created:** [March 7, 2020, 4:24pm UTC](https://discuss.elastic.co/t/why-i-am-getting-1-of-3-shards-failed/222565 "2020-03-07T16:24:20Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![tbhaxor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tbhaxor/32/63588_2.png) [@tbhaxor](https://discuss.elastic.co/u/tbhaxor)\
**Post date:** [March 7, 2020, 4:24pm UTC](https://discuss.elastic.co/t/why-i-am-getting-1-of-3-shards-failed/222565/1 "2020-03-07T16:24:20Z")

</div>

Why i am getting this error.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/1/f/1ff231da4d6c001791bb5b0072c9f56cb9d2c7e9.png)

**RESPONSE**

```auto
{
  "took": 27,
  "timed_out": false,
  "_shards": {
    "total": 3,
    "successful": 2,
    "skipped": 0,
    "failed": 1,
    "failures": [
      {
        "shard": 0,
        "index": "packetbeat-7.6.1-2020.03.07",
        "node": "THJOod5tSUGcF23uhLuKfw",
        "reason": {
          "type": "illegal_argument_exception",
          "reason": "Fielddata is disabled on text fields by default. Set fielddata=true on [event.dataset] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."
        }
      }
    ]
  },
  "hits": {
    "total": 0,
    "max_score": null,
    "hits": []
  },
  "aggregations": {
    "2": {
      "buckets": []
    }
  }
}

```

PS: This happened after fresh installation of packetbeat

---

<div class="post-metadata">

**Author:** ![mtojek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mtojek/32/63863_2.png) [@mtojek](https://discuss.elastic.co/u/mtojek)\
**Post date:** [March 9, 2020, 8:32am UTC](https://discuss.elastic.co/t/why-i-am-getting-1-of-3-shards-failed/222565/2 "2020-03-09T08:32:59Z")

</div>

Hi tbhaxor,

The packetbeat installation might be fresh, but what about the cluster? Did you perform an update? see a similar thread: [Fielddata is disabled on text fields by default. Set fielddata=true on [host.name] in order to load fielddata in memory by uninverting the inverted index](https://discuss.elastic.co/t/fielddata-is-disabled-on-text-fields-by-default-set-fielddata-true-on-host-name-in-order-to-load-fielddata-in-memory-by-uninverting-the-inverted-index/212111/3)

---

<div class="post-metadata">

**Author:** ![tbhaxor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tbhaxor/32/63588_2.png) [@tbhaxor](https://discuss.elastic.co/u/tbhaxor)\
**Post date:** [March 9, 2020, 9:29am UTC](https://discuss.elastic.co/t/why-i-am-getting-1-of-3-shards-failed/222565/3 "2020-03-09T09:29:37Z")

</div>

I am using elasticsearch `7.4.2`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 6, 2020, 9:29am UTC](https://discuss.elastic.co/t/why-i-am-getting-1-of-3-shards-failed/222565/4 "2020-04-06T09:29:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
