# Why there isn't a configuration 'ignore\_incoming'?

**URL:** <https://discuss.elastic.co/t/why-there-isnt-a-configuration-ignore-incoming/35640>\
**Category:** Beats\
**Tags:** packetbeat\
**Created:** [November 26, 2015, 8:17am UTC](https://discuss.elastic.co/t/why-there-isnt-a-configuration-ignore-incoming/35640 "2015-11-26T08:17:40Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Augustin\_Chen](https://avatars.discourse-cdn.com/v4/letter/a/b5ac83/32.png) [@Augustin\_Chen](https://discuss.elastic.co/u/Augustin_Chen)\
**Post date:** [November 26, 2015, 8:17am UTC](https://discuss.elastic.co/t/why-there-isnt-a-configuration-ignore-incoming/35640/1 "2015-11-26T08:17:40Z")

</div>

I have packetbeat installed in all the EC2 instances. The ignore\_outgoing is set to 'True' which prevents the duplicated transactions being stored in the ES.  
The applications makes call to MongoDB,as the ignore\_outgoing is true, the failed transactions to MongoDB are ignored. I don't see any Error MongoDB transcations in Kibana.  
I thought to install the packetbeat in a dedicated server, but it requires port mirror in switch, which is not feasible in AWS.  
Any ideas why don't we introduce 'ignore\_incoming'?

---

<div class="post-metadata">

**Author:** ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)\
**Post date:** [November 26, 2015, 2:19pm UTC](https://discuss.elastic.co/t/why-there-isnt-a-configuration-ignore-incoming/35640/2 "2015-11-26T14:19:49Z")

</div>

What's the exact use-case for 'ignore\_incoming' ? If you have packetbeat installed on all servers, the server doing the MongoDB request should forward the failed one, right?

Have you tried if the failed MongoDB transactions are sent to ES if ignore\_outgoing is set to false?

---

<div class="post-metadata">

**Author:** ![Augustin\_Chen](https://avatars.discourse-cdn.com/v4/letter/a/b5ac83/32.png) [@Augustin\_Chen](https://discuss.elastic.co/u/Augustin_Chen)\
**Post date:** [November 27, 2015, 7:53am UTC](https://discuss.elastic.co/t/why-there-isnt-a-configuration-ignore-incoming/35640/3 "2015-11-27T07:53:34Z")

</div>

There are MongoDB timeout in the applications logs, but I don't see any failed MongoDB transactions in the Kibana.  
I will try 'ignore\_outgoing=false', will let you know the result.

---

<div class="post-metadata">

**Author:** ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)\
**Post date:** [November 27, 2015, 2:18pm UTC](https://discuss.elastic.co/t/why-there-isnt-a-configuration-ignore-incoming/35640/4 "2015-11-27T14:18:49Z")

</div>

About MongoDB we've found some issues in message correlation. Follow this ticket for current state: [https://github.com/elastic/packetbeat/issues/377](https://github.com/elastic/packetbeat/issues/377) . A fix is proposed in this PR: [https://github.com/elastic/packetbeat/pull/405](https://github.com/elastic/packetbeat/pull/405)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 9:57pm UTC](https://discuss.elastic.co/t/why-there-isnt-a-configuration-ignore-incoming/35640/5 "2017-07-05T21:57:55Z")

</div>


