Windows integration does not add any integration settings in agent configuration

Trying out Elastic Agent 7.9.0-SNAPSHOT on Windows. Added windows integration together with system to a new agent configuration. However, there is no configuration related to windows integration can be seen in the agent configuration.

agent config
id: 947d54c0-d4cc-11ea-96b2-83f9a190b392
revision: 4
outputs:
  default:
    type: elasticsearch
    hosts:
      - 'https://localhost:9200'
agent:
  monitoring:
    enabled: true
    use_output: default
    logs: true
    metrics: true
inputs:
  - id: 97fa1f70-d4cc-11ea-96b2-83f9a190b392
    name: system-1
    type: system/metrics
    use_output: default
    meta:
      package:
        name: system
        version: 0.5.0
    dataset:
      namespace: default
    streams:
      - id: system/metrics-system.cpu
        dataset:
          name: system.cpu
          type: metrics
        period: 10s
        cpu.metrics:
          - percentages
          - normalized_percentages
        metricsets:
          - cpu
      - id: system/metrics-system.diskio
        dataset:
          name: system.diskio
          type: metrics
        period: 10s
        diskio.include_devices: null
        metricsets:
          - diskio
      - id: system/metrics-system.filesystem
        dataset:
          name: system.filesystem
          type: metrics
        period: 1m
        metricsets:
          - filesystem
        processors:
          - drop_event.when.regexp:
              system.filesystem.mount_point: ^/(sys|cgroup|proc|dev|etc|host|lib|snap)($|/)
      - id: system/metrics-system.fsstat
        dataset:
          name: system.fsstat
          type: metrics
        period: 1m
        metricsets:
          - fsstat
        processors:
          - drop_event.when.regexp:
              system.fsstat.mount_point: ^/(sys|cgroup|proc|dev|etc|host|lib|snap)($|/)
      - id: system/metrics-system.memory
        dataset:
          name: system.memory
          type: metrics
        period: 10s
        metricsets:
          - memory
      - id: system/metrics-system.network
        dataset:
          name: system.network
          type: metrics
        period: 10s
        network.interfaces: null
        metricsets:
          - network
      - id: system/metrics-system.process
        dataset:
          name: system.process
          type: metrics
        process.include_top_n.by_memory: 5
        period: 10s
        processes:
          - .*
        process.include_top_n.by_cpu: 5
        process.cgroups.enabled: false
        process.cmdline.cache.enabled: true
        metricsets:
          - process
      - id: system/metrics-system.process_summary
        dataset:
          name: system.process_summary
          type: metrics
        period: 10s
        metricsets:
          - process_summary
      - id: system/metrics-system.socket_summary
        dataset:
          name: system.socket_summary
          type: metrics
        period: 10s
        metricsets:
          - socket_summary
      - id: system/metrics-system.uptime
        dataset:
          name: system.uptime
          type: metrics
        period: 10s
        metricsets:
          - uptime

The Windows integration settings page shows Nothing to configure.

screenshot

The tags elastic-agent and stack-ingest-management are not recognised as tags. I kept receiving the following error if I tried to remove metricbeat tag.

image

Looks like the Windows integration not visible issue will be fixed in #212.

#212 was merged. This was fixed.