# Windows service 7.2 fails to stop

**URL:** <https://discuss.elastic.co/t/windows-service-7-2-fails-to-stop/188971>\
**Category:** Elasticsearch\
**Created:** [July 4, 2019, 8:48pm UTC](https://discuss.elastic.co/t/windows-service-7-2-fails-to-stop/188971 "2019-07-04T20:48:14Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![geoB](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/geob/32/49288_2.png) [@geoB](https://discuss.elastic.co/u/geoB)\
**Post date:** [July 4, 2019, 8:48pm UTC](https://discuss.elastic.co/t/windows-service-7-2-fails-to-stop/188971/1 "2019-07-04T20:48:15Z")

</div>

After properly [getting Elasticsearch 7.2 to start](https://discuss.elastic.co/t/windows-service-7-2-fails-to-start/188549/2) and its service to install I noted that it was set to Manual. I told it to start and services.msc showed it as running. When I elected to stop the service I got an error message that said "...If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 1."

Please advise.

Edit: Further investigation shows the following in elasticsearch.log on start attempt:

> [2019-07-05T06:12:52,949][ERROR][o.e.b.Bootstrap] [GWB-10] Exception  
> java.lang.SecurityException: Security misconfiguration: cannot access java.io.tmpdir  
> at org.elasticsearch.bootstrap.Security.selfTest(Security.java:423) ~[elasticsearch-7.2.0.jar:7.2.0]  
> at org.elasticsearch.bootstrap.Security.configure(Security.java:133) ~[elasticsearch-7.2.0.jar:7.2.0]  
> at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:216) ~[elasticsearch-7.2.0.jar:7.2.0]  
> at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349) [elasticsearch-7.2.0.jar:7.2.0]  
> at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) [elasticsearch-7.2.0.jar:7.2.0]  
> at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) [elasticsearch-7.2.0.jar:7.2.0]  
> at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-7.2.0.jar:7.2.0]  
> at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-7.2.0.jar:7.2.0]  
> at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-7.2.0.jar:7.2.0]  
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) [elasticsearch-7.2.0.jar:7.2.0]  
> at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-7.2.0.jar:7.2.0]  
> Caused by: java.lang.SecurityException: Unable to create temporary file or directory  
> at java.nio.file.TempFileHelper.create(TempFileHelper.java:142) ~[?:?]  
> at java.nio.file.TempFileHelper.createTempFile(TempFileHelper.java:160) ~[?:?]  
> at java.nio.file.Files.createTempFile(Files.java:912) ~[?:?]  
> at org.elasticsearch.bootstrap.Security.selfTest(Security.java:416) ~[elasticsearch-7.2.0.jar:7.2.0]  
> ... 10 more

---

<div class="post-metadata">

**Author:** ![geoB](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/geob/32/49288_2.png) [@geoB](https://discuss.elastic.co/u/geoB)\
**Post date:** [July 5, 2019, 4:42pm UTC](https://discuss.elastic.co/t/windows-service-7-2-fails-to-stop/188971/2 "2019-07-05T16:42:02Z")

</div>

Issue resolved - thanks to [this post](https://discuss.elastic.co/t/unable-to-run-elasticsearch-7-2-on-windows/188284).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 2, 2019, 4:42pm UTC](https://discuss.elastic.co/t/windows-service-7-2-fails-to-stop/188971/3 "2019-08-02T16:42:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
