# Winlogbeat 8.4.3 "Start-Service winlogbeat" error

**URL:** https://discuss.elastic.co/t/winlogbeat-8-4-3-start-service-winlogbeat-error/331532
**Category:** Beats
**Tags:** winlogbeat
**Created:** [May 1, 2023, 6:42am UTC](https://discuss.elastic.co/t/winlogbeat-8-4-3-start-service-winlogbeat-error/331532 "2023-05-01T06:42:58Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Banuka\_In\_A\_Shoe](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/banuka_in_a_shoe/32/120462_2.png) [@Banuka\_In\_A\_Shoe](https://discuss.elastic.co/u/Banuka_In_A_Shoe)
#### Post date: [May 1, 2023, 6:42am UTC](https://discuss.elastic.co/t/winlogbeat-8-4-3-start-service-winlogbeat-error/331532/1 "2023-05-01T06:42:58Z")

</div>

Hello,

I'm installing winlogbeat on a windows server 2019 machine.

I'm fairly certain the config files are ok as the following commands output a positive response. (Also my file/audit/metrics run fine on Linux)

.\winlogbeat.exe test config -c .\winlogbeat.yml

Config OK

.\winlogbeat.exe test output -c .\winlogbeat.yml  
All - OK

Is there any way to identify further information on the error below?  
There's nothing in the winlogbeat logs, event viewer or powershell

```auto
PS C:\Program Files\Winlogbeat> Start-Service winlogbeat
Start-Service : Service 'winlogbeat (winlogbeat)' cannot be started due to the following error: Cannot start service winlogbeat on computer '.'.
At line:1 char:1
+ Start-Service <<<< winlogbeat
    + CategoryInfo : OpenError: (System.ServiceProcess.ServiceController:ServiceController) [Start-Service],
   ServiceCommandException
    + FullyQualifiedErrorId : CouldNotStartService,Microsoft.PowerShell.Commands.StartServiceCommand

```

Please assist if possible.

Below is the YAML extract. The only edits I made are below. I may be missing something.

```auto
…
setup.kibana:
  host: "https://x.x.x.x:5601"
  ssl.enabled: true
  ssl.certificate_authorities: ["C:\\Program Files\\Winlogbeat\\x-ca.pem"]
  ssl.certificate: "C:\\Program Files\\Winlogbeat\\x.pem"
  ssl.key: "C:\\Program Files\\Winlogbeat\\x.key"
  ssl.verification_mode: "strict"
…
output.elasticsearch:
  hosts: ["https://x.x.x.x:9200"]
  ssl.enabled: true
  ssl.certificate_authorities: ["C:\\Program Files\\Winlogbeat\\x-ca.pem"]
  ssl.certificate: "C:\\Program Files\\Winlogbeat\\x.pem"
  ssl.key: "C:\\Program Files\\Winlogbeat\\x.key"
  protocol: "https"
  username: "elastic"
  password: "${xx}"
  keystore.path: "${path.config}/data/winlogbeat.keystore"

```

---

<div class="post-metadata">

### Author: ![Banuka\_In\_A\_Shoe](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/banuka_in_a_shoe/32/120462_2.png) [@Banuka\_In\_A\_Shoe](https://discuss.elastic.co/u/Banuka_In_A_Shoe)
#### Post date: [May 15, 2023, 4:13am UTC](https://discuss.elastic.co/t/winlogbeat-8-4-3-start-service-winlogbeat-error/331532/2 "2023-05-15T04:13:31Z")

</div>

Issue was with both the config file, which has a couple of forward slashes,  
and with the location of the winlogbeat.keystore file (It should be moved to ProgramData)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 12, 2023, 6:14am UTC](https://discuss.elastic.co/t/winlogbeat-8-4-3-start-service-winlogbeat-error/331532/3 "2023-06-12T06:14:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
