# Winlogbeat can’t start the service with tls enable

**URL:** https://discuss.elastic.co/t/winlogbeat-can-t-start-the-service-with-tls-enable/163449
**Category:** Logstash
**Created:** [January 9, 2019, 3:50am UTC](https://discuss.elastic.co/t/winlogbeat-can-t-start-the-service-with-tls-enable/163449 "2019-01-09T03:50:34Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![alexlu](https://avatars.discourse-cdn.com/v4/letter/a/7ea924/32.png) [@alexlu](https://discuss.elastic.co/u/alexlu)
#### Post date: [January 9, 2019, 3:50am UTC](https://discuss.elastic.co/t/winlogbeat-can-t-start-the-service-with-tls-enable/163449/1 "2019-01-09T03:50:34Z")

</div>

The error message:  
PS C:\Users\alex\Downloads\winlogbeat\> Start-Service winlogbeat  
Start-Service : Service 'winlogbeat (winlogbeat)' cannot be started due to the following error: Cannot start service  
winlogbeat on computer '.'.  
At line:1 char:1

- Start-Service winlogbeat
- 

```auto
  + CategoryInfo : OpenError: (System.ServiceProcess.ServiceController:ServiceController) [Start-Service],
 ServiceCommandException
  + FullyQualifiedErrorId : CouldNotStartService,Microsoft.PowerShell.Commands.StartServiceCommand

```

If I comment out ssl.certificate\_authorities ,then works well .

Part of configuration:

#----------------------------- Logstash output --------------------------------  
output.logstash:

# The Logstash hosts

hosts: ["192.168.248.71:5044"]

# Optional SSL. By default is off.

# List of root certificates for HTTPS server verifications

#ssl.certificate\_authorities: ["C:\Users\alex\Downloads\winlogbeat\ELK-Stack.crt"]

# Certificate for SSL client authentication

#ssl.certificate: "/etc/pki/client/cert.pem"

# Client Certificate Key

#ssl.key: "/etc/pki/client/cert.key"

Any advise ?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 6, 2019, 3:50am UTC](https://discuss.elastic.co/t/winlogbeat-can-t-start-the-service-with-tls-enable/163449/2 "2019-02-06T03:50:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
