# Winlogbeat doesn't connect to logstash server but filebeat does

**URL:** https://discuss.elastic.co/t/winlogbeat-doesnt-connect-to-logstash-server-but-filebeat-does/160511
**Category:** Beats
**Tags:** winlogbeat
**Created:** [December 12, 2018, 9:55am UTC](https://discuss.elastic.co/t/winlogbeat-doesnt-connect-to-logstash-server-but-filebeat-does/160511 "2018-12-12T09:55:56Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![nu11ahnung](https://avatars.discourse-cdn.com/v4/letter/n/3be4f8/32.png) [@nu11ahnung](https://discuss.elastic.co/u/nu11ahnung)
#### Post date: [December 12, 2018, 9:55am UTC](https://discuss.elastic.co/t/winlogbeat-doesnt-connect-to-logstash-server-but-filebeat-does/160511/1 "2018-12-12T09:55:56Z")

</div>

When I run winlogbeat I get this Error  
`ERROR	pipeline/output.go:100	Failed to connect to backoff(async(tcp://l92.168.0.86:5044)): lookup 192.168.0.86: no such host`

which is kinda weird since  
Test-NetConnection 192.168.0.86 -Port 5044 works totally fine and I also can connect to kibana which runs on the same server

My logstash config file looks like this  
\> input {

> ```
> beats {
> port => "5044"
> host => "192.168.0.86"
> }
> }
> 
> output {
> stdout { codec => rubydebug }
> }
> 
> ```

I don't really understand what I am doing wrong. I start logstash with `sudo bin/logstash -f /etc/logstash/conf.d/first-pipeline.conf --config.reload.automatic`  
my winlogbeat output looks like this

> ```
> output.logstash:
> # The Logstash hosts
> hosts: ["l92.168.0.86:5044"]
> 
> ```

Edit:  
I now started filebeat with almost the same confidurations and it works

---

<div class="post-metadata">

### Author: ![drivera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/drivera/32/39900_2.png) [@drivera](https://discuss.elastic.co/u/drivera)
#### Post date: [January 2, 2019, 6:55pm UTC](https://discuss.elastic.co/t/winlogbeat-doesnt-connect-to-logstash-server-but-filebeat-does/160511/2 "2019-01-02T18:55:14Z")

</div>

Two suggestions:

1. Sorry this may be a stupid suggestion but the number 1 in the IP address in output.logstash, looks like a lower case "L", maybe syntax issue on the post?
2. Did you try to test the connection using:  
winlogbeat.exe test connection  
If it's not connecting it will fail here

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 30, 2019, 6:55pm UTC](https://discuss.elastic.co/t/winlogbeat-doesnt-connect-to-logstash-server-but-filebeat-does/160511/3 "2019-01-30T18:55:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
