# Winlogbeat error when enabling Xpack

**URL:** https://discuss.elastic.co/t/winlogbeat-error-when-enabling-xpack/187335
**Category:** Beats
**Tags:** elastic-stack-monitoring, winlogbeat
**Created:** [June 25, 2019, 1:00pm UTC](https://discuss.elastic.co/t/winlogbeat-error-when-enabling-xpack/187335 "2019-06-25T13:00:07Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Marcell0e](https://avatars.discourse-cdn.com/v4/letter/m/ebca7d/32.png) [@Marcell0e](https://discuss.elastic.co/u/Marcell0e)
#### Post date: [June 25, 2019, 1:00pm UTC](https://discuss.elastic.co/t/winlogbeat-error-when-enabling-xpack/187335/1 "2019-06-25T13:00:07Z")

</div>

I get the following error when I uncommitted the Xpack monitoring reporter. I have also, uncommitted and entered the Elasticsearch host, but nothing seems to work. I also use Logstash as my output source. What am I missing?

2019-06-25T08:53:56.094-0400 ERROR instance/beat.go:802 Exiting: No monitoring reporter configured

```
#============================== Xpack Monitoring ===============================
# winlogbeat can export internal metrics to a central Elasticsearch monitoring
# cluster. This requires xpack monitoring to be enabled in Elasticsearch. The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
xpack.monitoring.enabled: true

# Uncomment to send the metrics to Elasticsearch. Most settings from the
# Elasticsearch output are accepted here as well. Any setting that is not set is
# automatically inherited from the Elasticsearch output configuration, so if you
# have the Elasticsearch output configured, you can simply uncomment the
# following line.
#xpack.monitoring.elasticsearch:
```

---

<div class="post-metadata">

### Author: ![Marcell0e](https://avatars.discourse-cdn.com/v4/letter/m/ebca7d/32.png) [@Marcell0e](https://discuss.elastic.co/u/Marcell0e)
#### Post date: [June 25, 2019, 6:22pm UTC](https://discuss.elastic.co/t/winlogbeat-error-when-enabling-xpack/187335/2 "2019-06-25T18:22:02Z")

</div>

Is there something I'm missing trying to set this up?

---

<div class="post-metadata">

### Author: ![Mike\_Place](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mike_place/32/39555_2.png) [@Mike\_Place](https://discuss.elastic.co/u/Mike_Place)
#### Post date: [July 2, 2019, 9:26am UTC](https://discuss.elastic.co/t/winlogbeat-error-when-enabling-xpack/187335/3 "2019-07-02T09:26:26Z")

</div>

Hi @Marcell0e

As mentioned in the configuration file, you have to also configure the Elasticsearch output. Look for an additional block in the configuration file similar to the following and uncomment it:

```auto
#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["localhost:9200"]

  # Optional protocol and basic auth credentials.
  #protocol: "https"
  #username: "elastic"
  #password: "changeme"

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 30, 2019, 9:26am UTC](https://discuss.elastic.co/t/winlogbeat-error-when-enabling-xpack/187335/4 "2019-07-30T09:26:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
