# Winlogbeat failed to start

**URL:** <https://discuss.elastic.co/t/winlogbeat-failed-to-start/109880>\
**Category:** Beats\
**Tags:** winlogbeat\
**Created:** [December 1, 2017, 5:41am UTC](https://discuss.elastic.co/t/winlogbeat-failed-to-start/109880 "2017-12-01T05:41:00Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![tuankun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tuankun/32/8590_2.png) [@tuankun](https://discuss.elastic.co/u/tuankun)\
**Post date:** [December 1, 2017, 5:41am UTC](https://discuss.elastic.co/t/winlogbeat-failed-to-start/109880/1 "2017-12-01T05:41:00Z")

</div>

Hi there,  
I'm trying to install winlogbeat 5.6.4 x64 on windows server 2012,but failed to start it,error as follows:

PS C:\winlogbeat-5.6.4\> **Start-Service -DisplayName “winlogbeat” -Verbose**  
VERBOSE: Performing the operation "Start-Service" on target "winlogbeat (winlogbeat)".  
Start-Service : Service 'winlogbeat (winlogbeat)' cannot be started due to the following error: Cannot start service  
winlogbeat on computer '.'.  
At line:1 char:1

- Start-Service -DisplayName “winlogbeat” -Verbose
- 

```auto
  + CategoryInfo : OpenError: (System.ServiceProcess.ServiceController:ServiceController) [Start-Service],
 ServiceCommandException
  + FullyQualifiedErrorId : CouldNotStartService,Microsoft.PowerShell.Commands.StartServiceCommand

```

I also tested yml file,and it's normal:

PS C:\winlogbeat-5.6.4\> **.\winlogbeat.exe -c .\winlogbeat.yml -configtest -e**  
2017/12/01 05:25:27.844099 beat.go:297: INFO Home path: [C:\winlogbeat-5.6.4] Config path: [C:\winlogbeat-5.6.4] Data pa  
th: [C:\winlogbeat-5.6.4\data] Logs path: [C:\winlogbeat-5.6.4\logs]  
2017/12/01 05:25:27.845095 beat.go:192: INFO Setup Beat: winlogbeat; Version: 5.6.4  
2017/12/01 05:25:27.844099 metrics.go:23: INFO Metrics logging every 30s  
2017/12/01 05:25:27.845095 logstash.go:91: INFO Max Retries set to: 3  
2017/12/01 05:25:27.845095 outputs.go:108: INFO Activated logstash as output plugin.  
2017/12/01 05:25:27.845095 publish.go:300: INFO Publisher name: CNKUSALLIEIAS04  
2017/12/01 05:25:27.849100 async.go:63: INFO Flush Interval set to: 1s  
2017/12/01 05:25:27.849100 async.go:64: INFO Max Bulk Size set to: 2048  
2017/12/01 05:25:27.849100 winlogbeat.go:71: INFO State will be read from and persisted to C:\winlogbeat-5.6.4\data.winlogbeat.yml  
Config OK

and I tried to execute **.\winlogbeat.exe -c winlogbeat.yml -e -v -d "\*"** , also it's successfully to transfer wineventlog to es.

is there any issue with windows server 2012? and how to fix it? really thanks.

---

<div class="post-metadata">

**Author:** ![maddin2016](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/maddin2016/32/16599_2.png) [@maddin2016](https://discuss.elastic.co/u/maddin2016)\
**Post date:** [December 1, 2017, 10:42am UTC](https://discuss.elastic.co/t/winlogbeat-failed-to-start/109880/2 "2017-12-01T10:42:19Z")

</div>

Can you try starting the PowerShell console with elevated privileges (as administrator)?

---

<div class="post-metadata">

**Author:** ![JKhondhu](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@JKhondhu](https://discuss.elastic.co/u/JKhondhu)\
**Post date:** [December 1, 2017, 10:51am UTC](https://discuss.elastic.co/t/winlogbeat-failed-to-start/109880/3 "2017-12-01T10:51:02Z")

</div>

Cool! Note action point 4.  
Steps as per here: [https://www.elastic.co/guide/en/beats/winlogbeat/current/winlogbeat-installation.html](https://www.elastic.co/guide/en/beats/winlogbeat/current/winlogbeat-installation.html)

---

<div class="post-metadata">

**Author:** ![tuankun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tuankun/32/8590_2.png) [@tuankun](https://discuss.elastic.co/u/tuankun)\
**Post date:** [December 3, 2017, 12:27pm UTC](https://discuss.elastic.co/t/winlogbeat-failed-to-start/109880/4 "2017-12-03T12:27:43Z")

</div>

yes,I've tried it(starting the PowerShell console with elevated privileges (as administrator)) several time,but still not work.

---

<div class="post-metadata">

**Author:** ![maddin2016](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/maddin2016/32/16599_2.png) [@maddin2016](https://discuss.elastic.co/u/maddin2016)\
**Post date:** [December 4, 2017, 10:14am UTC](https://discuss.elastic.co/t/winlogbeat-failed-to-start/109880/5 "2017-12-04T10:14:06Z")

</div>

Can you start the service manually per services mmc? Can you get the service with `Get-Service winlogbeat`?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 1, 2018, 10:14am UTC](https://discuss.elastic.co/t/winlogbeat-failed-to-start/109880/6 "2018-01-01T10:14:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
