# Winlogbeat Starts then Stops - Server 2016

**URL:** <https://discuss.elastic.co/t/winlogbeat-starts-then-stops-server-2016/239062>\
**Category:** Beats\
**Tags:** winlogbeat\
**Created:** [June 29, 2020, 6:13am UTC](https://discuss.elastic.co/t/winlogbeat-starts-then-stops-server-2016/239062 "2020-06-29T06:13:03Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![minorsatellite](https://avatars.discourse-cdn.com/v4/letter/m/f05b48/32.png) [@minorsatellite](https://discuss.elastic.co/u/minorsatellite)\
**Post date:** [June 29, 2020, 6:13am UTC](https://discuss.elastic.co/t/winlogbeat-starts-then-stops-server-2016/239062/1 "2020-06-29T06:13:03Z")

</div>

In the log is the following error message:

`2020-06-28T22:46:03.550-0700	INFO	[monitoring]	log/log.go:131	Stopping metrics logging.`  
`2020-06-28T22:46:03.550-0700	INFO	instance/beat.go:460	winlogbeat stopped.`  
`2020-06-28T22:46:03.570-0700	ERROR	instance/beat.go:958	Exiting: Error importing Kibana dashboards: fail to import the dashboards in Kibana: Error importing URL/file: Failed to unzip the archive: C:\Windows\TEMP\tmp404231103/10.101.10.200:5601: zip: not a valid zip file`

While the directory exists, no such file does.

---

<div class="post-metadata">

**Author:** ![MarianaD](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marianad/32/42687_2.png) [@MarianaD](https://discuss.elastic.co/u/MarianaD)\
**Post date:** [June 29, 2020, 12:49pm UTC](https://discuss.elastic.co/t/winlogbeat-starts-then-stops-server-2016/239062/2 "2020-06-29T12:49:13Z")

</div>

hi @minorsatellite, how does your winlogbeat.yml look like? Please remove any sensitive info before providing it.

---

<div class="post-metadata">

**Author:** ![minorsatellite](https://avatars.discourse-cdn.com/v4/letter/m/f05b48/32.png) [@minorsatellite](https://discuss.elastic.co/u/minorsatellite)\
**Post date:** [June 29, 2020, 4:49pm UTC](https://discuss.elastic.co/t/winlogbeat-starts-then-stops-server-2016/239062/3 "2020-06-29T16:49:08Z")

</div>

Hi-

Thanks for your reply. Please see below.

###################### Winlogbeat Configuration Example ########################

```
# This file is an example configuration file highlighting only the most common
# options. The winlogbeat.reference.yml file from the same directory contains
# all the supported options with more comments. You can use it as a reference.
#
# You can find the full configuration reference here:
# https://www.elastic.co/guide/en/beats/winlogbeat/index.html

# ======================== Winlogbeat specific options =========================

# event_logs specifies a list of event logs to monitor as well as any
# accompanying options. The YAML data type of event_logs is a list of
# dictionaries.
#
# The supported keys are name (required), tags, fields, fields_under_root,
# forwarded, ignore_older, level, event_id, provider, and include_xml. Please
# visit the documentation for the complete details of each option.
# https://go.es.io/WinlogbeatConfig

winlogbeat.event_logs:
  - name: Application
    provider: 
      - Application Error
      - Application Hang
      - Windows Error Reporting
      - EMET
      - DiskQuota
      - GroupPolicy
      - iDrac Service Module
      - MsiInstaller
      - VSS
      - Microsoft-Windows-Backup
      - Microsoft-Windows-User Profiles General
      - Microsoft-Windows-Winlogin
    ignore_older: 72h
    include_xml: true

  - name: System
    include_xml: true

  - name: Security
    processors:
      - script:
          lang: javascript
          id: security
          file: ${path.home}/module/security/config/winlogbeat-security.js
    level: critical, error, warning
    include_xml: true

  - name: Microsoft-Windows-Sysmon/Operational
    processors:
      - script:
          lang: javascript
          id: sysmon
          file: ${path.home}/module/sysmon/config/winlogbeat-sysmon.js

  - name: ForwardedEvents
    tags: [forwarded]
    processors:
      - script:
          when.equals.winlog.channel: Security
          lang: javascript
          id: security
          file: ${path.home}/module/security/config/winlogbeat-security.js
      - script:
          when.equals.winlog.channel: Microsoft-Windows-Sysmon/Operational
          lang: javascript
          id: sysmon
          file: ${path.home}/module/sysmon/config/winlogbeat-sysmon.js
  - name: DFS Replication
    include_xml: true
    
  - name: Directory Service
    include_xml: true
    
  - name: DNS Server
    include_xml: true
    
  - name: Hardware Events
    include_xml: true
# ====================== Elasticsearch template settings =======================

setup.template.settings:
  index.number_of_shards: 1
  #index.codec: best_compression
  #_source.enabled: false

# ================================== General ===================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.
name: myhost

# The tags of the shipper are included in their own field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
#fields:
# env: staging

# ================================= Dashboards =================================
# These settings control loading the sample dashboards to the Kibana index. Loading
# the dashboards is disabled by default and can be enabled either by setting the
# options here or by using the `setup` command.
setup.dashboards.enabled: true

# The URL from where to download the dashboards archive. By default this URL
# has a value which is computed based on the Beat name and version. For released
# versions, this URL points to the dashboard archive on the artifacts.elastic.co
# website.
setup.dashboards.url: "http://0.0.0.0:5601"

# =================================== Kibana ===================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
setup.kibana:

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
  host: "http://0.0.0.0:5601"

  # Kibana Space ID
  # ID of the Kibana Space into which the dashboards should be loaded. By default,
  # the Default Space will be used.
  space.id: my-space-id

# =============================== Elastic Cloud ================================

# These settings simplify using Winlogbeat with the Elastic Cloud (https://cloud.elastic.co/).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and
# `setup.kibana.host` options.
# You can find the `cloud.id` in the Elastic Cloud web UI.
#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and
# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.
#cloud.auth:

# ================================== Outputs ===================================

# Configure what output to use when sending the data collected by the beat.

# ---------------------------- Elasticsearch Output ----------------------------
#output.elasticsearch:
  # Array of hosts to connect to.
  #hosts: ["localhost:9200"]

  # Protocol - either `http` (default) or `https`.
  #protocol: "https"

  # Authentication credentials - either API key or username/password.
  #api_key: "id:api_key"
  #username: "elastic"
  #password: "changeme"

# ------------------------------ Logstash Output -------------------------------
output.logstash:
  # The Logstash hosts
  hosts: ["0.0.0.0:5044"]

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

  # Certificate for SSL client authentication
  #ssl.certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #ssl.key: "/etc/pki/client/cert.key"

# ================================= Processors =================================
processors:
  - add_host_metadata:
      when.not.contains.tags: forwarded
  - add_cloud_metadata: ~

# ================================== Logging ===================================

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
logging.to_files: true
logging.files:
  path: C:\Program Files\Winlogbeat\Logs
logging.level: info
# At debug level, you can selectively enable logging only for some components.
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publish", "service".
#logging.selectors: ["*"]

# ============================= X-Pack Monitoring ==============================
# Winlogbeat can export internal metrics to a central Elasticsearch monitoring
# cluster. This requires xpack monitoring to be enabled in Elasticsearch. The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
#monitoring.enabled: false

# Sets the UUID of the Elasticsearch cluster under which monitoring data for this
# Winlogbeat instance will appear in the Stack Monitoring UI. If output.elasticsearch
# is enabled, the UUID is derived from the Elasticsearch cluster referenced by output.elasticsearch.
#monitoring.cluster_uuid:

# Uncomment to send the metrics to Elasticsearch. Most settings from the
# Elasticsearch output are accepted here as well.
# Note that the settings should point to your Elasticsearch *monitoring* cluster.
# Any setting that is not set is automatically inherited from the Elasticsearch
# output configuration, so if you have the Elasticsearch output configured such
# that it is pointing to your Elasticsearch monitoring cluster, you can simply
# uncomment the following line.
#monitoring.elasticsearch:

# ================================= Migration ==================================

# This allows to enable 6.7 migration aliases
#migration.6_to_7.enabled: true
```

---

<div class="post-metadata">

**Author:** ![minorsatellite](https://avatars.discourse-cdn.com/v4/letter/m/f05b48/32.png) [@minorsatellite](https://discuss.elastic.co/u/minorsatellite)\
**Post date:** [June 29, 2020, 5:54pm UTC](https://discuss.elastic.co/t/winlogbeat-starts-then-stops-server-2016/239062/4 "2020-06-29T17:54:38Z")

</div>

Running the command interactively shows this additional logging info:

.\winlogbeat.exe -c winlogbeat.yml -e -v -d "\*"

> 2020-06-29T10:42:27.640-0700 ERROR instance/beat.go:958 Exiting: Error importing Kibana dashboards: fail to import the dashboards in Kibana: Error importing URL/file: Failed to unzip the  
> archive: C:\Users\my\_user\AppData\Local\Temp\tmp008764139/0.0.0.0:5601: zip: not a valid zip file  
> Exiting: Error importing Kibana dashboards: fail to import the dashboards in Kibana: Error importing URL/file: Failed to unzip the archive: C:\Users\my\_user\AppData\Local\Temp\tmp008764139/0.0.0.0:5601: zip: not a valid zip file

I see no files by that name under this directory.

---

<div class="post-metadata">

**Author:** ![minorsatellite](https://avatars.discourse-cdn.com/v4/letter/m/f05b48/32.png) [@minorsatellite](https://discuss.elastic.co/u/minorsatellite)\
**Post date:** [June 29, 2020, 11:48pm UTC](https://discuss.elastic.co/t/winlogbeat-starts-then-stops-server-2016/239062/5 "2020-06-29T23:48:47Z")

</div>

Any thoughts Mariana?

---

<div class="post-metadata">

**Author:** ![MarianaD](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marianad/32/42687_2.png) [@MarianaD](https://discuss.elastic.co/u/MarianaD)\
**Post date:** [June 30, 2020, 11:24am UTC](https://discuss.elastic.co/t/winlogbeat-starts-then-stops-server-2016/239062/6 "2020-06-30T11:24:05Z")

</div>

@minorsatellite, are you trying to import any local custom dashboards?  
You have set:  
`setup.dashboards.url: "http://0.0.0.0:5601"`  
inside your config file so Winlogbeat tried to download the dashboard archive from the specified URL instead of the local folder.  
Can you comment that out and retry starting windogbeat?

---

<div class="post-metadata">

**Author:** ![minorsatellite](https://avatars.discourse-cdn.com/v4/letter/m/f05b48/32.png) [@minorsatellite](https://discuss.elastic.co/u/minorsatellite)\
**Post date:** [June 30, 2020, 5:14pm UTC](https://discuss.elastic.co/t/winlogbeat-starts-then-stops-server-2016/239062/7 "2020-06-30T17:14:59Z")

</div>

Hi, that was the idea. I have ELK running on a single VM, and I substituted the real IP address with quad zeros (in order to sanitize by config file). Do you still recommend that I comment that line out?

---

<div class="post-metadata">

**Author:** ![minorsatellite](https://avatars.discourse-cdn.com/v4/letter/m/f05b48/32.png) [@minorsatellite](https://discuss.elastic.co/u/minorsatellite)\
**Post date:** [June 30, 2020, 11:24pm UTC](https://discuss.elastic.co/t/winlogbeat-starts-then-stops-server-2016/239062/8 "2020-06-30T23:24:49Z")

</div>

After I made the change I now see visualizations under Winlogbeat Overview Dashboard, but all of the others still error out. See the attached graphics. ![Screen Shot 2020-06-30 at 4.17.47 PM](https://us1.discourse-cdn.com/elastic/original/3X/3/3/33db0a6b6225f26b9ef7c8604c858b7f411698fc.png)

 ![Screen Shot 2020-06-30 at 4.17.38 PM](https://us1.discourse-cdn.com/elastic/original/3X/2/2/22a99bb9e9e668d0cba5195bedea61114bf54e59.png) ![Screen Shot 2020-06-30 at 4.24.03 PM](https://us1.discourse-cdn.com/elastic/original/3X/5/1/51b73fe0712a88e95cdbba6929114ccc490dab74.png) ![Screen Shot 2020-06-30 at 4.23.49 PM](https://us1.discourse-cdn.com/elastic/original/3X/6/2/62532f8b0361e7776ddb91279dbcd64b26f41630.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 29, 2020, 1:24am UTC](https://discuss.elastic.co/t/winlogbeat-starts-then-stops-server-2016/239062/9 "2020-07-29T01:24:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
