# Winlogbeat unable to connect to elasticsearch

**URL:** <https://discuss.elastic.co/t/winlogbeat-unable-to-connect-to-elasticsearch/253612>\
**Category:** Beats\
**Tags:** winlogbeat\
**Created:** [October 28, 2020, 7:15pm UTC](https://discuss.elastic.co/t/winlogbeat-unable-to-connect-to-elasticsearch/253612 "2020-10-28T19:15:09Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![antmar904](https://avatars.discourse-cdn.com/v4/letter/a/d2c977/32.png) [@antmar904](https://discuss.elastic.co/u/antmar904)\
**Post date:** [October 28, 2020, 7:15pm UTC](https://discuss.elastic.co/t/winlogbeat-unable-to-connect-to-elasticsearch/253612/1 "2020-10-28T19:15:09Z")

</div>

Hi.

I downloaded and installed SOF-ELK, imported it into VMware, powered it up then installed the winlogbeat on my Windows 10 laptop. I changed the following in the winlogbeat.yml file:

```auto
Under the "Kibana" section I edited:
host: "192.168.1.231:5601"

Under the "Elasticsearch output" I edited:
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["192.168.1.231:9200"]

```

however I am getting this error in winlogbeat:

ERROR [publisher\_pipeline\_output] pipeline/output.go:154 Failed to connect to backoff(elasticsearch([http://192.168.1.231:9200](http://192.168.1.231:9200))): Get "[http://192.168.1.231:9200](http://192.168.1.231:9200)": dial tcp 192.168.1.231:9200: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

Is there anything I have to change on the server side to bind ip address?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 25, 2020, 9:15pm UTC](https://discuss.elastic.co/t/winlogbeat-unable-to-connect-to-elasticsearch/253612/2 "2020-11-25T21:15:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
