# Writing to an ece run elastic from elastic-spark connector fails

**URL:** <https://discuss.elastic.co/t/writing-to-an-ece-run-elastic-from-elastic-spark-connector-fails/138458>\
**Category:** Elastic Cloud Enterprise (ECE)\
**Created:** [July 3, 2018, 9:58pm UTC](https://discuss.elastic.co/t/writing-to-an-ece-run-elastic-from-elastic-spark-connector-fails/138458 "2018-07-03T21:58:31Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![rkalluri](https://avatars.discourse-cdn.com/v4/letter/r/fbc32d/32.png) [@rkalluri](https://discuss.elastic.co/u/rkalluri)\
**Post date:** [July 3, 2018, 9:58pm UTC](https://discuss.elastic.co/t/writing-to-an-ece-run-elastic-from-elastic-spark-connector-fails/138458/1 "2018-07-03T21:58:31Z")

</div>

I have about 600M rows or 200GB of data being written from Hive to elastic via elastic-spark connectors.

Things start out fine and slow down progressively and around mid point I get the following exception on the spark client side.

Caused by: org.elasticsearch.hadoop.rest.EsHadoopNoNodesLeftException: Connection error (check network and/or pr  
oxy settings)- all nodes failed; tried tried [[[http://77eba63e96b349a88b3ce7560af43d4a.1.2.3.4.ip.es.io:9200](http://77eba63e96b349a88b3ce7560af43d4a.1.2.3.4.ip.es.io:9200)]]

My elastic cluster is a 4 node cluster with 8 GB RAM each.

I have not setup load balancer in front of the proxy, but specified all the proxies via the es.nodes=http://1.2.3.4:9200, http:2.3.4.5:9200 etc

Any tips on how to troubleshoot?

---

<div class="post-metadata">

**Author:** ![Yuri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yuri/32/52458_2.png) [@Yuri](https://discuss.elastic.co/u/Yuri)\
**Post date:** [July 4, 2018, 9:06am UTC](https://discuss.elastic.co/t/writing-to-an-ece-run-elastic-from-elastic-spark-connector-fails/138458/2 "2018-07-04T09:06:32Z")

</div>

I would suggest you to check cluster's metrics and logs. Logs and metrics are shipped to cluster `logging-and-metrics`. On the cluster details page you can find links that navigate to Kibana assigned to the logging cluster with pre-defined filters.

---

<div class="post-metadata">

**Author:** ![rkalluri](https://avatars.discourse-cdn.com/v4/letter/r/fbc32d/32.png) [@rkalluri](https://discuss.elastic.co/u/rkalluri)\
**Post date:** [July 4, 2018, 12:33pm UTC](https://discuss.elastic.co/t/writing-to-an-ece-run-elastic-from-elastic-spark-connector-fails/138458/3 "2018-07-04T12:33:56Z")

</div>

The cluster working fine after wards, what are we looking for in the metrics cluster anything specific.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 18, 2018, 12:33pm UTC](https://discuss.elastic.co/t/writing-to-an-ece-run-elastic-from-elastic-spark-connector-fails/138458/4 "2018-07-18T12:33:59Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
