# X-Pack Authentication issue

**URL:** https://discuss.elastic.co/t/x-pack-authentication-issue/121632
**Category:** Elasticsearch
**Created:** [February 27, 2018, 10:45am UTC](https://discuss.elastic.co/t/x-pack-authentication-issue/121632 "2018-02-27T10:45:17Z")
**Posts on this page:** 1
**Showing post:** 5

<div class="post-metadata">

### Author: ![HansCama](https://avatars.discourse-cdn.com/v4/letter/h/3ec8ea/32.png) [@HansCama](https://discuss.elastic.co/u/HansCama)
#### Post date: [March 5, 2018, 3:45pm UTC](https://discuss.elastic.co/t/x-pack-authentication-issue/121632/5 "2018-03-05T15:45:10Z")

</div>

I have the same situation. Tried time ago to install x-pack. Issues on configuring / making it running. Then I removed it and now I'm giving another try, without success...

./setup-passwords interactive

Failed to authenticate user 'elastic' against [http://10.150.2.116:9302/\_xpack/security/\_authenticate?pretty](http://10.150.2.116:9302/_xpack/security/_authenticate?pretty)  
Possible causes include:

- The password for the 'elastic' user has already been changed on this cluster
- Your elasticsearch node is running against a different keystore  
This tool used the keystore at /opt/software/elasticsearch-6.1.2/config/elasticsearch.keystore

ERROR: Failed to verify bootstrap password

I've also done a reset of the user elastic:

/opt/software/elasticsearch-6.1.2/bin/x-pack/users useradd my\_admin -p my\_pwd -r superuser

curl -u my\_admin -XPUT '[http://kibana:9302/\_xpack/security/user/elastic/\_password?pretty](http://kibana:9302/_xpack/security/user/elastic/_password?pretty)' -H 'Content-Type: application/json' -d'  
{  
"password" : "newpassword"  
}  
'

How can be fixed it? Please, help.

Marco

---

_[View the full topic](https://discuss.elastic.co/t/x-pack-authentication-issue/121632)._
