# X-pack bricking metricbeat after enabling Central Management

**URL:** <https://discuss.elastic.co/t/x-pack-bricking-metricbeat-after-enabling-central-management/203683>\
**Category:** Beats\
**Tags:** fleet\
**Created:** [October 15, 2019, 3:19pm UTC](https://discuss.elastic.co/t/x-pack-bricking-metricbeat-after-enabling-central-management/203683 "2019-10-15T15:19:03Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![mangeloco](https://avatars.discourse-cdn.com/v4/letter/m/bbe5ce/32.png) [@mangeloco](https://discuss.elastic.co/u/mangeloco)\
**Post date:** [October 15, 2019, 3:19pm UTC](https://discuss.elastic.co/t/x-pack-bricking-metricbeat-after-enabling-central-management/203683/1 "2019-10-15T15:19:03Z")

</div>

Before i enroll my metricbeat (either windows or linux), i have monitoring.enabled : true under X-pack monitoring, which will allow the beat to show up under Stack Monitoring in Kibana.  
But after I enroll that Metricbeat, it get replaced (obviously) back to # monitoring.enabled : false.  
I try re-enabling it, but the moment i restart the service it refuses to start

Systemctl Status gives the below

metricbeat.service - Metricbeat is a lightweight shipper for metrics.  
Loaded: loaded (/usr/lib/systemd/system/metricbeat.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Tue 2019-10-15 19:16:27 +04; 10s ago  
Docs: [https://www.elastic.co/products/beats/metricbeat](https://www.elastic.co/products/beats/metricbeat)  
Process: 21613 ExecStart=/usr/share/metricbeat/bin/metricbeat $BEAT\_LOG\_OPTS $BEAT\_CONFIG\_OPTS $BEAT\_PATH\_OPTS (code=exited, status=1/FAILURE)  
Main PID: 21613 (code=exited, status=1/FAILURE)

Oct 15 19:16:27 systemd[1]: metricbeat.service: Service RestartSec=100ms expired, scheduling restart.  
Oct 15 19:16:27 systemd[1]: metricbeat.service: Scheduled restart job, restart counter is at 5.  
Oct 15 19:16:27 systemd[1]: Stopped Metricbeat is a lightweight shipper for metrics..  
Oct 15 19:16:27systemd[1]: metricbeat.service: Start request repeated too quickly.  
Oct 15 19:16:27 systemd[1]: metricbeat.service: Failed with result 'exit-code'.  
Oct 15 19:16:27 systemd[1]: Failed to start Metricbeat is a lightweight shipper for metrics..

Any idea? It works properly before Central Management.

---

<div class="post-metadata">

**Author:** ![mangeloco](https://avatars.discourse-cdn.com/v4/letter/m/bbe5ce/32.png) [@mangeloco](https://discuss.elastic.co/u/mangeloco)\
**Post date:** [October 17, 2019, 1:21pm UTC](https://discuss.elastic.co/t/x-pack-bricking-metricbeat-after-enabling-central-management/203683/2 "2019-10-17T13:21:14Z")

</div>

Update: Apparently once you enable Central Management, you need to reinput the Hosts and User/Pass for it to work.

You would also need to input the below  
**cluster\_name: "name of your cluster"**  
**cluster\_uuid: "uuid of your cluster"**

You get those by inputting the following in Dev Tools (in the left side bar):

**GET /\_cluster/state//**

So, in the end, it should look something like that:

#============================== Xpack Monitoring ===============================  
**monitoring.enabled: true**  
**monitoring.elasticsearch:**  
\*\* cluster\_name: "elasticsearch"\*\*  
\*\* cluster\_uuid: "xxxxxxxxxxxxxxxxxxxx"\*\*  
\*\* hosts: ["ip.ip.ip.ip:port"]\*\*  
\*\* username: your-beat-usr\*\*  
\*\* password: a-good-pwd\*\*

Thanks for the help no one ^.^ and you're welcome if you stumble on the same issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 4, 2022, 7:29am UTC](https://discuss.elastic.co/t/x-pack-bricking-metricbeat-after-enabling-central-management/203683/3 "2022-11-04T07:29:25Z")

</div>


