# X-pack error while running elasticsearch

**URL:** <https://discuss.elastic.co/t/x-pack-error-while-running-elasticsearch/200105>\
**Category:** Elasticsearch\
**Created:** [September 19, 2019, 2:25am UTC](https://discuss.elastic.co/t/x-pack-error-while-running-elasticsearch/200105 "2019-09-19T02:25:22Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![niraj\_kumar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/niraj_kumar/32/4130_2.png) [@niraj\_kumar](https://discuss.elastic.co/u/niraj_kumar)\
**Post date:** [September 19, 2019, 2:25am UTC](https://discuss.elastic.co/t/x-pack-error-while-running-elasticsearch/200105/1 "2019-09-19T02:25:22Z")

</div>

I am seeing some issues with my elasticsearch cluster. I have not installed xpack and i have verified it using elasticsearch plugins list command. Am i doing something wrong here?

```
I
    6.3.1.jar:6.3.1]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_222]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_222]
        at java.lang.Thread.run(Thread.java:748) [?:1.8.0_222]
Caused by: org.elasticsearch.xpack.monitoring.exporter.ExportException: failed to flush export bulks
        at org.elasticsearch.xpack.monitoring.exporter.ExportBulk$Compound.lambda$doFlush$0(ExportBulk.java:156) ~[?:?]
        ... 31 more
Caused by: org.elasticsearch.xpack.monitoring.exporter.ExportException: failed to flush export bulk [default_local]
        ... 30 more
Caused by: java.lang.IllegalStateException: There are no ingest nodes in this cluster, unable to forward request to an ingest node.
        at org.elasticsearch.action.ingest.IngestActionForwarder.randomIngestNode(IngestActionForwarder.java:58) ~[elasticsearch-6.3.1.jar:6.3.1]
        at org.elasticsearch.action.ingest.IngestActionForwarder.forwardIngestRequest(IngestActionForwarder.java:51) ~[elasticsearch-6.3.1.jar:6.3.1]
        at org.elasticsearch.action.bulk.TransportBulkAction.doExecute(TransportBulkAction.java:136) ~[elasticsearch-6.3.1.jar:6.3.1]
        at org.elasticsearch.action.bulk.TransportBulkAction.doExecute(TransportBulkAction.java:85) ~[elasticsearch-6.3.1.jar:6.3.1]
        at org.elasticsearch.action.support.TransportAction$RequestFilterChain.proceed(TransportAction.java:167) ~[elasticsearch-6.3.1.jar:6.3.1]
        ... 25 more
```

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [September 19, 2019, 5:51am UTC](https://discuss.elastic.co/t/x-pack-error-while-running-elasticsearch/200105/2 "2019-09-19T05:51:53Z")

</div>

Looks like you have set **node.ingest: false**

> [@niraj\_kumar](#):
>
> There are no ingest nodes in this cluster, unable to forward request to an ingest node.

---

<div class="post-metadata">

**Author:** ![niraj\_kumar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/niraj_kumar/32/4130_2.png) [@niraj\_kumar](https://discuss.elastic.co/u/niraj_kumar)\
**Post date:** [September 19, 2019, 6:14am UTC](https://discuss.elastic.co/t/x-pack-error-while-running-elasticsearch/200105/3 "2019-09-19T06:14:42Z")

</div>

ingest.node: false or true?

It is set to false on all nodes.

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [September 19, 2019, 6:31am UTC](https://discuss.elastic.co/t/x-pack-error-while-running-elasticsearch/200105/4 "2019-09-19T06:31:45Z")

</div>

When set to false it is NOT an ingest node.. set it too true should fix your problem...

---

<div class="post-metadata">

**Author:** ![niraj\_kumar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/niraj_kumar/32/4130_2.png) [@niraj\_kumar](https://discuss.elastic.co/u/niraj_kumar)\
**Post date:** [September 19, 2019, 6:36am UTC](https://discuss.elastic.co/t/x-pack-error-while-running-elasticsearch/200105/5 "2019-09-19T06:36:54Z")

</div>

But i don't understand the concept of having an ingest node. Is it necessary?

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [September 19, 2019, 6:50am UTC](https://discuss.elastic.co/t/x-pack-error-while-running-elasticsearch/200105/6 "2019-09-19T06:50:20Z")

</div>

Well, according to the error you posted you need one. Of course I don't know your setup.

have [a read here](https://www.elastic.co/guide/en/elasticsearch/reference/master/ingest.html) about ingest nodes and what they do.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 17, 2019, 6:50am UTC](https://discuss.elastic.co/t/x-pack-error-while-running-elasticsearch/200105/7 "2019-10-17T06:50:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
