# X-pack error

**URL:** <https://discuss.elastic.co/t/x-pack-error/110595>\
**Category:** Elasticsearch\
**Created:** [December 7, 2017, 2:37am UTC](https://discuss.elastic.co/t/x-pack-error/110595 "2017-12-07T02:37:32Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![suhan\_kim](https://avatars.discourse-cdn.com/v4/letter/s/898d66/32.png) [@suhan\_kim](https://discuss.elastic.co/u/suhan_kim)\
**Post date:** [December 7, 2017, 2:37am UTC](https://discuss.elastic.co/t/x-pack-error/110595/1 "2017-12-07T02:37:32Z")

</div>

Let me know how to solve this situation.

This is what happens when you start kibana

log

```auto
 [02:36:35.142] [error][monitoring-ui] [export_exception]
   Exception when closing export bulk :: 
   {
      "path":"/_xpack/monitoring/_bulk",
      "query":{"system_id":"kibana","system_api_version":"6","interval":"10000ms"},
      "body":"{\"index\":{\"_type\":\"kibana_settings\"}}\n{\"kibana_uuid\":\"aa70b925-6549-43a1-a87d-cd9b05fe4f61\",\"xpack\":{\"default_admin_email\":null}}\n{\"index\":{\"_type\":\"kibana_stats\"}}\n{\"kibana\":{\"uuid\":\"aa70b925-6549-43a1-a87d-cd9b05fe4f61\",\"name\":\"elastic1-VirtualBox\",\"index\":\".kibana\",\"host\":\"elastic1-VirtualBox\",\"transport_address\":\"10.102.41.171:5601\",\"version\":\"6.0.0\",\"snapshot\":false,\"status\":\"green\"},\"concurrent_connections\":2400,\"os\":{\"load\":{\"1m\":0.2646484375,\"5m\":0.2724609375,\"15m\":0.34130859375},\"memory\":{\"total_in_bytes\":4141441024,\"free_in_bytes\":450953216,\"used_in_bytes\":3690487808},\"uptime_in_millis\":81094000},\"process\":{\"event_loop_delay\":8375.502967189997,\"memory\":{\"heap\":{\"total_in_bytes\":118341632,\"used_in_bytes\":103273544,\"size_limit\":1501560832},\"resident_set_size_in_bytes\":161976320},\"uptime_in_millis\":69573035},\"requests\":{\"disconnects\":0,\"total\":3163,\"status_codes\":{\"200\":1147,\"304\":2007,\"404\":7,\"503\":2}},\"response_times\":{\"average\":1475,\"max\":1475},\"timestamp\":\"2017-12-07T02:36:32.693Z\"}\n",
      "statusCode":500,
      "response":"{\"took\":44,\"errors\":true,\"error\":{\"type\":\"export_exception\",\"reason\":\"Exception when closing export bulk\",\"caused_by\":{\"type\":\"export_exception\",\"reason\":\"failed to flush export bulks\",\"caused_by\":{\"type\":\"export_exception\",\"reason\":\"bulk [default_local] reports failures when exporting documents\",\"exceptions\":[{\"type\":\"export_exception\",\"reason\":\"RemoteTransportException[[node-2][10.102.41.172:9301][indices:admin/create]]; nested: IllegalArgumentException[Rejecting mapping update to [.monitoring-kibana-6-2017.12.07] as the final mapping would have more than 1 type: [doc, type1]];\",\"caused_by\":{\"type\":\"illegal_argument_exception\",\"reason\":\"Rejecting mapping update to [.monitoring-kibana-6-2017.12.07] as the final mapping would have more than 1 type: [doc, type1]\"}},{\"type\":\"export_exception\",\"reason\":\"RemoteTransportException[[node-2][10.102.41.172:9301][indices:admin/create]]; nested: IllegalArgumentException[Rejecting mapping update to [.monitoring-kibana-6-2017.12.07] as the final mapping would have more than 1 type: [doc, type1]];\",\"caused_by\":{\"type\":\"illegal_argument_exception\",\"reason\":\"Rejecting mapping update to [.monitoring-kibana-6-2017.12.07] as the final mapping would have more than 1 type: [doc, type1]\"}}]}}}}"
    }
    at respond (/home/elastic1/kibana-6.0.0-linux-x86_64/node_modules/elasticsearch/src/lib/transport.js:295:15)
    at checkRespForFailure (/home/elastic1/kibana-6.0.0-linux-x86_64/node_modules/elasticsearch/src/lib/transport.js:254:7)
    at HttpConnector.<anonymous> (/home/elastic1/kibana-6.0.0-linux-x86_64/node_modules/elasticsearch/src/lib/connectors/http.js:159:7)
    at IncomingMessage.bound (/home/elastic1/kibana-6.0.0-linux-x86_64/node_modules/elasticsearch/node_modules/lodash/dist/lodash.js:729:21)
    at emitNone (events.js:91:20)
    at IncomingMessage.emit (events.js:185:7)
    at endReadableNT (_stream_readable.js:974:12)
    at _combinedTickCallback (internal/process/next_tick.js:80:11)
    at process._tickDomainCallback (internal/process/next_tick.js:128:9)

```

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [December 7, 2017, 7:48am UTC](https://discuss.elastic.co/t/x-pack-error/110595/2 "2017-12-07T07:48:24Z")

</div>

Hey,

I suppose you upgraded from 5.6 to 6.0? If so, have you run the upgrade API before doing that?

--Alex

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 4, 2018, 7:48am UTC](https://discuss.elastic.co/t/x-pack-error/110595/3 "2018-01-04T07:48:44Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
