# X-Pack Free license - change password

**URL:** <https://discuss.elastic.co/t/x-pack-free-license-change-password/119433>\
**Category:** Elasticsearch\
**Created:** [February 12, 2018, 8:59am UTC](https://discuss.elastic.co/t/x-pack-free-license-change-password/119433 "2018-02-12T08:59:33Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mojster](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mojster/32/21209_2.png) [@Mojster](https://discuss.elastic.co/u/Mojster)\
**Post date:** [February 12, 2018, 8:59am UTC](https://discuss.elastic.co/t/x-pack-free-license-change-password/119433/1 "2018-02-12T08:59:33Z")

</div>

I'm using X-Pack 6.2 over Elastic stack 6.2.

I've used auto-generated passwords during installation steps.  
As in the tutorial I've used U/P(elastic/_generatedPass_) to log into Kibana.

Now to share the login, I want to change the pass to sth simpler, but I get rejected:

```auto
{
  "error": {
    "root_cause": [
      {
        "type": "security_exception",
        "reason": "current license is non-compliant for [security]",
        "license.expired.feature": "security"
      }
    ],
    "type": "security_exception",
    "reason": "current license is non-compliant for [security]",
    "license.expired.feature": "security"
  },
  "status": 403
}

```

Can someone advice me further.

And another question. How can I logout?

---

<div class="post-metadata">

**Author:** ![Krunal\_kalaria](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krunal_kalaria/32/23862_2.png) [@Krunal\_kalaria](https://discuss.elastic.co/u/Krunal_kalaria)\
**Post date:** [February 12, 2018, 9:03am UTC](https://discuss.elastic.co/t/x-pack-free-license-change-password/119433/2 "2018-02-12T09:03:14Z")

</div>

Hi @Mojster,

You can see your default password using following command:  
bin/x-pack/setup-passwords auto -u "[http://localhost:9200](http://localhost:9200)"

You can change elastic password using Devtool:  
POST \_xpack/security/user/elastic/\_password  
{  
"password": "elasticpassword"  
}

You can change kibana password using Devtool:  
POST \_xpack/security/user/kibana/\_password  
{  
"password": "kibanapassword"  
}

Thanks & Regards,  
Krunal.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [February 12, 2018, 9:30am UTC](https://discuss.elastic.co/t/x-pack-free-license-change-password/119433/3 "2018-02-12T09:30:34Z")

</div>

Basic license does not give access to security feature.

---

<div class="post-metadata">

**Author:** ![Mojster](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mojster/32/21209_2.png) [@Mojster](https://discuss.elastic.co/u/Mojster)\
**Post date:** [February 12, 2018, 10:19am UTC](https://discuss.elastic.co/t/x-pack-free-license-change-password/119433/4 "2018-02-12T10:19:24Z")

</div>

Your right. I've done what @Krunal_kalaria is suggesting and got the above error. Therefore I've posted this post.

Ok, I get it, I have no access to security, so I cannot add additional users, etc.  
But there must be an option to change the password. You cannot force users to use password and don't let them change it. This is a serious flaw.

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [February 12, 2018, 11:14am UTC](https://discuss.elastic.co/t/x-pack-free-license-change-password/119433/5 "2018-02-12T11:14:00Z")

</div>

It's not just that you cannot add additional users, there are no users, so there are no passwords to change.

There shouldn't be any login screens or password prompts.

---

<div class="post-metadata">

**Author:** ![Mojster](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mojster/32/21209_2.png) [@Mojster](https://discuss.elastic.co/u/Mojster)\
**Post date:** [February 12, 2018, 11:20am UTC](https://discuss.elastic.co/t/x-pack-free-license-change-password/119433/6 "2018-02-12T11:20:08Z")

</div>

So also no passwords for Logstash and Kibana?

I've installed X-Pack following this steps:  
[https://www.elastic.co/guide/en/x-pack/current/installing-xpack.html](https://www.elastic.co/guide/en/x-pack/current/installing-xpack.html)

---

<div class="post-metadata">

**Author:** ![Mojster](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mojster/32/21209_2.png) [@Mojster](https://discuss.elastic.co/u/Mojster)\
**Post date:** [February 12, 2018, 12:41pm UTC](https://discuss.elastic.co/t/x-pack-free-license-change-password/119433/7 "2018-02-12T12:41:38Z")

</div>

You're right. It's working without.

I'm used that default tutorial go till basic version and then further. So this got me confused.

---

<div class="post-metadata">

**Author:** ![Mojster](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mojster/32/21209_2.png) [@Mojster](https://discuss.elastic.co/u/Mojster)\
**Post date:** [February 13, 2018, 8:18am UTC](https://discuss.elastic.co/t/x-pack-free-license-change-password/119433/8 "2018-02-13T08:18:48Z")

</div>

Removed the solution mark.

I'm optimizing ES installation, therefore I've moved config and data folder to new location.  
ES starts normal, but ES now stalls on login field and wants U/P, there there also is written that this module is disabled.

In error log I get:

```auto
{"type":"log","@timestamp":"2018-02-13T08:14:05Z","tags":["license","warning","xpack"],"pid":8312,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security_exception] failed to authenticate user [kibana], with { header={ WWW-Authenticate=\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\" } } :: {\"path\":\"/_xpack\",\"statusCode\":401,\"response\":\"{\\\"error\\\":{\\\"root_cause\\\":[{\\\"type\\\":\\\"security_exception\\\",\\\"reason\\\":\\\"failed to authenticate user [kibana]\\\",\\\"header\\\":{\\\"WWW-Authenticate\\\":\\\"Basic realm=\\\\\\\"security\\\\\\\" charset=\\\\\\\"UTF-8\\\\\\\"\\\"}}],\\\"type\\\":\\\"security_exception\\\",\\\"reason\\\":\\\"failed to authenticate user [kibana]\\\",\\\"header\\\":{\\\"WWW-Authenticate\\\":\\\"Basic realm=\\\\\\\"security\\\\\\\" charset=\\\\\\\"UTF-8\\\\\\\"\\\"}},\\\"status\\\":401}\",\"wwwAuthenticateDirective\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}"}

```

Edit:  
I've tried to remove X-pack in the location & I get:

```auto
PS G:\elasticStack\elasticsearch> .\bin\elasticsearch-plugin remove x-pack
Exception in thread "main" java.lang.IllegalStateException: Could not load plugin descriptor for existing plugin [x-pack
]. Was the plugin built before 2.0?
        at org.elasticsearch.plugins.PluginsService.getPluginBundles(PluginsService.java:352)
        at org.elasticsearch.plugins.RemovePluginCommand.execute(RemovePluginCommand.java:89)
        at org.elasticsearch.plugins.RemovePluginCommand.execute(RemovePluginCommand.java:67)
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)
        at org.elasticsearch.cli.MultiCommand.execute(MultiCommand.java:75)
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)
        at org.elasticsearch.cli.Command.main(Command.java:90)
        at org.elasticsearch.plugins.PluginCli.main(PluginCli.java:48)
Caused by: java.nio.file.NoSuchFileException: G:\elasticStack\elasticsearch\plugins\x-pack\plugin-descriptor.properties
        at sun.nio.fs.WindowsException.translateToIOException(Unknown Source)
        at sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
        at sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
        at sun.nio.fs.WindowsFileSystemProvider.newByteChannel(Unknown Source)
        at java.nio.file.Files.newByteChannel(Unknown Source)
        at java.nio.file.Files.newByteChannel(Unknown Source)
        at java.nio.file.spi.FileSystemProvider.newInputStream(Unknown Source)
        at java.nio.file.Files.newInputStream(Unknown Source)
        at org.elasticsearch.plugins.PluginInfo.readFromProperties(PluginInfo.java:202)
        at org.elasticsearch.plugins.PluginsService.getPluginBundles(PluginsService.java:349)
        ... 8 more
PS G:\elasticStack\elasticsearch>

```

And I cannot installed it over:

```auto
[=================================================] 100%  
ERROR: plugin directory [G:\elasticStack\elasticsearch\plugins\x-pack] already exists; if you need to update the plugin,
 uninstall it first using command 'remove x-pack'

```

---

<div class="post-metadata">

**Author:** ![Mojster](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mojster/32/21209_2.png) [@Mojster](https://discuss.elastic.co/u/Mojster)\
**Post date:** [February 13, 2018, 8:28am UTC](https://discuss.elastic.co/t/x-pack-free-license-change-password/119433/9 "2018-02-13T08:28:46Z")

</div>

I think it could be my problem with `data` directory.

I was a little bit to quick here.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 13, 2018, 8:28am UTC](https://discuss.elastic.co/t/x-pack-free-license-change-password/119433/10 "2018-03-13T08:28:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
