# X-pack installation error

**URL:** <https://discuss.elastic.co/t/x-pack-installation-error/133097>\
**Category:** Elasticsearch\
**Created:** [May 24, 2018, 9:16am UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097 "2018-05-24T09:16:42Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![manojbhupatiraju](https://avatars.discourse-cdn.com/v4/letter/m/ed8c4c/32.png) [@manojbhupatiraju](https://discuss.elastic.co/u/manojbhupatiraju)\
**Post date:** [May 24, 2018, 9:16am UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097/1 "2018-05-24T09:16:43Z")

</div>

Hi Experts,  
I have installed X-pack for security in my laptop. I am getting below error logs from kibana. Please find the attachment of screen shot for kibana. It would be great if it get resolved.

log [05:53:30.427] [info][status][plugin:reporting@6.2.3] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [05:53:30.465] [error][status][plugin:xpack\_main@6.2.3] Status changed from yellow to red - Request Timeout after 3000ms  
log [05:53:30.480] [error][status][plugin:searchprofiler@6.2.3] Status changed from yellow to red - Request Timeout after 3000ms  
log [05:53:30.480] [error][status][plugin:ml@6.2.3] Status changed from yellow to red - Request Timeout after 3000ms log [05:53:30.480] [error][status][plugin:tilemap@6.2.3] Status changed from yellow to red - Request Timeout after 3000ms  
log [05:53:30.480] [error][status][plugin:watcher@6.2.3] Status changed from yellow to red - Request Timeout after 3000ms  
log [05:53:30.480] [error][status][plugin:graph@6.2.3] Status changed from yellow to red - Request Timeout after 3000ms  
log [05:53:30.480] [error][status][plugin:reporting@6.2.3] Status changed from yellow to red - Request Timeout after 3000ms  
log [05:53:30.480] [error][status][plugin:elasticsearch@6.2.3] Status changed from yellow to red - Request Timeout after 3000ms

log [06:47:36.716] [warning][license][xpack] License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } } :: {"path":"/\_xpack","statusCode":401,"response":"{"error":{"root\_cause":[{"type":"security\_exception","reason":"missing authentication token for REST request [/\_xpack]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}}],"type":"security\_exception","reason":"missing authentication token for REST request [/\_xpack]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}},"status":401}","wwwAuthenticateDirective":"Basic realm="security" charset="UTF-8""}  
log [06:48:06.788] [warning][license][xpack] License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } } :: {"path":"/\_xpack","statusCode":401,"response":"{"error":{"root\_cause":[{"type":"security\_exception","reason":"missing authentication token for REST request [/\_xpack]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}}],"type":"security\_exception","reason":"missing authentication token for REST request [/\_xpack]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}},"status":401}","wwwAuthenticateDirective":"Basic realm="security" charset="UTF-8""}  
log [06:48:36.823] [warning][license][xpack] License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } } :: {"path":"/\_xpack","statusCode":401,"response":"{"error":{"root\_cause":[{"type":"security\_exception","reason":"missing authentication token for REST request [/\_xpack]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}}],"type":"security\_exception","reason":"missing authentication token for REST request [/\_xpack]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}},"status":401}","wwwAuthenticateDirective":"Basic realm="security" charset="UTF-8""}

 ![Kibbana%20screen%20error](https://us1.discourse-cdn.com/elastic/original/3X/d/e/defeedbd331774f6cbe77c686db422ebc96306ef.PNG)

---

<div class="post-metadata">

**Author:** ![JKhondhu](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@JKhondhu](https://discuss.elastic.co/u/JKhondhu)\
**Post date:** [May 24, 2018, 5:45pm UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097/2 "2018-05-24T17:45:04Z")

</div>

Did you follow?  
Install ES-\> install X-Pack -\> configure SSL/TLS -\> start ES -\> set passwords  
[https://www.elastic.co/guide/en/x-pack/current/installing-xpack.html](https://www.elastic.co/guide/en/x-pack/current/installing-xpack.html)

The above tells me you have set the cluster up but not setup your credentials and or placed them eloquently into the respective yaml files.

---

<div class="post-metadata">

**Author:** ![manojbhupatiraju](https://avatars.discourse-cdn.com/v4/letter/m/ed8c4c/32.png) [@manojbhupatiraju](https://discuss.elastic.co/u/manojbhupatiraju)\
**Post date:** [May 28, 2018, 9:39am UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097/3 "2018-05-28T09:39:49Z")

</div>

Hi Jymit,  
Thanks for the reply!  
I have made changes to kibana YML file by setting uername/password. Please find my file below.Is this the only change expected in YML files?

# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which

# is proxied through the Kibana server.

# elasticsearch.username: "kibana"

# elasticsearch.password: "changeme"

Thanks,  
Manoj b

---

<div class="post-metadata">

**Author:** ![JKhondhu](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@JKhondhu](https://discuss.elastic.co/u/JKhondhu)\
**Post date:** [May 28, 2018, 11:24am UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097/4 "2018-05-28T11:24:05Z")

</div>

And does this work for you now?

---

<div class="post-metadata">

**Author:** ![manojbhupatiraju](https://avatars.discourse-cdn.com/v4/letter/m/ed8c4c/32.png) [@manojbhupatiraju](https://discuss.elastic.co/u/manojbhupatiraju)\
**Post date:** [May 29, 2018, 6:49am UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097/5 "2018-05-29T06:49:54Z")

</div>

No. Still I am getting below error in kibana logs.

log [06:46:04.439] [error][status][plugin:logstash@6.2.3] Status changed from red to red - [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }

---

<div class="post-metadata">

**Author:** ![JKhondhu](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@JKhondhu](https://discuss.elastic.co/u/JKhondhu)\
**Post date:** [May 29, 2018, 9:08am UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097/6 "2018-05-29T09:08:55Z")

</div>

That is from Logstash.  
Are you able to login via Kibana?

---

<div class="post-metadata">

**Author:** ![manojbhupatiraju](https://avatars.discourse-cdn.com/v4/letter/m/ed8c4c/32.png) [@manojbhupatiraju](https://discuss.elastic.co/u/manojbhupatiraju)\
**Post date:** [May 29, 2018, 10:43am UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097/7 "2018-05-29T10:43:47Z")

</div>

It is same for kibana as well..  
log [06:46:04.408] [error][status][plugin:xpack\_main@6.2.3] Status changed from red to red - [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }  
log [06:46:04.423] [error][status][plugin:searchprofiler@6.2.3] Status changed from red to red - [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }  
log [06:46:04.423] [error][status][plugin:ml@6.2.3] Status changed from red to red - [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }  
log [06:46:04.423] [error][status][plugin:tilemap@6.2.3] Status changed from red to red - [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }  
log [06:46:04.423] [error][status][plugin:watcher@6.2.3] Status changed from red to red - [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }  
log [06:46:04.423] [error][status][plugin:graph@6.2.3] Status changed from red to red - [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }  
log [06:46:04.439] [error][status][plugin:reporting@6.2.3] Status changed from red to red - [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }  
log [06:46:04.439] [error][status][plugin:security@6.2.3] Status changed from red to red - [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }  
log [06:46:04.439] [error][status][plugin:logstash@6.2.3] Status changed from red to red - [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }

---

<div class="post-metadata">

**Author:** ![JKhondhu](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@JKhondhu](https://discuss.elastic.co/u/JKhondhu)\
**Post date:** [May 29, 2018, 12:05pm UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097/8 "2018-05-29T12:05:11Z")

</div>

Have you setup your built in users credentials?  
Please share your full elasticsearch.yml and kibana.yml

---

<div class="post-metadata">

**Author:** ![manojbhupatiraju](https://avatars.discourse-cdn.com/v4/letter/m/ed8c4c/32.png) [@manojbhupatiraju](https://discuss.elastic.co/u/manojbhupatiraju)\
**Post date:** [May 30, 2018, 7:54am UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097/9 "2018-05-30T07:54:08Z")

</div>

Elastic search file:

```auto
# ======================== Elasticsearch Configuration =========================
#
# NOTE: Elasticsearch comes with reasonable defaults for most settings.
# Before you set out to tweak and tune the configuration, make sure you
# understand what are you trying to accomplish and the consequences.
#
# The primary way of configuring a node is via this file. This template lists
# the most important settings you may want to configure for a production cluster.
#
# Please consult the documentation for further information on configuration options:
# https://www.elastic.co/guide/en/elasticsearch/reference/index.html
#
# ---------------------------------- Cluster -----------------------------------
#
# Use a descriptive name for your cluster:
#
#cluster.name: my-application
#
# ------------------------------------ Node ------------------------------------
#
# Use a descriptive name for the node:
#
#node.name: node-1
#
# Add custom attributes to the node:
#
#node.attr.rack: r1
#
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
#
#path.data: /path/to/data
#
# Path to log files:
#
#path.logs: /path/to/logs
#
# ----------------------------------- Memory -----------------------------------
#
# Lock the memory on startup:
#
#bootstrap.memory_lock: true
#
# Make sure that the heap size is set to about half the memory available
# on the system and that the owner of the process is allowed to use this
# limit.
#
# Elasticsearch performs poorly when the system is swapping the memory.
#
# ---------------------------------- Network -----------------------------------
#
# Set the bind address to a specific IP (IPv4 or IPv6):
#
#network.host: 192.168.0.1
#
# Set a custom port for HTTP:
#
#http.port: 9200
#
# For more information, consult the network module documentation.
#
# --------------------------------- Discovery ----------------------------------
#
# Pass an initial list of hosts to perform discovery when new node is started:
# The default list of hosts is ["127.0.0.1", "[::1]"]
#
#discovery.zen.ping.unicast.hosts: ["host1", "host2"]
#
# Prevent the "split brain" by configuring the majority of nodes (total number of master-eligible nodes / 2 + 1):
#
#discovery.zen.minimum_master_nodes: 
#
# For more information, consult the zen discovery module documentation.
#
# ---------------------------------- Gateway -----------------------------------
#
# Block initial recovery after a full cluster restart until N nodes are started:
#
#gateway.recover_after_nodes: 3
#
# For more information, consult the gateway module documentation.
#
# ---------------------------------- Various -----------------------------------
#
# Require explicit names when deleting indices:
#
#action.destructive_requires_name: true

```

---

<div class="post-metadata">

**Author:** ![manojbhupatiraju](https://avatars.discourse-cdn.com/v4/letter/m/ed8c4c/32.png) [@manojbhupatiraju](https://discuss.elastic.co/u/manojbhupatiraju)\
**Post date:** [May 30, 2018, 7:55am UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097/10 "2018-05-30T07:55:02Z")

</div>

Kibana YML file:

```auto
# Kibana is served by a back end server. This setting specifies the port to use.
#server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
#server.host: "localhost"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy. This only affects
# the URLs generated by Kibana, your proxy is expected to remove the basePath value before forwarding requests
# to Kibana. This setting cannot end in a slash.
#server.basePath: ""

# The maximum payload size in bytes for incoming server requests.
#server.maxPayloadBytes: 1048576

# The Kibana server's name. This is used for display purposes.
#server.name: "your-hostname"

# The URL of the Elasticsearch instance to use for all your queries.
#elasticsearch.url: "http://localhost:9200"

# When this setting's value is true Kibana uses the hostname specified in the server.host
# setting. When the value of this setting is false, Kibana uses the hostname of the host
# that connects to this Kibana instance.
#elasticsearch.preserveHost: true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
#kibana.index: ".kibana"

# The default application to load.
#kibana.defaultAppId: "home"

# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
# is proxied through the Kibana server.
# elasticsearch.username: "kibana"
# elasticsearch.password: "changeme"

# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

# Optional settings that provide the paths to the PEM-format SSL certificate and key files.
# These files validate that your Elasticsearch backend uses the same key files.
#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

# Optional setting that enables you to specify a path to the PEM file for the certificate
# authority for your Elasticsearch instance.
#elasticsearch.ssl.certificateAuthorities: ["/path/to/your/CA.pem"]

# To disregard the validity of SSL certificates, change this setting's value to 'none'.
#elasticsearch.ssl.verificationMode: full

# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
# the elasticsearch.requestTimeout setting.
#elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
# must be a positive integer.
#elasticsearch.requestTimeout: 30000

# List of Kibana client-side headers to send to Elasticsearch. To send *no* client-side
# headers, set this value to [] (an empty list).
#elasticsearch.requestHeadersWhitelist: [authorization]

# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
# by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
#elasticsearch.customHeaders: {}

# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
#elasticsearch.shardTimeout: 0

# Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.
#elasticsearch.startupTimeout: 5000

# Specifies the path where Kibana creates the process ID file.
#pid.file: /var/run/kibana.pid

# Enables you specify a file where Kibana stores log output.
#logging.dest: stdout

# Set the value of this setting to true to suppress all logging output.
#logging.silent: false

# Set the value of this setting to true to suppress all logging output other than error messages.
#logging.quiet: false

# Set the value of this setting to true to log all events, including system usage information
# and all requests.
#logging.verbose: false

# Set the interval in milliseconds to sample system and process performance
# metrics. Minimum is 100ms. Defaults to 5000.
#ops.interval: 5000

# The default locale. This locale can be used in certain circumstances to substitute any missing
# translations.
#i18n.defaultLocale: "en"

```

---

<div class="post-metadata">

**Author:** ![manojbhupatiraju](https://avatars.discourse-cdn.com/v4/letter/m/ed8c4c/32.png) [@manojbhupatiraju](https://discuss.elastic.co/u/manojbhupatiraju)\
**Post date:** [June 15, 2018, 6:53am UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097/11 "2018-06-15T06:53:33Z")

</div>

Hi Experts,  
Can some one guide me on the above error.

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [June 15, 2018, 7:16am UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097/12 "2018-06-15T07:16:31Z")

</div>

You need to remove the leading `#` from the configuration lines in your `.yml` files.

This:

```auto
# elasticsearch.username: "kibana"

```

is simply a comment in the file. It needs to be

```auto
elasticsearch.username: "kibana"

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 13, 2018, 7:16am UTC](https://discuss.elastic.co/t/x-pack-installation-error/133097/13 "2018-07-13T07:16:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
