# X-Pack Kibana failed to authenticate user

**URL:** https://discuss.elastic.co/t/x-pack-kibana-failed-to-authenticate-user/117193
**Category:** Kibana
**Created:** [January 26, 2018, 1:01pm UTC](https://discuss.elastic.co/t/x-pack-kibana-failed-to-authenticate-user/117193 "2018-01-26T13:01:42Z")
**Posts on this page:** 1
**Showing post:** 4

<div class="post-metadata">

### Author: ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)
#### Post date: [January 29, 2018, 10:00am UTC](https://discuss.elastic.co/t/x-pack-kibana-failed-to-authenticate-user/117193/4 "2018-01-29T10:00:45Z")

</div>

It sounds like that you are using the wrong password. Did you set the password yourself or did you get auto-generated passwords from `setup-passwords` ?

You can test the passwords you think are correct against elasticsearch manually by running

`curl -u <user_here> 'http://localhost:9200/_xpack/security/_authenticate?pretty'`

replacing `<user_here>` with the relevant username ( `elastic`, `kibana`, `logstash_system` ) and entering the appropriate password for each.

If you can't remember or are not sure which passwords were generated or what you have set, you can always reset the password of the builtin users manually using the instructions that @timv has shared in a [previous answer](https://discuss.elastic.co/t/i-lost-the-password-that-has-been-changed/91867/2)

---

_[View the full topic](https://discuss.elastic.co/t/x-pack-kibana-failed-to-authenticate-user/117193)._
