# X-pack plugin:reporting - Permission Denied Ubuntu

**URL:** https://discuss.elastic.co/t/x-pack-plugin-reporting-permission-denied-ubuntu/46753
**Category:** Kibana
**Created:** [April 7, 2016, 10:54pm UTC](https://discuss.elastic.co/t/x-pack-plugin-reporting-permission-denied-ubuntu/46753 "2016-04-07T22:54:36Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![dsudduth](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dsudduth/32/8993_2.png) [@dsudduth](https://discuss.elastic.co/u/dsudduth)
#### Post date: [April 7, 2016, 10:54pm UTC](https://discuss.elastic.co/t/x-pack-plugin-reporting-permission-denied-ubuntu/46753/1 "2016-04-07T22:54:36Z")

</div>

Thought I would give Elastic Stack 5 a try on Ubuntu, but I've bumped into a small problem. All X-Pack plugins are enabled with the exception of **plugin:reporting**. The error I'm getting is below. If anyone has any ideas on how to clear the permission issue for this plugin, I would greatly appreciate it. Otherwise, all else seems to be working well. 🙂

`Command failed: tar jxf /opt/kibana/installedPlugins/x-pack/reporting/.phantom/phantomjs-1.9.8-linux-x86_64.tar.bz2 tar: phantomjs-1.9.8-linux-x86_64: Cannot mkdir: Permission denied tar: phantomjs-1.9.8-linux-x86_64: Cannot mkdir: Permission denied tar: phantomjs-1.9.8-linux-x86_64/bin: Cannot mkdir: No such file or directory tar: phantomjs-1.9.8-linux-x86_64: Cannot mkdir: Permission denied tar: phantomjs-1.9.8-linux-x86_64/bin/phantomjs: ...`

---

<div class="post-metadata">

### Author: ![dsudduth](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dsudduth/32/8993_2.png) [@dsudduth](https://discuss.elastic.co/u/dsudduth)
#### Post date: [April 8, 2016, 1:27am UTC](https://discuss.elastic.co/t/x-pack-plugin-reporting-permission-denied-ubuntu/46753/2 "2016-04-08T01:27:49Z")

</div>

Solved my issue:

Run:  
`sudo tar jxf /opt/kibana/installedPlugins/x-pack/reporting/.phantom/phantomjs-1.9.8-linux-x86_64.tar.bz2`.

Next, restart Kibana:  
`sudo service kibana restart`.

So from what I gather this particular plugin drops a version for each platform (windows, linux, etc.). Next it attempts to extract the package for the appropriate platform. Unfortunately it does not have the proper permissions to execute `tar`.

Hope this is helpful to anyone else wanting to check out the Elastic Stack 5.0 release early.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:56pm UTC](https://discuss.elastic.co/t/x-pack-plugin-reporting-permission-denied-ubuntu/46753/3 "2017-07-06T13:56:34Z")

</div>


