# X-pack security enabled fails to start elastic search

**URL:** <https://discuss.elastic.co/t/x-pack-security-enabled-fails-to-start-elastic-search/154705>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [October 30, 2018, 6:05pm UTC](https://discuss.elastic.co/t/x-pack-security-enabled-fails-to-start-elastic-search/154705 "2018-10-30T18:05:16Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![shiv94](https://avatars.discourse-cdn.com/v4/letter/s/bc8723/32.png) [@shiv94](https://discuss.elastic.co/u/shiv94)\
**Post date:** [October 30, 2018, 6:05pm UTC](https://discuss.elastic.co/t/x-pack-security-enabled-fails-to-start-elastic-search/154705/1 "2018-10-30T18:05:17Z")

</div>

Enabling x-pack.security fails to connect to elastic search and closes the elastic search connection by throwing the following error

[2018-10-30T12:54:36,196][INFO][o.e.n.Node] [elk] initialized  
[2018-10-30T12:54:36,196][INFO][o.e.n.Node] [elk] starting ...  
[2018-10-30T12:54:36,777][INFO][o.e.t.TransportService] [elk] publish\_address {x.x.x.x:9300}, bound\_addresses {x.x.x.x:9300}  
[2018-10-30T12:54:37,250][INFO][o.e.m.j.JvmGcMonitorService] [elk] [gc][1] overhead, spent [288ms] collecting in the last [1s]  
[2018-10-30T12:54:37,789][INFO][o.e.b.BootstrapChecks] [elk] bound or publishing to a non-loopback address, enforcing bootstrap checks  
[2018-10-30T12:54:37,806][ERROR][o.e.b.Bootstrap] [elk] node validation exception  
[1] bootstrap checks failed  
[1]: Transport SSL must be enabled for setups with production licenses. Please set [xpack.security.transport.ssl.enabled] to [true] or disable security by setting [xpack.security.enabled] to [false]  
[2018-10-30T12:54:37,814][INFO][o.e.n.Node] [elk] stopping ...  
[2018-10-30T12:54:37,840][INFO][o.e.n.Node] [elk] stopped  
[2018-10-30T12:54:37,840][INFO][o.e.n.Node] [elk] closing ...  
[2018-10-30T12:54:37,858][INFO][o.e.n.Node] [elk] closed  
[2018-10-30T12:54:37,860][INFO][o.e.x.m.j.p.NativeController] Native controller process has stopped - no new native processes can be started

syslog

kibana[30887]: {"type":"log","@timestamp":"2018-10-30T19:16:56Z","tags":["warning","elasticsearch","monitoring-ui"],"pid":30887,"message":"Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)"}  
kibana[30887]: {"type":"log","@timestamp":"2018-10-30T19:16:56Z","tags":["warning","elasticsearch","monitoring-ui"],"pid":30887,"message":"No living connections"}  
kibana[30887]: {"type":"log","@timestamp":"2018-10-30T19:16:56Z","tags":["license","warning","xpack"],"pid":30887,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [monitoring] cluster. Error: No Living connections"}  
kibana[30887]: {"type":"log","@timestamp":"2018-10-30T19:16:58Z","tags":["warning","elasticsearch","admin"],"pid":30887,"message":"Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)"}  
kibana[30887]: {"type":"log","@timestamp":"2018-10-30T19:16:58Z","tags":["warning","elasticsearch","admin"],"pid":30887,"message":"No living connections"}  
kibana[30887]: {"type":"log","@timestamp":"2018-10-30T19:17:01Z","tags":["warning","elasticsearch","admin"],"pid":30887,"message":"Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)"}  
kibana[30887]: {"type":"log","@timestamp":"2018-10-30T19:17:01Z","tags":["warning","elasticsearch","admin"],"pid":30887,"message":"No living connections"}

have platinum licence

elasticsearch.yml file

cluster.name: xxxx  
discovery.zen.minimum\_master\_nodes: 2  
discovery.zen.ping.unicast.hosts: ["server-1","server-2","server-3"]  
network.host: 0.0.0.0  
node.data: false  
node.ingest: false  
node.name: xxx  
path.data: "/x/x/x"  
path.logs: "/x/x/x"  
path.repo: "/x/x/x"  
transport.host: _site_  
xpack.security.enabled: true

for now, there is no ssl set up. can't use x-pack security without using transport ssl in production mode?

---

<div class="post-metadata">

**Author:** ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)\
**Post date:** [October 31, 2018, 6:15am UTC](https://discuss.elastic.co/t/x-pack-security-enabled-fails-to-start-elastic-search/154705/2 "2018-10-31T06:15:06Z")

</div>

Hi,

> [@shiv94](#):
>
> for now, there is no ssl set up. can't use x-pack security without using transport ssl in production mode?

No. As clearly mentioned in the bootstrap check that failed

> [@shiv94](#):
>
> [1]: Transport SSL must be enabled for setups with production licenses. Please set [xpack.security.transport.ssl.enabled] to [true] or disable security by setting [xpack.security.enabled] to [false]

and in our [documentation](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks-xpack.html#_ssl_tls_check), TLS on the transport layer is required (unless using a single node listening on loopback )

---

<div class="post-metadata">

**Author:** ![shiv94](https://avatars.discourse-cdn.com/v4/letter/s/bc8723/32.png) [@shiv94](https://discuss.elastic.co/u/shiv94)\
**Post date:** [October 31, 2018, 12:29pm UTC](https://discuss.elastic.co/t/x-pack-security-enabled-fails-to-start-elastic-search/154705/3 "2018-10-31T12:29:08Z")

</div>

Thanks for sharing 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 28, 2018, 12:29pm UTC](https://discuss.elastic.co/t/x-pack-security-enabled-fails-to-start-elastic-search/154705/4 "2018-11-28T12:29:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
