# X-pack

**URL:** https://discuss.elastic.co/t/x-pack/64453
**Category:** Elasticsearch
**Created:** [October 31, 2016, 2:11pm UTC](https://discuss.elastic.co/t/x-pack/64453 "2016-10-31T14:11:10Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![lianst](https://avatars.discourse-cdn.com/v4/letter/l/eb9ed0/32.png) [@lianst](https://discuss.elastic.co/u/lianst)
#### Post date: [October 31, 2016, 2:11pm UTC](https://discuss.elastic.co/t/x-pack/64453/1 "2016-10-31T14:11:10Z")

</div>

I installed the x-pack after the start Elasticsearch suggest the following error, ask you how to solve?

[2016-10-31T21:54:07,380][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: ElasticsearchException[Failed to load plugin class [org.elasticsearch.xpack.XPackPlugin]]; nested: InvocationTargetException; nested: ElasticsearchException[failed to initialize a TrustManagerFactory]; nested: ProviderException[Error parsing configuration]; nested: ConfigurationException[Unexpected value Token['@'], line 2];  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:116) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:103) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:96) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.cli.Command.main(Command.java:62) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80) ~[elasticsearch-5.0.0.jar:5.0.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:73) ~[elasticsearch-5.0.0.jar:5.0.0]  
Caused by: org.elasticsearch.ElasticsearchException: Failed to load plugin class [org.elasticsearch.xpack.XPackPlugin]

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [October 31, 2016, 2:34pm UTC](https://discuss.elastic.co/t/x-pack/64453/2 "2016-10-31T14:34:54Z")

</div>

Hey,

can you provide some more information?

- Which Elasticsearch version is this?
- Which java version is this?
- Can you share your configuration file, the `elasticsearch.yml`
- Did you change any other default configuration?

--Alex

---

<div class="post-metadata">

### Author: ![lianst](https://avatars.discourse-cdn.com/v4/letter/l/eb9ed0/32.png) [@lianst](https://discuss.elastic.co/u/lianst)
#### Post date: [October 31, 2016, 2:46pm UTC](https://discuss.elastic.co/t/x-pack/64453/3 "2016-10-31T14:46:50Z")

</div>

Elasticsearch version : Version: 5.0.0, Build: 253032b/2016-10-26T04:37:51.531Z,  
java version:JVM: 1.8.0\_111

elasticsearch.yml(Only the following two options have been modified) :  
path.data: /data  
network.host: 10.10.174.223

No other default configuration files have been modified

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [November 2, 2016, 11:55am UTC](https://discuss.elastic.co/t/x-pack/64453/4 "2016-11-02T11:55:25Z")

</div>

Hey,

so this looks as if there is an error with the security manager and the config file that is being loaded.

- Which operating system is this?
- Did you change anything in `plugins/x-pack`?
- Can you show the contents of `plugins/x-pack/plugin-security.policy`
- Can you reinstall the `x-pack` plugin?
- Can you paste the full output `java -version`?

--Alex

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [November 2, 2016, 12:09pm UTC](https://discuss.elastic.co/t/x-pack/64453/5 "2016-11-02T12:09:37Z")

</div>

Also, the output of `/bin/elasticsearch-plugin install x-pack` would be nice to see

---

<div class="post-metadata">

### Author: ![FardinBehboudi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fardinbehboudi/32/14906_2.png) [@FardinBehboudi](https://discuss.elastic.co/u/FardinBehboudi)
#### Post date: [January 26, 2017, 1:59pm UTC](https://discuss.elastic.co/t/x-pack/64453/6 "2017-01-26T13:59:10Z")

</div>

i have also this problem:

i am using Elastic stack 5.1 i had elasticsearcha nd kibana installed with xpack installed on themPreformatted text and they were working also i installed logstash and beats.(order of installation was like what i wrote) after installing beat(i think) and some changes in my company VPN and proxy. my elasticsaerch andkibana stopped working, the service is not even getting start. i remove x-pack then the ES and kibana working but again when i install x-pack ES and kibana Stop. what should I do?

the log says teh xpack plugin cant load!

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [January 27, 2017, 2:31am UTC](https://discuss.elastic.co/t/x-pack/64453/7 "2017-01-27T02:31:27Z")

</div>

> [@FardinBehboudi](#):
>
> what should I do?

Please start a new discussion thread, and post details of what steps you have taken, and the exact error message(s) from the logs.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:40pm UTC](https://discuss.elastic.co/t/x-pack/64453/8 "2017-07-06T13:40:02Z")

</div>


