# X Pack

**URL:** <https://discuss.elastic.co/t/x-pack/92634>\
**Category:** Elasticsearch\
**Created:** [July 11, 2017, 11:37am UTC](https://discuss.elastic.co/t/x-pack/92634 "2017-07-11T11:37:56Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Akanksha\_Toshniwal](https://avatars.discourse-cdn.com/v4/letter/a/d9b06d/32.png) [@Akanksha\_Toshniwal](https://discuss.elastic.co/u/Akanksha_Toshniwal)\
**Post date:** [July 11, 2017, 11:37am UTC](https://discuss.elastic.co/t/x-pack/92634/1 "2017-07-11T11:37:56Z")

</div>

I am using windows 8 32bit, and working on elastic search and kibana. I want to use x-pack now, but unable to start ES after installing x-pack. I have following questions:

1. Can we install x-pack without logstash.  
2.Why ES is not starting?
2. What is ERROR Unable to unregister MBeans java.security.AccessControlException: access denied \<javax.management.MBeanTrustPermission\> means?
3. I have tried changes in .yml files for ES and Kibana, does it affect the performance?
4. I urgently need the answer, I am stuck and it is very frustrating!!

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 11, 2017, 1:04pm UTC](https://discuss.elastic.co/t/x-pack/92634/2 "2017-07-11T13:04:41Z")

</div>

1. Yes
2. We can't know without seeing your logs. May be share them? (And please format them as explained in [About the Elasticsearch category](https://discuss.elastic.co/t/about-the-elasticsearch-category/21)
3. Please share all logs
4. It can. Depending on what you are modifying. In short: don't touch settings you don't understand.
5. There is no SLA on this forum. Please read "be patient" section in [About the Elasticsearch category](https://discuss.elastic.co/t/about-the-elasticsearch-category/21)

---

<div class="post-metadata">

**Author:** ![Akanksha\_Toshniwal](https://avatars.discourse-cdn.com/v4/letter/a/d9b06d/32.png) [@Akanksha\_Toshniwal](https://discuss.elastic.co/u/Akanksha_Toshniwal)\
**Post date:** [July 12, 2017, 5:34am UTC](https://discuss.elastic.co/t/x-pack/92634/3 "2017-07-12T05:34:35Z")

</div>

ThankYou @dadoonet for quick reply and support

I installed x-pack successfully and when I run elastic search after installing x-pack, the following error occurs and it stops itself.

C:\Users\akankshaT\Desktop\Hotify\softwares\elasticsearch-5.4.0\elasticsearch-5.  
4.0\bin\>elasticsearch  
'findstr' is not recognized as an internal or external command,  
operable program or batch file.  
2017-07-12 10:48:19,763 main ERROR Could not register mbeans java.security.Acces  
sControlException: access denied ("javax.management.MBeanTrustPermission" "regis  
ter")  
at java.security.AccessControlContext.checkPermission(AccessControlConte  
xt.java:472)  
at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)  
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrust  
Permission(DefaultMBeanServerInterceptor.java:1848)  
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(D  
efaultMBeanServerInterceptor.java:322)  
at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.j  
ava:522)  
at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)  
at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfi  
gure(Server.java:167)  
at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfi  
gure(Server.java:140)  
at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerCo  
ntext.java:556)  
at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:  
261)  
at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log  
4jContextFactory.java:206)  
at org.apache.logging.log4j.core.config.Configurator.initialize(Configur  
ator.java:221)  
at org.apache.logging.log4j.core.config.Configurator.initialize(Configur  
ator.java:197)  
at org.elasticsearch.common.logging.LogConfigurator.configureStatusLogge  
r(LogConfigurator.java:126)  
at org.elasticsearch.common.logging.LogConfigurator.configureWithoutConf  
ig(LogConfigurator.java:68)  
at org.elasticsearch.cli.Command.main(Command.java:85)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)

```
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)

```

2017-07-12 10:48:22,091 main ERROR Could not register mbeans java.security.Acces  
sControlException: access denied ("javax.management.MBeanTrustPermission" "regis  
ter")  
at java.security.AccessControlContext.checkPermission(AccessControlConte  
xt.java:472)  
at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)  
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrust  
Permission(DefaultMBeanServerInterceptor.java:1848)  
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(D  
efaultMBeanServerInterceptor.java:322)  
at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.j  
ava:522)  
at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)  
at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfi  
gure(Server.java:167)  
at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfi  
gure(Server.java:140)  
at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerCo  
ntext.java:556)  
at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:  
261)  
at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigu  
rator.java:117)  
at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigu  
rator.java:84)  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:326)  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123  
)  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:  
114)  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwar  
eCommand.java:67)  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:1  
22)  
at org.elasticsearch.cli.Command.main(Command.java:88)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)

```
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)

```

[2017-07-12T10:48:25,583][INFO][o.e.n.Node] [] initializing ...  
[2017-07-12T10:48:26,425][INFO][o.e.e.NodeEnvironment] [WXVPNEi] using [1]  
data paths, mounts [[(C:)]], net usable\_space [20.9gb], net total\_space [115.5gb  
], spins? [unknown], types [NTFS]  
[2017-07-12T10:48:26,425][INFO][o.e.e.NodeEnvironment] [WXVPNEi] heap size  
[247.5mb], compressed ordinary object pointers [unknown]  
[2017-07-12T10:48:44,306][INFO][o.e.n.Node] node name [WXVPNEi]  
derived from node ID [WXVPNEiERGehyIQXr-5n7A]; set [[node.name](http://node.name)] to override  
[2017-07-12T10:48:44,306][INFO][o.e.n.Node] version[5.4.0], pid[  
2468], build[780f8c4/2017-04-28T17:43:27.229Z], OS[Windows 8/6.2/x86], JVM[Oracl  
e Corporation/Java HotSpot(TM) Client VM/1.8.0\_91/25.91-b15]  
[2017-07-12T10:48:56,969][INFO][o.e.p.PluginsService] [WXVPNEi] loaded mod  
ule [aggs-matrix-stats]  
[2017-07-12T10:48:56,969][INFO][o.e.p.PluginsService] [WXVPNEi] loaded mod  
ule [ingest-common]  
[2017-07-12T10:48:56,969][INFO][o.e.p.PluginsService] [WXVPNEi] loaded mod  
ule [lang-expression]  
[2017-07-12T10:48:56,969][INFO][o.e.p.PluginsService] [WXVPNEi] loaded mod  
ule [lang-groovy]  
[2017-07-12T10:48:56,969][INFO][o.e.p.PluginsService] [WXVPNEi] loaded mod  
ule [lang-mustache]  
[2017-07-12T10:48:56,969][INFO][o.e.p.PluginsService] [WXVPNEi] loaded mod  
ule [lang-painless]  
[2017-07-12T10:48:56,969][INFO][o.e.p.PluginsService] [WXVPNEi] loaded mod  
ule [percolator]  
[2017-07-12T10:48:56,969][INFO][o.e.p.PluginsService] [WXVPNEi] loaded mod  
ule [reindex]

---

<div class="post-metadata">

**Author:** ![Akanksha\_Toshniwal](https://avatars.discourse-cdn.com/v4/letter/a/d9b06d/32.png) [@Akanksha\_Toshniwal](https://discuss.elastic.co/u/Akanksha_Toshniwal)\
**Post date:** [July 12, 2017, 5:35am UTC](https://discuss.elastic.co/t/x-pack/92634/4 "2017-07-12T05:35:14Z")

</div>

[2017-07-12T10:48:56,969][INFO][o.e.p.PluginsService] [WXVPNEi] loaded mod  
ule [transport-netty3]  
[2017-07-12T10:48:56,969][INFO][o.e.p.PluginsService] [WXVPNEi] loaded mod  
ule [transport-netty4]  
[2017-07-12T10:48:56,985][INFO][o.e.p.PluginsService] [WXVPNEi] loaded plu  
gin [x-pack]  
[2017-07-12T10:49:16,651][DEBUG][o.e.a.ActionModule] Using REST wrapper f  
rom plugin org.elasticsearch.xpack.XPackPlugin  
[2017-07-12T10:49:18,072][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] []  
uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: ElasticsearchException[X-Pack is n  
ot supported and Machine Learning is not available for [windows-x86]; you can us  
e the other X-Pack features (unsupported) by setting xpack.ml.enabled: false in  
elasticsearch.yml]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:127  
) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:  
114) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwar  
eCommand.java:67) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:1  
22) ~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.cli.Command.main(Command.java:88) ~[elasticsearch-5  
.4.0.jar:5.4.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)  
~[elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)  
~[elasticsearch-5.4.0.jar:5.4.0]  
Caused by: org.elasticsearch.ElasticsearchException: X-Pack is not supported and  
Machine Learning is not available for [windows-x86]; you can use the other X-Pa  
ck features (unsupported) by setting xpack.ml.enabled: false in elasticsearch.ym  
l  
at org.elasticsearch.xpack.ml.MachineLearningFeatureSet.isRunningOnMlPla  
tform(MachineLearningFeatureSet.java:112) ~[?:?]  
at org.elasticsearch.xpack.ml.MachineLearningFeatureSet.isRunningOnMlPla  
tform(MachineLearningFeatureSet.java:103) ~[?:?]  
at org.elasticsearch.xpack.ml.MachineLearning.createComponents(MachineLe  
arning.java:285) ~[?:?]  
at org.elasticsearch.xpack.XPackPlugin.createComponents(XPackPlugin.java  
:288) ~[?:?]  
at org.elasticsearch.node.Node.lambda$new$7(Node.java:410) ~[elasticsear  
ch-5.4.0.jar:5.4.0]  
at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:  
267) ~[?:1.8.0\_91]  
at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.j  
ava:1374) ~[?:1.8.0\_91]  
at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481)  
~[?:1.8.0\_91]  
at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.ja  
va:471) ~[?:1.8.0\_91]  
at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java  
:708) ~[?:1.8.0\_91]  
at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)  
~[?:1.8.0\_91]  
at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:499  
) ~[?:1.8.0\_91]  
at org.elasticsearch.node.Node.(Node.java:412) ~[elasticsearch-5.4  
.0.jar:5.4.0]  
at org.elasticsearch.node.Node.(Node.java:242) ~[elasticsearch-5.4  
.0.jar:5.4.0]  
at org.elasticsearch.bootstrap.Bootstrap$6.(Bootstrap.java:242) ~[  
elasticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:242) ~[ela  
sticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:360) ~[elas  
ticsearch-5.4.0.jar:5.4.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123  
) ~[elasticsearch-5.4.0.jar:5.4.0]  
... 6 more  
2017-07-12 10:49:18,103 Thread-4 ERROR Unable to unregister MBeans java.security  
.AccessControlException: access denied ("javax.management.MBeanServerPermission"  
"createMBeanServer")  
at java.security.AccessControlContext.checkPermission(AccessControlConte  
xt.java:472)  
at java.security.AccessController.checkPermission(AccessController.java:  
884)  
at java.lang.SecurityManager.checkPermission(SecurityManager.java:549)  
at java.lang.management.ManagementFactory.getPlatformMBeanServer(Managem  
entFactory.java:465)  
at org.apache.logging.log4j.core.jmx.Server.unregisterLoggerContext(Serv  
er.java:246)  
at org.apache.logging.log4j.core.LoggerContext.stop(LoggerContext.java:3  
38)  
at org.apache.logging.log4j.core.AbstractLifeCycle.stop(AbstractLifeCycl  
e.java:136)  
at org.apache.logging.log4j.core.config.Configurator.shutdown(Configurat  
or.java:344)  
at org.elasticsearch.bootstrap.Bootstrap$5.run(Bootstrap.java:220)

**The following are the changes I have done to the .yml file. I added the following commands in**

**_elastic.yml_**  
#xpack.graph.enabled: false  
#xpack.ml.enable: false  
#xpack.monitoring.enabled: false  
#xpack.security.enabled: false  
#xpack.watcher.enabled: false  
#action.auto\_create\_index: true

**_kibana.yml_**  
#xpack.graph.enabled: false  
#xpack.ml.enable: false  
#xpack.monitoring.enabled: false  
#xpack.reposrting.enabled: false  
#xpack.security.enabled: false

as given in [https://www.elastic.co/guide/en/x-pack/current/installing-xpack.html](https://www.elastic.co/guide/en/x-pack/current/installing-xpack.html)

Kindly tell how can I solve this Error .  
I want to use Graph,Machine Learning and Security particularly.

**LOGSTASH**  
I also tried installing logstash but config file with following code. But it did not work, am I doing anything wrong(before installing x-pack)

input { stdin { } }  
output {  
elasticsearch { hosts =\> ["localhost:9200"] }

}

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [July 12, 2017, 6:15am UTC](https://discuss.elastic.co/t/x-pack/92634/5 "2017-07-12T06:15:22Z")

</div>

According to the stack trace it looks like you might be running on a 32-bit machine, on which machine learning is not supported.

---

<div class="post-metadata">

**Author:** ![Akanksha\_Toshniwal](https://avatars.discourse-cdn.com/v4/letter/a/d9b06d/32.png) [@Akanksha\_Toshniwal](https://discuss.elastic.co/u/Akanksha_Toshniwal)\
**Post date:** [July 12, 2017, 6:33am UTC](https://discuss.elastic.co/t/x-pack/92634/6 "2017-07-12T06:33:25Z")

</div>

Dear  
Christian [https://discuss.elastic.co/u/christian\_dahlqvist](https://discuss.elastic.co/u/christian_dahlqvist),  
Thanks for quick response.

According to the stack trace it looks like you might be running on a 32-bit

> machine, on which machine learning is not supported.

Can I use ES extension Graph on 32bit machine?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 12, 2017, 8:55am UTC](https://discuss.elastic.co/t/x-pack/92634/7 "2017-07-12T08:55:37Z")

</div>

> [@Akanksha\_Toshniwal](#):
>
> Can I use ES extension Graph on 32bit machine?

Nope.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 9, 2017, 8:55am UTC](https://discuss.elastic.co/t/x-pack/92634/8 "2017-08-09T08:55:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
