# X509: certificate signed by unknown authority

**URL:** <https://discuss.elastic.co/t/x509-certificate-signed-by-unknown-authority/298551>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [March 1, 2022, 7:24pm UTC](https://discuss.elastic.co/t/x509-certificate-signed-by-unknown-authority/298551 "2022-03-01T19:24:09Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![sath](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sath/32/82475_2.png) [@sath](https://discuss.elastic.co/u/sath)\
**Post date:** [March 1, 2022, 7:24pm UTC](https://discuss.elastic.co/t/x509-certificate-signed-by-unknown-authority/298551/1 "2022-03-01T19:24:09Z")

</div>

Hello,  
I'm running Elasticsearch 8 and am trying to output files on a Windows machine to Logstash.

Now in preparation, I'm trying to get the index setup by running the following:

`.\filebeat.exe setup --index-management`

Which throws an error:

> x509: certificate signed by unknown authority.

Now I tried to add the http\_ca.crt to the filebeat.yml file in multiple different ways as per some different documentations I found, but to no avail.  
Simple question; where in the filebeat.yml file do I need to define what? Elasticsearch generated the http\_ca.crt, http.p12 and transport.p12 files upon installation.

I'm aware I could create the index manually by exporting the json, but I really want to get this issue resolved to prevent any further ones. I doubt Filebeat would even be able to output data to Logstash when already it is throwing a certificate error.

_ **EDIT** _  
When I run this on the host:  
`curl -v https://debian-elk-log:9200 --user elastic: ******** --cacert http_ca.crt`

It throws an error:

> curl: (7) Failed to connect to debian-elk-log on port 9200: Connection refused

Same error if I use the IP instead.

thanks!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 29, 2022, 9:24pm UTC](https://discuss.elastic.co/t/x509-certificate-signed-by-unknown-authority/298551/2 "2022-03-29T21:24:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
