# "\\"\\\\xF8\\" from ASCII-8BIT to UTF-8", :error\_class=\>"LogStash::Json::GeneratorError"

**URL:** <https://discuss.elastic.co/t/xf8-from-ascii-8bit-to-utf-8-error-class-logstash-generatorerror/258668>\
**Category:** Logstash\
**Created:** [December 15, 2020, 3:54am UTC](https://discuss.elastic.co/t/xf8-from-ascii-8bit-to-utf-8-error-class-logstash-generatorerror/258668 "2020-12-15T03:54:08Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![charan\_teja\_sana](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/charan_teja_sana/32/80863_2.png) [@charan\_teja\_sana](https://discuss.elastic.co/u/charan_teja_sana)\
**Post date:** [December 15, 2020, 3:54am UTC](https://discuss.elastic.co/t/xf8-from-ascii-8bit-to-utf-8-error-class-logstash-generatorerror/258668/1 "2020-12-15T03:54:08Z")

</div>

Hello Team,

I am getting below message while running JDBC Connection against MS-SQL DB, Could you please help

**Error Message:**  
[ERROR] 2020-12-14 23:55:12.404 [[main]\>worker0] elasticsearch - An unknown error occurred sending a bulk request to Elasticsearch. We will retry indefinitely {:error\_message=\>""\xF8" from ASCII-8BIT to UTF-8", :error\_class=\>"LogStash::Json::GeneratorError", :backtrace=\>["/usr/share/logstash/logstash-core/lib/logstash/json.rb:43:in `jruby_dump'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.7.0-java/lib/logstash/outputs/elasticsearch/http_client.rb:119:in `block in bulk'", "org/jruby/RubyArray.java:2577:in `map'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.7.0-java/lib/logstash/outputs/elasticsearch/http_client.rb:119:in `block in bulk'", "org/jruby/RubyArray.java:1809:in `each'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.7.0-java/lib/logstash/outputs/elasticsearch/http_client.rb:117:in `bulk'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.7.0-java/lib/logstash/outputs/elasticsearch/common.rb:386:in `safe_bulk'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.7.0-java/lib/logstash/outputs/elasticsearch/common.rb:289:in `submit'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.7.0-java/lib/logstash/outputs/elasticsearch/common.rb:257:in `retrying_submit'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-elasticsearch-10.7.0-java/lib/logstash/outputs/elasticsearch/common.rb:36:in `multi\_receive'", "org/logstash/config/ir/compiler/OutputStrategyExt.java:138:in `multi_receive'", "org/logstash/config/ir/compiler/AbstractOutputDelegatorExt.java:121:in `multi\_receive'", "/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:293:in `block in start\_workers'"]}

**Configuration:**  
input {  
jdbc {  
jdbc\_driver\_library =\> "/etc/logstash/conf.d/mssql-jdbc-8.4.1.jre11.jar"  
jdbc\_connection\_string =\> "jdbc:sqlserver://_._._._:1433;databaseName=testdb"  
jdbc\_user =\> "_**"  
jdbc\_password =\> "**_"  
jdbc\_driver\_class =\> "com.microsoft.sqlserver.jdbc.SQLServerDriver"  
statement =\> "SELECT \* FROM sys.fn\_get\_audit\_file ('C:\SQL\_audit\*.sqlaudit',default,default)"  
schedule =\> "\* \* \* \* \*"  
}  
}

Using below setup  
Elastic stack 7.9.2  
MS-SQL 2017 Evaluation

Tried couple of methods from online which did not resolved the issue.

removed couple of fields from logstash using mutate which seems to be containing some random text, but no luck.

To use columns\_charset no idea which column is causing this and I checked the DB did not see any columns with ASCII characters in its name

Thank you in advance.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 12, 2021, 3:54am UTC](https://discuss.elastic.co/t/xf8-from-ascii-8bit-to-utf-8-error-class-logstash-generatorerror/258668/2 "2021-01-12T03:54:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
