# Xpack after success install Full of errors

**URL:** <https://discuss.elastic.co/t/xpack-after-success-install-full-of-errors/129251>\
**Category:** Elasticsearch\
**Created:** [April 24, 2018, 7:52am UTC](https://discuss.elastic.co/t/xpack-after-success-install-full-of-errors/129251 "2018-04-24T07:52:23Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![omid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/omid/32/33595_2.png) [@omid](https://discuss.elastic.co/u/omid)\
**Post date:** [April 24, 2018, 7:52am UTC](https://discuss.elastic.co/t/xpack-after-success-install-full-of-errors/129251/1 "2018-04-24T07:52:23Z")

</div>

im install after install successfully X-pack!  
but fully error!

 ![error%20xpack%20elk](https://us1.discourse-cdn.com/elastic/original/3X/2/1/218fd40ff6a1830ae68143a5fafb73a43442212e.PNG)

why !?  
how to solved error ?

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [April 24, 2018, 8:28am UTC](https://discuss.elastic.co/t/xpack-after-success-install-full-of-errors/129251/2 "2018-04-24T08:28:06Z")

</div>

Please do not post screenshots of error messages. They are hard to read on small devices and they cannot be searched. If you have errors, please take the time to copy-and-paste them into your post.

It does not look like you followed the instructions for setting up X-Pack.  
Did you run `setup-passwords` in Elasticsearch, and add the `kibana` user password to your `kibana.yml` ?

---

<div class="post-metadata">

**Author:** ![omid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/omid/32/33595_2.png) [@omid](https://discuss.elastic.co/u/omid)\
**Post date:** [April 24, 2018, 9:36am UTC](https://discuss.elastic.co/t/xpack-after-success-install-full-of-errors/129251/3 "2018-04-24T09:36:08Z")

</div>

> plugin:elasticsearch@6.2.4 Authentication Exception

> plugin:xpack\_main@6.2.4 [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }

> plugin:searchprofiler@6.2.4 [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }

> plugin:ml@6.2.4 [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }

> plugin:tilemap@6.2.4 [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }

> plugin:watcher@6.2.4 [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }

> plugin:graph@6.2.4 [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8""} }

> plugin:reporting@6.2.4 security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }

> plugin:security@6.2.4 [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }

> plugin:logstash@6.2.4 [security\_exception] missing authentication token for REST request [/\_xpack], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } }

this messages Error on pic!  
sorry send screnshot Error  
yes yes im setup-passwords in Elasticsearch, and add the kibana user password to your kibana.yml

---

<div class="post-metadata">

**Author:** ![omid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/omid/32/33595_2.png) [@omid](https://discuss.elastic.co/u/omid)\
**Post date:** [April 25, 2018, 6:59am UTC](https://discuss.elastic.co/t/xpack-after-success-install-full-of-errors/129251/4 "2018-04-25T06:59:19Z")

</div>

Why does not anyone say an answer?

---

<div class="post-metadata">

**Author:** ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)\
**Post date:** [April 25, 2018, 7:12am UTC](https://discuss.elastic.co/t/xpack-after-success-install-full-of-errors/129251/5 "2018-04-25T07:12:58Z")

</div>

Hi

In order to get some meaningful help, you would have to provide us with some information, at minimum:

1. The relevant parts of `kibana.yml`
2. The elasticsearch and kibana logs

Also you can verify that the password you have set for the `kibana` user is correct by executing

```auto
curl -u kibana:password 'http://localhost:9200/_xpack/security/_authenticate?pretty'

```

after changing `password` to the password you have set

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 25, 2018, 7:24am UTC](https://discuss.elastic.co/t/xpack-after-success-install-full-of-errors/129251/6 "2018-04-25T07:24:52Z")

</div>

Read [this](https://discuss.elastic.co/t/about-the-elasticsearch-category/21) and specifically the "Also be patient" part.

It's fine to answer on your own thread after 2 or 3 days (not including weekends) if you don't have an answer.

---

<div class="post-metadata">

**Author:** ![omid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/omid/32/33595_2.png) [@omid](https://discuss.elastic.co/u/omid)\
**Post date:** [April 25, 2018, 7:39am UTC](https://discuss.elastic.co/t/xpack-after-success-install-full-of-errors/129251/7 "2018-04-25T07:39:32Z")

</div>

> [@ikakavas](#):
>
> word to the password y

thanks  
im okay username and password !  
but  
after enter user&pass kibana  
502 Bad Gateway

my server elasticsearch,nginx,kibana,logstash is up and active services!  
my server ubuntu 16.04.3

but isntall xpack, xpack elasticsearchmkibana,logstash after install my elk is down!  
and fully error msg!

now kibana is down!

---

<div class="post-metadata">

**Author:** ![omid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/omid/32/33595_2.png) [@omid](https://discuss.elastic.co/u/omid)\
**Post date:** [April 25, 2018, 7:42am UTC](https://discuss.elastic.co/t/xpack-after-success-install-full-of-errors/129251/8 "2018-04-25T07:42:07Z")

</div>

sorry mester!  
I forgot the rules 😉

---

<div class="post-metadata">

**Author:** ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)\
**Post date:** [April 26, 2018, 6:17am UTC](https://discuss.elastic.co/t/xpack-after-success-install-full-of-errors/129251/9 "2018-04-26T06:17:59Z")

</div>

Hi,

Please take the time to describe your setup architecture and describe in detail the errors you are getting (it would be helpful to get the logs from Kibana and Elasticsearch, not just the errors in Kibana UI )

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 24, 2018, 6:29am UTC](https://discuss.elastic.co/t/xpack-after-success-install-full-of-errors/129251/10 "2018-05-24T06:29:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
