# Xpack enabled elasticsearch master node authentication error in kibana

**URL:** https://discuss.elastic.co/t/xpack-enabled-elasticsearch-master-node-authentication-error-in-kibana/146222
**Category:** Kibana
**Created:** [August 27, 2018, 6:11pm UTC](https://discuss.elastic.co/t/xpack-enabled-elasticsearch-master-node-authentication-error-in-kibana/146222 "2018-08-27T18:11:44Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![rijinmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rijinmp/32/24634_2.png) [@rijinmp](https://discuss.elastic.co/u/rijinmp)
#### Post date: [August 27, 2018, 6:11pm UTC](https://discuss.elastic.co/t/xpack-enabled-elasticsearch-master-node-authentication-error-in-kibana/146222/1 "2018-08-27T18:11:44Z")

</div>

Elasticsearch and Kibana ( 6.3.2 ) installed . Xpack is enabled. (ELK and Xpack in ( 10.100.234.241))

Working well . ( In kibana.yml username passwords entered . Authentication success . elastic:changeme )

For a cluster creation I am added two lines in elasticsearch.yml . This ES is master node.

node.master: true  
node.data: false

Then kibana showing error message

[warning][license][xpack] License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security\_exception] failed to authenticate user [elastic], with { header={ WWW-Authenticate="Basic realm="security" charset="UTF-8"" } } :: {"path":"/\_xpack","statusCode":401,"response":"{"error":{"root\_cause":[{"type":"security\_exception","reason":"failed to authenticate user [elastic]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}}],"type":"security\_exception","reason":"failed to authenticate user [elastic]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}},"status":401}","wwwAuthenticateDirective":"Basic realm="security" charset="UTF-8""}

If i am disabling new lines by # in ES  
#node.master: true  
#node.data: false

Then error will go . And ES and Kibana works well .

How it is happening?

I am runninng one another machine for ES as data node ( 10.100.234.240)

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [August 28, 2018, 3:57am UTC](https://discuss.elastic.co/t/xpack-enabled-elasticsearch-master-node-authentication-error-in-kibana/146222/2 "2018-08-28T03:57:51Z")

</div>

Please provide your Elasticsearch logs.

As best I can tell, your data node is not actually connected to your cluster, so when you disabled the "data" role on your master node, you no longer had anywhere to store you data, and your cluster turned red

A cluster with 1 master-only node, and 1 dats-only node is very strange. What are you trying to achieve?

---

<div class="post-metadata">

### Author: ![rijinmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rijinmp/32/24634_2.png) [@rijinmp](https://discuss.elastic.co/u/rijinmp)
#### Post date: [August 28, 2018, 7:48am UTC](https://discuss.elastic.co/t/xpack-enabled-elasticsearch-master-node-authentication-error-in-kibana/146222/3 "2018-08-28T07:48:44Z")

</div>

ES Master node log:

at io.netty.channel.DefaultChannelPipeline.fireChannelRead(DefaultChannelPipeline.java:935) [netty-transport-4.1.16.Final.jar:4.1.16.Final]  
at io.netty.channel.nio.AbstractNioByteChannel$NioByteUnsafe.read(AbstractNioByteChannel.java:134) [netty-transport-4.1.16.Final.jar:4.1.16.Final]  
at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:645) [netty-transport-4.1.16.Final.jar:4.1.16.Final]  
at io.netty.channel.nio.NioEventLoop.processSelectedKeysPlain(NioEventLoop.java:545) [netty-transport-4.1.16.Final.jar:4.1.16.Final]  
at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:499) [netty-transport-4.1.16.Final.jar:4.1.16.Final]  
at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:459) [netty-transport-4.1.16.Final.jar:4.1.16.Final]  
at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:858) [netty-common-4.1.16.Final.jar:4.1.16.Final] at java.lang.Thread.run(Thread.java:748) [?:1.8.0\_161]

[2018-08-28T13:19:55,481][INFO][o.e.x.s.a.AuthenticationService] [Redhat] Authentication of [elastic] was terminated by realm [reserved] - failed to authenticate user [elastic]

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [August 28, 2018, 8:06am UTC](https://discuss.elastic.co/t/xpack-enabled-elasticsearch-master-node-authentication-error-in-kibana/146222/4 "2018-08-28T08:06:38Z")

</div>

We need a bit more of the log than that. Look for anything marked as `[ERROR]` or `[WARN]`.

---

<div class="post-metadata">

### Author: ![rijinmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rijinmp/32/24634_2.png) [@rijinmp](https://discuss.elastic.co/u/rijinmp)
#### Post date: [August 30, 2018, 7:04pm UTC](https://discuss.elastic.co/t/xpack-enabled-elasticsearch-master-node-authentication-error-in-kibana/146222/5 "2018-08-30T19:04:55Z")

</div>

Hi @TimV Thank you .. Actually your reply in one another discussion is helped me to solve this issue.

[[X-Pack Authentication issue - #8 by TimV](https://discuss.elastic.co/t/x-pack-authentication-issue/121632/8)

> [@X-Pack Authentication issue](https://discuss.elastic.co/t/x-pack-authentication-issue/121632/5):
>
> I have the same situation. Tried time ago to install x-pack. Issues on configuring / making it running. Then I removed it and now I'm giving another try, without success... ./setup-passwords interactive Failed to authenticate user 'elastic' against [http://10.150.2.116:9302/\_xpack/security/\_authenticate?pretty](http://10.150.2.116:9302/_xpack/security/_authenticate?pretty) Possible causes include: The password for the 'elastic' user has already been changed on this cluster Your elasticsearch node is running against a different keystore This tool used th…

_Option 3:_ Delete all security data ]

As per your suggestion I am Deleted all Indexes and indexed one more time . I think the security indexes are cleared. Now cluster is working together .

Shards and replicas are created.

Now I recognized my fault.

I am indexed the the data in to elasticsearch nodes. That time they are not in a cluster. Just two different machines. Because of that no replicas are created.

When I am connected each other .. they cant connect with out replicas and with old security index.  
Then I am deleted whole index . And indexed doc one more time to fresh cluster. Then its worked.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 27, 2018, 7:05pm UTC](https://discuss.elastic.co/t/xpack-enabled-elasticsearch-master-node-authentication-error-in-kibana/146222/6 "2018-09-27T19:05:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
