# Xpack enabled elasticsearch master node authentication error in kibana

**URL:** https://discuss.elastic.co/t/xpack-enabled-elasticsearch-master-node-authentication-error-in-kibana/146222
**Category:** Kibana
**Created:** [August 27, 2018, 6:11pm UTC](https://discuss.elastic.co/t/xpack-enabled-elasticsearch-master-node-authentication-error-in-kibana/146222 "2018-08-27T18:11:44Z")
**Posts on this page:** 1
**Showing post:** 5

<div class="post-metadata">

### Author: ![rijinmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rijinmp/32/24634_2.png) [@rijinmp](https://discuss.elastic.co/u/rijinmp)
#### Post date: [August 30, 2018, 7:04pm UTC](https://discuss.elastic.co/t/xpack-enabled-elasticsearch-master-node-authentication-error-in-kibana/146222/5 "2018-08-30T19:04:55Z")

</div>

Hi @TimV Thank you .. Actually your reply in one another discussion is helped me to solve this issue.

[[X-Pack Authentication issue - #8 by TimV](https://discuss.elastic.co/t/x-pack-authentication-issue/121632/8)

> [@X-Pack Authentication issue](https://discuss.elastic.co/t/x-pack-authentication-issue/121632/5):
>
> I have the same situation. Tried time ago to install x-pack. Issues on configuring / making it running. Then I removed it and now I'm giving another try, without success... ./setup-passwords interactive Failed to authenticate user 'elastic' against [http://10.150.2.116:9302/\_xpack/security/\_authenticate?pretty](http://10.150.2.116:9302/_xpack/security/_authenticate?pretty) Possible causes include: The password for the 'elastic' user has already been changed on this cluster Your elasticsearch node is running against a different keystore This tool used th…

_Option 3:_ Delete all security data ]

As per your suggestion I am Deleted all Indexes and indexed one more time . I think the security indexes are cleared. Now cluster is working together .

Shards and replicas are created.

Now I recognized my fault.

I am indexed the the data in to elasticsearch nodes. That time they are not in a cluster. Just two different machines. Because of that no replicas are created.

When I am connected each other .. they cant connect with out replicas and with old security index.  
Then I am deleted whole index . And indexed doc one more time to fresh cluster. Then its worked.

---

_[View the full topic](https://discuss.elastic.co/t/xpack-enabled-elasticsearch-master-node-authentication-error-in-kibana/146222)._
