# Xpack Error in Elastic search. xpack settings not recognized

**URL:** <https://discuss.elastic.co/t/xpack-error-in-elastic-search-xpack-settings-not-recognized/200358>\
**Category:** Elasticsearch\
**Created:** [September 20, 2019, 6:55am UTC](https://discuss.elastic.co/t/xpack-error-in-elastic-search-xpack-settings-not-recognized/200358 "2019-09-20T06:55:55Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![katara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/katara/32/60143_2.png) [@katara](https://discuss.elastic.co/u/katara)\
**Post date:** [September 20, 2019, 6:55am UTC](https://discuss.elastic.co/t/xpack-error-in-elastic-search-xpack-settings-not-recognized/200358/1 "2019-09-20T06:55:56Z")

</div>

Hi,  
I am using Elasticsearch 7.1.0,  
and im setting up my xpack such as:  
`xpack.security.enabled: true discovery.type: single-node`  
in my elasticsearch.yml.  
Then, i ran  
`>elasticsearch-setup-passwords interactive`

```
ERROR: Elasticsearch keystore file is missing [D:\ELK 7.1.0\elasticsearch\elasti
csearch-7.1.0\config\elasticsearch.keystore]

```

Then i tried creating the same by  
`>elasticsearch-keystore create`

```
Created elasticsearch keystore in D:\ELK 7.1.0\elasticsearch\elasticsearch-7.1.0
\config`

```

Then im trying the interactive command again for which im getting,  
`>elasticsearch-setup-passwords interactive`

```
Unexpected response code [500] from calling GET http://127.0.0.1:9200/_security/
_authenticate?pretty
It doesn't look like the X-Pack security feature is enabled on this Elasticsearc
h node.
Please check if you have enabled X-Pack security in your elasticsearch.yml confi
guration file.

ERROR: X-Pack Security is disabled by configuration.`

```

My xpack is enabled in my yml file.  
What am i missing? Please help me.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 20, 2019, 7:03am UTC](https://discuss.elastic.co/t/xpack-error-in-elastic-search-xpack-settings-not-recognized/200358/2 "2019-09-20T07:03:34Z")

</div>

From version 7.2 (?) some security features are available with the free basic license. Prior to that a commercial license was required. I would recommend you upgrade.

---

<div class="post-metadata">

**Author:** ![katara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/katara/32/60143_2.png) [@katara](https://discuss.elastic.co/u/katara)\
**Post date:** [September 20, 2019, 7:56am UTC](https://discuss.elastic.co/t/xpack-error-in-elastic-search-xpack-settings-not-recognized/200358/3 "2019-09-20T07:56:13Z")

</div>

when i reinstalled 7.1.0 it worked fine.  
leaving no spaces or blank lines after xpack settings in my yml file.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 18, 2019, 7:56am UTC](https://discuss.elastic.co/t/xpack-error-in-elastic-search-xpack-settings-not-recognized/200358/4 "2019-10-18T07:56:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
