# Xpack on Elasticsearch 5.5

**URL:** <https://discuss.elastic.co/t/xpack-on-elasticsearch-5-5/93092>\
**Category:** Elasticsearch\
**Created:** [July 14, 2017, 12:19am UTC](https://discuss.elastic.co/t/xpack-on-elasticsearch-5-5/93092 "2017-07-14T00:19:18Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![chandu507.m](https://avatars.discourse-cdn.com/v4/letter/c/45deac/32.png) [@chandu507.m](https://discuss.elastic.co/u/chandu507.m)\
**Post date:** [July 14, 2017, 12:19am UTC](https://discuss.elastic.co/t/xpack-on-elasticsearch-5-5/93092/1 "2017-07-14T00:19:18Z")

</div>

Hello,

I am trying to install xpack for elasticsearch 5,5 version in LINUX machine. I am facing the below listed exception.PFB:  
-bash-4.2$ bin/elasticsearch-plugin install x-pack --batch  
Exception in thread "main" javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target  
at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)  
at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1949)  
at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:302)  
at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:296)  
at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1514)  
at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:216)  
at sun.security.ssl.Handshaker.processLoop(Handshaker.java:1026)  
at sun.security.ssl.Handshaker.process\_record(Handshaker.java:961)  
at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1062)  
at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1375)  
at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1403)  
at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1387)  
at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559)  
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185)  
at sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(HttpsURLConnectionImpl.java:153)  
at org.elasticsearch.plugins.InstallPluginCommand.urlExists(InstallPluginCommand.java:300)  
at org.elasticsearch.plugins.InstallPluginCommand.getElasticUrl(InstallPluginCommand.java:267)  
at org.elasticsearch.plugins.InstallPluginCommand.download(InstallPluginCommand.java:223)  
at org.elasticsearch.plugins.InstallPluginCommand.execute(InstallPluginCommand.java:215)  
at org.elasticsearch.plugins.InstallPluginCommand.execute(InstallPluginCommand.java:201)  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67)  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)  
at org.elasticsearch.cli.MultiCommand.execute(MultiCommand.java:69)  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)  
at org.elasticsearch.cli.Command.main(Command.java:88)  
at org.elasticsearch.plugins.PluginCli.main(PluginCli.java:47)  
Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target  
at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:387)  
at sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:292)  
at sun.security.validator.Validator.validate(Validator.java:260)  
at sun.security.ssl.X509TrustManagerImpl.validate(X509TrustManagerImpl.java:324)  
at sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:229)  
at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:124)  
at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1496)  
... 21 more  
Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target  
at sun.security.provider.certpath.SunCertPathBuilder.build(SunCertPathBuilder.java:141)  
at sun.security.provider.certpath.SunCertPathBuilder.engineBuild(SunCertPathBuilder.java:126)  
at java.security.cert.CertPathBuilder.build(CertPathBuilder.java:280)  
at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:382)  
... 27 more

Please share your suggestions ....

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [July 17, 2017, 8:50pm UTC](https://discuss.elastic.co/t/xpack-on-elasticsearch-5-5/93092/2 "2017-07-17T20:50:06Z")

</div>

Hi Chandra,

Is there a proxy or anything that could be blocking the plugin installer from getting to it? The easiest thing I can suggest is to see if you can download the x-pack.zip file from that machine and do the offline install.

`wget https://artifacts.elastic.co/downloads/packs/x-pack/x-pack-5.5.0.zip`

`bin/elasticsearch-plugin install file:///<path of your zip file>/x-pack-5.5.0.zip`

Note that the zip file URL above is for the combined X-Pack zip which can be used to install X-Pack on Elasticsearch, Logstash, and Kibana.

Please let us know if that works OK.

Regards,  
Lee

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 14, 2017, 8:50pm UTC](https://discuss.elastic.co/t/xpack-on-elasticsearch-5-5/93092/3 "2017-08-14T20:50:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
