# Yum install fails

**URL:** <https://discuss.elastic.co/t/yum-install-fails/215936>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [January 21, 2020, 6:10pm UTC](https://discuss.elastic.co/t/yum-install-fails/215936 "2020-01-21T18:10:02Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jathin](https://avatars.discourse-cdn.com/v4/letter/j/ea666f/32.png) [@Jathin](https://discuss.elastic.co/u/Jathin)\
**Post date:** [January 21, 2020, 6:10pm UTC](https://discuss.elastic.co/t/yum-install-fails/215936/1 "2020-01-21T18:10:02Z")

</div>

```
yum install filebeat-7.5.*
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package filebeat.x86_64 0:7.5.1-1 will be updated
---> Package filebeat.x86_64 0:7.5.2-1 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

=======================================================================================================================================================================================
 Package Arch Version Repository Size
=======================================================================================================================================================================================
Updating:
 filebeat x86_64 7.5.2-1 elastic-7.x 23 M

Transaction Summary
=======================================================================================================================================================================================
Upgrade 1 Package

Total download size: 23 M
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
filebeat-7.5.2-x86_64.rpm FAILED
https://artifacts.elastic.co/packages/7.x/yum/7.5.2/filebeat-7.5.2-x86_64.rpm: [Errno 14] HTTPS Error 404 - Not Found ] 0.0 B/s | 0 B --:--:-- ETA
Trying other mirror.
To address this issue please refer to the below wiki article

https://wiki.centos.org/yum-errors

If above article doesn't help to resolve this issue please use https://bugs.centos.org/.

Error downloading packages:
  filebeat-7.5.2-1.x86_64: [Errno 256] No more mirrors to try.

```

it seems yum metadata is updated with new release but i cant install latest as the contents are not released.. this is true for other elasticsearch and other elk binaries installed in similar fashion

---

<div class="post-metadata">

**Author:** ![Jathin](https://avatars.discourse-cdn.com/v4/letter/j/ea666f/32.png) [@Jathin](https://discuss.elastic.co/u/Jathin)\
**Post date:** [January 21, 2020, 6:12pm UTC](https://discuss.elastic.co/t/yum-install-fails/215936/2 "2020-01-21T18:12:25Z")

</div>

it fails when i try with generic command as below.. it still tries to pick 7.5.2 and fails with 404

```
yum install filebeat
```

---

<div class="post-metadata">

**Author:** ![jsoriano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jsoriano/32/27920_2.png) [@jsoriano](https://discuss.elastic.co/u/jsoriano)\
**Post date:** [January 21, 2020, 6:34pm UTC](https://discuss.elastic.co/t/yum-install-fails/215936/3 "2020-01-21T18:34:33Z")

</div>

Hi @Jathin,

I have just tried to install and upgrade filebeat on Centos 7 [using yum](https://www.elastic.co/guide/en/beats/filebeat/7.5/setup-repositories.html#_yum) and it works fine for me.

> [@Jathin](#):
>
> [https://artifacts.elastic.co/packages/7.x/yum/7.5.2/filebeat-7.5.2-x86\_64.rpm:](https://artifacts.elastic.co/packages/7.x/yum/7.5.2/filebeat-7.5.2-x86_64.rpm:) [Errno 14] HTTPS Error 404 - Not Found ] 0.0 B/s | 0 B --:--:-- ETA

Also manually downloading from this URL works for me.

Is it possible that your machine is behind a proxy?

Could you provide the output of the following command?

```auto
curl -I -v https://artifacts.elastic.co/packages/7.x/yum/7.5.2/filebeat-7.5.2-x86_64.rpm

```

---

<div class="post-metadata">

**Author:** ![Jathin](https://avatars.discourse-cdn.com/v4/letter/j/ea666f/32.png) [@Jathin](https://discuss.elastic.co/u/Jathin)\
**Post date:** [January 21, 2020, 6:37pm UTC](https://discuss.elastic.co/t/yum-install-fails/215936/4 "2020-01-21T18:37:14Z")

</div>

It works fine for me now.. but it seems for close to a hour before the release it was failing with 404

---

<div class="post-metadata">

**Author:** ![jsoriano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jsoriano/32/27920_2.png) [@jsoriano](https://discuss.elastic.co/u/jsoriano)\
**Post date:** [January 21, 2020, 6:42pm UTC](https://discuss.elastic.co/t/yum-install-fails/215936/5 "2020-01-21T18:42:04Z")

</div>

Filebeat 7.5.2 has been released today, it seems that something happened with the propagation of the new packages.

---

<div class="post-metadata">

**Author:** ![Jathin](https://avatars.discourse-cdn.com/v4/letter/j/ea666f/32.png) [@Jathin](https://discuss.elastic.co/u/Jathin)\
**Post date:** [January 21, 2020, 9:33pm UTC](https://discuss.elastic.co/t/yum-install-fails/215936/6 "2020-01-21T21:33:58Z")

</div>

But i feel till 7.5.2 is officially released below command should have pulled down 7.5.1 deliverable. But somehow it was trying to pull down 7.5.2 and failing with 404. the error caused all autoscaling nodes to fail boot up for close to one hour. instance boot up scripts were looking for latest filebeat deliverable.

```
yum install filebeat 

```

is this not the correct way to pull the latest filebeat deliverable ? i am just trying to find the best way so that i can update my instance boot up script so that it does not happen again during future releases.

---

<div class="post-metadata">

**Author:** ![jsoriano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jsoriano/32/27920_2.png) [@jsoriano](https://discuss.elastic.co/u/jsoriano)\
**Post date:** [January 22, 2020, 9:41am UTC](https://discuss.elastic.co/t/yum-install-fails/215936/7 "2020-01-22T09:41:33Z")

</div>

> [@Jathin](#):
>
> But i feel till 7.5.2 is officially released below command should have pulled down 7.5.1 deliverable. But somehow it was trying to pull down 7.5.2 and failing with 404. the error caused all autoscaling nodes to fail boot up for close to one hour. instance boot up scripts were looking for latest filebeat deliverable.

Yep, this has been unexpected, this shouldn't happen in future releases.

> [@Jathin](#):
>
> ```auto
> yum install filebeat 
> 
> ```
> 
> is this not the correct way to pull the latest filebeat deliverable ? i am just trying to find the best way so that i can update my instance boot up script so that it does not happen again during future releases.

Yes, this command should always work to install the latest available version in the repository configured in the machine.  
In any case I would recommend you to use pinned versions on automation so you can do controlled upgrades.

---

<div class="post-metadata">

**Author:** ![Jathin](https://avatars.discourse-cdn.com/v4/letter/j/ea666f/32.png) [@Jathin](https://discuss.elastic.co/u/Jathin)\
**Post date:** [January 22, 2020, 2:23pm UTC](https://discuss.elastic.co/t/yum-install-fails/215936/8 "2020-01-22T14:23:14Z")

</div>

Thanks for your response. if it was unexpected one time situation then then it should be ok. i will update my scripts to better handle this situation.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 19, 2020, 2:23pm UTC](https://discuss.elastic.co/t/yum-install-fails/215936/9 "2020-02-19T14:23:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
