# Top

**URL:** https://discuss.elastic.co/top.md?page=1&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 2

---

## [Who out there is still using Kibana 3?](https://discuss.elastic.co/t/who-out-there-is-still-using-kibana-3/24230)

<div class="topic-metadata">

**Author:** [@Asimov4](https://discuss.elastic.co/u/Asimov4)\
**Replies:** 83\
**Last updated:** [September 27, 2016, 2:29pm UTC](https://discuss.elastic.co/t/who-out-there-is-still-using-kibana-3/24230 "2016-09-27T14:29:29Z")

</div>

Hi all! I just wanted to know if anyone else was still using Kibana 3. We are not migrating to Kibana 4 yet because it is a bit harder to deploy in our environment and does not support a few important features for us. W…

---

## [New documentation Issues](https://discuss.elastic.co/t/new-documentation-issues/377445)

<div class="topic-metadata">

**Author:** [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Replies:** 42\
**Last updated:** [May 19, 2025, 10:32pm UTC](https://discuss.elastic.co/t/new-documentation-issues/377445 "2025-05-19T22:32:19Z")

</div>

Hello, Are there any plans to rolback the changes on the Documentation site and also on the new APIs documentation? Since the changes it is extremely hard to be able to find anything, they have been bad in terms of Use…

---

## [Elasticsearch-rails & -ruby are abandoned](https://discuss.elastic.co/t/elasticsearch-rails-ruby-are-abandoned/105610)

<div class="topic-metadata">

**Author:** [@kshnurov](https://discuss.elastic.co/u/kshnurov)\
**Replies:** 17\
**Last updated:** [November 3, 2017, 1:15pm UTC](https://discuss.elastic.co/t/elasticsearch-rails-ruby-are-abandoned/105610 "2017-11-03T13:15:45Z")

</div>

It was pointed out 3 months ago here and nothing has changed - 66 PRs and a lot of bugs not being fixed. Latest commit was made 5+ months ago. elasticsearch-rails will be incompatible with an upcoming Rails 5.2 and it …

---

## [Kibana did not load properly. Check the server output for more information - Kibana not working](https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-not-working/186224)

<div class="topic-metadata">

**Author:** [@Susmit07](https://discuss.elastic.co/u/Susmit07)\
**Replies:** 17\
**Last updated:** [August 6, 2019, 1:45pm UTC](https://discuss.elastic.co/t/kibana-did-not-load-properly-check-the-server-output-for-more-information-kibana-not-working/186224 "2019-08-06T13:45:44Z")

</div>

Getting this error not able to view Kibana outside VM. Did a F12 on the browser and found the below logs Refused to execute inline script because it violates the following Content Security Policy directive: "script-src …

---

## [Logstash not showing any output (SOLVED)](https://discuss.elastic.co/t/logstash-not-showing-any-output-solved/28636)

<div class="topic-metadata">

**Author:** [@lookingcloudy](https://discuss.elastic.co/u/lookingcloudy)\
**Replies:** 30\
**Last updated:** [May 23, 2017, 6:59am UTC](https://discuss.elastic.co/t/logstash-not-showing-any-output-solved/28636 "2017-05-23T06:59:26Z")

</div>

I'm starting off with Logstash, working through the tutorials. I find the plugin documentation very lacking for someone with no experience with logstash. Here is the config file I am starting with: input { file {…

---

## [Want to Process Multiple Files that exist in One Folder](https://discuss.elastic.co/t/want-to-process-multiple-files-that-exist-in-one-folder/28384)

<div class="topic-metadata">

**Author:** [@bhutchinson](https://discuss.elastic.co/u/bhutchinson)\
**Replies:** 9\
**Last updated:** [September 1, 2015, 9:05pm UTC](https://discuss.elastic.co/t/want-to-process-multiple-files-that-exist-in-one-folder/28384 "2015-09-01T21:05:10Z")

</div>

Windows 7 Elasticsearch v1.7.0 Logstash v1.5.4 I have multiple files that I want to run through Logstash and have Logstash insert into elasticsearch. Each of my files are apache access files. All my files are in one…

---

## [How to resolve elasticsearch status red](https://discuss.elastic.co/t/how-to-resolve-elasticsearch-status-red/8401)

<div class="topic-metadata">

**Author:** [@Yuhan](https://discuss.elastic.co/u/Yuhan)\
**Replies:** 18\
**Last updated:** [March 31, 2017, 10:42pm UTC](https://discuss.elastic.co/t/how-to-resolve-elasticsearch-status-red/8401 "2017-03-31T22:42:46Z")

</div>

Hi all, I got "No Active Record" exception on some index but works for other. The health was indicating status=red, and there are unassigned\_shards. { "cluster\_name" : "elasticsearch", "status" : "red", …

---

## [Ingesting documents (pdf, word, .txt) to elasticsearch](https://discuss.elastic.co/t/ingesting-documents-pdf-word-txt-to-elasticsearch/75128)

<div class="topic-metadata">

**Author:** [@Mark\_Dendrix\_Garcia](https://discuss.elastic.co/u/Mark_Dendrix_Garcia)\
**Replies:** 30\
**Last updated:** [February 21, 2017, 1:09am UTC](https://discuss.elastic.co/t/ingesting-documents-pdf-word-txt-to-elasticsearch/75128 "2017-02-21T01:09:56Z")

</div>

Hi I want to ask about how can this be done, so here's the scenario my group and I had a usecase about logs which we technically use logstash. The goal of the "logs usecase" is to ingest and analyse all logs . Every mach…

---

## [Failed to start Elasticsearch. (code=exited, status=1/FAILURE)](https://discuss.elastic.co/t/failed-to-start-elasticsearch-code-exited-status-1-failure/217898)

<div class="topic-metadata">

**Author:** [@gilang\_bilbisri](https://discuss.elastic.co/u/gilang_bilbisri)\
**Replies:** 16\
**Last updated:** [February 6, 2020, 3:28am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-code-exited-status-1-failure/217898 "2020-02-06T03:28:12Z")

</div>

Hallo i was try to make a single node of elasticsearch on my centos 7. In the first installation of elasticsearch after i've done install centos 7.its just fine,the elasticsearch works very well. But im very confused ,…

---

## [How to save dashboard as json file](https://discuss.elastic.co/t/how-to-save-dashboard-as-json-file/24561)

<div class="topic-metadata">

**Author:** [@schadalawada](https://discuss.elastic.co/u/schadalawada)\
**Replies:** 14\
**Last updated:** [July 11, 2016, 11:00am UTC](https://discuss.elastic.co/t/how-to-save-dashboard-as-json-file/24561 "2016-07-11T11:00:28Z")

</div>

Hi, I have created a dashboard with multiple visualizations. how can I export dashboard with visualizations as json file, so that I can use it to load from a link on my web page?

---

## [Warning 'Relying on default value of \`pipeline.ecs\_compatibility' after updating to logstash 7.16.1](https://discuss.elastic.co/t/warning-relying-on-default-value-of-pipeline-ecs-compatibility-after-updating-to-logstash-7-16-1/292018)

<div class="topic-metadata">

**Author:** [@d71247](https://discuss.elastic.co/u/d71247)\
**Replies:** 22\
**Last updated:** [March 23, 2022, 2:52pm UTC](https://discuss.elastic.co/t/warning-relying-on-default-value-of-pipeline-ecs-compatibility-after-updating-to-logstash-7-16-1/292018 "2022-03-23T14:52:31Z")

</div>

Hello, I just updated my Logstash to 7.16.1... but I noticed errors in my conf when starting Logstash.\* the same conf of Logstash works well in version 7.9.1 How do to fix this warning ? Anyone else experienced this? …

---

## [Logstash is not creating Indexes - SOLVED](https://discuss.elastic.co/t/logstash-is-not-creating-indexes-solved/57984)

<div class="topic-metadata">

**Author:** [@Vishal\_Sharma1](https://discuss.elastic.co/u/Vishal_Sharma1)\
**Replies:** 20\
**Last updated:** [August 29, 2016, 2:22pm UTC](https://discuss.elastic.co/t/logstash-is-not-creating-indexes-solved/57984 "2016-08-29T14:22:53Z")

</div>

i have logstash running and its suddnely stopped creating indexes. I have installed logstash from the repository on Centos7. service logstash configtest is ok sudo service logstash start starts log stash properly. In…

---

## [Append to existing field](https://discuss.elastic.co/t/append-to-existing-field/16423)

<div class="topic-metadata">

**Author:** [@bruskie24](https://discuss.elastic.co/u/bruskie24)\
**Replies:** 9\
**Last updated:** [April 10, 2020, 6:54am UTC](https://discuss.elastic.co/t/append-to-existing-field/16423 "2020-04-10T06:54:27Z")

</div>

In looking at the Elasticsearch documentation, specifically the Update API, it doesn't appear that Elasticsearch has the functionality to append to an array, it can "update" it with new values, but not preserve the e…

---

## [How to create my own document\_id in logstash?](https://discuss.elastic.co/t/how-to-create-my-own-document-id-in-logstash/1416)

<div class="topic-metadata">

**Author:** [@elastic\_paul](https://discuss.elastic.co/u/elastic_paul)\
**Replies:** 18\
**Last updated:** [June 7, 2017, 11:19am UTC](https://discuss.elastic.co/t/how-to-create-my-own-document-id-in-logstash/1416 "2017-06-07T11:19:05Z")

</div>

I would like to create my own document\_id to avoid duplication. I would like to make the document\_id as an MD5 hash of two fields; "ip" and "sha1\_fingerprint". eg; in pseudo code: md5\_hex( "ip" + " sha1\_fingerprin…

---

## [Date format for YYYY-mm-dd HH:mm:ss,SSS?](https://discuss.elastic.co/t/date-format-for-yyyy-mm-dd-hh-mm-ss-sss/80702)

<div class="topic-metadata">

**Author:** [@ZillaG](https://discuss.elastic.co/u/ZillaG)\
**Replies:** 10\
**Last updated:** [April 4, 2017, 1:41pm UTC](https://discuss.elastic.co/t/date-format-for-yyyy-mm-dd-hh-mm-ss-sss/80702 "2017-04-04T13:41:25Z")

</div>

I looked at the Elasticsearch date format docs after reading this post and can't find the format for a date of the form YYYY-mm-dd HH:mm:ss,SSSS, e.g., 2017-03-29 10:00:00,123, where there's a comma for the milliseconds …

---

## [How to move Elasticsearch indexes from one server to another one](https://discuss.elastic.co/t/how-to-move-elasticsearch-indexes-from-one-server-to-another-one/31909)

<div class="topic-metadata">

**Author:** [@billy6](https://discuss.elastic.co/u/billy6)\
**Replies:** 14\
**Last updated:** [March 20, 2017, 8:29pm UTC](https://discuss.elastic.co/t/how-to-move-elasticsearch-indexes-from-one-server-to-another-one/31909 "2017-03-20T20:29:27Z")

</div>

I would like to know how to move Elasticsearch indexes from one server to another one, with different versions of the software. Is there any plugin for it? Could I do it with ES head plugin?

---

## [Rename index in Elasticsearch](https://discuss.elastic.co/t/rename-index-in-elasticsearch/190166)

<div class="topic-metadata">

**Author:** [@smerzlyakov](https://discuss.elastic.co/u/smerzlyakov)\
**Replies:** 10\
**Last updated:** [July 22, 2019, 4:36am UTC](https://discuss.elastic.co/t/rename-index-in-elasticsearch/190166 "2019-07-22T04:36:26Z")

</div>

Hello. Why it is not possible to do in Kibana? You can delete index, but cannot rename. Will you plan to add this feature? How to rename index in Elasticsearch easilly?

---

## [How export logs from Kibana 4?](https://discuss.elastic.co/t/how-export-logs-from-kibana-4/186)

<div class="topic-metadata">

**Author:** [@Dnyaneshwar](https://discuss.elastic.co/u/Dnyaneshwar)\
**Replies:** 9\
**Last updated:** [August 4, 2020, 8:53am UTC](https://discuss.elastic.co/t/how-export-logs-from-kibana-4/186 "2020-08-04T08:53:32Z")

</div>

I have tried the export button in kibana 4, but it export the table with timestamp and count column.. there is not logs. How export logs from Kibana 4 ? Thanks

---

## [Get all documents from an index](https://discuss.elastic.co/t/get-all-documents-from-an-index/86977)

<div class="topic-metadata">

**Author:** [@McElroy](https://discuss.elastic.co/u/McElroy)\
**Replies:** 9\
**Last updated:** [May 24, 2017, 1:49pm UTC](https://discuss.elastic.co/t/get-all-documents-from-an-index/86977 "2017-05-24T13:49:47Z")

</div>

Is it possible to get all the documents from an index? I tried it with python and requests but always get query\_phase\_execution\_exception","reason":"Result window is too large, from + size must be less than or equal to: …

---

## [Decrease the number of shards](https://discuss.elastic.co/t/decrease-the-number-of-shards/86332)

<div class="topic-metadata">

**Author:** [@mitabrev](https://discuss.elastic.co/u/mitabrev)\
**Replies:** 11\
**Last updated:** [May 21, 2017, 9:31pm UTC](https://discuss.elastic.co/t/decrease-the-number-of-shards/86332 "2017-05-21T21:31:31Z")

</div>

Hi, I need help with changing the number of shards. I got basically default settings, ELK stack 5.4. Already had some indexes, but had 5 shards. Would like to change to two. I deleted existing indexes (not the system …

---

## [\[Solved\] Run Elasticsearch in network interface using IP@](https://discuss.elastic.co/t/solved-run-elasticsearch-in-network-interface-using-ip/91627)

<div class="topic-metadata">

**Author:** [@Chemse](https://discuss.elastic.co/u/Chemse)\
**Replies:** 9\
**Last updated:** [July 4, 2017, 8:23am UTC](https://discuss.elastic.co/t/solved-run-elasticsearch-in-network-interface-using-ip/91627 "2017-07-04T08:23:52Z")

</div>

Hello, Now I am using ES, it's run on localhost (127.0.0.1); I want to run it in network interface level (10.80.X.X); I modified elasticsearch.yml I tried this discovery.zen.ping.unicast.hosts: \["10.85.X.X","127…

---

## [Apt repo change? "E: Repository 'https://artifacts.elastic.co/packages/8.x/apt stable InRelease' changed its 'Origin' value from 'elastic' to 'Artifactory'"](https://discuss.elastic.co/t/apt-repo-change-e-repository-https-artifacts-elastic-co-packages-8-x-apt-stable-inrelease-changed-its-origin-value-from-elastic-to-artifactory/374021)

<div class="topic-metadata">

**Author:** [@juju](https://discuss.elastic.co/u/juju)\
**Replies:** 22\
**Last updated:** [February 7, 2025, 10:56am UTC](https://discuss.elastic.co/t/apt-repo-change-e-repository-https-artifacts-elastic-co-packages-8-x-apt-stable-inrelease-changed-its-origin-value-from-elastic-to-artifactory/374021 "2025-02-07T10:56:42Z")

</div>

\# apt update Get:2 http://nova.clouds.archive.ubuntu.com/ubuntu jammy InRelease \[270 kB\] Hit:3 http://security.ubuntu.com/ubuntu jammy-security InRelea…

---

## [Getting Failed to execute phase \[query\], all shards failed](https://discuss.elastic.co/t/getting-failed-to-execute-phase-query-all-shards-failed/27244)

<div class="topic-metadata">

**Author:** [@anusha6](https://discuss.elastic.co/u/anusha6)\
**Replies:** 12\
**Last updated:** [January 2, 2017, 8:42pm UTC](https://discuss.elastic.co/t/getting-failed-to-execute-phase-query-all-shards-failed/27244 "2017-01-02T20:42:51Z")

</div>

Hi All, Am getting the following exception Failed to execute phase \[query\], all shards failed org.elasticsearch.action.search.SearchPhaseExecutionException: Failed to execute phase \[query\], all shards failed at org.ela…

---

## [Logstash 5 not running](https://discuss.elastic.co/t/logstash-5-not-running/64449)

<div class="topic-metadata">

**Author:** [@Vishal\_Sharma1](https://discuss.elastic.co/u/Vishal_Sharma1)\
**Replies:** 71\
**Last updated:** [July 11, 2021, 11:39am UTC](https://discuss.elastic.co/t/logstash-5-not-running/64449 "2021-07-11T11:39:04Z")

</div>

hey there, I am following the official document and seems like it's not working. I am using a freshly installed CentOS 7 system and have Java 1.8 installed. As per the document when i run below \[Foo@Elastic logstash\]…

---

## [Hardware Recommendation](https://discuss.elastic.co/t/hardware-recommendation/66833)

<div class="topic-metadata">

**Author:** [@Mohana01](https://discuss.elastic.co/u/Mohana01)\
**Replies:** 12\
**Last updated:** [December 3, 2016, 6:54am UTC](https://discuss.elastic.co/t/hardware-recommendation/66833 "2016-12-03T06:54:10Z")

</div>

Hi All, We performed few sample reports thru Kibana for understanding the stack.We are about to use Elastic Stack in production . We would like to hear your suggestions on hardware for implementing.Here are my requirem…

---

## [Joins in Kibana to Fetch Data From Multiple Indexes](https://discuss.elastic.co/t/joins-in-kibana-to-fetch-data-from-multiple-indexes/31893)

<div class="topic-metadata">

**Author:** [@Asad\_Rehman](https://discuss.elastic.co/u/Asad_Rehman)\
**Replies:** 19\
**Last updated:** [December 22, 2016, 8:33am UTC](https://discuss.elastic.co/t/joins-in-kibana-to-fetch-data-from-multiple-indexes/31893 "2016-12-22T08:33:06Z")

</div>

Hi All, I have elasticsearch indexes which contain data for different machines regarding their performance. There are two types of indexes, first type contains information only about machines e.g its geo-location etc whi…

---

## [Logstash is not listening on port 5044](https://discuss.elastic.co/t/logstash-is-not-listening-on-port-5044/84495)

<div class="topic-metadata">

**Author:** [@mahesh\_cs](https://discuss.elastic.co/u/mahesh_cs)\
**Replies:** 12\
**Last updated:** [May 5, 2017, 6:11am UTC](https://discuss.elastic.co/t/logstash-is-not-listening-on-port-5044/84495 "2017-05-05T06:11:31Z")

</div>

I am using logstash version 5.3.0 . I have checked using netstat there is no port open of number 5044. I have checked log of logstash, found following error An unexpected error occurred! {:error=\># ArgumentError: Setti…

---

## [Filebeat sending data to Logstash seems too slow](https://discuss.elastic.co/t/filebeat-sending-data-to-logstash-seems-too-slow/37596)

<div class="topic-metadata">

**Author:** [@bluesman](https://discuss.elastic.co/u/bluesman)\
**Replies:** 19\
**Last updated:** [June 1, 2017, 12:34pm UTC](https://discuss.elastic.co/t/filebeat-sending-data-to-logstash-seems-too-slow/37596 "2017-06-01T12:34:27Z")

</div>

Hello, I'm trying out filebeat and Beat protocol with RPM Filebeat 1.0.0 and RPM Logstash 2.1.0 on two separated machine with 4 VCPU and 16 GB of RAM, Gigabit and SSD disk. I've configured filebeat to send 250GB of pla…

---

## [Kibana filter regex 'string starts with' doesn't work](https://discuss.elastic.co/t/kibana-filter-regex-string-starts-with-doesnt-work/131131)

<div class="topic-metadata">

**Author:** [@MichaelDz](https://discuss.elastic.co/u/MichaelDz)\
**Replies:** 13\
**Last updated:** [May 14, 2018, 8:53am UTC](https://discuss.elastic.co/t/kibana-filter-regex-string-starts-with-doesnt-work/131131 "2018-05-14T08:53:39Z")

</div>

In Kibana chart I want to filter 'url' field that starts with string CANCELLED so I wrote a regex: ^CANCELLED.\* but when I use filter in Discover tab then I notice that filter doesn't work properly because it also accept…

---

## [Confused about how to use .raw fields and not analyze string fields](https://discuss.elastic.co/t/confused-about-how-to-use-raw-fields-and-not-analyze-string-fields/28106)

<div class="topic-metadata">

**Author:** [@mackenza](https://discuss.elastic.co/u/mackenza)\
**Replies:** 36\
**Last updated:** [May 25, 2017, 11:35am UTC](https://discuss.elastic.co/t/confused-about-how-to-use-raw-fields-and-not-analyze-string-fields/28106 "2017-05-25T11:35:54Z")

</div>

I apologize if this is too newbie a question but I am struggling with setting up a terms visualization in Kibana 4 because the string field with the terms is analysed. I am using logstash with the elasticsearch output …

---

## [Post data to logstash using http input](https://discuss.elastic.co/t/post-data-to-logstash-using-http-input/69166)

<div class="topic-metadata">

**Author:** [@adhikz](https://discuss.elastic.co/u/adhikz)\
**Replies:** 10\
**Last updated:** [December 20, 2016, 1:05pm UTC](https://discuss.elastic.co/t/post-data-to-logstash-using-http-input/69166 "2016-12-20T13:05:55Z")

</div>

I am current trying to do a JavaScript post to Logstash by using a tcp input. JavaScript Post xhr = new XMLHttpRequest(); var url = "http://localhost:5043"; xhr.open("POST", url, true); xhr.setRequestHeader("Cont…

---

## [Can i replace logstash timestamp with timestamp of my logfile?](https://discuss.elastic.co/t/can-i-replace-logstash-timestamp-with-timestamp-of-my-logfile/32649)

<div class="topic-metadata">

**Author:** [@Anmol\_Gupta](https://discuss.elastic.co/u/Anmol_Gupta)\
**Replies:** 16\
**Last updated:** [October 9, 2016, 10:01am UTC](https://discuss.elastic.co/t/can-i-replace-logstash-timestamp-with-timestamp-of-my-logfile/32649 "2016-10-09T10:01:01Z")

</div>

i want my log event timestamp to replace @timestamp of logstash , what should i do? { "message" =\> "DEBUG", "@version" =\> "1", "@timestamp" =\> "2015-10-21T07:00:59.979Z", ###this timestamp is of logsta…

---

## [Field name cannot contain '.'](https://discuss.elastic.co/t/field-name-cannot-contain/33251)

<div class="topic-metadata">

**Author:** [@radu.stefanache](https://discuss.elastic.co/u/radu.stefanache)\
**Replies:** 46\
**Last updated:** [August 4, 2016, 4:31pm UTC](https://discuss.elastic.co/t/field-name-cannot-contain/33251 "2016-08-04T16:31:15Z")

</div>

Hello everyone, today I've upgraded to ELK 2.0 and did some tests . I am currently parsing a line that looks like this : key=value&key=value&key=value Obviously I am using the kv filter . There is one issue though,…

---

## [Kibana: mapping set to strict, dynamic introduction of \[references\] within \[doc\] is not allowed](https://discuss.elastic.co/t/kibana-mapping-set-to-strict-dynamic-introduction-of-references-within-doc-is-not-allowed/176403)

<div class="topic-metadata">

**Author:** [@raulk89](https://discuss.elastic.co/u/raulk89)\
**Replies:** 27\
**Last updated:** [April 24, 2019, 8:19am UTC](https://discuss.elastic.co/t/kibana-mapping-set-to-strict-dynamic-introduction-of-references-within-doc-is-not-allowed/176403 "2019-04-24T08:19:20Z")

</div>

Hi elastic, kibana 7.0.0 (rpm installation) Centos7 Updated both from 6.7.1 to 7.0.0. Cluster is green, but when browsing kibana on browser, I get: {"message":"mapping set to strict, dynamic introduction of \[refere…

---

## [Is it possible to export logs from Kibana?](https://discuss.elastic.co/t/is-it-possible-to-export-logs-from-kibana/133356)

<div class="topic-metadata">

**Author:** [@amruth](https://discuss.elastic.co/u/amruth)\
**Replies:** 10\
**Last updated:** [June 8, 2018, 8:29pm UTC](https://discuss.elastic.co/t/is-it-possible-to-export-logs-from-kibana/133356 "2018-06-08T20:29:41Z")

</div>

Hi, Can someone please say if there is a way to export logs from Kibana just like we have it in Splunk? Thanks

---

## [Elasticsearch-master election is taking too long (+30mins)](https://discuss.elastic.co/t/elasticsearch-master-election-is-taking-too-long-30mins/204488)

<div class="topic-metadata">

**Author:** [@zgergely](https://discuss.elastic.co/u/zgergely)\
**Replies:** 24\
**Last updated:** [November 10, 2019, 5:23pm UTC](https://discuss.elastic.co/t/elasticsearch-master-election-is-taking-too-long-30mins/204488 "2019-11-10T17:23:23Z")

</div>

Hi, We have a custom ELK stack deployed on IKS (Kubernetes Service @IBM) version 7.1.1 with HelmCharts. The setup is made up from 3x elasticsearch-master nodes, 2x elasticsearch-data nodes, 1x logstash pod for gatherin…

---

## [Kibana 6 Login is currently disabled](https://discuss.elastic.co/t/kibana-6-login-is-currently-disabled/107675)

<div class="topic-metadata">

**Author:** [@Zeeshan\_Alam](https://discuss.elastic.co/u/Zeeshan_Alam)\
**Replies:** 10\
**Last updated:** [December 16, 2017, 8:08pm UTC](https://discuss.elastic.co/t/kibana-6-login-is-currently-disabled/107675 "2017-12-16T20:08:53Z")

</div>

I am trying elastic 6 and elastic is running fine. But Kibana Login page is disabled. I didn't found anything in the kibana logs to resolve this issue. \[image\] My Kibana config: server.port: 5601 server.host: myhos…

---

## [Unable to fetch mapping. Do you have indices matching the pattern](https://discuss.elastic.co/t/unable-to-fetch-mapping-do-you-have-indices-matching-the-pattern/844)

<div class="topic-metadata">

**Author:** [@Laia\_Subirats](https://discuss.elastic.co/u/Laia_Subirats)\
**Replies:** 10\
**Last updated:** [October 30, 2015, 6:22am UTC](https://discuss.elastic.co/t/unable-to-fetch-mapping-do-you-have-indices-matching-the-pattern/844 "2015-10-30T06:22:52Z")

</div>

Hi, I cannot configure an index pattern because I do not have a green create button. \[image\] Do you know what is happening? Thanks, Laia

---

## [Convert Date String Into Date Format](https://discuss.elastic.co/t/convert-date-string-into-date-format/193913)

<div class="topic-metadata">

**Author:** [@Syed.Ubaid](https://discuss.elastic.co/u/Syed.Ubaid)\
**Replies:** 110\
**Last updated:** [August 19, 2019, 4:02am UTC](https://discuss.elastic.co/t/convert-date-string-into-date-format/193913 "2019-08-19T04:02:51Z")

</div>

I have a column date when i write a config file and parse data into logstash the date column save by default into string format i want to convert date string column into date format can someone help really appreciate i…

---

## [Shards unassigned after node restarts - reason: NODE\_LEFT](https://discuss.elastic.co/t/shards-unassigned-after-node-restarts-reason-node-left/67489)

<div class="topic-metadata">

**Author:** [@rkrombho](https://discuss.elastic.co/u/rkrombho)\
**Replies:** 15\
**Last updated:** [November 30, 2016, 12:28pm UTC](https://discuss.elastic.co/t/shards-unassigned-after-node-restarts-reason-node-left/67489 "2016-11-30T12:28:42Z")

</div>

Hi All, after we were forced to restart multiple ES 2.2.0 cluster nodes (becuase of massive full GCs due to a heavy aggregation) we now experience ~30 shards (mixed - primaries and replicas) to be unassigned with the r…

---

## [Rejecting mapping update to as the final mapping would have more than 1 type: \[log, doc\]](https://discuss.elastic.co/t/rejecting-mapping-update-to-as-the-final-mapping-would-have-more-than-1-type-log-doc/111866)

<div class="topic-metadata">

**Author:** [@kyle\_che](https://discuss.elastic.co/u/kyle_che)\
**Replies:** 14\
**Last updated:** [December 20, 2017, 8:02pm UTC](https://discuss.elastic.co/t/rejecting-mapping-update-to-as-the-final-mapping-would-have-more-than-1-type-log-doc/111866 "2017-12-20T20:02:14Z")

</div>

I'm trying to use logstash 6.0.1 and I'm getting the following error from filebeats 6.0.1. I understand the error but not sure how to correct this issue. Rejecting mapping update to \[filebeat-6.0.1-postgres-2017.11.29\]…

---

## [Kibana's filter (partial matching)](https://discuss.elastic.co/t/kibanas-filter-partial-matching/98494)

<div class="topic-metadata">

**Author:** [@alexus](https://discuss.elastic.co/u/alexus)\
**Replies:** 10\
**Last updated:** [September 11, 2017, 8:50pm UTC](https://discuss.elastic.co/t/kibanas-filter-partial-matching/98494 "2017-09-11T20:50:15Z")

</div>

I’m running elasticsearch 5.5.1 and while trying to follow Partial Matching | Elasticsearch: The Definitive Guide \[2.x\] | Elastic, I was not able to do partial matching through Kibana’s filter( My filter: { "query": …

---

## [ClusterBlockException\[blocked by: \[SERVICE\_UNAVAILABLE/1/state not recovered / initialized\]](https://discuss.elastic.co/t/clusterblockexception-blocked-by-service-unavailable-1-state-not-recovered-initialized/59793)

<div class="topic-metadata">

**Author:** [@Antoine\_Brun](https://discuss.elastic.co/u/Antoine_Brun)\
**Replies:** 10\
**Last updated:** [September 6, 2016, 12:35pm UTC](https://discuss.elastic.co/t/clusterblockexception-blocked-by-service-unavailable-1-state-not-recovered-initialized/59793 "2016-09-06T12:35:26Z")

</div>

Hello, I hope someone can help here. I have a lab cluster running 1.7.5. It has been running fine for month. It's a lab so we can delete the index, the data,... last week i realized that the cluster state was red and…

---

## [Grouping values?](https://discuss.elastic.co/t/grouping-values/117001)

<div class="topic-metadata">

**Author:** [@Sjaak01](https://discuss.elastic.co/u/Sjaak01)\
**Replies:** 14\
**Last updated:** [February 23, 2018, 9:01am UTC](https://discuss.elastic.co/t/grouping-values/117001 "2018-02-23T09:01:30Z")

</div>

Hi, I was wondering if it's possible to group similar values together in Kibana? Example: Facebook and google use many different hosts so if I create a simple pie chart (metric SUM total bytes, bucket destination\_host…

---

## [Elasticsearch 6.3: X-Pack and remote connection doesn't work](https://discuss.elastic.co/t/elasticsearch-6-3-x-pack-and-remote-connection-doesnt-work/136618)

<div class="topic-metadata">

**Author:** [@cmenendez](https://discuss.elastic.co/u/cmenendez)\
**Replies:** 17\
**Last updated:** [August 14, 2018, 5:22pm UTC](https://discuss.elastic.co/t/elasticsearch-6-3-x-pack-and-remote-connection-doesnt-work/136618 "2018-08-14T17:22:56Z")

</div>

Hi, I'm trying to install Elasticsearch 6.3 in my PC. The first problem I find is when I want to set an user and a password. I follow the documentation and use bin/elasticsearch-setup-passwords interactive but the r…

---

## [How to configure different indexes in logstash](https://discuss.elastic.co/t/how-to-configure-different-indexes-in-logstash/58665)

<div class="topic-metadata">

**Author:** [@rocky4bmw](https://discuss.elastic.co/u/rocky4bmw)\
**Replies:** 37\
**Last updated:** [May 23, 2020, 3:07pm UTC](https://discuss.elastic.co/t/how-to-configure-different-indexes-in-logstash/58665 "2020-05-23T15:07:11Z")

</div>

Hi Team, Can anyone help me in confugiring multiple indexes so that logs are shipped to different indices based on the environment type(PROD,SIT & DEV). Currently my stepup is working with default filebeat-\* index L…

---

## [Reverse proxy Kibana](https://discuss.elastic.co/t/reverse-proxy-kibana/43647)

<div class="topic-metadata">

**Author:** [@abhijitdeka11](https://discuss.elastic.co/u/abhijitdeka11)\
**Replies:** 14\
**Last updated:** [August 10, 2016, 4:19am UTC](https://discuss.elastic.co/t/reverse-proxy-kibana/43647 "2016-08-10T04:19:19Z")

</div>

Hi, I am embedding kibana inside my application which has other features also.I use reverse proxy to do this mapping. So,whenever I hit this URL /analytics/\* all calls are redirected to kibana server. Now with the new …

---

## [Elasticsearch is not starting when bootstrap.memory\_lock is set to true](https://discuss.elastic.co/t/elasticsearch-is-not-starting-when-bootstrap-memory-lock-is-set-to-true/120962)

<div class="topic-metadata">

**Author:** [@amruth](https://discuss.elastic.co/u/amruth)\
**Replies:** 15\
**Last updated:** [February 22, 2018, 3:42pm UTC](https://discuss.elastic.co/t/elasticsearch-is-not-starting-when-bootstrap-memory-lock-is-set-to-true/120962 "2018-02-22T15:42:00Z")

</div>

Hi, Elasticsearch throws following error when bootstrap.memory\_lock is set to true, \[2018-02-21T15:00:09,690\]\[INFO \]\[o.e.t.TransportService \] \[mynode\] publish\_address {xxxxxx:9300}, bound\_addresses {\[::\]:9300} \[2018-…

---

## [Logstash '\_grokparsefailure' issue](https://discuss.elastic.co/t/logstash--grokparsefailure-issue/49756)

<div class="topic-metadata">

**Author:** [@shubham\_deodia](https://discuss.elastic.co/u/shubham_deodia)\
**Replies:** 13\
**Last updated:** [May 11, 2016, 1:22pm UTC](https://discuss.elastic.co/t/logstash--grokparsefailure-issue/49756 "2016-05-11T13:22:56Z")

</div>

I am using custom grok pattern to parse my log file, Not matter what i do it always give me the \_grokparsefailure exception. However, it work perfectly on https://grokdebug.herokuapp.com/ My custom pattern file is loca…

---

## [Kibana 5: "Request Timeout after 30000ms" for simple query](https://discuss.elastic.co/t/kibana-5-request-timeout-after-30000ms-for-simple-query/72213)

<div class="topic-metadata">

**Author:** [@ash007](https://discuss.elastic.co/u/ash007)\
**Replies:** 17\
**Last updated:** [January 24, 2017, 5:39pm UTC](https://discuss.elastic.co/t/kibana-5-request-timeout-after-30000ms-for-simple-query/72213 "2017-01-24T17:39:42Z")

</div>

Hello, I am running Kibana 5 in DEV environment and trying to search for a url within 'last 7 days' filter. The search is taking a long time and timing out with "Request Timeout after 30000ms" message. I am performing th…

[Previous page](https://discuss.elastic.co/top.md?per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=2&per_page=50&period=all)
