# Top

**URL:** https://discuss.elastic.co/top.md?page=10&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 11

---

## [Failed to execute org.elasticsearch.action.search.SearchRequest error](https://discuss.elastic.co/t/failed-to-execute-org-elasticsearch-action-search-searchrequest-error/25373)

<div class="topic-metadata">

**Author:** [@bluethundr](https://discuss.elastic.co/u/bluethundr)\
**Replies:** 10\
**Last updated:** [July 12, 2015, 11:14pm UTC](https://discuss.elastic.co/t/failed-to-execute-org-elasticsearch-action-search-searchrequest-error/25373 "2015-07-12T23:14:23Z")

</div>

Hey guys, I noticed that results stopped turning up in Logstash. And when I tailed the Elasticsearch logs, I noticed this exception repeated over and over again, a total of 85 times: #grep "Failed to execute \\…

---

## [Query\_string on nested objects](https://discuss.elastic.co/t/query-string-on-nested-objects/58587)

<div class="topic-metadata">

**Author:** [@Fabien\_Sarlat](https://discuss.elastic.co/u/Fabien_Sarlat)\
**Replies:** 11\
**Last updated:** [August 23, 2016, 1:54pm UTC](https://discuss.elastic.co/t/query-string-on-nested-objects/58587 "2016-08-23T13:54:53Z")

</div>

Hello there ! I have a problem with nested objetcts :smiley: Field : "listSecteurs": { "type" : "nested", "include\_in\_parent": true, "properties" : { "secteurName" : {"type": "string", …

---

## [Unable to start logstash getting error](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093)

<div class="topic-metadata">

**Author:** [@Shiv\_Gupta](https://discuss.elastic.co/u/Shiv_Gupta)\
**Replies:** 65\
**Last updated:** [April 11, 2018, 5:31pm UTC](https://discuss.elastic.co/t/unable-to-start-logstash-getting-error/126093 "2018-04-11T17:31:58Z")

</div>

Hello All, could you please help me to solve the below error getting in logstash while starting. earlier it was working fine , suddenly started getting below- \[ERROR\] 2018-03-29 17:47:09.503 \[main\] Logstash - java.lang…

---

## [Error loading config file: yaml: line 21: did not find expected key](https://discuss.elastic.co/t/error-loading-config-file-yaml-line-21-did-not-find-expected-key/147081)

<div class="topic-metadata">

**Author:** [@elk11](https://discuss.elastic.co/u/elk11)\
**Replies:** 10\
**Last updated:** [September 5, 2018, 4:41am UTC](https://discuss.elastic.co/t/error-loading-config-file-yaml-line-21-did-not-find-expected-key/147081 "2018-09-05T04:41:16Z")

</div>

I referred other similar discussions but none of those helped. i'm getting this error after adding second prospector. and the error line specified is also at the beginning of the second prospector. Please take a look at …

---

## [Doubts about Filebeat Threat Intel Module \[7.12.0\]](https://discuss.elastic.co/t/doubts-about-filebeat-threat-intel-module-7-12-0/270810)

<div class="topic-metadata">

**Author:** [@RdrgPorto](https://discuss.elastic.co/u/RdrgPorto)\
**Replies:** 13\
**Last updated:** [May 27, 2021, 11:33am UTC](https://discuss.elastic.co/t/doubts-about-filebeat-threat-intel-module-7-12-0/270810 "2021-05-27T11:33:04Z")

</div>

Hi, everyone I have been testing with Filebeat Threat Intel module in order to get events from MISP. I have some doubts regarding configuration: I have to disable every input plugin because they are enabled by defau…

---

## [\[ERROR\] 2019-01-08 10:18:42.313 \[main\] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit](https://discuss.elastic.co/t/error-2019-01-08-1042-313-main-logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/163302)

<div class="topic-metadata">

**Author:** [@Dv\_Thiyanesh](https://discuss.elastic.co/u/Dv_Thiyanesh)\
**Replies:** 11\
**Last updated:** [February 6, 2019, 6:00am UTC](https://discuss.elastic.co/t/error-2019-01-08-1042-313-main-logstash-java-lang-illegalstateexception-logstash-stopped-processing-because-of-an-error-systemexit-exit/163302 "2019-02-06T06:00:25Z")

</div>

I have an error at first i have run the config for beasts but now just for checking it's shows an error like this(in windows) what can i do did i make any mistake correct me C:\\ELK\\logstash-6.5.3\\bin\>logstash -e 'inpu…

---

## [Connecting to Elasticsearch with Java](https://discuss.elastic.co/t/connecting-to-elasticsearch-with-java/2489)

<div class="topic-metadata">

**Author:** [@mc1392](https://discuss.elastic.co/u/mc1392)\
**Replies:** 14\
**Last updated:** [July 11, 2016, 6:34pm UTC](https://discuss.elastic.co/t/connecting-to-elasticsearch-with-java/2489 "2016-07-11T18:34:25Z")

</div>

I’m using the Java API, but I keep getting this error: org.elasticsearch.client.transport.NoNodeAvailableException: None of the configured nodes are available: Even if I run my code on the same machine as Elasticse…

---

## [No outputs are defined. Please define one under the output section](https://discuss.elastic.co/t/no-outputs-are-defined-please-define-one-under-the-output-section/38626)

<div class="topic-metadata">

**Author:** [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)\
**Replies:** 11\
**Last updated:** [October 29, 2016, 5:56pm UTC](https://discuss.elastic.co/t/no-outputs-are-defined-please-define-one-under-the-output-section/38626 "2016-10-29T17:56:26Z")

</div>

Hi i'm very new to filebeat previously i had use log-courier to process my log. i have created the filebeat.yml like this filebeat: prospectors: - paths: - C:\\elkenter\\Data\\sample\*.csv docume…

---

## [Data too large, data for \[\<transport\_request\>\] would be \[10554893106/9.8gb\], which is larger than the limit of \[10092838912/9.3gb\], real usage: \[10523239224/9.8gb\], new bytes reserved: \[31653882/30.1mb\]\]\]\]](https://discuss.elastic.co/t/data-too-large-data-for-transport-request-would-be-10554893106-9-8gb-which-is-larger-than-the-limit-of-10092838912-9-3gb-real-usage-10523239224-9-8gb-new-bytes-reserved-31653882-30-1mb/192215)

<div class="topic-metadata">

**Author:** [@Rakesh4](https://discuss.elastic.co/u/Rakesh4)\
**Replies:** 16\
**Last updated:** [August 5, 2019, 11:54am UTC](https://discuss.elastic.co/t/data-too-large-data-for-transport-request-would-be-10554893106-9-8gb-which-is-larger-than-the-limit-of-10092838912-9-3gb-real-usage-10523239224-9-8gb-new-bytes-reserved-31653882-30-1mb/192215 "2019-08-05T11:54:37Z")

</div>

Hi, We have elastic search configuration : version : 7.1.1 3 master node 3 data node 2 coordinating node memory configuration Data node : 64 machine java heap allocation : 10 gb coord : 32 gb java heap aloc …

---

## [Master not discovered yet, this node has not previously joined a bootstrapped](https://discuss.elastic.co/t/master-not-discovered-yet-this-node-has-not-previously-joined-a-bootstrapped/289075)

<div class="topic-metadata">

**Author:** [@Maks\_7v](https://discuss.elastic.co/u/Maks_7v)\
**Replies:** 15\
**Last updated:** [November 15, 2021, 2:29pm UTC](https://discuss.elastic.co/t/master-not-discovered-yet-this-node-has-not-previously-joined-a-bootstrapped/289075 "2021-11-15T14:29:59Z")

</div>

Hi there. I'm trying to deploy 3 masters, 2 data, and 2 ingest nodes to GCP k8s. There is a problem that masters struggle to discover each other. Here are the logs I get: "master not discovered yet, this node has not…

---

## [\#Unable to connect to Elasticsearch](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch/128191)

<div class="topic-metadata">

**Author:** [@rajushrajan](https://discuss.elastic.co/u/rajushrajan)\
**Replies:** 38\
**Last updated:** [April 27, 2018, 11:01am UTC](https://discuss.elastic.co/t/unable-to-connect-to-elasticsearch/128191 "2018-04-27T11:01:33Z")

</div>

After enabling xpack in elasticsearch.yml i am geting the below error in kibana. \[image\]

---

## [Issue with filebeat & logstash "Beats input: unhandled exception"](https://discuss.elastic.co/t/issue-with-filebeat-logstash-beats-input-unhandled-exception/33934)

<div class="topic-metadata">

**Author:** [@Matthew\_Prinvale](https://discuss.elastic.co/u/Matthew_Prinvale)\
**Replies:** 19\
**Last updated:** [July 29, 2016, 11:41am UTC](https://discuss.elastic.co/t/issue-with-filebeat-logstash-beats-input-unhandled-exception/33934 "2016-07-29T11:41:56Z")

</div>

OS: Ubuntu 14.094 filebeat: filebeat version 1.0.0-rc1 (amd64) logstash: 2.0.0-1 Current ELK user in production. Building a test Filebeat =\> Logstash =\> Elasticsearch stack to try out filebeat. After installing lostas…

---

## [Can't delete Index!](https://discuss.elastic.co/t/cant-delete-index/19210)

<div class="topic-metadata">

**Author:** [@IronMike](https://discuss.elastic.co/u/IronMike)\
**Replies:** 15\
**Last updated:** [August 13, 2014, 1:27am UTC](https://discuss.elastic.co/t/cant-delete-index/19210 "2014-08-13T01:27:33Z")

</div>

I got myself in trouble by changing the mapping. I am on a cluster of 2 nodes, and trying to delete the index, I keep getting acknowleged = false with normal delete curl -X GET "http://localhost:9200/myIndex If…

---

## [KIbana - Elasticsearch : Request time out after 3000ms](https://discuss.elastic.co/t/kibana-elasticsearch-request-time-out-after-3000ms/127092)

<div class="topic-metadata">

**Author:** [@charanjitkaur](https://discuss.elastic.co/u/charanjitkaur)\
**Replies:** 31\
**Last updated:** [April 12, 2018, 12:48pm UTC](https://discuss.elastic.co/t/kibana-elasticsearch-request-time-out-after-3000ms/127092 "2018-04-12T12:48:19Z")

</div>

Hi, Elasticsearh version: 6.1.2 Kibana version : 6.1.2 We are processing logs through Filebeat - Logstash - ES - Kibana Log file in CSV format with 23 columns , Total logs count upto 2-3lakh We are creating a datata…

---

## [Bug? Elasticsearch 7 (after upgrade from 6.7) slow search during 3-5 seconds every 60 seconds](https://discuss.elastic.co/t/bug-elasticsearch-7-after-upgrade-from-6-7-slow-search-during-3-5-seconds-every-60-seconds/177017)

<div class="topic-metadata">

**Author:** [@Nenad](https://discuss.elastic.co/u/Nenad)\
**Replies:** 36\
**Last updated:** [April 18, 2019, 1:10pm UTC](https://discuss.elastic.co/t/bug-elasticsearch-7-after-upgrade-from-6-7-slow-search-during-3-5-seconds-every-60-seconds/177017 "2019-04-18T13:10:27Z")

</div>

This post is regarding my Github Issue: https://github.com/elastic/elasticsearch/issues/41231 Elasticsearch Version: 7.0.0 OpenJDK Runtime Environment (build 1.8.0\_201-b09) Centos 7 Linux 3.10.0-957.5.1.el7.x86\_64 Af…

---

## [Regarding to curator delete indices older than 5 days](https://discuss.elastic.co/t/regarding-to-curator-delete-indices-older-than-5-days/76073)

<div class="topic-metadata">

**Author:** [@Ximeng\_Zhao](https://discuss.elastic.co/u/Ximeng_Zhao)\
**Replies:** 26\
**Last updated:** [March 7, 2017, 2:16pm UTC](https://discuss.elastic.co/t/regarding-to-curator-delete-indices-older-than-5-days/76073 "2017-03-07T14:16:35Z")

</div>

Hello, I have a index and mapping like this: { "\_index": "user", "\_type": "profile", "\_id": "2", "\_score": 1, "\_source": { "full\_name": "Elon Musk", "bio": "E…

---

## [Parsing and indexing documents with Apache Tika](https://discuss.elastic.co/t/parsing-and-indexing-documents-with-apache-tika/292)

<div class="topic-metadata">

**Author:** [@Jean\_Wisser](https://discuss.elastic.co/u/Jean_Wisser)\
**Replies:** 10\
**Last updated:** [February 23, 2016, 2:54am UTC](https://discuss.elastic.co/t/parsing-and-indexing-documents-with-apache-tika/292 "2016-02-23T02:54:09Z")

</div>

Hello everyone, I'm trying to parse and index .doc files into elasticsearch with apache Tika. Actually, my project is to build a resume search engine for my company. Since we have a standardized resume format, I woul…

---

## [How to ignore properties in mapping](https://discuss.elastic.co/t/how-to-ignore-properties-in-mapping/65840)

<div class="topic-metadata">

**Author:** [@bwillis614](https://discuss.elastic.co/u/bwillis614)\
**Replies:** 15\
**Last updated:** [November 14, 2016, 5:16pm UTC](https://discuss.elastic.co/t/how-to-ignore-properties-in-mapping/65840 "2016-11-14T17:16:51Z")

</div>

Thanks in advance. I'm retrieving my records from mongo, then using Node to insert into ES thru API. here is a small part of my mapping { "price\_list\_tier": { "dynamic": "static", "properties": { "sku…

---

## [Convert a date format in logstash pipeline](https://discuss.elastic.co/t/convert-a-date-format-in-logstash-pipeline/95000)

<div class="topic-metadata">

**Author:** [@marwa](https://discuss.elastic.co/u/marwa)\
**Replies:** 16\
**Last updated:** [August 1, 2017, 8:22am UTC](https://discuss.elastic.co/t/convert-a-date-format-in-logstash-pipeline/95000 "2017-08-01T08:22:31Z")

</div>

hello , i am trying to load a csv file into elasticsearch via logstash .this is a snippet of my data sets transaction\_date,customer\_name,product\_name,product\_id,price\_unit,quantity,fidelity\_card\_id,discount,category 2-…

---

## [Version conflict, document already exists (current version \[1\])](https://discuss.elastic.co/t/version-conflict-document-already-exists-current-version-1/139230)

<div class="topic-metadata">

**Author:** [@darkmoon](https://discuss.elastic.co/u/darkmoon)\
**Replies:** 13\
**Last updated:** [August 28, 2018, 1:16pm UTC](https://discuss.elastic.co/t/version-conflict-document-already-exists-current-version-1/139230 "2018-08-28T13:16:46Z")

</div>

With this config: output { if (\[type\] == "state" ) { elasticsearch { hosts =\> \[ \] index =\> "%{\[meta\]\[target\]\[index\]}" document\_id =\> "%{\[@metadata\]\[target\]\[id\]}" action =\> "update" doc\_as\_upsert =\> true id =\> "…

---

## [FileBeat Not starting due to config in yml file](https://discuss.elastic.co/t/filebeat-not-starting-due-to-config-in-yml-file/97876)

<div class="topic-metadata">

**Author:** [@aditya\_soni](https://discuss.elastic.co/u/aditya_soni)\
**Replies:** 14\
**Last updated:** [August 25, 2017, 6:17am UTC](https://discuss.elastic.co/t/filebeat-not-starting-due-to-config-in-yml-file/97876 "2017-08-25T06:17:23Z")

</div>

HI experts, This is my filebeat.yml file … i am getting error :1053 whenever i am starting filebeat service. may be some mistake i am doing in this file, please correct me where i am wrong. ###################### Fi…

---

## [Failed to send ping to](https://discuss.elastic.co/t/failed-to-send-ping-to/1235)

<div class="topic-metadata">

**Author:** [@ccrivelli](https://discuss.elastic.co/u/ccrivelli)\
**Replies:** 10\
**Last updated:** [September 23, 2016, 5:28am UTC](https://discuss.elastic.co/t/failed-to-send-ping-to/1235 "2016-09-23T05:28:55Z")

</div>

Hi guys, after setting up my elasticsearch cluster, I got some 'failed to send ping' errors. Then I increased the discovery.zen.ping.timeout from 3s (default) to 6s and finally to 30s, but I'm still getting the same err…

---

## [How to create security certificate pem for elasticsearch an kibana](https://discuss.elastic.co/t/how-to-create-security-certificate-pem-for-elasticsearch-an-kibana/189249)

<div class="topic-metadata">

**Author:** [@mouna\_boujrad](https://discuss.elastic.co/u/mouna_boujrad)\
**Replies:** 21\
**Last updated:** [July 8, 2019, 12:55am UTC](https://discuss.elastic.co/t/how-to-create-security-certificate-pem-for-elasticsearch-an-kibana/189249 "2019-07-08T00:55:05Z")

</div>

I am trying to intall the helm chart of elasticsearch and kibana but in the security configuration I need to have : certificateAuthorities: /usr/share/kibana/config/certs/elastic-certificate.pem key: /usr/share/kiban…

---

## [Higher CPU vs Higher Memory. Which helps in what cases?](https://discuss.elastic.co/t/higher-cpu-vs-higher-memory-which-helps-in-what-cases/272798)

<div class="topic-metadata">

**Author:** [@Aurel\_Drejta](https://discuss.elastic.co/u/Aurel_Drejta)\
**Replies:** 23\
**Last updated:** [June 16, 2021, 12:33pm UTC](https://discuss.elastic.co/t/higher-cpu-vs-higher-memory-which-helps-in-what-cases/272798 "2021-06-16T12:33:32Z")

</div>

Hi everyone, What are the cases where a higher CPU and/or faster CPU benefits the cluster more than higher memory? I am currently running on 3 Nodes that are 8 CPU 16GB RAM configurations. I will scale the cluster fir…

---

## [Adding 1 day to the date](https://discuss.elastic.co/t/adding-1-day-to-the-date/129168)

<div class="topic-metadata">

**Author:** [@HRG](https://discuss.elastic.co/u/HRG)\
**Replies:** 42\
**Last updated:** [April 25, 2018, 7:06pm UTC](https://discuss.elastic.co/t/adding-1-day-to-the-date/129168 "2018-04-25T19:06:52Z")

</div>

I am new to Logstash and have a requirement to add 1 day to the date(Businessdate) and compare log event date with Businessdate. Can you please suggest how to achieve this. Ex: Parsed string to extract YEAR, MONTH AND …

---

## [G1GC cause CircuitBreakingException: \[parent\] Data too large on 7.1.1](https://discuss.elastic.co/t/g1gc-cause-circuitbreakingexception-parent-data-too-large-on-7-1-1/187272)

<div class="topic-metadata">

**Author:** [@Wing924](https://discuss.elastic.co/u/Wing924)\
**Replies:** 39\
**Last updated:** [October 10, 2019, 11:26am UTC](https://discuss.elastic.co/t/g1gc-cause-circuitbreakingexception-parent-data-too-large-on-7-1-1/187272 "2019-10-10T11:26:20Z")

</div>

Elasticsearch version ( bin/elasticsearch --version ): 7.1.1 Plugins installed : none JVM version ( java -version ): openjdk version "11.0.3" 2019-04-16 LTS OpenJDK Runtime Environment 18.9 (build 11.0.3+7-LTS) …

---

## [Calling groovy script from Kibana](https://discuss.elastic.co/t/calling-groovy-script-from-kibana/2542)

<div class="topic-metadata">

**Author:** [@Darpan205](https://discuss.elastic.co/u/Darpan205)\
**Replies:** 11\
**Last updated:** [July 25, 2016, 1:34pm UTC](https://discuss.elastic.co/t/calling-groovy-script-from-kibana/2542 "2016-07-25T13:34:11Z")

</div>

Hi, I have a groovy script at $ES/config/scripts location. I wantto invoke that script while doing a search from Kibana & pass the parameters in the groovy script. Could you please guide me the set of steps needed in K…

---

## [Receiving "No subject alternative names matching IP address" when using wildcard cert in ES 5.0.2 cluster](https://discuss.elastic.co/t/receiving-no-subject-alternative-names-matching-ip-address-when-using-wildcard-cert-in-es-5-0-2-cluster/69322)

<div class="topic-metadata">

**Author:** [@mungoknotwise](https://discuss.elastic.co/u/mungoknotwise)\
**Replies:** 9\
**Last updated:** [December 19, 2016, 6:41pm UTC](https://discuss.elastic.co/t/receiving-no-subject-alternative-names-matching-ip-address-when-using-wildcard-cert-in-es-5-0-2-cluster/69322 "2016-12-19T18:41:50Z")

</div>

I've built a two node cluster and connected each node with no issues. I've installed the x-pack plugin and I'm trying to add SSL/TLS. Rather than generating a separate self-signed certificate for each node, I've got a wi…

---

## [How to replace a String with another string in a field while Re-indexing an old Index](https://discuss.elastic.co/t/how-to-replace-a-string-with-another-string-in-a-field-while-re-indexing-an-old-index/49905)

<div class="topic-metadata">

**Author:** [@sanju1323](https://discuss.elastic.co/u/sanju1323)\
**Replies:** 16\
**Last updated:** [June 7, 2016, 10:39am UTC](https://discuss.elastic.co/t/how-to-replace-a-string-with-another-string-in-a-field-while-re-indexing-an-old-index/49905 "2016-06-07T10:39:52Z")

</div>

Hi, I'm trying to Re-Index an old index in which I have to replace a String with another in a field. Here is the old index data. From this I want to replace "Mr.Rakesh Kumar" with "RK" in the new Index. I have tried …

---

## [Logstash "Could not index event to Elasticsearch"](https://discuss.elastic.co/t/logstash-could-not-index-event-to-elasticsearch/236181)

<div class="topic-metadata">

**Author:** [@Abdul\_Hameed](https://discuss.elastic.co/u/Abdul_Hameed)\
**Replies:** 11\
**Last updated:** [July 1, 2020, 12:39pm UTC](https://discuss.elastic.co/t/logstash-could-not-index-event-to-elasticsearch/236181 "2020-07-01T12:39:29Z")

</div>

Hi, I am trying to index my data into Elasticsearch from logstash but I keep getting this type of errors for all indices. 2020-05-06T14:38:11,434\]\[WARN \]\[logstash.outputs.elasticsearch\] Could not index event to Elastic…

---

## [Changing the number of shards and index frequency of an existing index](https://discuss.elastic.co/t/changing-the-number-of-shards-and-index-frequency-of-an-existing-index/121419)

<div class="topic-metadata">

**Author:** [@cheleyace](https://discuss.elastic.co/u/cheleyace)\
**Replies:** 14\
**Last updated:** [March 5, 2018, 6:50am UTC](https://discuss.elastic.co/t/changing-the-number-of-shards-and-index-frequency-of-an-existing-index/121419 "2018-03-05T06:50:08Z")

</div>

Hi, I am new with elasticsearch and I need to change the number of shards and index frequency of an existing index. Is there any way on how to change the shards and index frequency of an existing index without creating a…

---

## [Moving shards is slow](https://discuss.elastic.co/t/moving-shards-is-slow/127363)

<div class="topic-metadata">

**Author:** [@klahnakoski](https://discuss.elastic.co/u/klahnakoski)\
**Replies:** 14\
**Last updated:** [April 12, 2018, 10:48pm UTC](https://discuss.elastic.co/t/moving-shards-is-slow/127363 "2018-04-12T22:48:11Z")

</div>

This question is for ES version 6.1.2 I have a 30Gb index split into 60shards (about 500megs each). I turned off allocation, "cluster.routing.allocation.enable": "none" I send move commands to move 6 shards. It is…

---

## [Best Way to create nested field](https://discuss.elastic.co/t/best-way-to-create-nested-field/26757)

<div class="topic-metadata">

**Author:** [@DavidL](https://discuss.elastic.co/u/DavidL)\
**Replies:** 9\
**Last updated:** [November 4, 2015, 7:22pm UTC](https://discuss.elastic.co/t/best-way-to-create-nested-field/26757 "2015-11-04T19:22:11Z")

</div>

I successfully parsed out some fields, and am trying to aggregate some of them into one fields. Anyone suggestions on how to to that would be really appreciated. I haven't found a way to do so, but I assume this must be …

---

## [Elasticsearch querying is terribly slow](https://discuss.elastic.co/t/elasticsearch-querying-is-terribly-slow/81144)

<div class="topic-metadata">

**Author:** [@beshbesh](https://discuss.elastic.co/u/beshbesh)\
**Replies:** 10\
**Last updated:** [April 21, 2017, 2:44pm UTC](https://discuss.elastic.co/t/elasticsearch-querying-is-terribly-slow/81144 "2017-04-21T14:44:34Z")

</div>

Hello, I have been testing Elasticsearch & Kibana for some time. I need a cluster that can process 40k events per second and search inside the last week of data under one minute of search time. My cluster consists of 9 …

---

## [Extract value from message field ( runtime fields)](https://discuss.elastic.co/t/extract-value-from-message-field-runtime-fields/311679)

<div class="topic-metadata">

**Author:** [@jplopezy](https://discuss.elastic.co/u/jplopezy)\
**Replies:** 16\
**Last updated:** [August 10, 2022, 2:23pm UTC](https://discuss.elastic.co/t/extract-value-from-message-field-runtime-fields/311679 "2022-08-10T14:23:44Z")

</div>

Hello everyone, Currently, I have an OpenVPN log that is sent from the server to elastic... from what I see the fields are pretty generic and the most important one is "message", it has all the information and I can't p…

---

## [Can't load an invalid configuration (:reason=\>"Expected one of #](https://discuss.elastic.co/t/cant-load-an-invalid-configuration-reason-expected-one-of/77422)

<div class="topic-metadata">

**Author:** [@hispeed](https://discuss.elastic.co/u/hispeed)\
**Replies:** 16\
**Last updated:** [March 15, 2017, 1:44pm UTC](https://discuss.elastic.co/t/cant-load-an-invalid-configuration-reason-expected-one-of/77422 "2017-03-15T13:44:34Z")

</div>

Hi, I have now figured out a little bit more about my problems. I get the following error in: /var/log/logstash: Error message: \[2017-03-05T00:01:22,530\]\[ERROR\]\[logstash.agent \] Cannot load an invalid con…

---

## [Filebeat deployment in Kubernetes/Docker](https://discuss.elastic.co/t/filebeat-deployment-in-kubernetes-docker/113759)

<div class="topic-metadata">

**Author:** [@Asher\_Shoshan](https://discuss.elastic.co/u/Asher_Shoshan)\
**Replies:** 26\
**Last updated:** [January 18, 2018, 8:51am UTC](https://discuss.elastic.co/t/filebeat-deployment-in-kubernetes-docker/113759 "2018-01-18T08:51:37Z")

</div>

General guidelines for deploying Filebeat in Docker/Kubernetes is to run one instance (container) of Filebeat (in each Kubernetes node), and to harvest logs located in "/var/lib/docker/containers//.log". However, I can'…

---

## [Logstash input speed slow, around 8,000events / sec writing to local file](https://discuss.elastic.co/t/logstash-input-speed-slow-around-8-000events-sec-writing-to-local-file/2591)

<div class="topic-metadata">

**Author:** [@nathaniel](https://discuss.elastic.co/u/nathaniel)\
**Replies:** 9\
**Last updated:** [April 5, 2017, 11:22pm UTC](https://discuss.elastic.co/t/logstash-input-speed-slow-around-8-000events-sec-writing-to-local-file/2591 "2017-04-05T23:22:36Z")

</div>

Hello guys, thanks for noticing this question. I am trying to build up a centralized logging system using ELK framework, but the speed is very slow. I checked and the problem is on logstash. I used a generator to generat…

---

## [{"statusCode":404,"error":"Not Found","message":"Not Found"} after security](https://discuss.elastic.co/t/statuscode-404-error-not-found-message-not-found-after-security/252730)

<div class="topic-metadata">

**Author:** [@txmrlevine](https://discuss.elastic.co/u/txmrlevine)\
**Replies:** 13\
**Last updated:** [October 26, 2020, 8:10pm UTC](https://discuss.elastic.co/t/statuscode-404-error-not-found-message-not-found-after-security/252730 "2020-10-26T20:10:51Z")

</div>

after implementing the following lines in my 7.7.1 nodes I try to bring up Kibana and AFTER I use the login credentials I supplied in the password-setup binary I get the 404. I created the cert on the master node and p…

---

## [Customize Kibana 6.5 Login Page](https://discuss.elastic.co/t/customize-kibana-6-5-login-page/157153)

<div class="topic-metadata">

**Author:** [@nandrik](https://discuss.elastic.co/u/nandrik)\
**Replies:** 11\
**Last updated:** [December 31, 2018, 2:54am UTC](https://discuss.elastic.co/t/customize-kibana-6-5-login-page/157153 "2018-12-31T02:54:25Z")

</div>

I've read a few posts around how to customize the login page of Kibana but all seem obsolete since from version to version, the code gets changed and so do the mods. I managed to replace the "Welcome to Kibana" and the…

---

## [Must delete files in message queue to start logstash](https://discuss.elastic.co/t/must-delete-files-in-message-queue-to-start-logstash/71907)

<div class="topic-metadata">

**Author:** [@panaman](https://discuss.elastic.co/u/panaman)\
**Replies:** 18\
**Last updated:** [February 15, 2017, 8:06pm UTC](https://discuss.elastic.co/t/must-delete-files-in-message-queue-to-start-logstash/71907 "2017-02-15T20:06:48Z")

</div>

For some reason if i restart logstash and there is a few gig of messages in the queue logstash complains that there is a config error \[2017-01-17T20:34:41,732\]\[ERROR\]\[logstash.agent \] fetched an invalid con…

---

## [Current license is non-compliant for \[jdbc\]](https://discuss.elastic.co/t/current-license-is-non-compliant-for-jdbc/152594)

<div class="topic-metadata">

**Author:** [@prashantmipl](https://discuss.elastic.co/u/prashantmipl)\
**Replies:** 9\
**Last updated:** [October 16, 2018, 7:39am UTC](https://discuss.elastic.co/t/current-license-is-non-compliant-for-jdbc/152594 "2018-10-16T07:39:19Z")

</div>

current license is non-compliant for \[jdbc\] try{ Class.forName("org.elasticsearch.xpack.sql.jdbc.jdbc.JdbcDriver"); Connection con=DriverManager.getConnection("jdbc:es://http://localhost:9200/text"); //here s…

---

## [How to share dashboard for others without login after enable xpack.security](https://discuss.elastic.co/t/how-to-share-dashboard-for-others-without-login-after-enable-xpack-security/191124)

<div class="topic-metadata">

**Author:** [@wenchaodu](https://discuss.elastic.co/u/wenchaodu)\
**Replies:** 9\
**Last updated:** [August 7, 2019, 5:54am UTC](https://discuss.elastic.co/t/how-to-share-dashboard-for-others-without-login-after-enable-xpack-security/191124 "2019-08-07T05:54:30Z")

</div>

After enbale expack.secuiry, all of users should be login if they are want to discover, dashboard..etc. If i want to share a dashboard and embed the dashboard to other web site, how i can do it ? Another question, is t…

---

## [Notifications from Elasticsearch when documents are added](https://discuss.elastic.co/t/notifications-from-elasticsearch-when-documents-are-added/5106)

<div class="topic-metadata">

**Author:** [@vineeth\_mohan](https://discuss.elastic.co/u/vineeth_mohan)\
**Replies:** 30\
**Last updated:** [June 27, 2014, 6:12pm UTC](https://discuss.elastic.co/t/notifications-from-elasticsearch-when-documents-are-added/5106 "2014-06-27T18:12:21Z")

</div>

In couchDB there is a service where any external application interested in a particular document can hook to coucDB and if the sth document is available , couchDB notifies the external application. Is there any sim…

---

## [Logstash Out of memory](https://discuss.elastic.co/t/logstash-out-of-memory/28687)

<div class="topic-metadata">

**Author:** [@michaellizhou](https://discuss.elastic.co/u/michaellizhou)\
**Replies:** 22\
**Last updated:** [April 5, 2016, 12:51pm UTC](https://discuss.elastic.co/t/logstash-out-of-memory/28687 "2016-04-05T12:51:20Z")

</div>

Has anyone experience this when trying to run logstash with the jdbc input plugin ../bin/logstash -f logstash.conf Logstash startup completed Error: Your application used more memory than the safety cap of 500M. Speci…

---

## [Error 500 Internal Server Error](https://discuss.elastic.co/t/error-500-internal-server-error/46513)

<div class="topic-metadata">

**Author:** [@theo.bot](https://discuss.elastic.co/u/theo.bot)\
**Replies:** 9\
**Last updated:** [July 20, 2016, 10:11am UTC](https://discuss.elastic.co/t/error-500-internal-server-error/46513 "2016-07-20T10:11:54Z")

</div>

I just install graph to an es server (2.3.1) with shield. But when I tried to pass a query I got an error 500. In the logs i found the following: Kibana.stdout: {"type":"error","@timestamp":"2016-04-06T10:55:06+00:00","t…

---

## [Elasticsearch errors](https://discuss.elastic.co/t/elasticsearch-errors/89720)

<div class="topic-metadata">

**Author:** [@raghvendra](https://discuss.elastic.co/u/raghvendra)\
**Replies:** 15\
**Last updated:** [August 4, 2017, 2:28pm UTC](https://discuss.elastic.co/t/elasticsearch-errors/89720 "2017-08-04T14:28:15Z")

</div>

I ..I have 3 node of cluster . I have installed x pack . Everything was working fine but by mistake , one node of my cluster got disconnected . So I restarted cluster .. now it is giving these errors . \[2017-06-16T18…

---

## [Elasitcsearch-ruby raises "Cannot get new connection from pool" error](https://discuss.elastic.co/t/elasitcsearch-ruby-raises-cannot-get-new-connection-from-pool-error/36252)

<div class="topic-metadata">

**Author:** [@repeatedly](https://discuss.elastic.co/u/repeatedly)\
**Replies:** 11\
**Last updated:** [July 25, 2016, 10:02am UTC](https://discuss.elastic.co/t/elasitcsearch-ruby-raises-cannot-get-new-connection-from-pool-error/36252 "2016-07-25T10:02:28Z")

</div>

Hi folks, Original discussion is here: https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363 Recently, some users reported fluent-plugin-elasticsearch failed to import logs to…

---

## [Creating Dashboard for apache access logs using Filebeat](https://discuss.elastic.co/t/creating-dashboard-for-apache-access-logs-using-filebeat/333159)

<div class="topic-metadata">

**Author:** [@kriti\_dabas](https://discuss.elastic.co/u/kriti_dabas)\
**Replies:** 73\
**Last updated:** [June 1, 2023, 8:48am UTC](https://discuss.elastic.co/t/creating-dashboard-for-apache-access-logs-using-filebeat/333159 "2023-06-01T08:48:05Z")

</div>

Hey I want to create Dashboard using filebeat for apache access logs. I have complete 11 nodes on staging out of which 7 nodes are of elasticsearch(3 master nodes, 2 coordination nodes, 2 data nodes), and other 3 nodes a…

---

## [Uploading Images in kibana Dashboard](https://discuss.elastic.co/t/uploading-images-in-kibana-dashboard/27999)

<div class="topic-metadata">

**Author:** [@Suganthi\_Thangavel](https://discuss.elastic.co/u/Suganthi_Thangavel)\
**Replies:** 10\
**Last updated:** [February 23, 2022, 12:54pm UTC](https://discuss.elastic.co/t/uploading-images-in-kibana-dashboard/27999 "2022-02-23T12:54:53Z")

</div>

Hi, I have requirement to add some images to the Kibana Dashboard. Is there any plugin for kibana so that i can browse the image and upload to the panel. we are using kibana 3 Thanks Suganthi

[Previous page](https://discuss.elastic.co/top.md?page=9&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=11&per_page=50&period=all)
