# Top

**URL:** https://discuss.elastic.co/top.md?page=15&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 16

---

## [error=\>#\<ArgumentError: Setting "" hasn't been registered\>](https://discuss.elastic.co/t/error-argumenterror-setting-hasnt-been-registered/78666)

<div class="topic-metadata">

**Author:** [@Ragnar](https://discuss.elastic.co/u/Ragnar)\
**Replies:** 15\
**Last updated:** [April 6, 2017, 1:46am UTC](https://discuss.elastic.co/t/error-argumenterror-setting-hasnt-been-registered/78666 "2017-04-06T01:46:24Z")

</div>

Hi there, I want to send a +8Go csv file to my ES server form my machine. I use Logstash to send the file with this conf : input { file { path =\> "/Users/karnag/Downloads/siren201703.csv" start\_position …

---

## [Logstash configuration](https://discuss.elastic.co/t/logstash-configuration/74982)

<div class="topic-metadata">

**Author:** [@Nikparab](https://discuss.elastic.co/u/Nikparab)\
**Replies:** 46\
**Last updated:** [March 20, 2017, 8:04am UTC](https://discuss.elastic.co/t/logstash-configuration/74982 "2017-03-20T08:04:32Z")

</div>

I need to parse mongodb logs in elasticsearch using logstash. I need to index only command that fired in mongodb logs. I have following config file of logstash:- input { file { path =\> "C:/Data/log/mongod.log" …

---

## [Grok filter to Replace @timestamp with my log-time](https://discuss.elastic.co/t/grok-filter-to-replace-timestamp-with-my-log-time/105364)

<div class="topic-metadata">

**Author:** [@Toni\_Riera](https://discuss.elastic.co/u/Toni_Riera)\
**Replies:** 12\
**Last updated:** [November 14, 2017, 2:05pm UTC](https://discuss.elastic.co/t/grok-filter-to-replace-timestamp-with-my-log-time/105364 "2017-11-14T14:05:36Z")

</div>

Hi there, I'm trying to find out what to do, but got stucked in there. I've got ELK runnning on a single machine, and i'm trying to analyze certain logs using Logstash. Currently i've got an entry like this: Jan 22 15…

---

## [How do I query for a tag in Kibana?](https://discuss.elastic.co/t/how-do-i-query-for-a-tag-in-kibana/119144)

<div class="topic-metadata">

**Author:** [@daved](https://discuss.elastic.co/u/daved)\
**Replies:** 11\
**Last updated:** [February 9, 2018, 9:29pm UTC](https://discuss.elastic.co/t/how-do-i-query-for-a-tag-in-kibana/119144 "2018-02-09T21:29:53Z")

</div>

Hi, I'm trying to understand the syntax to query for the existence of a tag in Kibana? I understand I could use filters but I want to be able to use OR to combine results from multiple tags (from what I see this isn't p…

---

## [How do I know if curator is cleaning up? (SOLVED)](https://discuss.elastic.co/t/how-do-i-know-if-curator-is-cleaning-up-solved/28887)

<div class="topic-metadata">

**Author:** [@killmasta93](https://discuss.elastic.co/u/killmasta93)\
**Replies:** 16\
**Last updated:** [October 23, 2016, 4:57pm UTC](https://discuss.elastic.co/t/how-do-i-know-if-curator-is-cleaning-up-solved/28887 "2016-10-23T16:57:45Z")

</div>

Hi, I was wondering if someone could clear up a question I have with curator. So I installed Curator sudo apt-get install python-pip then pip install elasticsearch-curator then crontab -e then at the end of…

---

## ["Failed to connect" error](https://discuss.elastic.co/t/failed-to-connect-error/144180)

<div class="topic-metadata">

**Author:** [@g.myznikov.tinkoff](https://discuss.elastic.co/u/g.myznikov.tinkoff)\
**Replies:** 10\
**Last updated:** [August 15, 2018, 3:40pm UTC](https://discuss.elastic.co/t/failed-to-connect-error/144180 "2018-08-15T15:40:11Z")

</div>

Hello! I've used ELK stack with filebeat on docker. There are my config file. elasticsearch.yml: path.data: /var/lib/elasticsearch path.logs: /var/log/elasticsearch network.host: 0.0.0.0 kibana.yml: server.port: 5601…

---

## [File input for gz files](https://discuss.elastic.co/t/file-input-for-gz-files/35822)

<div class="topic-metadata">

**Author:** [@mvenkat\_in](https://discuss.elastic.co/u/mvenkat_in)\
**Replies:** 11\
**Last updated:** [November 28, 2016, 1:36pm UTC](https://discuss.elastic.co/t/file-input-for-gz-files/35822 "2016-11-28T13:36:30Z")

</div>

HI I have seen few topics on logstash supporting reading from the gz files. Would like to know if this feature is supported !! I am using logstash 2.1.0. If supported please share me the sample input config. Below …

---

## [Failed to execute bulk item (index) index](https://discuss.elastic.co/t/failed-to-execute-bulk-item-index-index/51890)

<div class="topic-metadata">

**Author:** [@X-Mars](https://discuss.elastic.co/u/X-Mars)\
**Replies:** 10\
**Last updated:** [June 8, 2016, 5:07am UTC](https://discuss.elastic.co/t/failed-to-execute-bulk-item-index-index/51890 "2016-06-08T05:07:45Z")

</div>

dear all \*\*the elasticsearch often have no response 。\*\* \*\* when it's NO RESPONSE ，i can stop the service with “service elasticsearch stop”，i olny can ”KILL -9”，Please help me。\*\* \*\* and i can not open …

---

## [Configuring filebeat to send specified logs to E.L.K server's logstash HELP!](https://discuss.elastic.co/t/configuring-filebeat-to-send-specified-logs-to-e-l-k-servers-logstash-help/44830)

<div class="topic-metadata">

**Author:** [@brayndasilva](https://discuss.elastic.co/u/brayndasilva)\
**Replies:** 15\
**Last updated:** [September 20, 2016, 12:59am UTC](https://discuss.elastic.co/t/configuring-filebeat-to-send-specified-logs-to-e-l-k-servers-logstash-help/44830 "2016-09-20T00:59:11Z")

</div>

Hi there, About two days ago I started looking into ELK and decided to try it out on a few machines. My set-up is the following: 1 E.L.K server, 2 Client servers and 1 Laptop to access Kibana. I have followed the o…

---

## [Logtash to elasticsearch connection error using certificate](https://discuss.elastic.co/t/logtash-to-elasticsearch-connection-error-using-certificate/204799)

<div class="topic-metadata">

**Author:** [@akshatBais](https://discuss.elastic.co/u/akshatBais)\
**Replies:** 23\
**Last updated:** [October 24, 2019, 6:17am UTC](https://discuss.elastic.co/t/logtash-to-elasticsearch-connection-error-using-certificate/204799 "2019-10-24T06:17:03Z")

</div>

Hi All, I am facing this isssue while connecting elasticsearch with logstash over certificate . I have mentioned the logstash.yml path in startup.options file is LS\_HOME and LS\_SETTINGS\_DIR . Still it gives me the foll…

---

## [What does "Indices Lucene memory" mean? Using a large amount of heap space](https://discuss.elastic.co/t/what-does-indices-lucene-memory-mean-using-a-large-amount-of-heap-space/42615)

<div class="topic-metadata">

**Author:** [@Melanie\_Zamora](https://discuss.elastic.co/u/Melanie_Zamora)\
**Replies:** 16\
**Last updated:** [February 21, 2017, 8:39pm UTC](https://discuss.elastic.co/t/what-does-indices-lucene-memory-mean-using-a-large-amount-of-heap-space/42615 "2017-02-21T20:39:29Z")

</div>

Hi, I'm running ES 1.7. 2 node cluster on Centos 7. Heap Size: 30GB out of 96GB total RAM. 533 total shards 155 indices 1.7TB total index size Fielddata size is set to 40% of heap, so 12GB Issue: Very long old JVM…

---

## [Kibana Discover - No results found :|](https://discuss.elastic.co/t/kibana-discover-no-results-found/33146)

<div class="topic-metadata">

**Author:** [@jsps](https://discuss.elastic.co/u/jsps)\
**Replies:** 14\
**Last updated:** [November 24, 2016, 8:48am UTC](https://discuss.elastic.co/t/kibana-discover-no-results-found/33146 "2016-11-24T08:48:05Z")

</div>

Im doing something wrong but cant work it out, any help is appreciated. I have a bunch of documents in elasticsearch, this is the search and result from Marvel: GET /my\_index/my\_type/\_search {"query" : { "bool" :…

---

## [Set field as not\_analyzed in Elastic Search](https://discuss.elastic.co/t/set-field-as-not-analyzed-in-elastic-search/58553)

<div class="topic-metadata">

**Author:** [@Denis\_Wessels](https://discuss.elastic.co/u/Denis_Wessels)\
**Replies:** 22\
**Last updated:** [August 22, 2016, 9:25am UTC](https://discuss.elastic.co/t/set-field-as-not-analyzed-in-elastic-search/58553 "2016-08-22T09:25:10Z")

</div>

I have a string field in my Elastic search index.When I view it in Kibana it splits it to form multiple words, I want to prevent this from happenening. This is the warning I get in Kibana: Careful! The field selected…

---

## [Logstash didn't receive Filebeat data](https://discuss.elastic.co/t/logstash-didnt-receive-filebeat-data/117920)

<div class="topic-metadata">

**Author:** [@tracywan](https://discuss.elastic.co/u/tracywan)\
**Replies:** 9\
**Last updated:** [February 2, 2018, 11:04am UTC](https://discuss.elastic.co/t/logstash-didnt-receive-filebeat-data/117920 "2018-02-02T11:04:47Z")

</div>

Hi, I configured filebeat on my mac os local, logstash on the vm with public internet. But I didn't see the filebeat client logs coming through, not on the logstash debug logs, not on the kibana either. Logstash was us…

---

## [Kibana cannot create index pattern](https://discuss.elastic.co/t/kibana-cannot-create-index-pattern/111001)

<div class="topic-metadata">

**Author:** [@Terry](https://discuss.elastic.co/u/Terry)\
**Replies:** 10\
**Last updated:** [December 18, 2017, 4:36am UTC](https://discuss.elastic.co/t/kibana-cannot-create-index-pattern/111001 "2017-12-18T04:36:47Z")

</div>

After deleting all indexes using curl -XDELETE http://localhost:9200/\_all I tried to create index pattern again but when I clicked the create button, it didn't response and no index was created. How to fix this problem? …

---

## [Logstash stopped working (sincedb is not updated) after upgrade from 6.2.4 –\> 6.4.0 (Update 6.5 doesn't work also)](https://discuss.elastic.co/t/logstash-stopped-working-sincedb-is-not-updated-after-upgrade-from-6-2-4-6-4-0-update-6-5-doesnt-work-also/161335)

<div class="topic-metadata">

**Author:** [@RonGros](https://discuss.elastic.co/u/RonGros)\
**Replies:** 67\
**Last updated:** [April 15, 2019, 6:33am UTC](https://discuss.elastic.co/t/logstash-stopped-working-sincedb-is-not-updated-after-upgrade-from-6-2-4-6-4-0-update-6-5-doesnt-work-also/161335 "2019-04-15T06:33:31Z")

</div>

Hi, In continuation of the following topic which is now closed: We found no solution for that. moreover - we just tried installing Logstash 6.5 on a new machine and we get the same results - the logstash runs, but sin…

---

## [Elasticsearch Linux Installation: Permission Denied](https://discuss.elastic.co/t/elasticsearch-linux-installation-permission-denied/44517)

<div class="topic-metadata">

**Author:** [@krushnat\_khawale](https://discuss.elastic.co/u/krushnat_khawale)\
**Replies:** 9\
**Last updated:** [March 16, 2016, 8:18pm UTC](https://discuss.elastic.co/t/elasticsearch-linux-installation-permission-denied/44517 "2016-03-16T20:18:26Z")

</div>

Following error I am getting while running ES on amazon linux server: ubuntu@ip-1XX-XX-XX-1X5:~/elasticsearch-2.2.1$ bin/elasticsearch -bash: bin/elasticsearch: Permission denied

---

## [Elasticsearch 7.x support for ARM64 (Raspberry Pi 4 B)](https://discuss.elastic.co/t/elasticsearch-7-x-support-for-arm64-raspberry-pi-4-b/187976)

<div class="topic-metadata">

**Author:** [@Jason\_Baumgartner](https://discuss.elastic.co/u/Jason_Baumgartner)\
**Replies:** 10\
**Last updated:** [August 21, 2019, 1:37pm UTC](https://discuss.elastic.co/t/elasticsearch-7-x-support-for-arm64-raspberry-pi-4-b/187976 "2019-08-21T13:37:13Z")

</div>

Previous versions of Elasticsearch (6.x, etc.) could easily be installed on ARM64 but Elasticsearch 7.x gives an error: "package architecture (amd64) does not match system (armhf)" Previously, I was able to install pac…

---

## [Is ES capable of doing pagination?](https://discuss.elastic.co/t/is-es-capable-of-doing-pagination/5526)

<div class="topic-metadata">

**Author:** [@Boris\_Yen](https://discuss.elastic.co/u/Boris_Yen)\
**Replies:** 15\
**Last updated:** [July 23, 2014, 1:55pm UTC](https://discuss.elastic.co/t/is-es-capable-of-doing-pagination/5526 "2014-07-23T13:55:30Z")

</div>

Hi, I am fairly new to ES. I was wondering if ES is capable of doing the pagination? My use case is if the query result is huge, can ES return a specific amount of data as request? For example, I might only need rec…

---

## [Elasticsearch Won't Start After Upgrading from 5.5 to 6.0](https://discuss.elastic.co/t/elasticsearch-wont-start-after-upgrading-from-5-5-to-6-0/108167)

<div class="topic-metadata">

**Author:** [@megadevx](https://discuss.elastic.co/u/megadevx)\
**Replies:** 14\
**Last updated:** [November 21, 2017, 7:15pm UTC](https://discuss.elastic.co/t/elasticsearch-wont-start-after-upgrading-from-5-5-to-6-0/108167 "2017-11-21T19:15:45Z")

</div>

We have been unable to get Elasticsearch to start back up after upgrading following this guide: https://www.elastic.co/guide/en/elasticsearch/reference/current/restart-upgrade.html Elasticsearchhas this status : elasti…

---

## [Logstash not ingesting syslog](https://discuss.elastic.co/t/logstash-not-ingesting-syslog/68613)

<div class="topic-metadata">

**Author:** [@sfchrisgleason](https://discuss.elastic.co/u/sfchrisgleason)\
**Replies:** 15\
**Last updated:** [December 14, 2016, 5:19am UTC](https://discuss.elastic.co/t/logstash-not-ingesting-syslog/68613 "2016-12-14T05:19:07Z")

</div>

Good evening. This is my first post here, so forgive me if I'm missing some rules here. I'll try to be as concise as possible: Issue: I am not able to get logstash to ingest Syslog files from servers using the syslog s…

---

## [ElasticSearch 2.0 java api JarHell problems](https://discuss.elastic.co/t/elasticsearch-2-0-java-api-jarhell-problems/34776)

<div class="topic-metadata">

**Author:** [@George](https://discuss.elastic.co/u/George)\
**Replies:** 29\
**Last updated:** [August 2, 2016, 12:01pm UTC](https://discuss.elastic.co/t/elasticsearch-2-0-java-api-jarhell-problems/34776 "2016-08-02T12:01:20Z")

</div>

Hello everybody, I'm trying to migrate from elasticsearch 1.6.0 to 2.0.0 using the Java API. The tests were passing with 1.60. However, after I made the tests compile with 2.0.0 my tests are failing when running them …

---

## [Inserting Datetime field using ES Nest](https://discuss.elastic.co/t/inserting-datetime-field-using-es-nest/51899)

<div class="topic-metadata">

**Author:** [@ASN](https://discuss.elastic.co/u/ASN)\
**Replies:** 19\
**Last updated:** [June 6, 2016, 10:41am UTC](https://discuss.elastic.co/t/inserting-datetime-field-using-es-nest/51899 "2016-06-06T10:41:18Z")

</div>

I'm trying to add a field which takes the system's datetime (DateTime.Now) and index it on ES server. When I insert it without any custom format, I can index the documents. But if I mention any format, it is throwing an…

---

## [Upgrade issue with Elastic Stack 5.6.0, workaround option until fix is available](https://discuss.elastic.co/t/upgrade-issue-with-elastic-stack-5-6-0-workaround-option-until-fix-is-available/100595)

<div class="topic-metadata">

**Author:** [@marty](https://discuss.elastic.co/u/marty)\
**Replies:** 9\
**Last updated:** [September 25, 2017, 2:33pm UTC](https://discuss.elastic.co/t/upgrade-issue-with-elastic-stack-5-6-0-workaround-option-until-fix-is-available/100595 "2017-09-25T14:33:05Z")

</div>

Since the release of Elastic Stack 5.6.0, we’ve discovered an issue during the upgrade process to this version. Who is affected Anyone upgrading a cluster that has indexes created with Elasticsearch 2.x or prior. This d…

---

## [Elasticsearch Create a snapshot repository error](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830)

<div class="topic-metadata">

**Author:** [@Canon88](https://discuss.elastic.co/u/Canon88)\
**Replies:** 13\
**Last updated:** [May 17, 2021, 10:16am UTC](https://discuss.elastic.co/t/elasticsearch-create-a-snapshot-repository-error/60830 "2021-05-17T10:16:46Z")

</div>

When I use curl -XPUT 'http://192.168.184.33:9200/\_snapshot/elkbak' -d '{"type": "fs","settings": {"location": "/data/elk\_bak","compress": true}}'. Shows the following error: {"error":{"root\_cause":\[{"type":"repository…

---

## [Update timestamp in all documents in an index](https://discuss.elastic.co/t/update-timestamp-in-all-documents-in-an-index/170540)

<div class="topic-metadata">

**Author:** [@ramzey1981](https://discuss.elastic.co/u/ramzey1981)\
**Replies:** 28\
**Last updated:** [March 6, 2019, 4:08pm UTC](https://discuss.elastic.co/t/update-timestamp-in-all-documents-in-an-index/170540 "2019-03-06T16:08:06Z")

</div>

we had a backlog of messages in kafa for filebeat coming from syslog with the following format which were from 2018, Dec 31 23:59:59 phc1803-hdfs-03 consul: 2018/12/31 23:59:59 \[WARN\] agent: Check 'service:timeseries-hd…

---

## [ES Single Index Scalability Limited to 3TB of RAM?](https://discuss.elastic.co/t/es-single-index-scalability-limited-to-3tb-of-ram/61431)

<div class="topic-metadata">

**Author:** [@Michael\_Sander](https://discuss.elastic.co/u/Michael_Sander)\
**Replies:** 32\
**Last updated:** [December 17, 2016, 4:14pm UTC](https://discuss.elastic.co/t/es-single-index-scalability-limited-to-3tb-of-ram/61431 "2016-12-17T16:14:53Z")

</div>

I am curious if any ES users have scaled their systems to reliably handle several terabytes of data or beyond. My back-of-the-napkin calculations below suggest that an ES system is limited to about 3TB of RAM, which make…

---

## [Getting empty response from server](https://discuss.elastic.co/t/getting-empty-response-from-server/319175)

<div class="topic-metadata">

**Author:** [@Neelam\_Zanvar](https://discuss.elastic.co/u/Neelam_Zanvar)\
**Replies:** 9\
**Last updated:** [November 18, 2022, 4:42am UTC](https://discuss.elastic.co/t/getting-empty-response-from-server/319175 "2022-11-18T04:42:00Z")

</div>

Hi I've installed elk stack of version 8.5.1. All services are active. But when i try to access curl http://localhost:9200 or publicip:9200 getting empty response error path.data: /var/lib/elasticsearch path.logs: /var…

---

## [Waiting for Marvel Data.... No Data](https://discuss.elastic.co/t/waiting-for-marvel-data-no-data/50631)

<div class="topic-metadata">

**Author:** [@jnpetty](https://discuss.elastic.co/u/jnpetty)\
**Replies:** 23\
**Last updated:** [September 1, 2016, 3:06pm UTC](https://discuss.elastic.co/t/waiting-for-marvel-data-no-data/50631 "2016-09-01T15:06:56Z")

</div>

While trying to resolve an issue where the node names where showing up as the node ID numbers it was suggested that I remove the Marvel indexes and the .marvel-es-data file. After doing so data is no longer showing up in…

---

## [Gc overhead reduces ElasticSearch Performance](https://discuss.elastic.co/t/gc-overhead-reduces-elasticsearch-performance/145065)

<div class="topic-metadata">

**Author:** [@pranay\_sankpal](https://discuss.elastic.co/u/pranay_sankpal)\
**Replies:** 13\
**Last updated:** [August 25, 2018, 7:12am UTC](https://discuss.elastic.co/t/gc-overhead-reduces-elasticsearch-performance/145065 "2018-08-25T07:12:11Z")

</div>

Infrastructure details : 3 \* i3.xlarge instances for ES 1 \* t2.medium instance for logstash Volume type : io1 Software details : ElasticSearch Docker image : 6.3.0 Logstash : 5.3 Beats : 5.3 Requests : 350/sec P…

---

## [Solving version\_conflict\_engine\_exception on update](https://discuss.elastic.co/t/solving-version-conflict-engine-exception-on-update/317337)

<div class="topic-metadata">

**Author:** [@OranShuster](https://discuss.elastic.co/u/OranShuster)\
**Replies:** 9\
**Last updated:** [October 24, 2022, 8:31pm UTC](https://discuss.elastic.co/t/solving-version-conflict-engine-exception-on-update/317337 "2022-10-24T20:31:46Z")

</div>

Preface - Cluster is running version 6.8 and we are doing a mix of search/create/update using the NodeJS Operations can access the same document in quick succession/concurrently since its based off events coming from k…

---

## [Split array fields in logstash](https://discuss.elastic.co/t/split-array-fields-in-logstash/84546)

<div class="topic-metadata">

**Author:** [@Aditya\_Srivastava](https://discuss.elastic.co/u/Aditya_Srivastava)\
**Replies:** 21\
**Last updated:** [May 10, 2017, 10:03am UTC](https://discuss.elastic.co/t/split-array-fields-in-logstash/84546 "2017-05-10T10:03:11Z")

</div>

I have an input where field and value is "id"=\["0", "7", "11", "39", "70"\] I want to split it and make index as key and split value as value. and then print the index where value is 39. ruby { code =\> " …

---

## [Exclude specific terms from term aggregation's buckets list](https://discuss.elastic.co/t/exclude-specific-terms-from-term-aggregations-buckets-list/131122)

<div class="topic-metadata">

**Author:** [@randomuser](https://discuss.elastic.co/u/randomuser)\
**Replies:** 10\
**Last updated:** [June 1, 2018, 7:10pm UTC](https://discuss.elastic.co/t/exclude-specific-terms-from-term-aggregations-buckets-list/131122 "2018-06-01T19:10:27Z")

</div>

Hello, Is there any way to filter the searched term from the results? I'm using a standard tokeniser, the field "word" usually contains values like "green table", "big table", "yellow tables".. my aggregation will put …

---

## [Много вопросов от новичка](https://discuss.elastic.co/t/topic/114753)

<div class="topic-metadata">

**Author:** [@leov](https://discuss.elastic.co/u/leov)\
**Replies:** 33\
**Last updated:** [January 25, 2018, 5:19pm UTC](https://discuss.elastic.co/t/topic/114753 "2018-01-25T17:19:19Z")

</div>

Здравствуйте! пытаюсь изучать эластик потому как надо допилить одну софтину работающую криво не скажу что уж совсем новичек но эта тема идет уж так туго что просто удивляюсь себе хотел бы найти где позадавать вопросы…

---

## [Log/log.go:145 Non-zero metrics in the last 30s](https://discuss.elastic.co/t/log-log-go-145-non-zero-metrics-in-the-last-30s/231873)

<div class="topic-metadata">

**Author:** [@sai\_charan](https://discuss.elastic.co/u/sai_charan)\
**Replies:** 16\
**Last updated:** [May 16, 2020, 11:16am UTC](https://discuss.elastic.co/t/log-log-go-145-non-zero-metrics-in-the-last-30s/231873 "2020-05-16T11:16:23Z")

</div>

Hello, I am new to ELK stack and configured my filebeat in such a way that it directly send logs to elasticsearch itself. Problem here is when i ran the filebeat in debug mode using the below command, i am getting the l…

---

## [How to send a json object to elasticsearch throw logstash](https://discuss.elastic.co/t/how-to-send-a-json-object-to-elasticsearch-throw-logstash/79516)

<div class="topic-metadata">

**Author:** [@DemeCarvO](https://discuss.elastic.co/u/DemeCarvO)\
**Replies:** 14\
**Last updated:** [March 22, 2017, 8:25pm UTC](https://discuss.elastic.co/t/how-to-send-a-json-object-to-elasticsearch-throw-logstash/79516 "2017-03-22T20:25:30Z")

</div>

I am creating "bill" feature in my nodejs application that basically will save in Elasticsearch the username every time any user access any rest service. I have struggling for the last two days with no success. It is my…

---

## [Filebeat not connecting directly to Elasticsearch from particular machine](https://discuss.elastic.co/t/filebeat-not-connecting-directly-to-elasticsearch-from-particular-machine/51999)

<div class="topic-metadata">

**Author:** [@Michael1](https://discuss.elastic.co/u/Michael1)\
**Replies:** 23\
**Last updated:** [June 21, 2016, 11:09am UTC](https://discuss.elastic.co/t/filebeat-not-connecting-directly-to-elasticsearch-from-particular-machine/51999 "2016-06-21T11:09:18Z")

</div>

Beats: latest OS: Windows Server 2012 R2 Datacenter I am able to get other machines working fine but for some reason, I ran into issues with one particular machine. Here is the filebeat.yml ################### Fil…

---

## [Missing plugin-descriptor.properties](https://discuss.elastic.co/t/missing-plugin-descriptor-properties/120122)

<div class="topic-metadata">

**Author:** [@ryext](https://discuss.elastic.co/u/ryext)\
**Replies:** 10\
**Last updated:** [February 16, 2018, 9:30am UTC](https://discuss.elastic.co/t/missing-plugin-descriptor-properties/120122 "2018-02-16T09:30:12Z")

</div>

hey, i am trying to install x-pack plugin. Here is my command: ./elasticsearch-plugin install file:///home/admin/Downloads/x-pack-6.2.1.zip Once i execute i get the following error: Exception in thread "main" java.ni…

---

## [Sometimes "Ruby exception occurred: no implicit conversion of nil into String"](https://discuss.elastic.co/t/sometimes-ruby-exception-occurred-no-implicit-conversion-of-nil-into-string/135401)

<div class="topic-metadata">

**Author:** [@vb4t](https://discuss.elastic.co/u/vb4t)\
**Replies:** 14\
**Last updated:** [June 11, 2018, 7:40pm UTC](https://discuss.elastic.co/t/sometimes-ruby-exception-occurred-no-implicit-conversion-of-nil-into-string/135401 "2018-06-11T19:40:10Z")

</div>

Hello, I use following ruby code in ruby filter to remove empty fields and fields containing "-" from fields nested in "parentfield" . The code works 99% time well, but sometimes I get ruby exception "Ruby exception occ…

---

## [Choosing the right heap size for warm data nodes](https://discuss.elastic.co/t/choosing-the-right-heap-size-for-warm-data-nodes/136341)

<div class="topic-metadata">

**Author:** [@iamredlus](https://discuss.elastic.co/u/iamredlus)\
**Replies:** 10\
**Last updated:** [July 4, 2018, 11:35pm UTC](https://discuss.elastic.co/t/choosing-the-right-heap-size-for-warm-data-nodes/136341 "2018-07-04T23:35:50Z")

</div>

Hi One of our production clusters has 40 hot data nodes (8 cores, 64gb ram out of which 30.5gb heap and 1.5tb of local SSD storage), and 30 warm data nodes (8 cores, 32gb ram out of which 16gb heap and 5tb of attached H…

---

## [Curl single quotes vs. double quotes](https://discuss.elastic.co/t/curl-single-quotes-vs-double-quotes/114671)

<div class="topic-metadata">

**Author:** [@boudewijnk](https://discuss.elastic.co/u/boudewijnk)\
**Replies:** 11\
**Last updated:** [January 10, 2018, 4:50pm UTC](https://discuss.elastic.co/t/curl-single-quotes-vs-double-quotes/114671 "2018-01-10T16:50:34Z")

</div>

I follow the Elastic tutorial and experience and error when I use the curl code provided in the tutorial: curl -H "Content-Type: application/json" -XPOST 'localhost:9200/bank/account/\_bulk?pretty&refresh' --data-binary …

---

## [Elasticsearch is still initializing the kibana index](https://discuss.elastic.co/t/elasticsearch-is-still-initializing-the-kibana-index/34755)

<div class="topic-metadata">

**Author:** [@gugansankar](https://discuss.elastic.co/u/gugansankar)\
**Replies:** 16\
**Last updated:** [August 8, 2016, 5:18pm UTC](https://discuss.elastic.co/t/elasticsearch-is-still-initializing-the-kibana-index/34755 "2016-08-08T17:18:52Z")

</div>

I'm getting the same error message but its not resolved even I deleting .kibana index and restarted the service. Elasticsearch cluster state : Red Versions: Elasticsearch : 2.0 Kibana : 4.2.0 Cluster health Log: c…

---

## [Retrieve Search Results Based on the First Letter in a Specific Field](https://discuss.elastic.co/t/retrieve-search-results-based-on-the-first-letter-in-a-specific-field/185852)

<div class="topic-metadata">

**Author:** [@maryam\_abdullah](https://discuss.elastic.co/u/maryam_abdullah)\
**Replies:** 29\
**Last updated:** [July 1, 2019, 11:50am UTC](https://discuss.elastic.co/t/retrieve-search-results-based-on-the-first-letter-in-a-specific-field/185852 "2019-07-01T11:50:32Z")

</div>

Hey, Is it possible to search based on the first letter in a specified field of documents? for example, when the query is letter 'A", all documents that have titles that start with 'A' are returned. thanks.

---

## [Sending logs to logstash using http](https://discuss.elastic.co/t/sending-logs-to-logstash-using-http/81361)

<div class="topic-metadata">

**Author:** [@Leela\_Kodali](https://discuss.elastic.co/u/Leela_Kodali)\
**Replies:** 9\
**Last updated:** [April 12, 2017, 2:21pm UTC](https://discuss.elastic.co/t/sending-logs-to-logstash-using-http/81361 "2017-04-12T14:21:41Z")

</div>

Hi, My logs are exposed on http. , how to push logs to logstash using http, earlier i use file beat it is working fine, but if i use http how is my logstash.json file will be: input { http { host =\> "127.0.0.1" #…

---

## [Could Not index event to ElasticSearch](https://discuss.elastic.co/t/could-not-index-event-to-elasticsearch/250027)

<div class="topic-metadata">

**Author:** [@dhoman](https://discuss.elastic.co/u/dhoman)\
**Replies:** 37\
**Last updated:** [October 16, 2020, 7:05pm UTC](https://discuss.elastic.co/t/could-not-index-event-to-elasticsearch/250027 "2020-10-16T19:05:06Z")

</div>

I am new to Elasticsearch, and I had been running Elasticsearch, Kibana, Filebeat, and Zabbix Server. My visualization stopped on August 28. I can pull visualization before that just fine. But when I try to watch curren…

---

## [Using Filebeat for logging ssh log in](https://discuss.elastic.co/t/using-filebeat-for-logging-ssh-log-in/133822)

<div class="topic-metadata">

**Author:** [@vishnuduttpv](https://discuss.elastic.co/u/vishnuduttpv)\
**Replies:** 12\
**Last updated:** [July 8, 2018, 10:57am UTC](https://discuss.elastic.co/t/using-filebeat-for-logging-ssh-log-in/133822 "2018-07-08T10:57:01Z")

</div>

Hi, I am using the following configuration, OS - CentOS Linux release 7.4.1708 (Core) ES - 6.2 LogStash - 6.2 Kibana - 6.2 FileBeat - 6.2 I was using the filebeat for pushing the logs from the server to the kibana…

---

## [Read a gzip file with gzip\_lines codec](https://discuss.elastic.co/t/read-a-gzip-file-with-gzip-lines-codec/24558)

<div class="topic-metadata">

**Author:** [@dima\_eam](https://discuss.elastic.co/u/dima_eam)\
**Replies:** 11\
**Last updated:** [January 12, 2016, 9:42am UTC](https://discuss.elastic.co/t/read-a-gzip-file-with-gzip-lines-codec/24558 "2016-01-12T09:42:34Z")

</div>

Hi! I need to use Logstash for parsing \*.gz files. I've downloaded gzip\_lines gem and installed it with logstash-1.5.1\\bin\>plugin install logstash-codec-gzip\_lines-0.1.5.gem the output said "Installation succesful…

---

## [Kibana 4 and geoip](https://discuss.elastic.co/t/kibana-4-and-geoip/1665)

<div class="topic-metadata">

**Author:** [@elastic\_paul](https://discuss.elastic.co/u/elastic_paul)\
**Replies:** 23\
**Last updated:** [July 15, 2016, 5:43am UTC](https://discuss.elastic.co/t/kibana-4-and-geoip/1665 "2016-07-15T05:43:28Z")

</div>

Hi Guys, I have created some indexes on ES, using LogStash, and then trying to visualise with Kibana 4. To visualise the geo data I try to select a 'Tile Map' and then 'Aggregation' with Geohash, and finally 'Field' o…

---

## [Anonymous Kibana Users](https://discuss.elastic.co/t/anonymous-kibana-users/270071)

<div class="topic-metadata">

**Author:** [@caitlyn.carlisle](https://discuss.elastic.co/u/caitlyn.carlisle)\
**Replies:** 27\
**Last updated:** [April 28, 2021, 7:35am UTC](https://discuss.elastic.co/t/anonymous-kibana-users/270071 "2021-04-28T07:35:10Z")

</div>

I am attempting to add anonymous users to view my Kibana dashboards but it is giving me this error when I attempt to edit the elasticsearch.yml file. Additionally, will adding this feature allow the dashboard to comp…

---

## [Ingesting & indexing text files while keeping formatting](https://discuss.elastic.co/t/ingesting-indexing-text-files-while-keeping-formatting/78279)

<div class="topic-metadata">

**Author:** [@Bob\_Metelsky](https://discuss.elastic.co/u/Bob_Metelsky)\
**Replies:** 15\
**Last updated:** [March 13, 2017, 2:01am UTC](https://discuss.elastic.co/t/ingesting-indexing-text-files-while-keeping-formatting/78279 "2017-03-13T02:01:36Z")

</div>

Greetings - I have a use case where We have plain text files in a very specific formatting These files are in a directory I want to do a search in ES or (another front end) for a specific id in those files I want to r…

[Previous page](https://discuss.elastic.co/top.md?page=14&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=16&per_page=50&period=all)
