# Top

**URL:** https://discuss.elastic.co/top.md?page=1610&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 1611

---

## [Error in Kibana when looking back 60 days](https://discuss.elastic.co/t/error-in-kibana-when-looking-back-60-days/45969)

<div class="topic-metadata">

**Author:** [@kmroz](https://discuss.elastic.co/u/kmroz)\
**Replies:** 3\
**Last updated:** [April 1, 2016, 8:48pm UTC](https://discuss.elastic.co/t/error-in-kibana-when-looking-back-60-days/45969 "2016-04-01T20:48:12Z")

</div>

seems anytime i change the filter to past week or more it gives me this error "TypeError: Unable to start request because it has already started" . Then i refresh and it is ok. Any idea what is causing this? I am on vers…

---

## [Muting category does not mute sub-categories in email](https://discuss.elastic.co/t/muting-category-does-not-mute-sub-categories-in-email/23948)

<div class="topic-metadata">

**Author:** [@mattweber](https://discuss.elastic.co/u/mattweber)\
**Replies:** 0\
**Last updated:** [June 18, 2015, 10:56pm UTC](https://discuss.elastic.co/t/muting-category-does-not-mute-sub-categories-in-email/23948 "2015-06-18T22:56:05Z")

</div>

Muting a category with sub-categories such as "Elastic in your native tongue" does not mute emails for the sub-categories. Is this expected? Do I need to mute every sub-category?

---

## [Elasticsearch cluster across multiple docker hosts](https://discuss.elastic.co/t/elasticsearch-cluster-across-multiple-docker-hosts/358314)

<div class="topic-metadata">

**Author:** [@Janusz\_Mikluszka](https://discuss.elastic.co/u/Janusz_Mikluszka)\
**Replies:** 4\
**Last updated:** [April 29, 2024, 5:59pm UTC](https://discuss.elastic.co/t/elasticsearch-cluster-across-multiple-docker-hosts/358314 "2024-04-29T17:59:13Z")

</div>

Hello, I'm trying to create multi node cluster across multiple VMs running docker. For now I tried setting up master node on my local docker engine. When second node is in the same docker network then there is no issue…

---

## [Unable to apply memory lock to deploy elastic 8 on k8s](https://discuss.elastic.co/t/unable-to-apply-memory-lock-to-deploy-elastic-8-on-k8s/334897)

<div class="topic-metadata">

**Author:** [@rsingh\_2023](https://discuss.elastic.co/u/rsingh_2023)\
**Replies:** 4\
**Last updated:** [June 5, 2023, 8:08pm UTC](https://discuss.elastic.co/t/unable-to-apply-memory-lock-to-deploy-elastic-8-on-k8s/334897 "2023-06-05T20:08:51Z")

</div>

I am running into issues with deploying elastic version 8.7 on kubernetes (k8s) I am using this docker image for elastic version 8.7 I have enabled bootstrap memory\_lock as "true" but I see these error logs in my elast…

---

## [Json data from Filebeat to Logstash](https://discuss.elastic.co/t/json-data-from-filebeat-to-logstash/322672)

<div class="topic-metadata">

**Author:** [@Hamburglar](https://discuss.elastic.co/u/Hamburglar)\
**Replies:** 4\
**Last updated:** [January 8, 2023, 1:54pm UTC](https://discuss.elastic.co/t/json-data-from-filebeat-to-logstash/322672 "2023-01-08T13:54:35Z")

</div>

Json data to be ingested: /var/log/file.json {"event\_type":"temp","time":"2023-01-07 23:30:12","temp":64.0,"fan":2291} {"event\_type":"temp","time":"2023-01-07 23:30:22","temp":63.0,"fan":2308} {"event\_type":"temp","time…

---

## [Configure TCP input via Central Management](https://discuss.elastic.co/t/configure-tcp-input-via-central-management/186152)

<div class="topic-metadata">

**Author:** [@jderose](https://discuss.elastic.co/u/jderose)\
**Replies:** 4\
**Last updated:** [September 13, 2019, 2:49pm UTC](https://discuss.elastic.co/t/configure-tcp-input-via-central-management/186152 "2019-09-13T14:49:07Z")

</div>

I can setup an input in Filebeat as a TCP listener in the config file, but when I enroll it with Beats Central Management, my configuration is erased in favor of the UI configuration. However, I can't see any way to conf…

---

## [Delete indices now working](https://discuss.elastic.co/t/delete-indices-now-working/183718)

<div class="topic-metadata">

**Author:** [@Bhargav\_Patel](https://discuss.elastic.co/u/Bhargav_Patel)\
**Replies:** 4\
**Last updated:** [June 12, 2019, 6:59am UTC](https://discuss.elastic.co/t/delete-indices-now-working/183718 "2019-06-12T06:59:39Z")

</div>

I tried following command with curator cli curator\_cli --host ray-elasticsearch-service delete\_indices --filter\_list '{"filtertype":"age","source":"name","timestring":"%Y.%m.%d","unit":"days","unit\_count" :1,"direction"…

---

## [Struggling to define the mapping for nested schema where same element name is used in parent and child](https://discuss.elastic.co/t/struggling-to-define-the-mapping-for-nested-schema-where-same-element-name-is-used-in-parent-and-child/85861)

<div class="topic-metadata">

**Author:** [@sujitbehera27](https://discuss.elastic.co/u/sujitbehera27)\
**Replies:** 4\
**Last updated:** [May 16, 2017, 6:52am UTC](https://discuss.elastic.co/t/struggling-to-define-the-mapping-for-nested-schema-where-same-element-name-is-used-in-parent-and-child/85861 "2017-05-16T06:52:45Z")

</div>

I have been trying to define the proper mapping for my json schema. but after trying all possible variable types and other attributes I have not been able to upload my json. In my json I have a key "P" which is nested an…

---

## [100% peak of processing in one of the machines](https://discuss.elastic.co/t/100-peak-of-processing-in-one-of-the-machines/76992)

<div class="topic-metadata">

**Author:** [@RafaelPosthaus](https://discuss.elastic.co/u/RafaelPosthaus)\
**Replies:** 4\
**Last updated:** [March 2, 2017, 3:26pm UTC](https://discuss.elastic.co/t/100-peak-of-processing-in-one-of-the-machines/76992 "2017-03-02T15:26:35Z")

</div>

Good morning, how are you? I'm a friend of Waldemar Neto, and I work with elastic from V1.2, Today I released production on v2.4.2, but I noticed that every 5 minutes I have a 100% peak of processing in one of the machin…

---

## [X-pack reporting shows loading screen instead of graph](https://discuss.elastic.co/t/x-pack-reporting-shows-loading-screen-instead-of-graph/67722)

<div class="topic-metadata">

**Author:** [@tabakkie](https://discuss.elastic.co/u/tabakkie)\
**Replies:** 4\
**Last updated:** [December 2, 2016, 6:33am UTC](https://discuss.elastic.co/t/x-pack-reporting-shows-loading-screen-instead-of-graph/67722 "2016-12-02T06:33:03Z")

</div>

when I export a visualization or dashboard to pdf it will take a screenshot of the kibana loading screen and not the graph, looks like it should wait longer before taking the screenshot in phantomjs. I'm using a very bas…

---

## [Date Range of returned documents](https://discuss.elastic.co/t/date-range-of-returned-documents/66252)

<div class="topic-metadata">

**Author:** [@eperry](https://discuss.elastic.co/u/eperry)\
**Replies:** 4\
**Last updated:** [November 16, 2016, 5:14pm UTC](https://discuss.elastic.co/t/date-range-of-returned-documents/66252 "2016-11-16T17:14:17Z")

</div>

I was writing some reports for the boss and was using the timepicker option "Last week" and was wanting to but a Panel in the Dashboard for what the actual date range was. I can think of any way to do this, Basical…

---

## [Shard Aware Routing of Query](https://discuss.elastic.co/t/shard-aware-routing-of-query/18672)

<div class="topic-metadata">

**Author:** [@ElasticSearch\_Users\_](https://discuss.elastic.co/u/ElasticSearch_Users_)\
**Replies:** 4\
**Last updated:** [August 22, 2014, 8:50am UTC](https://discuss.elastic.co/t/shard-aware-routing-of-query/18672 "2014-08-22T08:50:46Z")

</div>

Hi, I have a large-ish data set that could grow beyond a 100M. I have queries to be executed for this index. I would like to have query filter data local to a shard being sent to that shard, so that I spend less t…

---

## [KeyCloak redirect\_uri gives 404 page not found error](https://discuss.elastic.co/t/keycloak-redirect-uri-gives-404-page-not-found-error/315892)

<div class="topic-metadata">

**Author:** [@ssimmons](https://discuss.elastic.co/u/ssimmons)\
**Replies:** 2\
**Last updated:** [October 6, 2022, 12:53am UTC](https://discuss.elastic.co/t/keycloak-redirect-uri-gives-404-page-not-found-error/315892 "2022-10-06T00:53:41Z")

</div>

I'm using Elasticsearch and Kibana 7.16.3. I've gotten SSL/TLS properly setup on my local install. I've gotten KeyCloak set up and working. I can bring up Kibana and login with Keycloak successfully. However, after login…

---

## [Cannot get failed shard back online](https://discuss.elastic.co/t/cannot-get-failed-shard-back-online/275003)

<div class="topic-metadata">

**Author:** [@agKaspar](https://discuss.elastic.co/u/agKaspar)\
**Replies:** 2\
**Last updated:** [June 8, 2021, 6:33am UTC](https://discuss.elastic.co/t/cannot-get-failed-shard-back-online/275003 "2021-06-08T06:33:17Z")

</div>

Hi, I'm trying to get failed shard in a single node cluster back online. The cluster is a single docker container running the docker.elastic.co/elasticsearch/elasticsearch:7.9.2 image. It has 10 indices and somewhere thi…

---

## [Maximum shards per node](https://discuss.elastic.co/t/maximum-shards-per-node/273830)

<div class="topic-metadata">

**Author:** [@Muna](https://discuss.elastic.co/u/Muna)\
**Replies:** 2\
**Last updated:** [May 25, 2021, 2:17am UTC](https://discuss.elastic.co/t/maximum-shards-per-node/273830 "2021-05-25T02:17:54Z")

</div>

Is there any option to disable the max\_shard\_per\_node in cluster settings in Elastic 7.12 as in the older version 6.5 there is no such values. Elastic 7.12 "cluster" : { "max\_shards\_per\_node" : "1000" }

---

## [ERROR instance/beat.go:906](https://discuss.elastic.co/t/error-instance-beat-go-906/238611)

<div class="topic-metadata">

**Author:** [@Ivan\_Bykov](https://discuss.elastic.co/u/Ivan_Bykov)\
**Replies:** 2\
**Last updated:** [June 29, 2020, 2:29pm UTC](https://discuss.elastic.co/t/error-instance-beat-go-906/238611 "2020-06-29T14:29:38Z")

</div>

Filebeat 6.8.10 при старте ругается ERROR instance/beat.go:906 Exiting: setup.template.name and setup.template.pattern have to be set if index name is modified filebeat .yml такой - type: log paths: - /varl…

---

## [Char\_filter and lowercase not working for search\_analyzer](https://discuss.elastic.co/t/char-filter-and-lowercase-not-working-for-search-analyzer/195074)

<div class="topic-metadata">

**Author:** [@KrisMeister](https://discuss.elastic.co/u/KrisMeister)\
**Replies:** 2\
**Last updated:** [August 14, 2019, 7:49am UTC](https://discuss.elastic.co/t/char-filter-and-lowercase-not-working-for-search-analyzer/195074 "2019-08-14T07:49:36Z")

</div>

I've been experimenting with many different iterations of the below but haven't been able to match all the cases I'd like to. My objective is to match the following cases: "7-eleven" or "7eleven" to the text "7-Eleven…

---

## [One of nodes fails with anonymous\_access\_denied error in audit log](https://discuss.elastic.co/t/one-of-nodes-fails-with-anonymous-access-denied-error-in-audit-log/176259)

<div class="topic-metadata">

**Author:** [@ethanfama](https://discuss.elastic.co/u/ethanfama)\
**Replies:** 2\
**Last updated:** [April 11, 2019, 1:22pm UTC](https://discuss.elastic.co/t/one-of-nodes-fails-with-anonymous-access-denied-error-in-audit-log/176259 "2019-04-11T13:22:04Z")

</div>

I have set up a 3-node cluster for Elasticsearch 6.7. When I start it up, two of the master-eligible nodes can communicate just fine, but the third complains with anonymous\_access\_denied events: One of the master nodes …

---

## [Does winlogbeat support windows xp sp3 embedded?](https://discuss.elastic.co/t/does-winlogbeat-support-windows-xp-sp3-embedded/173399)

<div class="topic-metadata">

**Author:** [@akumo](https://discuss.elastic.co/u/akumo)\
**Replies:** 2\
**Last updated:** [March 22, 2019, 12:00am UTC](https://discuss.elastic.co/t/does-winlogbeat-support-windows-xp-sp3-embedded/173399 "2019-03-22T00:00:11Z")

</div>

Hi, I tried to install winlogbeat on Windows XP SP3 Embedded but fail. Does winlogbeat support Windows XP Embedded ? Rgds.

---

## [How do we differentiate inbound and outbound traffic in packetbeat](https://discuss.elastic.co/t/how-do-we-differentiate-inbound-and-outbound-traffic-in-packetbeat/151679)

<div class="topic-metadata">

**Author:** [@varun1992](https://discuss.elastic.co/u/varun1992)\
**Replies:** 2\
**Last updated:** [October 10, 2018, 1:16pm UTC](https://discuss.elastic.co/t/how-do-we-differentiate-inbound-and-outbound-traffic-in-packetbeat/151679 "2018-10-10T13:16:54Z")

</div>

How do we differentiate inbound and outbound traffic in packetbeat ? or how do we can find out connection to server and connection from server ?

---

## [\[JAVA API\] Sorting on field return error "active fielddata"](https://discuss.elastic.co/t/java-api-sorting-on-field-return-error-active-fielddata/139170)

<div class="topic-metadata">

**Author:** [@younesbenallal](https://discuss.elastic.co/u/younesbenallal)\
**Replies:** 2\
**Last updated:** [July 10, 2018, 3:00pm UTC](https://discuss.elastic.co/t/java-api-sorting-on-field-return-error-active-fielddata/139170 "2018-07-10T15:00:29Z")

</div>

Hey, I'm using the Java API to do some search on an Elastic base. I have differents functions of listing, filtering etc,.. (all working). But, when I want to sort by a field, I have this error : \`Elasticsearch exceptio…

---

## [Upgrade from 5.2.1 to 5.4.1](https://discuss.elastic.co/t/upgrade-from-5-2-1-to-5-4-1/89234)

<div class="topic-metadata">

**Author:** [@nbari](https://discuss.elastic.co/u/nbari)\
**Replies:** 2\
**Last updated:** [June 15, 2017, 9:40am UTC](https://discuss.elastic.co/t/upgrade-from-5-2-1-to-5-4-1/89234 "2017-06-15T09:40:54Z")

</div>

Having a 2 node cluster I disabled the shard allocation, stoped one node, download elasticsearch-5.4.1 and installed it . After starting up the node I get on the logs: \[o.e.x.m.e.l.LocalExporter\] waiting for elected …

---

## [How combine different data inputs in logstash](https://discuss.elastic.co/t/how-combine-different-data-inputs-in-logstash/73997)

<div class="topic-metadata">

**Author:** [@yoshua](https://discuss.elastic.co/u/yoshua)\
**Replies:** 2\
**Last updated:** [February 6, 2017, 2:30pm UTC](https://discuss.elastic.co/t/how-combine-different-data-inputs-in-logstash/73997 "2017-02-06T14:30:22Z")

</div>

Hello, I have a set of http API one of them with "no time" data based , the fields are ID, geo location(lat,lon) and others data. The ID is the key to access another API, (time based) , our target is to send a…

---

## [Logging events lost when Elastic Search connection goes down](https://discuss.elastic.co/t/logging-events-lost-when-elastic-search-connection-goes-down/47801)

<div class="topic-metadata">

**Author:** [@ono](https://discuss.elastic.co/u/ono)\
**Replies:** 2\
**Last updated:** [April 20, 2016, 8:38am UTC](https://discuss.elastic.co/t/logging-events-lost-when-elastic-search-connection-goes-down/47801 "2016-04-20T08:38:18Z")

</div>

Guys, We're trying filebeat, forwarding logs to logstash (for JSON parsing) and then onwards into Elastic Search (ES). One of the scenarios we're testing is connection between logstash and ES going down and then the lo…

---

## [What does this error mean?](https://discuss.elastic.co/t/what-does-this-error-mean/1901)

<div class="topic-metadata">

**Author:** [@yehosef](https://discuss.elastic.co/u/yehosef)\
**Replies:** 2\
**Last updated:** [June 4, 2015, 1:17pm UTC](https://discuss.elastic.co/t/what-does-this-error-mean/1901 "2015-06-04T13:17:08Z")

</div>

I occasionally see errors that look like this in the logstash stdout: Jun 04, 2015 8:48:01 AM org.elasticsearch.monitor.jvm.JvmMonitorService$JvmMonitor monitorLongGc WARNING: \[logstash-es1-20422-9784\] \[gc\]\[young\]\[219\]…

---

## [Kibana: Cold indices not showing when using filter in index management](https://discuss.elastic.co/t/kibana-cold-indices-not-showing-when-using-filter-in-index-management/350200)

<div class="topic-metadata">

**Author:** [@basiltitus](https://discuss.elastic.co/u/basiltitus)\
**Replies:** 8\
**Last updated:** [January 4, 2024, 12:40pm UTC](https://discuss.elastic.co/t/kibana-cold-indices-not-showing-when-using-filter-in-index-management/350200 "2024-01-04T12:40:47Z")

</div>

I have a two node cluster with a master/hot and a single data node defined in cold tier. I have created few indices for testing data tier. But when I apply "lifecycle phase" filter the indices supposed to be in cold tie…

---

## [Elastic rejected execution of coordinating operation](https://discuss.elastic.co/t/elastic-rejected-execution-of-coordinating-operation/280656)

<div class="topic-metadata">

**Author:** [@mug3n451](https://discuss.elastic.co/u/mug3n451)\
**Replies:** 0\
**Last updated:** [August 6, 2021, 2:39pm UTC](https://discuss.elastic.co/t/elastic-rejected-execution-of-coordinating-operation/280656 "2021-08-06T14:39:29Z")

</div>

Hi, i have a problem with elasticsearch on kubernetes. here the problem: "current\_state" : "unassigned", "unassigned\_info" : { "reason" : "ALLOCATION\_FAILED", "at" : "2021-08-06T14:28:31.995Z", "failed\_al…

---

## [Cluster going down because of garbage collector](https://discuss.elastic.co/t/cluster-going-down-because-of-garbage-collector/170326)

<div class="topic-metadata">

**Author:** [@dihpierrick](https://discuss.elastic.co/u/dihpierrick)\
**Replies:** 8\
**Last updated:** [March 1, 2019, 4:14pm UTC](https://discuss.elastic.co/t/cluster-going-down-because-of-garbage-collector/170326 "2019-03-01T16:14:35Z")

</div>

Hello, We just have an issue on our cluster : 1 Coordinator Nodes 3 Master Eligible Nodes Version 6.1.2 Yesterday, around 16PM our cluster stopped working well. In the logs files of our coordinator node we had : \[…

---

## [After 6.8 -\> 7.17 upgrade, logstash not sending data to logstash-\* indexes](https://discuss.elastic.co/t/after-6-8-7-17-upgrade-logstash-not-sending-data-to-logstash-indexes/322479)

<div class="topic-metadata">

**Author:** [@willdennis](https://discuss.elastic.co/u/willdennis)\
**Replies:** 7\
**Last updated:** [January 7, 2023, 4:45pm UTC](https://discuss.elastic.co/t/after-6-8-7-17-upgrade-logstash-not-sending-data-to-logstash-indexes/322479 "2023-01-07T16:45:48Z")

</div>

Hi all, Did an upgrade to my single-node cluster yesterday evening, now up on 7.17.8 and everything's basically working, except that it seems that Logstash is no longer creating logstash-\<YYYY.MM.DD\> indexes... I see th…

---

## [How can define multi indices in logstash configuration file based on the type of inputs](https://discuss.elastic.co/t/how-can-define-multi-indices-in-logstash-configuration-file-based-on-the-type-of-inputs/157226)

<div class="topic-metadata">

**Author:** [@sahere37](https://discuss.elastic.co/u/sahere37)\
**Replies:** 7\
**Last updated:** [November 19, 2018, 8:11am UTC](https://discuss.elastic.co/t/how-can-define-multi-indices-in-logstash-configuration-file-based-on-the-type-of-inputs/157226 "2018-11-19T08:11:46Z")

</div>

Hi all, I am using logstash to get file from filebeats and ship them to two nodes of elasticsearch. logstash has two inputs with different types. I want to define different indices based on the input type, so I write fo…

---

## [Scalability Issue: Significant delay in shipping out log files & the delay is dramatically different for different log files!](https://discuss.elastic.co/t/scalability-issue-significant-delay-in-shipping-out-log-files-the-delay-is-dramatically-different-for-different-log-files/145476)

<div class="topic-metadata">

**Author:** [@filebeater](https://discuss.elastic.co/u/filebeater)\
**Replies:** 7\
**Last updated:** [August 22, 2018, 5:00pm UTC](https://discuss.elastic.co/t/scalability-issue-significant-delay-in-shipping-out-log-files-the-delay-is-dramatically-different-for-different-log-files/145476 "2018-08-22T17:00:55Z")

</div>

We use filebeat to tail log files on disk and ship them to kafka. We observed there is some significant delay between the logs are written to disk and they were processed and sent to kafka. For example: for READER-6.log…

---

## [Not able to give a different name for Label and Legends in Lens chart Y-axis](https://discuss.elastic.co/t/not-able-to-give-a-different-name-for-label-and-legends-in-lens-chart-y-axis/238386)

<div class="topic-metadata">

**Author:** [@Kavin](https://discuss.elastic.co/u/Kavin)\
**Replies:** 1\
**Last updated:** [June 24, 2020, 7:17am UTC](https://discuss.elastic.co/t/not-able-to-give-a-different-name-for-label-and-legends-in-lens-chart-y-axis/238386 "2020-06-24T07:17:51Z")

</div>

I like to have a different name for Y-axis in lens chart. The name I am providing in the label column is being showed for both label and legends. Please guide me where can I change that to have different names.

---

## [Update API script - create array of structures](https://discuss.elastic.co/t/update-api-script-create-array-of-structures/204418)

<div class="topic-metadata">

**Author:** [@MMH](https://discuss.elastic.co/u/MMH)\
**Replies:** 1\
**Last updated:** [October 22, 2019, 3:43pm UTC](https://discuss.elastic.co/t/update-api-script-create-array-of-structures/204418 "2019-10-22T15:43:04Z")

</div>

I am using Elasticsearch 6.5. I am writing a script for an update API in painless. I need to add structures to an array of structures. If this field does not exist in the document (I can detect that) I am creating a new …

---

## [Metricbeat cannot get metrics from kafka running in k8](https://discuss.elastic.co/t/metricbeat-cannot-get-metrics-from-kafka-running-in-k8/196014)

<div class="topic-metadata">

**Author:** [@memelet](https://discuss.elastic.co/u/memelet)\
**Replies:** 1\
**Last updated:** [August 21, 2019, 2:28pm UTC](https://discuss.elastic.co/t/metricbeat-cannot-get-metrics-from-kafka-running-in-k8/196014 "2019-08-21T14:28:09Z")

</div>

My configuration contains: - condition: equals: kubernetes.labels: strimzi\_io/name: vikafka-kafka …

---

## [Empty Gantt chart](https://discuss.elastic.co/t/empty-gantt-chart/185011)

<div class="topic-metadata">

**Author:** [@clamorforchange](https://discuss.elastic.co/u/clamorforchange)\
**Replies:** 1\
**Last updated:** [June 27, 2019, 9:52am UTC](https://discuss.elastic.co/t/empty-gantt-chart/185011 "2019-06-27T09:52:28Z")

</div>

Hi everyone, I'm trying to create a Gantt chart from log files that I'm pushing to Elasticsearch via curl. Very similar to this https://discuss.elastic.co/t/gantt-visualization-using-vega/136532 I'm trying this out on a…

---

## [Unable to reach Kibana on http://ipadress:5601](https://discuss.elastic.co/t/unable-to-reach-kibana-on-http-ipadress-5601/150872)

<div class="topic-metadata">

**Author:** [@moa](https://discuss.elastic.co/u/moa)\
**Replies:** 1\
**Last updated:** [October 4, 2018, 10:38am UTC](https://discuss.elastic.co/t/unable-to-reach-kibana-on-http-ipadress-5601/150872 "2018-10-04T10:38:49Z")

</div>

I'm trying to set up Elastic Stack on Azure to monitor my app services running on Azure. I have set up a new vm on Azure where I installed Elasticsearch, Kibana and Logstash using Azure CLI. When I try to go to http://…

---

## [Filter not showing all records](https://discuss.elastic.co/t/filter-not-showing-all-records/118863)

<div class="topic-metadata">

**Author:** [@chauffo](https://discuss.elastic.co/u/chauffo)\
**Replies:** 1\
**Last updated:** [February 7, 2018, 3:02pm UTC](https://discuss.elastic.co/t/filter-not-showing-all-records/118863 "2018-02-07T15:02:18Z")

</div>

I'm using a filter to limit a visualisation which I then export to as .csv. However, selecting e.g. "Previous year" includes more records than "Last 5 years" does. I'm not sure why this is - maybe a low record limit impo…

---

## [Index level setting is not working for the merge factory and concurrency paramater](https://discuss.elastic.co/t/index-level-setting-is-not-working-for-the-merge-factory-and-concurrency-paramater/99427)

<div class="topic-metadata">

**Author:** [@JAYALAKSHMI](https://discuss.elastic.co/u/JAYALAKSHMI)\
**Replies:** 1\
**Last updated:** [September 14, 2017, 2:25pm UTC](https://discuss.elastic.co/t/index-level-setting-is-not-working-for-the-merge-factory-and-concurrency-paramater/99427 "2017-09-14T14:25:08Z")

</div>

Hi All, We have installed the 2.4.5 and 5.5.0 cluster in one environment and currently we are moving the data from 2.4.5 to 5.5.0 cluster using logstash. For making the indexing speed we have enabled the following facto…

---

## [No data being discovered in Kibana front end](https://discuss.elastic.co/t/no-data-being-discovered-in-kibana-front-end/74131)

<div class="topic-metadata">

**Author:** [@gperez234](https://discuss.elastic.co/u/gperez234)\
**Replies:** 1\
**Last updated:** [February 9, 2017, 4:48pm UTC](https://discuss.elastic.co/t/no-data-being-discovered-in-kibana-front-end/74131 "2017-02-09T16:48:28Z")

</div>

I am installing the entire ELK stack and have been following your getting started guide. My issue is that I am not seeing logs in Kibana, so I tried combing through logs to find out why. I seem to be getting errors bet…

---

## [Dynamic name in the path of filebeat](https://discuss.elastic.co/t/dynamic-name-in-the-path-of-filebeat/65600)

<div class="topic-metadata">

**Author:** [@Aditya\_Srivastava](https://discuss.elastic.co/u/Aditya_Srivastava)\
**Replies:** 1\
**Last updated:** [November 10, 2016, 11:58am UTC](https://discuss.elastic.co/t/dynamic-name-in-the-path-of-filebeat/65600 "2016-11-10T11:58:27Z")

</div>

I wanted to give dynamic name in the path section of filebeat ex. paths: - /var/log/ABC/{hostname}/\*.log can the hostname field be dynamic???

---

## [Filebeat Multiline eats up the entire log file](https://discuss.elastic.co/t/filebeat-multiline-eats-up-the-entire-log-file/40982)

<div class="topic-metadata">

**Author:** [@mguiwin](https://discuss.elastic.co/u/mguiwin)\
**Replies:** 1\
**Last updated:** [February 4, 2016, 5:03pm UTC](https://discuss.elastic.co/t/filebeat-multiline-eats-up-the-entire-log-file/40982 "2016-02-04T17:03:57Z")

</div>

Hello, I'm trying out the new multiline feature by running FB on an existing log file and having an issue: FB pushes the entire file contents to Logstash as one single message. Here is my setup: OS: Windows 7 64 F…

---

## [Unable to install logstash via chef cookbook in aws opsworks](https://discuss.elastic.co/t/unable-to-install-logstash-via-chef-cookbook-in-aws-opsworks/40705)

<div class="topic-metadata">

**Author:** [@mazjs](https://discuss.elastic.co/u/mazjs)\
**Replies:** 1\
**Last updated:** [February 2, 2016, 10:13am UTC](https://discuss.elastic.co/t/unable-to-install-logstash-via-chef-cookbook-in-aws-opsworks/40705 "2016-02-02T10:13:43Z")

</div>

HI, I am using https://github.com/lusis/chef-logstash coobook to install logstash in aws opsworks. But the chef gives error with : Missing Cookbooks: No such cookbook: chef\_handler I do have chef-handler cookbook…

---

## [Upgrade elastic 1.4.2 to 1.7.0](https://discuss.elastic.co/t/upgrade-elastic-1-4-2-to-1-7-0/28389)

<div class="topic-metadata">

**Author:** [@silvina](https://discuss.elastic.co/u/silvina)\
**Replies:** 1\
**Last updated:** [September 16, 2015, 6:30am UTC](https://discuss.elastic.co/t/upgrade-elastic-1-4-2-to-1-7-0/28389 "2015-09-16T06:30:06Z")

</div>

Hi, I have an elasticsearch cluster with 1.4.2. elastic version, 20 nodes with 16 GB, java 7 and 32 shards and I created another cluster with 1.7.0 elastic version, 20 nodes with 32 GB, java 8 and 32 shards. I have a set…

---

## [Dynamic Baseline](https://discuss.elastic.co/t/dynamic-baseline/322317)

<div class="topic-metadata">

**Author:** [@Rbb](https://discuss.elastic.co/u/Rbb)\
**Replies:** 5\
**Last updated:** [January 5, 2023, 4:29pm UTC](https://discuss.elastic.co/t/dynamic-baseline/322317 "2023-01-05T16:29:05Z")

</div>

Hi! I need to create a dynamic baseline which is based on the average of the field transaction.duration.us of the previous month. I have tried to create a runtime field, but the fact that the data is located in seperate…

---

## [Data not updating automatically when I change my MySQL table](https://discuss.elastic.co/t/data-not-updating-automatically-when-i-change-my-mysql-table/273536)

<div class="topic-metadata">

**Author:** [@pablixelastic](https://discuss.elastic.co/u/pablixelastic)\
**Replies:** 5\
**Last updated:** [May 26, 2021, 9:25am UTC](https://discuss.elastic.co/t/data-not-updating-automatically-when-i-change-my-mysql-table/273536 "2021-05-26T09:25:05Z")

</div>

Hi! I'm having some issues at the moment of updating my data in Kibana when I change any info from MySQL table. I don't really know if it's possible. Can someone help me? Thanks!

---

## [EQL: Why basic query is different from dataset](https://discuss.elastic.co/t/eql-why-basic-query-is-different-from-dataset/252242)

<div class="topic-metadata">

**Author:** [@kelk](https://discuss.elastic.co/u/kelk)\
**Replies:** 5\
**Last updated:** [October 15, 2020, 9:14pm UTC](https://discuss.elastic.co/t/eql-why-basic-query-is-different-from-dataset/252242 "2020-10-15T21:14:45Z")

</div>

I'm running a simple EQL query to test as follows, but NOT reporting anything back GET winlogbeat\*/\_eql/search { "query": """ process where process.name == "services.exe" """ } Quite lot of data is present and If…

---

## [Converting century date format to yyyymmdd format](https://discuss.elastic.co/t/converting-century-date-format-to-yyyymmdd-format/169048)

<div class="topic-metadata">

**Author:** [@shruti51](https://discuss.elastic.co/u/shruti51)\
**Replies:** 5\
**Last updated:** [February 22, 2019, 1:29pm UTC](https://discuss.elastic.co/t/converting-century-date-format-to-yyyymmdd-format/169048 "2019-02-22T13:29:40Z")

</div>

Hi, I am trying to convert century format CYYMMDD to YYYYMMDD format in logstash. Please provide some inputs of how to do it.

---

## [Can't start elasticsearch with config saml](https://discuss.elastic.co/t/cant-start-elasticsearch-with-config-saml/127529)

<div class="topic-metadata">

**Author:** [@zonete](https://discuss.elastic.co/u/zonete)\
**Replies:** 5\
**Last updated:** [April 10, 2018, 7:06pm UTC](https://discuss.elastic.co/t/cant-start-elasticsearch-with-config-saml/127529 "2018-04-10T19:06:30Z")

</div>

Hi, we are trying configure ELK with SAML (with ADFS) but when we add the realm configuration to elasticsearch.yml we get the following error. Elasticseach.yml bootstrap.memory\_lock: false cluster.name: elasticsearch …

---

## [Error start logstash after update from 5.4.3 to 5.5](https://discuss.elastic.co/t/error-start-logstash-after-update-from-5-4-3-to-5-5/92418)

<div class="topic-metadata">

**Author:** [@tatdat](https://discuss.elastic.co/u/tatdat)\
**Replies:** 5\
**Last updated:** [July 11, 2017, 12:54am UTC](https://discuss.elastic.co/t/error-start-logstash-after-update-from-5-4-3-to-5-5/92418 "2017-07-11T00:54:25Z")

</div>

Hi, I updated my elastic stask from 5.4.3 to 5.5.0. When i start logstash, i got some error Data flow : Log -\> logstash collector(v5.5) -\> RabbitMQ (v3.6.1) -\> Logstash proccessor (filter)(v5.5) -\> ES(v5.5) This is er…

---

## [ES 1.5.2 cluster crashes](https://discuss.elastic.co/t/es-1-5-2-cluster-crashes/29008)

<div class="topic-metadata">

**Author:** [@Rural\_Hunter](https://discuss.elastic.co/u/Rural_Hunter)\
**Replies:** 5\
**Last updated:** [February 29, 2016, 7:40am UTC](https://discuss.elastic.co/t/es-1-5-2-cluster-crashes/29008 "2016-02-29T07:40:29Z")

</div>

Hi, I have a es 1.5.2 cluster with 6 nodes. They are all configured with 16G heap size. The total shard number is 10\*2(10 primary and 10 replica). The total number of doc is about 300 millions and the storage is about …

[Previous page](https://discuss.elastic.co/top.md?page=1609&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=1611&per_page=50&period=all)
