# Top

**URL:** https://discuss.elastic.co/top.md?page=20&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 21

---

## [Problem with Logstash SSL](https://discuss.elastic.co/t/problem-with-logstash-ssl/298084)

<div class="topic-metadata">

**Author:** [@gustavoluza](https://discuss.elastic.co/u/gustavoluza)\
**Replies:** 18\
**Last updated:** [March 3, 2022, 8:50pm UTC](https://discuss.elastic.co/t/problem-with-logstash-ssl/298084 "2022-03-03T20:50:26Z")

</div>

hi, im having difficulties when changing my logstash SSL certificate, today i have a certificate that is in the /etc/logstash folder and i generated a new one through the elastic tool, using Elasticsearch-certutil and th…

---

## [Parent-child and sorting on a child](https://discuss.elastic.co/t/parent-child-and-sorting-on-a-child/6354)

<div class="topic-metadata">

**Author:** [@Nick\_Hoffman](https://discuss.elastic.co/u/Nick_Hoffman)\
**Replies:** 10\
**Last updated:** [May 3, 2017, 5:45pm UTC](https://discuss.elastic.co/t/parent-child-and-sorting-on-a-child/6354 "2017-05-03T17:45:29Z")

</div>

Hi guys. If you create a parent-child relationship between 2 indices, is it possible to sort the parent documents by one of its children's fields?

---

## [Time range query performance \[7.6\]](https://discuss.elastic.co/t/time-range-query-performance-7-6/223194)

<div class="topic-metadata">

**Author:** [@itizir](https://discuss.elastic.co/u/itizir)\
**Replies:** 17\
**Last updated:** [March 24, 2020, 3:03pm UTC](https://discuss.elastic.co/t/time-range-query-performance-7-6/223194 "2020-03-24T15:03:19Z")

</div>

Hello! While investigating the performance of time range queries, I found some surprising things, and was wondering if anyone had insights to share as to what optimisations or heuristics happen behind the scenes that mi…

---

## [Filebeat filestream input parsers multiline fails](https://discuss.elastic.co/t/filebeat-filestream-input-parsers-multiline-fails/290543)

<div class="topic-metadata">

**Author:** [@fgjensen](https://discuss.elastic.co/u/fgjensen)\
**Replies:** 18\
**Last updated:** [January 29, 2022, 2:31pm UTC](https://discuss.elastic.co/t/filebeat-filestream-input-parsers-multiline-fails/290543 "2022-01-29T14:31:30Z")

</div>

Hello This is filebeat 7.15.0. I have configured several filebeat log inputs with multiline patterns and it works. Next I change the input type to filestream, while following the documentation. However, when starting t…

---

## [Elasticsearch Plugin is red](https://discuss.elastic.co/t/elasticsearch-plugin-is-red/69216)

<div class="topic-metadata">

**Author:** [@adm](https://discuss.elastic.co/u/adm)\
**Replies:** 9\
**Last updated:** [December 17, 2016, 11:29pm UTC](https://discuss.elastic.co/t/elasticsearch-plugin-is-red/69216 "2016-12-17T23:29:23Z")

</div>

Hi, I just downloaded kibana 5.1.1 alpha 5 and elasticsearch 5.1.1 alpha 5 version for windows. My problem is while going to localhost:5601, the status is red and under status breakdown, it says plugin:elasticsearch@5.1.…

---

## [Tuning the ES performance](https://discuss.elastic.co/t/tuning-the-es-performance/105832)

<div class="topic-metadata">

**Author:** [@f26227279](https://discuss.elastic.co/u/f26227279)\
**Replies:** 35\
**Last updated:** [November 8, 2017, 4:16pm UTC](https://discuss.elastic.co/t/tuning-the-es-performance/105832 "2017-11-08T16:16:07Z")

</div>

I am using ES to ingest flow data from other application, but I found that the speed isn't high enough, so sometimes it would drop flow. How can I change the setting of ES performance ? I have seen the elasticsearch.y…

---

## [Elasticsearch Unable to revive connection](https://discuss.elastic.co/t/elasticsearch-unable-to-revive-connection/109055)

<div class="topic-metadata">

**Author:** [@AskingBoy](https://discuss.elastic.co/u/AskingBoy)\
**Replies:** 11\
**Last updated:** [November 26, 2017, 10:59am UTC](https://discuss.elastic.co/t/elasticsearch-unable-to-revive-connection/109055 "2017-11-26T10:59:21Z")

</div>

Here the hole is what i am running into i tried to resolve the issue with "elasticsearch plugin is red". Then i thought the index .kibana still there, so i remove it by "curl -XDELETE http://localhost:9200/.kibana". i…

---

## [Could not index event to Elasticsearch in ES 6.0.0](https://discuss.elastic.co/t/could-not-index-event-to-elasticsearch-in-es-6-0-0/111325)

<div class="topic-metadata">

**Author:** [@tatdat](https://discuss.elastic.co/u/tatdat)\
**Replies:** 16\
**Last updated:** [December 14, 2017, 4:24pm UTC](https://discuss.elastic.co/t/could-not-index-event-to-elasticsearch-in-es-6-0-0/111325 "2017-12-14T16:24:19Z")

</div>

I'm using ES 6.0 and beat 6.0. I check in logstash-plain.log, i got many error like this \[2017-12-12T18:30:25,655\]\[WARN \]\[logstash.outputs.elasticsearch\] Could not index event to Elasticsearch. {:status=\>400, :action=\>…

---

## [How to hide some menus in Kibana](https://discuss.elastic.co/t/how-to-hide-some-menus-in-kibana/80460)

<div class="topic-metadata">

**Author:** [@PrabakarKaruppasamy](https://discuss.elastic.co/u/PrabakarKaruppasamy)\
**Replies:** 11\
**Last updated:** [March 29, 2017, 4:06pm UTC](https://discuss.elastic.co/t/how-to-hide-some-menus-in-kibana/80460 "2017-03-29T16:06:51Z")

</div>

How to hide some menus in kibana left side menu bar.. I want to hide Dev Tools. Is there any way to work around..

---

## [Parsing syslog from linux rsyslog](https://discuss.elastic.co/t/parsing-syslog-from-linux-rsyslog/31267)

<div class="topic-metadata">

**Author:** [@cnozmn](https://discuss.elastic.co/u/cnozmn)\
**Replies:** 24\
**Last updated:** [September 30, 2015, 3:16pm UTC](https://discuss.elastic.co/t/parsing-syslog-from-linux-rsyslog/31267 "2015-09-30T15:16:54Z")

</div>

Hi, I setup ELK stack on my centos machine. In addition, I'm getting syslogs from rsyslog of another centos, So I can see it with "tcpdump" but I wanna see that on Kibana. I think my problem is "logstash.conf file". I…

---

## [Kibana on localhost still requires an active Internet connection?](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749)

<div class="topic-metadata">

**Author:** [@johncst](https://discuss.elastic.co/u/johncst)\
**Replies:** 14\
**Last updated:** [September 6, 2017, 1:41pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749 "2017-09-06T13:41:52Z")

</div>

I'm new and trying to install Elasticsearch and Kibana on the same Windows 10 computer without an active Internet connection. Elasticsearch seems to work OK, but Kibana can't find Elasticsearch on the same host without a…

---

## [Access\_denied\_exception](https://discuss.elastic.co/t/access-denied-exception/114403)

<div class="topic-metadata">

**Author:** [@alexus](https://discuss.elastic.co/u/alexus)\
**Replies:** 13\
**Last updated:** [January 10, 2018, 10:20pm UTC](https://discuss.elastic.co/t/access-denied-exception/114403 "2018-01-10T22:20:34Z")

</div>

I need to look into my backups, so I'm trying to run older version of elasticsearch and register a snapshot repository and getting following error: root@bckp:/# docker run -p 9200:9200 -p 9300:9300 -e "discovery.type=si…

---

## [Monitoring interface unable to find the cluster](https://discuss.elastic.co/t/monitoring-interface-unable-to-find-the-cluster/156705)

<div class="topic-metadata">

**Author:** [@alaphoid](https://discuss.elastic.co/u/alaphoid)\
**Replies:** 15\
**Last updated:** [November 14, 2018, 10:41pm UTC](https://discuss.elastic.co/t/monitoring-interface-unable-to-find-the-cluster/156705 "2018-11-14T22:41:16Z")

</div>

We are currently running ELK 6.4.2 with OpenJDK 1.8.0-191 on CentOS 7.5. This cluster currently contains 30 billion docs, 9820 shards, 919 indices, 90TB of data. We were previously running 6.2.4, and one day while we w…

---

## [Kibana server is not ready yet - kibana 6.7](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-kibana-6-7/178519)

<div class="topic-metadata">

**Author:** [@ashnav\_msit](https://discuss.elastic.co/u/ashnav_msit)\
**Replies:** 18\
**Last updated:** [April 26, 2019, 10:24pm UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-kibana-6-7/178519 "2019-04-26T22:24:23Z")

</div>

Hi, I have been using Kibana 6.7 and Elastic Search 6.7. Both my services are running fine but I am getting "Kibana server is not ready yet" error. I tried deleting all four indices. this is snapshot of my recent kiba…

---

## [Get \[parent\] Data too large from kibana logs](https://discuss.elastic.co/t/get-parent-data-too-large-from-kibana-logs/190647)

<div class="topic-metadata">

**Author:** [@yuecong](https://discuss.elastic.co/u/yuecong)\
**Replies:** 13\
**Last updated:** [August 1, 2019, 4:56am UTC](https://discuss.elastic.co/t/get-parent-data-too-large-from-kibana-logs/190647 "2019-08-01T04:56:43Z")

</div>

I get the following error logs and my kibana instance can not load index patterns now. could someone suggest what is happening on this error? {"type":"error","@timestamp":"2019-07-16T05:35:01Z","tags":,"pid":1,"level":"…

---

## [Serch text with special character](https://discuss.elastic.co/t/serch-text-with-special-character/242040)

<div class="topic-metadata">

**Author:** [@Katia](https://discuss.elastic.co/u/Katia)\
**Replies:** 9\
**Last updated:** [July 23, 2020, 1:38pm UTC](https://discuss.elastic.co/t/serch-text-with-special-character/242040 "2020-07-23T13:38:56Z")

</div>

I really need help. I indexed my data using logstash. The data is as follows: 20200807 00:10:02.934 Mes émis à l'appli Hôte 3 3 -1 The issue is that, I need to search "3 3-1", but it seems that the caracter "-" cau…

---

## [Comparing two date fields in Kibana](https://discuss.elastic.co/t/comparing-two-date-fields-in-kibana/29100)

<div class="topic-metadata">

**Author:** [@owardman](https://discuss.elastic.co/u/owardman)\
**Replies:** 10\
**Last updated:** [May 2, 2016, 1:35pm UTC](https://discuss.elastic.co/t/comparing-two-date-fields-in-kibana/29100 "2016-05-02T13:35:23Z")

</div>

Hi. I would like to be able to use Kibana's Discover functionality to compare two fields, something like date1 LT date2. Does this sound possible? I have searched for the correct syntax with no luck so far. Both fie…

---

## [Kibana doesn't work with Nginx after update 4.1.2 to 4.2.0](https://discuss.elastic.co/t/kibana-doesnt-work-with-nginx-after-update-4-1-2-to-4-2-0/33572)

<div class="topic-metadata">

**Author:** [@Miguel\_Bessa](https://discuss.elastic.co/u/Miguel_Bessa)\
**Replies:** 19\
**Last updated:** [November 26, 2015, 5:54am UTC](https://discuss.elastic.co/t/kibana-doesnt-work-with-nginx-after-update-4-1-2-to-4-2-0/33572 "2015-11-26T05:54:23Z")

</div>

Hi, I'm trying to update kibana to 4.2.0, so I deleted old files on kibana folder and replace for news (downloaded in: https://download.elastic.co/…/kibana/kibana-4.2.0-linux-x64…). I change kibana.yml on /config, but…

---

## [Filter with millions of record](https://discuss.elastic.co/t/filter-with-millions-of-record/134561)

<div class="topic-metadata">

**Author:** [@chaudharys31](https://discuss.elastic.co/u/chaudharys31)\
**Replies:** 43\
**Last updated:** [July 5, 2018, 3:00pm UTC](https://discuss.elastic.co/t/filter-with-millions-of-record/134561 "2018-07-05T15:00:40Z")

</div>

Can someone explain term filter or any other filter work with millions or 100 K records in the filter? How will be performed and how it will work?

---

## [Timelion: how-to \[1\] derivative \[2\] sum \[3\] groupby](https://discuss.elastic.co/t/timelion-how-to-1-derivative-2-sum-3-groupby/50132)

<div class="topic-metadata">

**Author:** [@nskalis](https://discuss.elastic.co/u/nskalis)\
**Replies:** 10\
**Last updated:** [May 23, 2016, 8:45am UTC](https://discuss.elastic.co/t/timelion-how-to-1-derivative-2-sum-3-groupby/50132 "2016-05-23T08:45:32Z")

</div>

Hi guys, Am seeking for your help and advice on this one; This is a timelion query (and the groupby is set to 5min): $q='peer\_src\_ip:x.x.x.x AND ifindex\_in:905', .es($q, metric='sum:bytes').multiply(8).divide(300).der…

---

## [Could not get cluster status after master node goes down](https://discuss.elastic.co/t/could-not-get-cluster-status-after-master-node-goes-down/132455)

<div class="topic-metadata">

**Author:** [@Vahid](https://discuss.elastic.co/u/Vahid)\
**Replies:** 50\
**Last updated:** [June 15, 2018, 7:33am UTC](https://discuss.elastic.co/t/could-not-get-cluster-status-after-master-node-goes-down/132455 "2018-06-15T07:33:17Z")

</div>

Hi, recently we have upgraded ES to 5.6.7 I have a two nodes cluster. After stopping master node, the command "curl -X GET localhost:9211/\_cluster/health doesn't respond. I've run jstack and seen that many threads are…

---

## [MySQL to Elasticsearch](https://discuss.elastic.co/t/mysql-to-elasticsearch/41367)

<div class="topic-metadata">

**Author:** [@Croos](https://discuss.elastic.co/u/Croos)\
**Replies:** 25\
**Last updated:** [February 15, 2016, 1:29pm UTC](https://discuss.elastic.co/t/mysql-to-elasticsearch/41367 "2016-02-15T13:29:31Z")

</div>

Please propose a better way to import selected MySQL tables to Elasticsearch using Logstash or similar latest way with examples. I already did the same successfully using my Own PHP script directly without more issue…

---

## [Kibana 5.0.1 Request Timeout after 3000ms](https://discuss.elastic.co/t/kibana-5-0-1-request-timeout-after-3000ms/67083)

<div class="topic-metadata">

**Author:** [@mna](https://discuss.elastic.co/u/mna)\
**Replies:** 10\
**Last updated:** [December 1, 2016, 2:50pm UTC](https://discuss.elastic.co/t/kibana-5-0-1-request-timeout-after-3000ms/67083 "2016-12-01T14:50:47Z")

</div>

Hello everyone, I'm new here, and basically a newbie in ELK and many other things. I've been asked to prototype ELK to process logs generated by the application we are developing and being able to analyze them easily. …

---

## [How to Customize Kibana 7.6.0 Login Page?](https://discuss.elastic.co/t/how-to-customize-kibana-7-6-0-login-page/232769)

<div class="topic-metadata">

**Author:** [@Emna1](https://discuss.elastic.co/u/Emna1)\
**Replies:** 32\
**Last updated:** [June 23, 2020, 10:32am UTC](https://discuss.elastic.co/t/how-to-customize-kibana-7-6-0-login-page/232769 "2020-06-23T10:32:24Z")

</div>

Hi, I've read a few posts around how to customize the login page of Kibana but all seem obsolete since from version to version, the code gets changed and so do the mods. so can i have a guide to : 1- Browser title an…

---

## [Create Custom geoip database for Logstash 5.2](https://discuss.elastic.co/t/create-custom-geoip-database-for-logstash-5-2/79473)

<div class="topic-metadata">

**Author:** [@Grenouille06](https://discuss.elastic.co/u/Grenouille06)\
**Replies:** 20\
**Last updated:** [March 29, 2017, 1:53pm UTC](https://discuss.elastic.co/t/create-custom-geoip-database-for-logstash-5-2/79473 "2017-03-29T13:53:17Z")

</div>

Hi, in old versions of Logstash, it was easy to create a custom dat file from a csv for having a geoip private ip database. The csv looks like : startIpNum,endIpNum,country,region,city,postalCode,latitude,longitude,me…

---

## [NoNodeAvailableException\[None of the configured nodes are available exception](https://discuss.elastic.co/t/nonodeavailableexception-none-of-the-configured-nodes-are-available-exception/91713)

<div class="topic-metadata">

**Author:** [@Subhasish\_Sahu](https://discuss.elastic.co/u/Subhasish_Sahu)\
**Replies:** 9\
**Last updated:** [July 10, 2017, 3:19pm UTC](https://discuss.elastic.co/t/nonodeavailableexception-none-of-the-configured-nodes-are-available-exception/91713 "2017-07-10T15:19:46Z")

</div>

I am using ES 5.4.2 and Java 1.8 and getting below error while connecting to local ES server. Exception in thread "main" NoNodeAvailableException\[None of the configured nodes are available: \[{#transport#-1}{cv2EOOhCQ3O…

---

## [Compréhension et utilisation logstash, Kibana](https://discuss.elastic.co/t/comprehension-et-utilisation-logstash-kibana/87676)

<div class="topic-metadata">

**Author:** [@pitieu](https://discuss.elastic.co/u/pitieu)\
**Replies:** 39\
**Last updated:** [June 8, 2017, 6:57am UTC](https://discuss.elastic.co/t/comprehension-et-utilisation-logstash-kibana/87676 "2017-06-08T06:57:04Z")

</div>

Bonjour, Je suis novice dans elastic stack et je suis en formation d'administrateur systèmes et réseaux. Et pendant ma formation je dois faire une présentation d'elastic stack. J'ai réussi à installer les 3 logiciels (EL…

---

## [Bulk indexing. Not all documents inserted, but no errors](https://discuss.elastic.co/t/bulk-indexing-not-all-documents-inserted-but-no-errors/24376)

<div class="topic-metadata">

**Author:** [@javadevmtl](https://discuss.elastic.co/u/javadevmtl)\
**Replies:** 11\
**Last updated:** [June 29, 2015, 1:47pm UTC](https://discuss.elastic.co/t/bulk-indexing-not-all-documents-inserted-but-no-errors/24376 "2015-06-29T13:47:07Z")

</div>

Using E.S 1.6.0 Hi I'm running a bulk process with the following java/vertx code. I tried bulking 192,000 documents but only 20,000 got indexed. This used to be fine I have indexed over 1.3 billion documents. I'm loo…

---

## [Kibana 4.2 as a service](https://discuss.elastic.co/t/kibana-4-2-as-a-service/33426)

<div class="topic-metadata">

**Author:** [@niraj\_kumar](https://discuss.elastic.co/u/niraj_kumar)\
**Replies:** 9\
**Last updated:** [June 17, 2016, 3:45pm UTC](https://discuss.elastic.co/t/kibana-4-2-as-a-service/33426 "2016-06-17T15:45:21Z")

</div>

Hey All, Kibana 4.2 is live and i really love it , but what really annoys me is that why can't be it run as a service like the usual elasticsearch and all which comes with a debian package. Is there a proper way to run…

---

## [Problem searching queries with accents](https://discuss.elastic.co/t/problem-searching-queries-with-accents/6401)

<div class="topic-metadata">

**Author:** [@Felipe\_Hummel](https://discuss.elastic.co/u/Felipe_Hummel)\
**Replies:** 9\
**Last updated:** [January 17, 2012, 6:37pm UTC](https://discuss.elastic.co/t/problem-searching-queries-with-accents/6401 "2012-01-17T18:37:51Z")

</div>

Hi, I'm indexing brazilian portuguese text that contains accents. To remove them I used the asciifolding filter. My "test" index settings is as follows: { "test": { "settings": { "in…

---

## [Filebeat and Multiline](https://discuss.elastic.co/t/filebeat-and-multiline/38499)

<div class="topic-metadata">

**Author:** [@ori.rubinfeld](https://discuss.elastic.co/u/ori.rubinfeld)\
**Replies:** 11\
**Last updated:** [June 10, 2016, 12:12pm UTC](https://discuss.elastic.co/t/filebeat-and-multiline/38499 "2016-06-10T12:12:19Z")

</div>

Hi, We would like to implement the Filebeat as a shipper for log files. Some of the log files are multilines. Some servers are sending same types of logs. What is the best way of doing it ? Can I use conditions on …

---

## [Can filebeat push the Windows Event logs to logstash](https://discuss.elastic.co/t/can-filebeat-push-the-windows-event-logs-to-logstash/52830)

<div class="topic-metadata">

**Author:** [@disalassalyjose](https://discuss.elastic.co/u/disalassalyjose)\
**Replies:** 9\
**Last updated:** [June 23, 2016, 9:51am UTC](https://discuss.elastic.co/t/can-filebeat-push-the-windows-event-logs-to-logstash/52830 "2016-06-23T09:51:52Z")

</div>

Can we push Event logs from Windows server 2012 r2 to logststash which is installed on ubuntu using filebeat. Server : Ubuntu 14.04 Client : Windows server 2012 r2

---

## [Lots of deleted documents above 40%](https://discuss.elastic.co/t/lots-of-deleted-documents-above-40/96841)

<div class="topic-metadata">

**Author:** [@Slava\_G](https://discuss.elastic.co/u/Slava_G)\
**Replies:** 40\
**Last updated:** [August 29, 2017, 8:07am UTC](https://discuss.elastic.co/t/lots-of-deleted-documents-above-40/96841 "2017-08-29T08:07:09Z")

</div>

Hi, In my index I recently removed many documents, but after 3 weeks I still see that index has above 40% of deleted documents, I know that merger somehow, eventually should clean this, but it’s not happened yet and ind…

---

## [Visualization & Dashboard return no results found, while discover tab successfully displays results ?!](https://discuss.elastic.co/t/visualization-dashboard-return-no-results-found-while-discover-tab-successfully-displays-results/91729)

<div class="topic-metadata">

**Author:** [@adilld](https://discuss.elastic.co/u/adilld)\
**Replies:** 9\
**Last updated:** [July 12, 2017, 12:49pm UTC](https://discuss.elastic.co/t/visualization-dashboard-return-no-results-found-while-discover-tab-successfully-displays-results/91729 "2017-07-12T12:49:39Z")

</div>

Hello everybody, I have a problem with Kibana: Dashboard and visualizations don't show any results! As you can see in this screenshot, in the discover tab I get some results! Which means data exists in my index "as-\*".…

---

## [Elasticsearch nodes are leaving the cluster continuously](https://discuss.elastic.co/t/elasticsearch-nodes-are-leaving-the-cluster-continuously/242853)

<div class="topic-metadata">

**Author:** [@darshan](https://discuss.elastic.co/u/darshan)\
**Replies:** 20\
**Last updated:** [August 1, 2020, 6:29am UTC](https://discuss.elastic.co/t/elasticsearch-nodes-are-leaving-the-cluster-continuously/242853 "2020-08-01T06:29:29Z")

</div>

Hi, The nodes in the cluster are leaving continuously and rejoins after few seconds. when I checked for error it says "master not discovered yet: have discovered" error. I don't have any clue what is happening. please c…

---

## [Fluentd cannot connect to Elasticsearch](https://discuss.elastic.co/t/fluentd-cannot-connect-to-elasticsearch/322269)

<div class="topic-metadata">

**Author:** [@Zeynal\_Hajili](https://discuss.elastic.co/u/Zeynal_Hajili)\
**Replies:** 13\
**Last updated:** [January 1, 2023, 9:08pm UTC](https://discuss.elastic.co/t/fluentd-cannot-connect-to-elasticsearch/322269 "2023-01-01T21:08:29Z")

</div>

Hello everybody, First of all, happy new year to everybody :slight\_smile: I need your help with the ELK stack. I have installed Elastic , Kibana and Fluentd with HelmChart. I have healthy cluster of Elasticsearch ,I …

---

## [Filebeat is not sending logs to logstash](https://discuss.elastic.co/t/filebeat-is-not-sending-logs-to-logstash/56249)

<div class="topic-metadata">

**Author:** [@Saurabh\_Jambhule](https://discuss.elastic.co/u/Saurabh_Jambhule)\
**Replies:** 10\
**Last updated:** [July 27, 2016, 1:54pm UTC](https://discuss.elastic.co/t/filebeat-is-not-sending-logs-to-logstash/56249 "2016-07-27T13:54:33Z")

</div>

There are some sample apache logs in folder listed in paths, but still they not going to logstash Here is my configuration, filebeat: filebeat: prospectors: - paths: - /home/saurabh/sample-log/\*.l…

---

## [Elasticsearch cluster is in Red state. How to recover it?](https://discuss.elastic.co/t/elasticsearch-cluster-is-in-red-state-how-to-recover-it/207444)

<div class="topic-metadata">

**Author:** [@chaitra\_hegde](https://discuss.elastic.co/u/chaitra_hegde)\
**Replies:** 13\
**Last updated:** [November 27, 2019, 6:58am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-is-in-red-state-how-to-recover-it/207444 "2019-11-27T06:58:36Z")

</div>

Hi, I am using Elasticsearch 6.6.1 in k8s environment. My cluster was in green state before. But now my cluster is in red state due to UNASSIGNED shards. I see many shards are in PRIMARY\_FAILED state. You can find the …

---

## [Create new user in kibana](https://discuss.elastic.co/t/create-new-user-in-kibana/190952)

<div class="topic-metadata">

**Author:** [@Melok](https://discuss.elastic.co/u/Melok)\
**Replies:** 9\
**Last updated:** [July 19, 2019, 1:17pm UTC](https://discuss.elastic.co/t/create-new-user-in-kibana/190952 "2019-07-19T13:17:12Z")

</div>

I am trying to create a new user with the privilege kibana-user. But when I log in, I get an Oops error! Error. Try again.

---

## [Read image text from pdf](https://discuss.elastic.co/t/read-image-text-from-pdf/82380)

<div class="topic-metadata">

**Author:** [@Nikparab](https://discuss.elastic.co/u/Nikparab)\
**Replies:** 53\
**Last updated:** [May 10, 2017, 10:16am UTC](https://discuss.elastic.co/t/read-image-text-from-pdf/82380 "2017-05-10T10:16:16Z")

</div>

Hello team, I m using Fscrawler 2.3 snapshot.Using this I m able to load pdf in elasticsearch , but not able to read the image text from it.Is there any way to read image text?? If anyone knows this then please reply.

---

## [Get Openshift Metrices via metricbeat in elasticsearch](https://discuss.elastic.co/t/get-openshift-metrices-via-metricbeat-in-elasticsearch/246958)

<div class="topic-metadata">

**Author:** [@Harshi1](https://discuss.elastic.co/u/Harshi1)\
**Replies:** 19\
**Last updated:** [October 5, 2020, 6:18am UTC](https://discuss.elastic.co/t/get-openshift-metrices-via-metricbeat-in-elasticsearch/246958 "2020-10-05T06:18:35Z")

</div>

Kibana version : 7.7.0 Elasticsearch version : 7.7.0 Metricbeat version : 7.7 Browser version : Chrome 84.0 Original install method (e.g. download page, yum, deb, from source, etc.) and version : RPM from download pa…

---

## [Filebeat is blocked since the bulk send failure](https://discuss.elastic.co/t/filebeat-is-blocked-since-the-bulk-send-failure/155331)

<div class="topic-metadata">

**Author:** [@guanghaofan](https://discuss.elastic.co/u/guanghaofan)\
**Replies:** 19\
**Last updated:** [November 8, 2018, 5:30am UTC](https://discuss.elastic.co/t/filebeat-is-blocked-since-the-bulk-send-failure/155331 "2018-11-08T05:30:32Z")

</div>

hi experts, My filebeat case is the filebeat is always blocked since there are some bulk send failures due to the unexpected bad format of log event in each file, then it seems filebeat is busy in trying re-send the fai…

---

## [How to quikly parsing 1 million xml](https://discuss.elastic.co/t/how-to-quikly-parsing-1-million-xml/73141)

<div class="topic-metadata">

**Author:** [@111126](https://discuss.elastic.co/u/111126)\
**Replies:** 19\
**Last updated:** [February 2, 2017, 8:56pm UTC](https://discuss.elastic.co/t/how-to-quikly-parsing-1-million-xml/73141 "2017-02-02T20:56:45Z")

</div>

Hello. I have 1 million file with xml. Each file size from a few kilobytes to 20mb. I need parsing their and put to elastic. I tried to use the next config: file { path =\> "/opt/lun1/data-unzip/ftp/228-pur-plan/.xm…

---

## [Rejecting mapping update to \[xxx\] as the final mapping would have more than 1 type: \[\_doc, xxx\]](https://discuss.elastic.co/t/rejecting-mapping-update-to-xxx-as-the-final-mapping-would-have-more-than-1-type-doc-xxx/298839)

<div class="topic-metadata">

**Author:** [@Ramesh\_balasubramani](https://discuss.elastic.co/u/Ramesh_balasubramani)\
**Replies:** 11\
**Last updated:** [March 5, 2022, 6:57pm UTC](https://discuss.elastic.co/t/rejecting-mapping-update-to-xxx-as-the-final-mapping-would-have-more-than-1-type-doc-xxx/298839 "2022-03-05T18:57:31Z")

</div>

I am using Elasticsearch 7.10.2 version. I need to create one index, Index name = device \_type name = device But I am not able to create getting error. POST device/device/169062 { "device\_name": "DESK…

---

## [LogStash 2.2 start as a service does not read config file](https://discuss.elastic.co/t/logstash-2-2-start-as-a-service-does-not-read-config-file/43675)

<div class="topic-metadata">

**Author:** [@Jeremy\_Colton](https://discuss.elastic.co/u/Jeremy_Colton)\
**Replies:** 10\
**Last updated:** [June 19, 2017, 2:35pm UTC](https://discuss.elastic.co/t/logstash-2-2-start-as-a-service-does-not-read-config-file/43675 "2017-06-19T14:35:26Z")

</div>

Hi, I am running logstash 2.2 on ubuntu 14.0.4. I SSH into my linux box using a cert and sudo to root user. My config file is under /etc/logstash/conf.d/default.conf. a) When I run logstash from the command line: …

---

## [Drill down on charts](https://discuss.elastic.co/t/drill-down-on-charts/94178)

<div class="topic-metadata">

**Author:** [@patrickian](https://discuss.elastic.co/u/patrickian)\
**Replies:** 11\
**Last updated:** [July 29, 2017, 3:01am UTC](https://discuss.elastic.co/t/drill-down-on-charts/94178 "2017-07-29T03:01:39Z")

</div>

Is there a way in kibana to do a drill down function on charts? I'm trying to create a pie chart that when a part of the chart is clicked, it will show what makes that part up. let's say I sub bucket my data by "gr…

---

## [\[Solved\] "message":"write EPIPE","name":"Error"](https://discuss.elastic.co/t/solved-message-write-epipe-name-error/66343)

<div class="topic-metadata">

**Author:** [@ironbeast](https://discuss.elastic.co/u/ironbeast)\
**Replies:** 32\
**Last updated:** [November 17, 2016, 2:03pm UTC](https://discuss.elastic.co/t/solved-message-write-epipe-name-error/66343 "2016-11-17T14:03:12Z")

</div>

Dear Al After I removed mij filebeat index from kibana, kibana doesn't load the webinterface anymore This is the error I have i my logs: {"type":"log","@timestamp":"2016-11-17T07:45:32Z","tags":\["connection","clie…

---

## [All field error - Could not index event to Elasticsearch](https://discuss.elastic.co/t/all-field-error-could-not-index-event-to-elasticsearch/120906)

<div class="topic-metadata">

**Author:** [@atom](https://discuss.elastic.co/u/atom)\
**Replies:** 17\
**Last updated:** [February 22, 2018, 11:41am UTC](https://discuss.elastic.co/t/all-field-error-could-not-index-event-to-elasticsearch/120906 "2018-02-22T11:41:53Z")

</div>

HI, i have done an upgraded of my elkstack (elasticsearch, kibana, logstash, filebeat). Everything was fine yesterday. Now i am getting these error messages in logstash: \[2018-02-21T18:29:46,901\]\[WARN \]\[logstash.outpu…

---

## [Long delay between indexing and search availability](https://discuss.elastic.co/t/long-delay-between-indexing-and-search-availability/157022)

<div class="topic-metadata">

**Author:** [@HPVRNP](https://discuss.elastic.co/u/HPVRNP)\
**Replies:** 17\
**Last updated:** [November 23, 2018, 5:38am UTC](https://discuss.elastic.co/t/long-delay-between-indexing-and-search-availability/157022 "2018-11-23T05:38:24Z")

</div>

I am using Elastic search version 6.1 , Nest 6.1 , C# 4.5.2 for development. I receive huge volumes of data from different applications in short intervals (50000 documents/sec) and then store all the documents in Elas…

---

## [Aggregation pagination and sort by document field](https://discuss.elastic.co/t/aggregation-pagination-and-sort-by-document-field/240211)

<div class="topic-metadata">

**Author:** [@nerd2000](https://discuss.elastic.co/u/nerd2000)\
**Replies:** 9\
**Last updated:** [July 8, 2020, 2:05pm UTC](https://discuss.elastic.co/t/aggregation-pagination-and-sort-by-document-field/240211 "2020-07-08T14:05:15Z")

</div>

Hi, I would like to know how to sort an aggregation result by a field in the document. My indice configuration { "id": { "type": "long" }, "film\_id": { "type": "long" }, "film\_group\_id": { "type"…

[Previous page](https://discuss.elastic.co/top.md?page=19&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=21&per_page=50&period=all)
