# Top

**URL:** https://discuss.elastic.co/top.md?page=22&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 23

---

## [Template is not being used, mapping not working](https://discuss.elastic.co/t/template-is-not-being-used-mapping-not-working/190207)

<div class="topic-metadata">

**Author:** [@mpes](https://discuss.elastic.co/u/mpes)\
**Replies:** 16\
**Last updated:** [July 13, 2019, 9:09pm UTC](https://discuss.elastic.co/t/template-is-not-being-used-mapping-not-working/190207 "2019-07-13T21:09:33Z")

</div>

Hey there! I am analysing access logs for a project. I have everything set up, Logstash is doing what is supposed to do, Elasticsearch and Kibana, too (using 5.2). BUT: Yesterday I decided to write my own template, sinc…

---

## [Elasticsearch Status Active Failed](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143)

<div class="topic-metadata">

**Author:** [@yrizal](https://discuss.elastic.co/u/yrizal)\
**Replies:** 13\
**Last updated:** [September 12, 2017, 6:59am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143 "2017-09-12T06:59:45Z")

</div>

Hello, OS = centos7, install in vm java version ========================================================================== openjdk version "1.8.0\_102" OpenJDK Runtime Environment (build 1.8.0\_102-b14) OpenJDK 64-Bi…

---

## [Semantic search engine on the top of ES ! (Any suggestions/comments)](https://discuss.elastic.co/t/semantic-search-engine-on-the-top-of-es-any-suggestions-comments/41527)

<div class="topic-metadata">

**Author:** [@Yongyao\_Jiang](https://discuss.elastic.co/u/Yongyao_Jiang)\
**Replies:** 9\
**Last updated:** [January 31, 2017, 4:13pm UTC](https://discuss.elastic.co/t/semantic-search-engine-on-the-top-of-es-any-suggestions-comments/41527 "2017-01-31T16:13:03Z")

</div>

Hey guys, I am trying to build up a semantic search engine on the top of ES, and below is my idea. I was wondering if this makes sense to you, especially for the ranking part. Feel free to be critical. Simply put, if…

---

## [Trying to get simplest of "now" to work in date range queries](https://discuss.elastic.co/t/trying-to-get-simplest-of-now-to-work-in-date-range-queries/96660)

<div class="topic-metadata">

**Author:** [@Jaspreet\_Singh](https://discuss.elastic.co/u/Jaspreet_Singh)\
**Replies:** 14\
**Last updated:** [August 11, 2017, 1:48pm UTC](https://discuss.elastic.co/t/trying-to-get-simplest-of-now-to-work-in-date-range-queries/96660 "2017-08-11T13:48:22Z")

</div>

Here is a simple query im trying out … "query": { "bool": { "filter": \[ { "range": { "publishdate": { "lt": "now" }}} \] } } } Im hoping to get back almost…

---

## [ERROR: Could not locate that index-pattern-field on filebeat](https://discuss.elastic.co/t/error-could-not-locate-that-index-pattern-field-on-filebeat/93380)

<div class="topic-metadata">

**Author:** [@Sujith](https://discuss.elastic.co/u/Sujith)\
**Replies:** 17\
**Last updated:** [August 8, 2017, 7:28pm UTC](https://discuss.elastic.co/t/error-could-not-locate-that-index-pattern-field-on-filebeat/93380 "2017-08-08T19:28:41Z")

</div>

Hi All, I have installed ELK stack 5.5.0 Version and beats as of the only file beat installed on my machine. When i import file beat dashboard and visualization of 5.5.0 version, I'm getting below error while clicking …

---

## [Logstash not show any output](https://discuss.elastic.co/t/logstash-not-show-any-output/88445)

<div class="topic-metadata">

**Author:** [@baha1](https://discuss.elastic.co/u/baha1)\
**Replies:** 15\
**Last updated:** [June 8, 2017, 10:58am UTC](https://discuss.elastic.co/t/logstash-not-show-any-output/88445 "2017-06-08T10:58:12Z")

</div>

Hi there, i have LS and ES are runing,but there is nothing printed in ES or LS. this is pipeline config. input { file { path =\> "access\_log.txt" } } filter { grok { match =\> { "message" =\> "%{COMBINEDAPACHELOG}" } } …

---

## [Metricbeat does not start service](https://discuss.elastic.co/t/metricbeat-does-not-start-service/231059)

<div class="topic-metadata">

**Author:** [@ElAouane](https://discuss.elastic.co/u/ElAouane)\
**Replies:** 18\
**Last updated:** [May 5, 2020, 2:41am UTC](https://discuss.elastic.co/t/metricbeat-does-not-start-service/231059 "2020-05-05T02:41:33Z")

</div>

Hi guys I've been trying to implement kibana in my aws. i have 4 instances in total elasticsearch 2.logstash kibana,filebeat and metricbeat app instance (nginx) i would like, from kibana, be able to display meatricb…

---

## [Err: Error decoding JSON](https://discuss.elastic.co/t/err-error-decoding-json/71244)

<div class="topic-metadata">

**Author:** [@dallmon](https://discuss.elastic.co/u/dallmon)\
**Replies:** 17\
**Last updated:** [February 24, 2017, 2:09pm UTC](https://discuss.elastic.co/t/err-error-decoding-json/71244 "2017-02-24T14:09:00Z")

</div>

I get this very often with Filebeat 5.1.1. I modified the logp call in json.go to log the input data. Two examples: JSON in input file: {"QuestionId":922254,"Username":"jtberry","Expiration":"2016-12-28T00:04:00","Sour…

---

## [Elasticsearch is running but it does not connect when the public ip is given in browser](https://discuss.elastic.co/t/elasticsearch-is-running-but-it-does-not-connect-when-the-public-ip-is-given-in-browser/287040)

<div class="topic-metadata">

**Author:** [@spo](https://discuss.elastic.co/u/spo)\
**Replies:** 10\
**Last updated:** [October 20, 2021, 9:09pm UTC](https://discuss.elastic.co/t/elasticsearch-is-running-but-it-does-not-connect-when-the-public-ip-is-given-in-browser/287040 "2021-10-20T21:09:04Z")

</div>

browser error when accessing Elasticsearch Elasticsearch.yml file: # ======================== Elasticsearch Configuration ========================= # # NOTE: Elasticsearch comes with reasonable defaults for most set…

---

## [How to disable nested data type keyword in dynamic mapping](https://discuss.elastic.co/t/how-to-disable-nested-data-type-keyword-in-dynamic-mapping/81157)

<div class="topic-metadata">

**Author:** [@anand.d](https://discuss.elastic.co/u/anand.d)\
**Replies:** 9\
**Last updated:** [April 5, 2017, 9:48am UTC](https://discuss.elastic.co/t/how-to-disable-nested-data-type-keyword-in-dynamic-mapping/81157 "2017-04-05T09:48:22Z")

</div>

I am using Elasticsearch 5.2.2. I have a requirement that in my index, some fields will be defined and some field will be dynamic. But the dynamic mapping is creating a structure something like this: "COLOR": { …

---

## [Exact Search on multiple wildcard-fields](https://discuss.elastic.co/t/exact-search-on-multiple-wildcard-fields/141921)

<div class="topic-metadata">

**Author:** [@cherry-wave](https://discuss.elastic.co/u/cherry-wave)\
**Replies:** 22\
**Last updated:** [August 8, 2018, 11:26am UTC](https://discuss.elastic.co/t/exact-search-on-multiple-wildcard-fields/141921 "2018-08-08T11:26:41Z")

</div>

Hello guys, I have to do searches on fields with wildcards in it. Like for example: { "query\_string": { "fields": \["variations.generalData\*", "variations.addresses\*"\], "query": "Müll" } } But I didn'…

---

## [Error: Failed to decrypt report job data. Please re-generate this report. how? 5.6.4](https://discuss.elastic.co/t/error-failed-to-decrypt-report-job-data-please-re-generate-this-report-how-5-6-4/112768)

<div class="topic-metadata">

**Author:** [@zqc0512](https://discuss.elastic.co/u/zqc0512)\
**Replies:** 10\
**Last updated:** [January 8, 2018, 2:51pm UTC](https://discuss.elastic.co/t/error-failed-to-decrypt-report-job-data-please-re-generate-this-report-how-5-6-4/112768 "2018-01-08T14:51:00Z")

</div>

Error: Failed to decrypt report job data. Please re-generate this report. how to do about it ? \[image\] the other error. Unhandled rejection Error: You must install fontconfig and freetype for Reporting to work

---

## [SQL Server data to Elasticsearch using LogStash](https://discuss.elastic.co/t/sql-server-data-to-elasticsearch-using-logstash/245488)

<div class="topic-metadata">

**Author:** [@sukumar.koganti](https://discuss.elastic.co/u/sukumar.koganti)\
**Replies:** 30\
**Last updated:** [August 20, 2020, 2:15pm UTC](https://discuss.elastic.co/t/sql-server-data-to-elasticsearch-using-logstash/245488 "2020-08-20T14:15:18Z")

</div>

HI I am tryting to integrate the Sql server data to Elasticsearch with Logstash in my local machine. I am using the Microsoft Sql Server 2019 and jdbc using the below --Microsoft JDBC Driver 4.2 for SQL Server This i…

---

## [ES JVM memory usage consistently above 90%](https://discuss.elastic.co/t/es-jvm-memory-usage-consistently-above-90/22800)

<div class="topic-metadata">

**Author:** [@Yogesh\_Kansal](https://discuss.elastic.co/u/Yogesh_Kansal)\
**Replies:** 10\
**Last updated:** [March 25, 2015, 7:51am UTC](https://discuss.elastic.co/t/es-jvm-memory-usage-consistently-above-90/22800 "2015-03-25T07:51:31Z")

</div>

Hi, I have set up elasticsearch on one node and am using the Twitter river to index tweets. It has been going fine with almost 50M tweets indexed so far in 13 days. When I started indexing, the JVM usage (observe…

---

## [Русская морфология](https://discuss.elastic.co/t/topic/41386)

<div class="topic-metadata">

**Author:** [@glukhovd](https://discuss.elastic.co/u/glukhovd)\
**Replies:** 21\
**Last updated:** [March 31, 2016, 8:24am UTC](https://discuss.elastic.co/t/topic/41386 "2016-03-31T08:24:08Z")

</div>

Здравствуйте. Я использую ES версии 1.7.0 + elasticsearch-analysis-morphology (полагаю, версии 1.2.1). В настройках я имею: "analyzer": { "ru\_analyzer": { "filter": \[ "lowercase", "russian\_morphology", "engl…

---

## [Logstash does not send apache logs to elasticsearch](https://discuss.elastic.co/t/logstash-does-not-send-apache-logs-to-elasticsearch/90797)

<div class="topic-metadata">

**Author:** [@themoisis](https://discuss.elastic.co/u/themoisis)\
**Replies:** 52\
**Last updated:** [June 29, 2017, 9:45am UTC](https://discuss.elastic.co/t/logstash-does-not-send-apache-logs-to-elasticsearch/90797 "2017-06-29T09:45:24Z")

</div>

Here is the logstash.conf input { file { path =\> "/home/test6/admin\_access.log" type =\> "apache-access" start\_position =\> "beginning" sincedb\_path =\> "/dev/null" } } filter { if \[type\] == "apach…

---

## [Unable to revive connection: http://localhost:9200 with Docker](https://discuss.elastic.co/t/unable-to-revive-connection-http-localhost-9200-with-docker/260726)

<div class="topic-metadata">

**Author:** [@gcio](https://discuss.elastic.co/u/gcio)\
**Replies:** 9\
**Last updated:** [January 11, 2021, 2:54pm UTC](https://discuss.elastic.co/t/unable-to-revive-connection-http-localhost-9200-with-docker/260726 "2021-01-11T14:54:17Z")

</div>

Hi everyone, I'm starting a docker container as follows docker run -d --rm --name ejq-elk -v $PWD:/var/backups -p 5601:5601 sebp/elk:7.10.0 However, this returns a connection error ==\> /var/log/kibana/kibana5.log \<==…

---

## [Getting Error while trying to create and Index Pattern : "Error Fetching Fields" "Request Entity Too Large"](https://discuss.elastic.co/t/getting-error-while-trying-to-create-and-index-pattern-error-fetching-fields-request-entity-too-large/248835)

<div class="topic-metadata">

**Author:** [@Sebastien\_Lelak](https://discuss.elastic.co/u/Sebastien_Lelak)\
**Replies:** 15\
**Last updated:** [October 1, 2020, 3:08pm UTC](https://discuss.elastic.co/t/getting-error-while-trying-to-create-and-index-pattern-error-fetching-fields-request-entity-too-large/248835 "2020-10-01T15:08:41Z")

</div>

Greetings, We have an elastic cluster containing 12 nodes and 1.4Tb of documents, daily indexed through a total of 7.5k shards. Everything was working fine, but a human error caused the deletion of the .kibana\* indexes…

---

## [Must\_not in bool filter much slower than must for same terms filter](https://discuss.elastic.co/t/must-not-in-bool-filter-much-slower-than-must-for-same-terms-filter/1479)

<div class="topic-metadata">

**Author:** [@bobbyrenwick](https://discuss.elastic.co/u/bobbyrenwick)\
**Replies:** 13\
**Last updated:** [June 8, 2015, 2:04pm UTC](https://discuss.elastic.co/t/must-not-in-bool-filter-much-slower-than-must-for-same-terms-filter/1479 "2015-06-08T14:04:19Z")

</div>

Is there any reason that a must\_not clause would run a lot slower than a must clause in the same bool filter? { "query": { "filtered": { "filter": { "bool": { "must\_not": { "t…

---

## [Why is IDs query slow?](https://discuss.elastic.co/t/why-is-ids-query-slow/29075)

<div class="topic-metadata">

**Author:** [@Nikita\_Tovstoles](https://discuss.elastic.co/u/Nikita_Tovstoles)\
**Replies:** 17\
**Last updated:** [September 16, 2015, 2:23pm UTC](https://discuss.elastic.co/t/why-is-ids-query-slow/29075 "2015-09-16T14:23:18Z")

</div>

Have an index of ~ 9M docs, of which ~ 20K are "programs". This IDs query (with 20 IDs) takes 600ms on a local server, running on MBP with SSD. If I halve number of IDs, query latency cuts in half too. Same query takes 2…

---

## [I have ran filebeat but not showing up anything on kibana](https://discuss.elastic.co/t/i-have-ran-filebeat-but-not-showing-up-anything-on-kibana/48046)

<div class="topic-metadata">

**Author:** [@GSL10019](https://discuss.elastic.co/u/GSL10019)\
**Replies:** 18\
**Last updated:** [May 10, 2016, 1:00pm UTC](https://discuss.elastic.co/t/i-have-ran-filebeat-but-not-showing-up-anything-on-kibana/48046 "2016-05-10T13:00:19Z")

</div>

Hi, I just ran filebeat with the typical commands of filebeat start within the directory of filebeat. But when i open Kibana with my configured yml, i dont see anything too it but I see my previous defaulted filebeat…

---

## [Filebeat is not closig the file descriptor once the file is deleted/renamed](https://discuss.elastic.co/t/filebeat-is-not-closig-the-file-descriptor-once-the-file-is-deleted-renamed/104077)

<div class="topic-metadata">

**Author:** [@swethamahesh](https://discuss.elastic.co/u/swethamahesh)\
**Replies:** 26\
**Last updated:** [November 27, 2017, 4:53am UTC](https://discuss.elastic.co/t/filebeat-is-not-closig-the-file-descriptor-once-the-file-is-deleted-renamed/104077 "2017-11-27T04:53:01Z")

</div>

filebeat is not closing the file descriptor incase of file is been removed/rotated with version 5.5 and due to which disk usage is full 14327 0 lrwx------ 1 xxx xxx 64 Oct 13 13:23 /proc/1079/fd/7 -\>…

---

## [Filebeat install E: Unable to locate package filebeat](https://discuss.elastic.co/t/filebeat-install-e-unable-to-locate-package-filebeat/203921)

<div class="topic-metadata">

**Author:** [@Mehak\_Bhargava](https://discuss.elastic.co/u/Mehak_Bhargava)\
**Replies:** 9\
**Last updated:** [October 28, 2019, 11:43pm UTC](https://discuss.elastic.co/t/filebeat-install-e-unable-to-locate-package-filebeat/203921 "2019-10-28T23:43:43Z")

</div>

Following Install Filebeat 7.x, I typed these commands in this order- apt-get install apt-transport-https apt update apt install filebeat But the last command gave me the error shown in picture. I tried sudo rm /va…

---

## [Does http\_poller handle https?](https://discuss.elastic.co/t/does-http-poller-handle-https/28864)

<div class="topic-metadata">

**Author:** [@CraigFoote](https://discuss.elastic.co/u/CraigFoote)\
**Replies:** 24\
**Last updated:** [December 13, 2016, 5:25pm UTC](https://discuss.elastic.co/t/does-http-poller-handle-https/28864 "2016-12-13T17:25:09Z")

</div>

This input plugin looks perfect for what I need except I need to call https and so must provide certificate information. I found this closed github issue, https://github.com/logstash-plugins/logstash-input-http\_poller/is…

---

## [IO Reactor errors closing connection](https://discuss.elastic.co/t/io-reactor-errors-closing-connection/279148)

<div class="topic-metadata">

**Author:** [@Mariusz\_Pala](https://discuss.elastic.co/u/Mariusz_Pala)\
**Replies:** 11\
**Last updated:** [July 20, 2021, 12:18pm UTC](https://discuss.elastic.co/t/io-reactor-errors-closing-connection/279148 "2021-07-20T12:18:22Z")

</div>

Hi, I asked ES about the IOReactor connection issues(Request cannot be executed; I/O reactor status: STOPPED) and as per an answer in my ticket RestHighLevelClient disconnection issues · Issue #75364 · elastic/elasticse…

---

## [Using cidr plugin for tagging logs](https://discuss.elastic.co/t/using-cidr-plugin-for-tagging-logs/72878)

<div class="topic-metadata">

**Author:** [@vdsm](https://discuss.elastic.co/u/vdsm)\
**Replies:** 27\
**Last updated:** [January 27, 2017, 4:36pm UTC](https://discuss.elastic.co/t/using-cidr-plugin-for-tagging-logs/72878 "2017-01-27T16:36:37Z")

</div>

Hi everyone, Before I start I have to warn you that i'm French and my English is kind limited. I just started with ELK but I want to so something like this : host A --\> logs -- LANA | …

---

## [Performance degradation after ES upgrade (v1.7 -\> v5.2)](https://discuss.elastic.co/t/performance-degradation-after-es-upgrade-v1-7-v5-2/81178)

<div class="topic-metadata">

**Author:** [@telendt](https://discuss.elastic.co/u/telendt)\
**Replies:** 9\
**Last updated:** [April 19, 2017, 4:24pm UTC](https://discuss.elastic.co/t/performance-degradation-after-es-upgrade-v1-7-v5-2/81178 "2017-04-19T16:24:14Z")

</div>

Long story short - last year we tried to migrate from Elasticsearch 1.7 to 2.4 but we noticed quite significant performance degradation (details in this thread). We tried all suggested changes but we were not able to mat…

---

## [Bool query in array field](https://discuss.elastic.co/t/bool-query-in-array-field/57494)

<div class="topic-metadata">

**Author:** [@guilherme\_maranhao](https://discuss.elastic.co/u/guilherme_maranhao)\
**Replies:** 10\
**Last updated:** [August 12, 2016, 5:41pm UTC](https://discuss.elastic.co/t/bool-query-in-array-field/57494 "2016-08-12T17:41:17Z")

</div>

Hi, I have a very particular issue concerning querying over a boolean field and a string field which are nested to an array field. The index mapping is as follow: indexes :string\_field\_1, type: 'string' indexes :string…

---

## [ECE Unhealthy platform, internal server error](https://discuss.elastic.co/t/ece-unhealthy-platform-internal-server-error/222714)

<div class="topic-metadata">

**Author:** [@mesiasc](https://discuss.elastic.co/u/mesiasc)\
**Replies:** 41\
**Last updated:** [March 25, 2020, 11:13am UTC](https://discuss.elastic.co/t/ece-unhealthy-platform-internal-server-error/222714 "2020-03-25T11:13:20Z")

</div>

My ECE had hosting related problems. I lost the host which was initially the first installed host. This left two remaining hosts. The ECE UI shows "There was an internal server error" The platform was initially installe…

---

## [Logstash Does Not Read In Last Line of Log](https://discuss.elastic.co/t/logstash-does-not-read-in-last-line-of-log/2706)

<div class="topic-metadata">

**Author:** [@michaellizhou](https://discuss.elastic.co/u/michaellizhou)\
**Replies:** 15\
**Last updated:** [May 26, 2017, 10:21am UTC](https://discuss.elastic.co/t/logstash-does-not-read-in-last-line-of-log/2706 "2017-05-26T10:21:24Z")

</div>

So recently noticed that my logstash config is not reading in the last line from my log file. I think that it may be my input config fault though I do not see any problems with it right now. What else could it be? Here i…

---

## [Logstash sflow](https://discuss.elastic.co/t/logstash-sflow/50203)

<div class="topic-metadata">

**Author:** [@Karl\_Trasschaert](https://discuss.elastic.co/u/Karl_Trasschaert)\
**Replies:** 14\
**Last updated:** [February 6, 2017, 10:43pm UTC](https://discuss.elastic.co/t/logstash-sflow/50203 "2017-02-06T22:43:42Z")

</div>

Hi, I've read that it's possible to get sflow logs from switches to logstash. Can yo explain me how to do it ? I've followed that tutorial, but nothing appear in my logs: http://whiskeyalpharomeo.com/2015/06/13/logs…

---

## [Logstash not creating an index in elasticsearch](https://discuss.elastic.co/t/logstash-not-creating-an-index-in-elasticsearch/24231)

<div class="topic-metadata">

**Author:** [@PavanRGowda](https://discuss.elastic.co/u/PavanRGowda)\
**Replies:** 11\
**Last updated:** [October 19, 2016, 5:25am UTC](https://discuss.elastic.co/t/logstash-not-creating-an-index-in-elasticsearch/24231 "2016-10-19T05:25:47Z")

</div>

Below is my config file - input { file { path =\> "/home/pavan/Downloads/sample.csv" type =\> "Sample" start\_position =\> "beginning" } } filter { csv { columns =\> \['cda…

---

## [Run "---setup" netflow module when LS is a service (was Install netflow module error)](https://discuss.elastic.co/t/run-setup-netflow-module-when-ls-is-a-service-was-install-netflow-module-error/109166)

<div class="topic-metadata">

**Author:** [@tatdat](https://discuss.elastic.co/u/tatdat)\
**Replies:** 20\
**Last updated:** [December 13, 2017, 7:06am UTC](https://discuss.elastic.co/t/run-setup-netflow-module-when-ls-is-a-service-was-install-netflow-module-error/109166 "2017-12-13T07:06:13Z")

</div>

ENV: Cluster 6.0, LS 6.0, x-pack trial, Cent0s 7 When i run install module netflow i got error /usr/share/logstash/bin/logstash --path.settings=/etc/logstash --modules netflow --setup -M "netflow.var.kibana.host=http…

---

## [Replicas out of sync](https://discuss.elastic.co/t/replicas-out-of-sync/117128)

<div class="topic-metadata">

**Author:** [@edamtoft](https://discuss.elastic.co/u/edamtoft)\
**Replies:** 18\
**Last updated:** [January 31, 2018, 10:54am UTC](https://discuss.elastic.co/t/replicas-out-of-sync/117128 "2018-01-31T10:54:48Z")

</div>

For one particular index, I've been having issues with the primary and replicas repeatedly getting out of sync. \[image\] When updating this index, I make a delete by query request to delete all values with a particular …

---

## [Dealing with the plus sign (+) character in Indexing/Searching](https://discuss.elastic.co/t/dealing-with-the-plus-sign-character-in-indexing-searching/33278)

<div class="topic-metadata">

**Author:** [@bigterminal](https://discuss.elastic.co/u/bigterminal)\
**Replies:** 10\
**Last updated:** [November 18, 2015, 2:46pm UTC](https://discuss.elastic.co/t/dealing-with-the-plus-sign-character-in-indexing-searching/33278 "2015-11-18T14:46:12Z")

</div>

I'm trying to search text for "C++" and can't seem to get it to work. The other characters are treated properly as alphanum it seems but the + isn't working. Help is much appreciated. I have the following settings: set…

---

## [Kibana Server not ready yet](https://discuss.elastic.co/t/kibana-server-not-ready-yet/229685)

<div class="topic-metadata">

**Author:** [@aman97](https://discuss.elastic.co/u/aman97)\
**Replies:** 9\
**Last updated:** [April 27, 2020, 4:59pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet/229685 "2020-04-27T16:59:50Z")

</div>

Hi Everyone, I have installed kibana and elastic search on my VM, elasticsearch is running and accessible outside the VM but when I run kibana and try to access on the browser it showing kibana server not ready yet.but …

---

## [Timeout executing grok & Value too large to output](https://discuss.elastic.co/t/timeout-executing-grok-value-too-large-to-output/96400)

<div class="topic-metadata">

**Author:** [@Slop](https://discuss.elastic.co/u/Slop)\
**Replies:** 10\
**Last updated:** [August 10, 2017, 10:08am UTC](https://discuss.elastic.co/t/timeout-executing-grok-value-too-large-to-output/96400 "2017-08-10T10:08:31Z")

</div>

Hello, I've already read a lot about that problem but I really don't know what to do precisely. I'm using ELK 5.4.1 since a week now and after adding some grok filters, there is a tons of Timeout on my logstash-plain.…

---

## [No index pattern for logstash](https://discuss.elastic.co/t/no-index-pattern-for-logstash/262297)

<div class="topic-metadata">

**Author:** [@mof\_cmsmith](https://discuss.elastic.co/u/mof_cmsmith)\
**Replies:** 26\
**Last updated:** [February 1, 2021, 7:41pm UTC](https://discuss.elastic.co/t/no-index-pattern-for-logstash/262297 "2021-02-01T19:41:55Z")

</div>

I am struggling a bit with this. Windows 2019 running ELK 7.10.2. I have it ingesting filebeat, metricbeat, etc. Proper indices and patterns are present, except... Logstash has an index, so I know its ingesting. How…

---

## [java.io.IOException: Too many open files](https://discuss.elastic.co/t/java-io-ioexception-too-many-open-files/76080)

<div class="topic-metadata">

**Author:** [@Lior\_Abramov](https://discuss.elastic.co/u/Lior_Abramov)\
**Replies:** 11\
**Last updated:** [February 27, 2017, 11:38am UTC](https://discuss.elastic.co/t/java-io-ioexception-too-many-open-files/76080 "2017-02-27T11:38:47Z")

</div>

Hi all, I am using in elasticsearch and I am getting this error "java.io.IOException: Too many open files" I'm running the following command: sudo lsof | grep java | grep mpidcmgr | wc -l,the result increased after any …

---

## [Which web interface is used by Kibana, Logstash and Elasticsearch](https://discuss.elastic.co/t/which-web-interface-is-used-by-kibana-logstash-and-elasticsearch/30044)

<div class="topic-metadata">

**Author:** [@NiteshBarnwal](https://discuss.elastic.co/u/NiteshBarnwal)\
**Replies:** 12\
**Last updated:** [September 30, 2015, 1:47pm UTC](https://discuss.elastic.co/t/which-web-interface-is-used-by-kibana-logstash-and-elasticsearch/30044 "2015-09-30T13:47:17Z")

</div>

Hi, I have installed Kibana, logstash and elasticsearch in my linux server. Does kibana uses any web interface. How it works? I was searching in the document but didnt get that. Can anyone help ?

---

## [Kibana startup fails - Cannot find module 'source-map'](https://discuss.elastic.co/t/kibana-startup-fails-cannot-find-module-source-map/38501)

<div class="topic-metadata">

**Author:** [@danleong](https://discuss.elastic.co/u/danleong)\
**Replies:** 11\
**Last updated:** [July 12, 2016, 10:01pm UTC](https://discuss.elastic.co/t/kibana-startup-fails-cannot-find-module-source-map/38501 "2016-07-12T22:01:34Z")

</div>

Anyone else got this, and know a fix for it? $ ./bin/kibana plugin --install elastic/sense Installing sense Attempting to extract from https://download.elastic.co/elastic/sense/sense-latest.tar.gz Downloading 318236 by…

---

## [Kibana flapping between red and green](https://discuss.elastic.co/t/kibana-flapping-between-red-and-green/36328)

<div class="topic-metadata">

**Author:** [@mad\_min](https://discuss.elastic.co/u/mad_min)\
**Replies:** 9\
**Last updated:** [December 27, 2015, 5:43am UTC](https://discuss.elastic.co/t/kibana-flapping-between-red-and-green/36328 "2015-12-27T05:43:43Z")

</div>

Hi List, Running an ES2.1 cluster with 4 nodes and Kibana 4.3. I am constantly seeing this when Kibana starts up: log \[09:39:20.395\] \[error\]\[status\]\[plugin:elasticsearch\] Status changed from green to red - Reques…

---

## [Kibana running issue](https://discuss.elastic.co/t/kibana-running-issue/88312)

<div class="topic-metadata">

**Author:** [@Ximeng\_Zhao](https://discuss.elastic.co/u/Ximeng_Zhao)\
**Replies:** 10\
**Last updated:** [June 7, 2017, 3:52pm UTC](https://discuss.elastic.co/t/kibana-running-issue/88312 "2017-06-07T15:52:52Z")

</div>

Hello All, I installed elasticsearch 5-2-2 and kibana 5-2-2 on a single ec2 instance. I can run my elasticsearch without any issue. But when I tried to run kibana, it gives the following error. In my kibana.yml, I did …

---

## [Curl: (7) failed to connect](https://discuss.elastic.co/t/curl-7-failed-to-connect/120073)

<div class="topic-metadata">

**Author:** [@brownri](https://discuss.elastic.co/u/brownri)\
**Replies:** 17\
**Last updated:** [February 16, 2018, 10:48pm UTC](https://discuss.elastic.co/t/curl-7-failed-to-connect/120073 "2018-02-16T22:48:52Z")

</div>

Hello, I have an application that requires ElasticSearch as one of its components to work with the application. After successfully installing ElasticSearch, my application wants me to run the CURL -XGET command from an…

---

## [Terms Aggregation with include filter](https://discuss.elastic.co/t/terms-aggregation-with-include-filter/50976)

<div class="topic-metadata">

**Author:** [@ayushsangani](https://discuss.elastic.co/u/ayushsangani)\
**Replies:** 9\
**Last updated:** [September 22, 2017, 10:27am UTC](https://discuss.elastic.co/t/terms-aggregation-with-include-filter/50976 "2017-09-22T10:27:31Z")

</div>

Hey all, ES version: 2.3.2 (recently upgraded) I'm doing terms aggregations on not\_analyzed string field using include filter. https://www.elastic.co/guide/en/elasticsearch/reference/current/search-aggregations-bucke…

---

## [Logstash Pipeline for Microsoft SQL Server to Elasticsearch](https://discuss.elastic.co/t/logstash-pipeline-for-microsoft-sql-server-to-elasticsearch/212649)

<div class="topic-metadata">

**Author:** [@jporter](https://discuss.elastic.co/u/jporter)\
**Replies:** 9\
**Last updated:** [January 8, 2020, 8:01am UTC](https://discuss.elastic.co/t/logstash-pipeline-for-microsoft-sql-server-to-elasticsearch/212649 "2020-01-08T08:01:43Z")

</div>

I have a Microsoft SQL Server which I wish to ( contuously) push into Elasticsearch. In my base directory I have a docker-compose.yml file version: "3.7" services: backend: build: ./flask …

---

## [How to configure ELK (Elasticsearch, Logstash,Kibana) for different application log files and display each application separately in Kibana?](https://discuss.elastic.co/t/how-to-configure-elk-elasticsearch-logstash-kibana-for-different-application-log-files-and-display-each-application-separately-in-kibana/70411)

<div class="topic-metadata">

**Author:** [@sezanawa](https://discuss.elastic.co/u/sezanawa)\
**Replies:** 15\
**Last updated:** [January 6, 2017, 9:50am UTC](https://discuss.elastic.co/t/how-to-configure-elk-elasticsearch-logstash-kibana-for-different-application-log-files-and-display-each-application-separately-in-kibana/70411 "2017-01-06T09:50:25Z")

</div>

Hallo Everybody Since last 2 days i am busy with ELK. I have successfully installed Elasticsearch 5.1.1, Logstash 5.1.1 and Kibana 5.1.1 on my local windows VM and set up logstash configuration as it can parse IIS Log …

---

## [How to change the top left header logo in kibana 7.9.2](https://discuss.elastic.co/t/how-to-change-the-top-left-header-logo-in-kibana-7-9-2/250084)

<div class="topic-metadata">

**Author:** [@witcher](https://discuss.elastic.co/u/witcher)\
**Replies:** 59\
**Last updated:** [October 7, 2020, 9:37am UTC](https://discuss.elastic.co/t/how-to-change-the-top-left-header-logo-in-kibana-7-9-2/250084 "2020-10-07T09:37:57Z")

</div>

this is where the dark theme is located. kibana-7.9.2-windows-x86\_64\\node\_modules\\@kbn\\ui-shared-deps\\target and this is the theme file exactly from inspecting the element. http://localhost:5601/33984/bundles/kbn-ui-s…

---

## [Couldn't configure Elastic Retry or update the kibana.yml file manually](https://discuss.elastic.co/t/couldnt-configure-elastic-retry-or-update-the-kibana-yml-file-manually/338624)

<div class="topic-metadata">

**Author:** [@Aditya\_Bollam](https://discuss.elastic.co/u/Aditya_Bollam)\
**Replies:** 31\
**Last updated:** [July 20, 2023, 2:00pm UTC](https://discuss.elastic.co/t/couldnt-configure-elastic-retry-or-update-the-kibana-yml-file-manually/338624 "2023-07-20T14:00:09Z")

</div>

even after editing manually same problem is persisiting.

---

## [ClusterBlockException SERVICE\_UNAVAILABLE/1/state not recovered](https://discuss.elastic.co/t/clusterblockexception-service-unavailable-1-state-not-recovered/161521)

<div class="topic-metadata">

**Author:** [@Bukhtawar\_Khan](https://discuss.elastic.co/u/Bukhtawar_Khan)\
**Replies:** 16\
**Last updated:** [December 20, 2018, 7:59am UTC](https://discuss.elastic.co/t/clusterblockexception-service-unavailable-1-state-not-recovered/161521 "2018-12-20T07:59:11Z")

</div>

\[2018-12-19T05:10:26,684\]\[DEBUG\]\[o.e.a.a.i.c.TransportCreateIndexAction\] \[epcvLK5\] #\[org.elasticsearch.cluster.block.ClusterBlockException\]#timed out while retrying \[indices:admin/create\] after failure (timeout \[30s\]) …

[Previous page](https://discuss.elastic.co/top.md?page=21&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=23&per_page=50&period=all)
