# Top

**URL:** https://discuss.elastic.co/top.md?page=28&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 29

---

## [Using sql server queries in elasticsearch 5.6.3](https://discuss.elastic.co/t/using-sql-server-queries-in-elasticsearch-5-6-3/104027)

<div class="topic-metadata">

**Author:** [@parsa](https://discuss.elastic.co/u/parsa)\
**Replies:** 43\
**Last updated:** [December 13, 2017, 3:03pm UTC](https://discuss.elastic.co/t/using-sql-server-queries-in-elasticsearch-5-6-3/104027 "2017-12-13T15:03:23Z")

</div>

How can I use sql server queries in elastic search 5.6.3? I don't know anything about this process. Just I could install elastic search on windows successfully. please help for more details.

---

## [Reference UI - how to modify what's displayed (React newbie)](https://discuss.elastic.co/t/reference-ui-how-to-modify-whats-displayed-react-newbie/199471)

<div class="topic-metadata">

**Author:** [@Per\_Burstrom](https://discuss.elastic.co/u/Per_Burstrom)\
**Replies:** 13\
**Last updated:** [September 28, 2019, 5:50pm UTC](https://discuss.elastic.co/t/reference-ui-how-to-modify-whats-displayed-react-newbie/199471 "2019-09-28T17:50:00Z")

</div>

Hi, I'm currently evaluating Elastic App Search. I have written a script that inserts that data, and then I generated and downloaded the Reference UI React code to query the data from my site. It works great, but I woul…

---

## [Log File is not being created with logstash output config](https://discuss.elastic.co/t/log-file-is-not-being-created-with-logstash-output-config/140110)

<div class="topic-metadata">

**Author:** [@DGMurthy](https://discuss.elastic.co/u/DGMurthy)\
**Replies:** 23\
**Last updated:** [July 20, 2018, 6:01pm UTC](https://discuss.elastic.co/t/log-file-is-not-being-created-with-logstash-output-config/140110 "2018-07-20T18:01:59Z")

</div>

Hi All, I am trying to create a log file(txt) by configuring logstash output section with codec =\> json\_lines, logstash is running successful but file is not been created . Mean time i am not doing any filters, once i s…

---

## [Location to geo\_point mapping not working with logtash and kibana](https://discuss.elastic.co/t/location-to-geo-point-mapping-not-working-with-logtash-and-kibana/160980)

<div class="topic-metadata">

**Author:** [@pravinnair](https://discuss.elastic.co/u/pravinnair)\
**Replies:** 14\
**Last updated:** [December 19, 2018, 12:10pm UTC](https://discuss.elastic.co/t/location-to-geo-point-mapping-not-working-with-logtash-and-kibana/160980 "2018-12-19T12:10:06Z")

</div>

Hello, I am trying to plot a group of store locations on a map, i have zip and lat and long of the store. version being used is 6.4.2 I am covert the location feild to geo\_point using logstash output for elastic and s…

---

## [Installing Gem for Ruby Filter Plugin](https://discuss.elastic.co/t/installing-gem-for-ruby-filter-plugin/79994)

<div class="topic-metadata">

**Author:** [@uschtwill](https://discuss.elastic.co/u/uschtwill)\
**Replies:** 10\
**Last updated:** [April 10, 2017, 10:57am UTC](https://discuss.elastic.co/t/installing-gem-for-ruby-filter-plugin/79994 "2017-04-10T10:57:23Z")

</div>

Hello there, I am trying to install the jdbc-mysql gem in a dockerized Logstash (after I miserably failed to set Xcext.enabled=true and use the mysql2 gem). In the Dockerfile I am first running this RUN env GEM\_HOM…

---

## [Have couple questions about Logstash configuration](https://discuss.elastic.co/t/have-couple-questions-about-logstash-configuration/28794)

<div class="topic-metadata">

**Author:** [@AlekMarkus](https://discuss.elastic.co/u/AlekMarkus)\
**Replies:** 26\
**Last updated:** [September 15, 2015, 11:36am UTC](https://discuss.elastic.co/t/have-couple-questions-about-logstash-configuration/28794 "2015-09-15T11:36:21Z")

</div>

Hello , i have 1 main server that ElasticSearch+kibana+logstash installed on. and i want to monitor 2 apache servers and 1 firewall with this server, is it possible ? on each server i will install Logstash-Forward…

---

## [Reindexing indices between clusters](https://discuss.elastic.co/t/reindexing-indices-between-clusters/109316)

<div class="topic-metadata">

**Author:** [@Itay\_Bittan](https://discuss.elastic.co/u/Itay_Bittan)\
**Replies:** 31\
**Last updated:** [December 11, 2017, 8:09am UTC](https://discuss.elastic.co/t/reindexing-indices-between-clusters/109316 "2017-12-11T08:09:55Z")

</div>

Hi @Igor\_Motov, Following our thread (closed), We consider upgrading from 1.4.7 to Elasticsearch 6 in both clusters (the one how baked the index and the serving) for using the reindex feature. It is going to be very ch…

---

## [No data moving into elasticsearch](https://discuss.elastic.co/t/no-data-moving-into-elasticsearch/127651)

<div class="topic-metadata">

**Author:** [@jarnold](https://discuss.elastic.co/u/jarnold)\
**Replies:** 21\
**Last updated:** [April 18, 2018, 11:11am UTC](https://discuss.elastic.co/t/no-data-moving-into-elasticsearch/127651 "2018-04-18T11:11:20Z")

</div>

Hello all, it was suggested I post this on the filebeat page instead of the elasticsearch page. I've installed elastic stack (elasticsearch, kibana, logstash, filebeat) and everything appears to be configured correctly,…

---

## [Logstash not running](https://discuss.elastic.co/t/logstash-not-running/146925)

<div class="topic-metadata">

**Author:** [@rorobolla](https://discuss.elastic.co/u/rorobolla)\
**Replies:** 17\
**Last updated:** [September 15, 2018, 3:23pm UTC](https://discuss.elastic.co/t/logstash-not-running/146925 "2018-09-15T15:23:53Z")

</div>

I've been trying and trying to get logstash to run but it keeps coming up with the same error: ERROR: Pipelines YAML file is empty. Location: /Users/bollampally.r/Downloads/sre/logstash-6.4.0/config/pipelines.yml usage…

---

## [Kibana Stack monitoring page not showing data from metricbeats](https://discuss.elastic.co/t/kibana-stack-monitoring-page-not-showing-data-from-metricbeats/237167)

<div class="topic-metadata">

**Author:** [@souravsahoo](https://discuss.elastic.co/u/souravsahoo)\
**Replies:** 15\
**Last updated:** [July 31, 2020, 9:18pm UTC](https://discuss.elastic.co/t/kibana-stack-monitoring-page-not-showing-data-from-metricbeats/237167 "2020-07-31T21:18:12Z")

</div>

I have been trying to setup a separate monitoring cluster for collecting monitoring data from the production cluster. I have installed metricbeat on each of the production cluster's nodes and metricbeats is successfully …

---

## [Logstash eventlog filter](https://discuss.elastic.co/t/logstash-eventlog-filter/51316)

<div class="topic-metadata">

**Author:** [@babeesh](https://discuss.elastic.co/u/babeesh)\
**Replies:** 25\
**Last updated:** [June 13, 2016, 12:47pm UTC](https://discuss.elastic.co/t/logstash-eventlog-filter/51316 "2016-06-13T12:47:34Z")

</div>

I need to filter error messages from eventlog from logstash. logstash configuration input { tcp { port =\> 5045 type =\> 'eventlog' } } filter{ if \[type\] == 'eventlog' { if \[Severity\] == "ERROR" {…

---

## [Can we monitor IBM webSphere event logs using elasticsearch?](https://discuss.elastic.co/t/can-we-monitor-ibm-websphere-event-logs-using-elasticsearch/26543)

<div class="topic-metadata">

**Author:** [@Ashok](https://discuss.elastic.co/u/Ashok)\
**Replies:** 13\
**Last updated:** [July 31, 2015, 7:28am UTC](https://discuss.elastic.co/t/can-we-monitor-ibm-websphere-event-logs-using-elasticsearch/26543 "2015-07-31T07:28:35Z")

</div>

Hi, I want to monitor the near real time logs of IBM webSphere. How can we do with elasticsearch?

---

## [Snapshot create \[Index Shard Snapshot Failed \] :: Acess Denied](https://discuss.elastic.co/t/snapshot-create-index-shard-snapshot-failed-acess-denied/116969)

<div class="topic-metadata">

**Author:** [@hpandey](https://discuss.elastic.co/u/hpandey)\
**Replies:** 11\
**Last updated:** [January 29, 2018, 12:51pm UTC](https://discuss.elastic.co/t/snapshot-create-index-shard-snapshot-failed-acess-denied/116969 "2018-01-29T12:51:45Z")

</div>

Hi All Having issue while taking cluster snapshot . Env : suse 12 5 node cluster 3M + 2D elastic version : 5.5 Backup type : fs Error : "reason": "IndexShardSnapshotFailedException\[Failed to snapshot\]; ne…

---

## [Tribe Node Connect to specific IP's](https://discuss.elastic.co/t/tribe-node-connect-to-specific-ips/45721)

<div class="topic-metadata">

**Author:** [@KFletcher](https://discuss.elastic.co/u/KFletcher)\
**Replies:** 32\
**Last updated:** [August 26, 2016, 11:00am UTC](https://discuss.elastic.co/t/tribe-node-connect-to-specific-ips/45721 "2016-08-26T11:00:10Z")

</div>

I am trying to use a tribe node to connect to two separate clusters, both running ESv2.2. The clusters both have a default configuration. When I try to start the ES tribe using the below elasticsearch.yml, it doesn't st…

---

## [New data not showing in dashboard](https://discuss.elastic.co/t/new-data-not-showing-in-dashboard/48174)

<div class="topic-metadata">

**Author:** [@mc1392](https://discuss.elastic.co/u/mc1392)\
**Replies:** 10\
**Last updated:** [April 29, 2016, 3:42pm UTC](https://discuss.elastic.co/t/new-data-not-showing-in-dashboard/48174 "2016-04-29T15:42:15Z")

</div>

I have new data loading into an index. I can see the data under the discover tab. But I cannot see the data in my dashboard. Anyone ever experience this? Here is the discover tab: I am positive I am not seeing thi…

---

## [How to disable xpack check in Filebeat](https://discuss.elastic.co/t/how-to-disable-xpack-check-in-filebeat/145997)

<div class="topic-metadata">

**Author:** [@xiaowangwindow](https://discuss.elastic.co/u/xiaowangwindow)\
**Replies:** 12\
**Last updated:** [August 31, 2018, 3:37am UTC](https://discuss.elastic.co/t/how-to-disable-xpack-check-in-filebeat/145997 "2018-08-31T03:37:58Z")

</div>

hello, I am a newbie to use ES and Kibana in Amazon Elasticsearch Service, which do not support xpack plugin. I use Filebeat to send nginx log to ES directly. However, when run sudo filebeat setup -e, error happen like …

---

## [Filebeat - Elasticsearch output is not configured](https://discuss.elastic.co/t/filebeat-elasticsearch-output-is-not-configured/283637)

<div class="topic-metadata">

**Author:** [@X\_T](https://discuss.elastic.co/u/X_T)\
**Replies:** 14\
**Last updated:** [September 9, 2021, 9:31am UTC](https://discuss.elastic.co/t/filebeat-elasticsearch-output-is-not-configured/283637 "2021-09-09T09:31:10Z")

</div>

Hi team, i'm facing an issue when setting up Filebeat 6.5.0 (testing on this version for an upcoming upgrade) in a Windows machine. I know that Filebeat is not the best to use it on Windows but i am just sending logs in…

---

## [Using logstash for parsing logs](https://discuss.elastic.co/t/using-logstash-for-parsing-logs/24329)

<div class="topic-metadata">

**Author:** [@chinmoyd](https://discuss.elastic.co/u/chinmoyd)\
**Replies:** 20\
**Last updated:** [September 22, 2015, 5:33pm UTC](https://discuss.elastic.co/t/using-logstash-for-parsing-logs/24329 "2015-09-22T17:33:46Z")

</div>

Hello, I am new to ELK, I have installed Logstash, Elastic search and Kibana. My use case is as below: Logstash will read the application log, parse it and send to Elastic Search. Can you please suggest whether I need …

---

## [Verification failed for logstash-output-zabbix](https://discuss.elastic.co/t/verification-failed-for-logstash-output-zabbix/29383)

<div class="topic-metadata">

**Author:** [@sunilmchaudhari](https://discuss.elastic.co/u/sunilmchaudhari)\
**Replies:** 18\
**Last updated:** [February 13, 2017, 12:01pm UTC](https://discuss.elastic.co/t/verification-failed-for-logstash-output-zabbix/29383 "2017-02-13T12:01:19Z")

</div>

Hi, I am trying to install logstash-output-zabbix plugin with below command. $sudo ./plugin install logstash-output-zabbix But it shows below error. " Validating logstash-output-zabbix "Unable to download data …

---

## [How to filter the uppercase fields in Kibana](https://discuss.elastic.co/t/how-to-filter-the-uppercase-fields-in-kibana/233)

<div class="topic-metadata">

**Author:** [@rkhapre](https://discuss.elastic.co/u/rkhapre)\
**Replies:** 10\
**Last updated:** [August 20, 2015, 1:35pm UTC](https://discuss.elastic.co/t/how-to-filter-the-uppercase-fields-in-kibana/233 "2015-08-20T13:35:08Z")

</div>

In my Discovery View i have following columns First Name Last Name Email Phone Now in "First Name" fields i have some records with uppercase and some with lowercase. How can i filter records in Discovery page with 1.…

---

## [Elasticsearch cluster is not working](https://discuss.elastic.co/t/elasticsearch-cluster-is-not-working/156853)

<div class="topic-metadata">

**Author:** [@jatinseth2007](https://discuss.elastic.co/u/jatinseth2007)\
**Replies:** 11\
**Last updated:** [November 23, 2018, 4:18am UTC](https://discuss.elastic.co/t/elasticsearch-cluster-is-not-working/156853 "2018-11-23T04:18:55Z")

</div>

I am trying to run ES(6.4.3) cluster where I have 2 nodes and I want to make one node as master and data and other as only data. My both nodes are up and running but not able to communicate with each other to discover …

---

## [Elasticsearch 7.6.1 service won't start in Ubuntu server 18.04](https://discuss.elastic.co/t/elasticsearch-7-6-1-service-wont-start-in-ubuntu-server-18-04/222341)

<div class="topic-metadata">

**Author:** [@ManuelF](https://discuss.elastic.co/u/ManuelF)\
**Replies:** 21\
**Last updated:** [March 11, 2020, 2:32pm UTC](https://discuss.elastic.co/t/elasticsearch-7-6-1-service-wont-start-in-ubuntu-server-18-04/222341 "2020-03-11T14:32:31Z")

</div>

Hi, Fresh install Ubuntu server 18.04 and I am trying to use Elasticserach, Kibana, Logstash. I used command "apt-get install" so the system will detect/install all dependencies for the software. Also installed Java Ope…

---

## [Logstash with web interface](https://discuss.elastic.co/t/logstash-with-web-interface/69803)

<div class="topic-metadata">

**Author:** [@udaykirankona](https://discuss.elastic.co/u/udaykirankona)\
**Replies:** 10\
**Last updated:** [January 19, 2017, 9:28am UTC](https://discuss.elastic.co/t/logstash-with-web-interface/69803 "2017-01-19T09:28:45Z")

</div>

Hi, Is there any possibility of using logstash from web interface. Like, can we create/modify logstash configuration from front end application. My requirement is to create application to process "any logs/ any log…

---

## [Rate limiting between Filebeat and Logstash?](https://discuss.elastic.co/t/rate-limiting-between-filebeat-and-logstash/95377)

<div class="topic-metadata">

**Author:** [@DravenJohnson](https://discuss.elastic.co/u/DravenJohnson)\
**Replies:** 9\
**Last updated:** [August 17, 2017, 9:27pm UTC](https://discuss.elastic.co/t/rate-limiting-between-filebeat-and-logstash/95377 "2017-08-17T21:27:38Z")

</div>

If there any rate limiting between filebeat and logstash? or some kind of back pressure setting that between filebeat and logstash? We have ~2K server running filebeat and input logs to (12) logstash by using the beat …

---

## [In RHEL how to run Configuration file along with logstash?](https://discuss.elastic.co/t/in-rhel-how-to-run-configuration-file-along-with-logstash/121479)

<div class="topic-metadata">

**Author:** [@naveen\_K.N](https://discuss.elastic.co/u/naveen_K.N)\
**Replies:** 43\
**Last updated:** [March 20, 2018, 2:51pm UTC](https://discuss.elastic.co/t/in-rhel-how-to-run-configuration-file-along-with-logstash/121479 "2018-03-20T14:51:52Z")

</div>

Hi ELK team, i have successfully installed Logstash in RHEL. but what issue is we want to run Config file placed under config.d folder when we run "sudo initctl start logstash ". it is not reading those config files pl…

---

## [Kibana 6.0.0. RC2 - not creating an index pattern](https://discuss.elastic.co/t/kibana-6-0-0-rc2-not-creating-an-index-pattern/106999)

<div class="topic-metadata">

**Author:** [@Peter\_Steenbergen](https://discuss.elastic.co/u/Peter_Steenbergen)\
**Replies:** 29\
**Last updated:** [November 28, 2017, 6:58pm UTC](https://discuss.elastic.co/t/kibana-6-0-0-rc2-not-creating-an-index-pattern/106999 "2017-11-28T18:58:36Z")

</div>

Hi, I try to store the metricbeat-\* index pattern. It can see the fields after I filled that pattern and can choose the @timestamp field. After 1 second of loading, I can click on set as default (with the star). However…

---

## [Removing fields from logstash](https://discuss.elastic.co/t/removing-fields-from-logstash/341782)

<div class="topic-metadata">

**Author:** [@bharti](https://discuss.elastic.co/u/bharti)\
**Replies:** 66\
**Last updated:** [September 8, 2023, 11:06am UTC](https://discuss.elastic.co/t/removing-fields-from-logstash/341782 "2023-09-08T11:06:15Z")

</div>

input { file { path =\> "/var/log/abc.log" } beats { port =\> 5044 } } filter { mutate { remove\_field =\> \[ "agent.version.keyword" \] } }

---

## [Kibana: can't open kibana in my web browser](https://discuss.elastic.co/t/kibana-cant-open-kibana-in-my-web-browser/263893)

<div class="topic-metadata">

**Author:** [@Liora](https://discuss.elastic.co/u/Liora)\
**Replies:** 16\
**Last updated:** [February 14, 2021, 3:35pm UTC](https://discuss.elastic.co/t/kibana-cant-open-kibana-in-my-web-browser/263893 "2021-02-14T15:35:18Z")

</div>

Hi team, I am not able to open Kibana page in my web browser. Earlier i was able to open Kibana page in my browser. Later i have uninstalled my Ubuntu server on virtualbox and reinstalled again. Then i reinstalled elas…

---

## [Rsyslog to send logs to logstash](https://discuss.elastic.co/t/rsyslog-to-send-logs-to-logstash/264973)

<div class="topic-metadata">

**Author:** [@Prabhath\_samarasingh](https://discuss.elastic.co/u/Prabhath_samarasingh)\
**Replies:** 11\
**Last updated:** [February 22, 2021, 2:41pm UTC](https://discuss.elastic.co/t/rsyslog-to-send-logs-to-logstash/264973 "2021-02-22T14:41:57Z")

</div>

Hi, Configured rsyslog to send logs to logstash. But kibana dosen't receive. Please help. OS : Ubuntu 20.04 \</\> cat /etc/elasticsearch/elasticsearch.yml Elasticsearch performs poorly when the system is swapping t…

---

## [Document is not updated although the response is successful](https://discuss.elastic.co/t/document-is-not-updated-although-the-response-is-successful/56483)

<div class="topic-metadata">

**Author:** [@tpraizler](https://discuss.elastic.co/u/tpraizler)\
**Replies:** 9\
**Last updated:** [July 27, 2016, 2:35pm UTC](https://discuss.elastic.co/t/document-is-not-updated-although-the-response-is-successful/56483 "2016-07-27T14:35:46Z")

</div>

Hey, I am having a weird scenario, in which sometimes Elasticsearch claims to update a document successfully but it actually didn't do any thing. So this is my code: override def addTerms(id: String, terms: Set\[…

---

## [Init container fails](https://discuss.elastic.co/t/init-container-fails/193684)

<div class="topic-metadata">

**Author:** [@ransoor](https://discuss.elastic.co/u/ransoor)\
**Replies:** 14\
**Last updated:** [April 17, 2021, 10:30pm UTC](https://discuss.elastic.co/t/init-container-fails/193684 "2021-04-17T22:30:44Z")

</div>

I followed the quickstart guide version 0.9. I applied the elastic operator CRD. I deployed the elastic cluster with one node, but its status is Init:CrashLoopBackOff. After some debugging, I found that the init conta…

---

## [No connection could be made because the target machine actively refused filebeat](https://discuss.elastic.co/t/no-connection-could-be-made-because-the-target-machine-actively-refused-filebeat/93152)

<div class="topic-metadata">

**Author:** [@jogoinar10](https://discuss.elastic.co/u/jogoinar10)\
**Replies:** 14\
**Last updated:** [July 18, 2017, 6:20am UTC](https://discuss.elastic.co/t/no-connection-could-be-made-because-the-target-machine-actively-refused-filebeat/93152 "2017-07-18T06:20:10Z")

</div>

After starting file filebeat I encountered an error in the filebeat log file which is the "No connection could be made because the target machine actively refused it"

---

## [Exiting: Failed to start crawler: creating module reloader failed:](https://discuss.elastic.co/t/exiting-failed-to-start-crawler-creating-module-reloader-failed/321604)

<div class="topic-metadata">

**Author:** [@ant2ne](https://discuss.elastic.co/u/ant2ne)\
**Replies:** 9\
**Last updated:** [December 28, 2022, 4:37pm UTC](https://discuss.elastic.co/t/exiting-failed-to-start-crawler-creating-module-reloader-failed/321604 "2022-12-28T16:37:42Z")

</div>

using: https://www.elastic.co/guide/en/elastic-stack/current/installing-elastic-stack.html Versions on ubuntu 22.04. /usr/share/logstash/bin/logstash -V Using bundled JDK: /usr/share/logstash/jdk logstash 8.5.3 /usr…

---

## [Node not finding the master node](https://discuss.elastic.co/t/node-not-finding-the-master-node/103718)

<div class="topic-metadata">

**Author:** [@Maxclac](https://discuss.elastic.co/u/Maxclac)\
**Replies:** 16\
**Last updated:** [October 23, 2017, 7:22am UTC](https://discuss.elastic.co/t/node-not-finding-the-master-node/103718 "2017-10-23T07:22:10Z")

</div>

Hello everyone! I am using ES 5.6.2 and I created two nodes within a cluster. I simply want to have one master node and one slave node. Here are the configuration files for both of them: cluster.name: nomad-cluster…

---

## [Parse single line multi object json with logstash](https://discuss.elastic.co/t/parse-single-line-multi-object-json-with-logstash/207608)

<div class="topic-metadata">

**Author:** [@sili.redwork](https://discuss.elastic.co/u/sili.redwork)\
**Replies:** 12\
**Last updated:** [November 14, 2019, 11:59pm UTC](https://discuss.elastic.co/t/parse-single-line-multi-object-json-with-logstash/207608 "2019-11-14T23:59:44Z")

</div>

Hello, We are sending collecting cloudwatch logs to central log account's S3 bucket using Cloudwatch --\> Log Destination --\> Kinesis --\> S3 S3 file has multiple json objects in single line, below is the sample format {…

---

## [Topbeat and logstash error](https://discuss.elastic.co/t/topbeat-and-logstash-error/43213)

<div class="topic-metadata">

**Author:** [@gabe](https://discuss.elastic.co/u/gabe)\
**Replies:** 23\
**Last updated:** [March 7, 2016, 7:10am UTC](https://discuss.elastic.co/t/topbeat-and-logstash-error/43213 "2016-03-07T07:10:50Z")

</div>

HI There, First time using these products, working through the installation procedure and all was going well until the config file /etc/topbeat/topbeat.yml all looks good but getting a strange error about a key in line…

---

## [Logstash Keeps Restarting](https://discuss.elastic.co/t/logstash-keeps-restarting/111122)

<div class="topic-metadata">

**Author:** [@MultiplierMultiplier](https://discuss.elastic.co/u/MultiplierMultiplier)\
**Replies:** 9\
**Last updated:** [December 11, 2017, 5:07pm UTC](https://discuss.elastic.co/t/logstash-keeps-restarting/111122 "2017-12-11T17:07:01Z")

</div>

The only setting I have changed in the Logstash .yml is: log.level: debug. Logstash keeps restarting and there is absolutely nothing in the log file (/var/log/logstash/logstash-plaing.log) The only info I can find is …

---

## [Visualize Request Timeout after 30000ms](https://discuss.elastic.co/t/visualize-request-timeout-after-30000ms/93939)

<div class="topic-metadata">

**Author:** [@swatititame](https://discuss.elastic.co/u/swatititame)\
**Replies:** 14\
**Last updated:** [August 1, 2017, 6:31am UTC](https://discuss.elastic.co/t/visualize-request-timeout-after-30000ms/93939 "2017-08-01T06:31:32Z")

</div>

I am getting Visualize Request Timeout after 30000ms while loading dashboard in kibana.I increase requestTimeout. elasticsearch.requestTimeout: 200000 After this I am not getting error in kibana but my dashboard fails…

---

## [High disk watermark exceeded on one or more nodes, rerouting shards](https://discuss.elastic.co/t/high-disk-watermark-exceeded-on-one-or-more-nodes-rerouting-shards/38506)

<div class="topic-metadata">

**Author:** [@thyfere](https://discuss.elastic.co/u/thyfere)\
**Replies:** 16\
**Last updated:** [January 21, 2016, 8:41am UTC](https://discuss.elastic.co/t/high-disk-watermark-exceeded-on-one-or-more-nodes-rerouting-shards/38506 "2016-01-21T08:41:06Z")

</div>

I am running Elasticsearch, and Kibana on Windows and using Synology NAS as storage for Elasticsearch. For few days, Elasticsearch started behaving weird; therefore, I checked elasticsearch.log and found the following er…

---

## [Grok Patterns for Application logs](https://discuss.elastic.co/t/grok-patterns-for-application-logs/90386)

<div class="topic-metadata">

**Author:** [@Pandiyan\_M](https://discuss.elastic.co/u/Pandiyan_M)\
**Replies:** 15\
**Last updated:** [June 26, 2017, 9:17pm UTC](https://discuss.elastic.co/t/grok-patterns-for-application-logs/90386 "2017-06-26T21:17:14Z")

</div>

I am newbie to ELK and need to integrate my logs as below to elasticsearch from logstash. Can some help me by providing log patterrns for below log format Filelog 2017-06-05 00:03:03 INFO HeartBeatDetailsTimerTask:…

---

## [Auto authenticating to an embedded Kibana dashboard (on Elastic.co CLOUD)](https://discuss.elastic.co/t/auto-authenticating-to-an-embedded-kibana-dashboard-on-elastic-co-cloud/71248)

<div class="topic-metadata">

**Author:** [@Gabriele](https://discuss.elastic.co/u/Gabriele)\
**Replies:** 12\
**Last updated:** [January 18, 2017, 9:52am UTC](https://discuss.elastic.co/t/auto-authenticating-to-an-embedded-kibana-dashboard-on-elastic-co-cloud/71248 "2017-01-18T09:52:53Z")

</div>

I have ElasticSearch 5.1 on Elastic.co with a Kibana 5.1 dashboard that I'm embedding into a web app via iframe, protected by XPack authentication. Is there any way to programmatically provide the user/password so that …

---

## [Kibana 4 unattended configuration of default index pattern?](https://discuss.elastic.co/t/kibana-4-unattended-configuration-of-default-index-pattern/1737)

<div class="topic-metadata">

**Author:** [@mpavlov](https://discuss.elastic.co/u/mpavlov)\
**Replies:** 9\
**Last updated:** [March 1, 2016, 10:37am UTC](https://discuss.elastic.co/t/kibana-4-unattended-configuration-of-default-index-pattern/1737 "2016-03-01T10:37:00Z")

</div>

Today configuration is often managed by software (Chef, Ansible, etc.) with zero human interaction. Configuring Kibana4's required default index pattern on first install, however, seems to be intended to require human at…

---

## [Update single field of a document](https://discuss.elastic.co/t/update-single-field-of-a-document/5138)

<div class="topic-metadata">

**Author:** [@Ridvan\_Gyundogan](https://discuss.elastic.co/u/Ridvan_Gyundogan)\
**Replies:** 23\
**Last updated:** [June 15, 2014, 10:17am UTC](https://discuss.elastic.co/t/update-single-field-of-a-document/5138 "2014-06-15T10:17:39Z")

</div>

Is it possible to update a field of a document without sending the whole document again. I try something like the following but it just replaces the whole document with this ""price1 field only: #curl -XPUT 'http://l…

---

## [How to configure Elasticsearch with single node?](https://discuss.elastic.co/t/how-to-configure-elasticsearch-with-single-node/125394)

<div class="topic-metadata">

**Author:** [@daved](https://discuss.elastic.co/u/daved)\
**Replies:** 9\
**Last updated:** [March 27, 2018, 2:35pm UTC](https://discuss.elastic.co/t/how-to-configure-elasticsearch-with-single-node/125394 "2018-03-27T14:35:06Z")

</div>

Hi, So I keep having a problem where once I start doing stuff on Kibana elasticsearch crashes and goes Red. That's my real issue but I am wondering how elasticsearch should be configured using a single node as I haven't…

---

## [Deleted document count very high compared to the actual count of documents in the index](https://discuss.elastic.co/t/deleted-document-count-very-high-compared-to-the-actual-count-of-documents-in-the-index/224648)

<div class="topic-metadata">

**Author:** [@mohankumarb](https://discuss.elastic.co/u/mohankumarb)\
**Replies:** 13\
**Last updated:** [April 15, 2020, 4:21pm UTC](https://discuss.elastic.co/t/deleted-document-count-very-high-compared-to-the-actual-count-of-documents-in-the-index/224648 "2020-04-15T16:21:03Z")

</div>

ES version: 7.5 Number of shards: 5 Number of replicas: 4 We have a use case, where we have a lot of updates happening to the document (location updates). So every update is deleting and creating a new document in th…

---

## [We are getting logstash 5.4 error](https://discuss.elastic.co/t/we-are-getting-logstash-5-4-error/88360)

<div class="topic-metadata">

**Author:** [@bvnages](https://discuss.elastic.co/u/bvnages)\
**Replies:** 13\
**Last updated:** [June 16, 2017, 2:36pm UTC](https://discuss.elastic.co/t/we-are-getting-logstash-5-4-error/88360 "2017-06-16T14:36:55Z")

</div>

\[2017-06-06T06:43:36,425\]\[FATAL\]\[logstash.runner \] Logstash could not be started because there is already another instance using the configured data directory. If you wish to run multiple instances, you must ch…

---

## [Export and Import Index Patterns using elasticdump in ELK ver 7](https://discuss.elastic.co/t/export-and-import-index-patterns-using-elasticdump-in-elk-ver-7/267302)

<div class="topic-metadata">

**Author:** [@nguyenduyhung1979](https://discuss.elastic.co/u/nguyenduyhung1979)\
**Replies:** 13\
**Last updated:** [March 16, 2021, 3:16pm UTC](https://discuss.elastic.co/t/export-and-import-index-patterns-using-elasticdump-in-elk-ver-7/267302 "2021-03-16T15:16:26Z")

</div>

I try setup automation system which has the workflow: Have server where ELK stack has been installed and has basic configuration Import the index into ElasticSearch (ES), next Kibana can use that index for Visualize F…

---

## [Combining multiple documents based on ID](https://discuss.elastic.co/t/combining-multiple-documents-based-on-id/105534)

<div class="topic-metadata">

**Author:** [@qube](https://discuss.elastic.co/u/qube)\
**Replies:** 21\
**Last updated:** [November 6, 2017, 7:22am UTC](https://discuss.elastic.co/t/combining-multiple-documents-based-on-id/105534 "2017-11-06T07:22:34Z")

</div>

Hello logstash! I'm new to Elastic stack. We are transferring data from Sql Server to ElasticSearch using LogStash's jdbc plugin. So far, it's fine. Normally jdbc plugin creates a new document for each Sql Server row, …

---

## [Elasticsearch takes minutes to start](https://discuss.elastic.co/t/elasticsearch-takes-minutes-to-start/84284)

<div class="topic-metadata">

**Author:** [@Abid\_Hussain](https://discuss.elastic.co/u/Abid_Hussain)\
**Replies:** 14\
**Last updated:** [May 5, 2017, 10:21am UTC](https://discuss.elastic.co/t/elasticsearch-takes-minutes-to-start/84284 "2017-05-05T10:21:30Z")

</div>

Hi all, I downloaded elasticsearch 5.3.2 and changed some settings. There is no data indexed. Still it takes about 5 minutes until the first log message appears. Here are the settings I have changed in my config file…

---

## [LogLevel field in kibana](https://discuss.elastic.co/t/loglevel-field-in-kibana/164524)

<div class="topic-metadata">

**Author:** [@shiv94](https://discuss.elastic.co/u/shiv94)\
**Replies:** 11\
**Last updated:** [January 16, 2019, 8:32pm UTC](https://discuss.elastic.co/t/loglevel-field-in-kibana/164524 "2019-01-16T20:32:15Z")

</div>

Hello, I want to get the log level field in kibana for all the logs For example, 2019-01-16 13:54:55,833 INFO \[org.apache.cxf.wsdl.service.factory.ReflectionServiceFactoryBean\] (default task-29) Creating Service {htt…

[Previous page](https://discuss.elastic.co/top.md?page=27&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=29&per_page=50&period=all)
