# Top

**URL:** https://discuss.elastic.co/top.md?page=32&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 33

---

## [Nested Json with ruby filter](https://discuss.elastic.co/t/nested-json-with-ruby-filter/128193)

<div class="topic-metadata">

**Author:** [@chrigui94](https://discuss.elastic.co/u/chrigui94)\
**Replies:** 11\
**Last updated:** [April 17, 2018, 12:57pm UTC](https://discuss.elastic.co/t/nested-json-with-ruby-filter/128193 "2018-04-17T12:57:15Z")

</div>

I want to index this JSON file : {"environment":"urban","envType":"outdoor","positionNumber":1,"frameIndex":15,"fcntUp":22324,"numberOfGateways":3,"numberOfTimestamps":0,"serverTimestamp":"23:44:36","lnsAppEui":"4883C7D…

---

## [Memory and CPU on one graph or gauge](https://discuss.elastic.co/t/memory-and-cpu-on-one-graph-or-gauge/174039)

<div class="topic-metadata">

**Author:** [@syedsfayaz](https://discuss.elastic.co/u/syedsfayaz)\
**Replies:** 11\
**Last updated:** [March 27, 2019, 10:01pm UTC](https://discuss.elastic.co/t/memory-and-cpu-on-one-graph-or-gauge/174039 "2019-03-27T22:01:43Z")

</div>

Hi I am trying to create a custom dashboard for monitoring system metrics using metric beat. I want to show both memory and cpu usage on one graph or gauge. Can you please tell me possible solution.

---

## [\[warning\]\[savedobjects-service\] Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms](https://discuss.elastic.co/t/warning-savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/240083)

<div class="topic-metadata">

**Author:** [@Splunk](https://discuss.elastic.co/u/Splunk)\
**Replies:** 12\
**Last updated:** [July 7, 2020, 11:09pm UTC](https://discuss.elastic.co/t/warning-savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/240083 "2020-07-07T23:09:27Z")

</div>

I have no idea what is the cause. anyone help me with this. kibana installation \[warning\]\[savedobjects-service\] Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms

---

## [Making custom ES queries form a Kibana plugin](https://discuss.elastic.co/t/making-custom-es-queries-form-a-kibana-plugin/40456)

<div class="topic-metadata">

**Author:** [@timroes](https://discuss.elastic.co/u/timroes)\
**Replies:** 11\
**Last updated:** [January 18, 2017, 8:14am UTC](https://discuss.elastic.co/t/making-custom-es-queries-form-a-kibana-plugin/40456 "2017-01-18T08:14:49Z")

</div>

When writing a Kibana plugin (especially a visualization) you sometimes need to make custom ES queries, i.e. queries, that do not use the aggregations, that you can define via Schemas in your visualization definition. Yo…

---

## [Cannot start File beat in windows](https://discuss.elastic.co/t/cannot-start-file-beat-in-windows/71143)

<div class="topic-metadata">

**Author:** [@Dharma\_Teja\_Koneru](https://discuss.elastic.co/u/Dharma_Teja_Koneru)\
**Replies:** 12\
**Last updated:** [January 22, 2017, 11:41am UTC](https://discuss.elastic.co/t/cannot-start-file-beat-in-windows/71143 "2017-01-22T11:41:25Z")

</div>

Hi, I'm trying to configure filebeat in windows 2012 R2 to send logs to a ubuntu server where the logstash and kibana are configured. when i try to start filebeat in windows i get the error: ERROR 1053: The service did …

---

## [Seeing Grok regexp exception "incompatible encoding regexp match (UTF-8 regexp with ASCII-8BIT string)"](https://discuss.elastic.co/t/seeing-grok-regexp-exception-incompatible-encoding-regexp-match-utf-8-regexp-with-ascii-8bit-string/120084)

<div class="topic-metadata">

**Author:** [@cb2015](https://discuss.elastic.co/u/cb2015)\
**Replies:** 10\
**Last updated:** [April 17, 2018, 9:07am UTC](https://discuss.elastic.co/t/seeing-grok-regexp-exception-incompatible-encoding-regexp-match-utf-8-regexp-with-ascii-8bit-string/120084 "2018-04-17T09:07:11Z")

</div>

Hi everyone, I am seeing this error in my logstash logs \[2018-02-15T10:00:48,009\]\[WARN \]\[logstash.filters.grok \] Grok regexp threw exception {:exception=\>"incompatible encoding regexp match (UTF-8 regexp with ASCII-…

---

## [CouchDB plugin set dynamic type for Elasticsearch](https://discuss.elastic.co/t/couchdb-plugin-set-dynamic-type-for-elasticsearch/2293)

<div class="topic-metadata">

**Author:** [@JuHwon](https://discuss.elastic.co/u/JuHwon)\
**Replies:** 21\
**Last updated:** [November 23, 2015, 3:34pm UTC](https://discuss.elastic.co/t/couchdb-plugin-set-dynamic-type-for-elasticsearch/2293 "2015-11-23T15:34:15Z")

</div>

Hello I try to set up couchdb with logstash and elasticsearch. I already managed to get the couchdb. My documents in the couchDB do have a type attribute and i want this type to be the index type in my elasticsearch. …

---

## [Grok parser not working as expected with GREEDYDATA](https://discuss.elastic.co/t/grok-parser-not-working-as-expected-with-greedydata/125849)

<div class="topic-metadata">

**Author:** [@sachinvy](https://discuss.elastic.co/u/sachinvy)\
**Replies:** 12\
**Last updated:** [March 29, 2018, 7:31pm UTC](https://discuss.elastic.co/t/grok-parser-not-working-as-expected-with-greedydata/125849 "2018-03-29T19:31:20Z")

</div>

Here is an example: Data in file: 03-27-18 09:32:10,563 \[1452\] DEBUG AdvancedProperties - No value in: HKEY\_LOCAL\_MACHINE\\SOFTWARE\\GlobalSCAPE Inc.\\EFT Server 7.0\\ReplaceBackslashWithSlashInPathsForFTP, using default: …

---

## [Search finds 42 hits, yet hits object empty](https://discuss.elastic.co/t/search-finds-42-hits-yet-hits-object-empty/4396)

<div class="topic-metadata">

**Author:** [@searchersteve](https://discuss.elastic.co/u/searchersteve)\
**Replies:** 10\
**Last updated:** [July 11, 2011, 5:04pm UTC](https://discuss.elastic.co/t/search-finds-42-hits-yet-hits-object-empty/4396 "2011-07-11T17:04:00Z")

</div>

I've suddenly gotten an inexplicable search result: {"took":36,"\_shards":{"total":15,"successful":15,"failed":0},"hits":{"total":42,"max\_score":4.101285,"hits":\[\]}} How can this be? I've never encountered this …

---

## [Are bulk index operations serialized?](https://discuss.elastic.co/t/are-bulk-index-operations-serialized/83770)

<div class="topic-metadata">

**Author:** [@\_markus](https://discuss.elastic.co/u/_markus)\
**Replies:** 9\
**Last updated:** [May 1, 2017, 1:11pm UTC](https://discuss.elastic.co/t/are-bulk-index-operations-serialized/83770 "2017-05-01T13:11:56Z")

</div>

I'm tracking a synchronization problem at work and wondering if the following is possible. I'm using 5.3.0 . Assume that I've two bulk requests, both containing a) exactly one and b) the same document (type/id) but di…

---

## [Using logstash-output-email plugin](https://discuss.elastic.co/t/using-logstash-output-email-plugin/75074)

<div class="topic-metadata">

**Author:** [@vdsm](https://discuss.elastic.co/u/vdsm)\
**Replies:** 16\
**Last updated:** [February 20, 2017, 8:38am UTC](https://discuss.elastic.co/t/using-logstash-output-email-plugin/75074 "2017-02-20T08:38:45Z")

</div>

Hi everyone, Before all, sorry for my English, it's not my native language. I try to configure Logstash for sending mail when some specific events coming with the logstash-output-email plugin. I'm using SMTPS mail ser…

---

## [Speeding up indexing in ES 2.2.0](https://discuss.elastic.co/t/speeding-up-indexing-in-es-2-2-0/45620)

<div class="topic-metadata">

**Author:** [@mkelkar](https://discuss.elastic.co/u/mkelkar)\
**Replies:** 17\
**Last updated:** [May 4, 2016, 5:47pm UTC](https://discuss.elastic.co/t/speeding-up-indexing-in-es-2-2-0/45620 "2016-05-04T17:47:11Z")

</div>

Hi All, I am trying to test performance of service with ES 2.2.0 and I am seeing slowness in rate of indexing. We use SSDs for all of our data nodes. What I am seeing is that if I test with the same setup with ES 1…

---

## [Logstash not sending syslog to elasticsearch](https://discuss.elastic.co/t/logstash-not-sending-syslog-to-elasticsearch/289020)

<div class="topic-metadata">

**Author:** [@MKirby](https://discuss.elastic.co/u/MKirby)\
**Replies:** 41\
**Last updated:** [November 19, 2021, 3:36pm UTC](https://discuss.elastic.co/t/logstash-not-sending-syslog-to-elasticsearch/289020 "2021-11-19T15:36:16Z")

</div>

Hello Elastic team. I have been asking tons of questions and have been slowly making my way through the final part of my ELK SIEM installation. I am running a small environment with Elasticsearch, Logstash and Kibana i…

---

## [Metricbeat kafka module - consumergroup metric set does not report metrics](https://discuss.elastic.co/t/metricbeat-kafka-module-consumergroup-metric-set-does-not-report-metrics/83623)

<div class="topic-metadata">

**Author:** [@Rahul\_Joshi](https://discuss.elastic.co/u/Rahul_Joshi)\
**Replies:** 24\
**Last updated:** [May 11, 2017, 10:24am UTC](https://discuss.elastic.co/t/metricbeat-kafka-module-consumergroup-metric-set-does-not-report-metrics/83623 "2017-05-11T10:24:32Z")

</div>

We are are using metricbeats with the kafka module turned on. The kafka module is configured to send both partition and consumergroup metric sets to elastic search. We see that metricbeats is sending the partition metric…

---

## [HELP ! Upgrade ES 6.7.0 to 7.1.0](https://discuss.elastic.co/t/help-upgrade-es-6-7-0-to-7-1-0/185317)

<div class="topic-metadata">

**Author:** [@skyluke.1987](https://discuss.elastic.co/u/skyluke.1987)\
**Replies:** 30\
**Last updated:** [June 19, 2019, 9:11am UTC](https://discuss.elastic.co/t/help-upgrade-es-6-7-0-to-7-1-0/185317 "2019-06-19T09:11:41Z")

</div>

Hi all, I need some help on the upgrading. Following the guide from here: https://www.elastic.co/blog/getting-started-with-elasticsearch-security. I downloaded the installation files and configured. When about to start…

---

## [Configuring Heap Size in CentOS](https://discuss.elastic.co/t/configuring-heap-size-in-centos/110432)

<div class="topic-metadata">

**Author:** [@motts](https://discuss.elastic.co/u/motts)\
**Replies:** 16\
**Last updated:** [December 15, 2017, 1:24am UTC](https://discuss.elastic.co/t/configuring-heap-size-in-centos/110432 "2017-12-15T01:24:08Z")

</div>

I am new to ELK and I am trying to figure out this heap problem I am having. I am trying to search the site here, but I get multiple results on how to set heap and on what parts of ELK need the heap size adjusted. I am …

---

## [Trying to use filebeat postgresql conf.d to push logs to kibana](https://discuss.elastic.co/t/trying-to-use-filebeat-postgresql-conf-d-to-push-logs-to-kibana/240550)

<div class="topic-metadata">

**Author:** [@Andrew\_Freitas](https://discuss.elastic.co/u/Andrew_Freitas)\
**Replies:** 10\
**Last updated:** [July 17, 2020, 8:50am UTC](https://discuss.elastic.co/t/trying-to-use-filebeat-postgresql-conf-d-to-push-logs-to-kibana/240550 "2020-07-17T08:50:49Z")

</div>

Hey guys, I'm trying to configure filebeat output to logstash, the full pipeline is as follows: filebeat \> redis cache \> logstash \> elastic \> kibana Below is a screenshot of what I get in kibana About two logs com…

---

## [Failed to send join request to master due to same id](https://discuss.elastic.co/t/failed-to-send-join-request-to-master-due-to-same-id/76908)

<div class="topic-metadata">

**Author:** [@Leo\_Li](https://discuss.elastic.co/u/Leo_Li)\
**Replies:** 11\
**Last updated:** [March 2, 2017, 11:05pm UTC](https://discuss.elastic.co/t/failed-to-send-join-request-to-master-due-to-same-id/76908 "2017-03-02T23:05:08Z")

</div>

I use template created two elasticsearch instances on two aws ec2 instance with the same docker container (5.2) and data folder. However the elasticsearch instances failed to join a cluster and the error message is: fa…

---

## [Simple Scripted Field Not Working](https://discuss.elastic.co/t/simple-scripted-field-not-working/186919)

<div class="topic-metadata">

**Author:** [@RayS](https://discuss.elastic.co/u/RayS)\
**Replies:** 9\
**Last updated:** [July 15, 2019, 7:57pm UTC](https://discuss.elastic.co/t/simple-scripted-field-not-working/186919 "2019-07-15T19:57:58Z")

</div>

This is probably silly but here goes. I'm running heartbeat which pings a series of IP address. It hands back the rtt.us with a value of 10,000 and I want to converted a field from say 10,000 to 0.01. I was going to d…

---

## [Index.priority setting not working for replicas](https://discuss.elastic.co/t/index-priority-setting-not-working-for-replicas/178048)

<div class="topic-metadata">

**Author:** [@Andy\_Wick](https://discuss.elastic.co/u/Andy_Wick)\
**Replies:** 16\
**Last updated:** [April 25, 2019, 11:35am UTC](https://discuss.elastic.co/t/index-priority-setting-not-working-for-replicas/178048 "2019-04-25T11:35:41Z")

</div>

Using 6.7.0 and when my cluster recovers, replicas with NO index.priority setting are recovered before replicas with an index.priority set. Is this a known issue? Should I just set a priority on all indices? This is …

---

## [About the kibana.yml configuration file](https://discuss.elastic.co/t/about-the-kibana-yml-configuration-file/143785)

<div class="topic-metadata">

**Author:** [@xionghaizi](https://discuss.elastic.co/u/xionghaizi)\
**Replies:** 13\
**Last updated:** [August 22, 2018, 7:19am UTC](https://discuss.elastic.co/t/about-the-kibana-yml-configuration-file/143785 "2018-08-22T07:19:32Z")

</div>

Can you give me information about the kibana.yml configuration file?I don't know what's wrong with me,thank you

---

## [Kubernetes data collection error with metricbeat!](https://discuss.elastic.co/t/kubernetes-data-collection-error-with-metricbeat/143511)

<div class="topic-metadata">

**Author:** [@b22565875b81d856c5b0](https://discuss.elastic.co/u/b22565875b81d856c5b0)\
**Replies:** 21\
**Last updated:** [August 15, 2018, 10:45am UTC](https://discuss.elastic.co/t/kubernetes-data-collection-error-with-metricbeat/143511 "2018-08-15T10:45:33Z")

</div>

Hello all! I am trying to get kubernetes describing data (kubernetes.) via metricbeat. For installation i used metricbeat-kubernetes.yaml template. I have installed locally single-node kubernetes via docker, and many-no…

---

## [Is snapshot restore incremental？](https://discuss.elastic.co/t/is-snapshot-restore-incremental/298474)

<div class="topic-metadata">

**Author:** [@casterQ](https://discuss.elastic.co/u/casterQ)\
**Replies:** 14\
**Last updated:** [March 2, 2022, 7:17am UTC](https://discuss.elastic.co/t/is-snapshot-restore-incremental/298474 "2022-03-02T07:17:50Z")

</div>

As we know, the snapshot process is incremental, so we can take snapshots frequently and It will be very fast after the first time。 My question is how restore work, When I restore snapshots in other clusters, is it incr…

---

## [Kibana hits are different](https://discuss.elastic.co/t/kibana-hits-are-different/103033)

<div class="topic-metadata">

**Author:** [@sudi\_2611](https://discuss.elastic.co/u/sudi_2611)\
**Replies:** 18\
**Last updated:** [October 25, 2017, 2:22pm UTC](https://discuss.elastic.co/t/kibana-hits-are-different/103033 "2017-10-25T14:22:20Z")

</div>

Hi Team, Thanks a lot for all the advice and help its been a wonderful forum to ask and learn stuffs. The issue is that the hit counts in discovery tab are varying when compared to the actual data because of which i a…

---

## [Падает Эластик 5.2.1, те же запросы Elastiс 2.4.1 отрабатывает влёт](https://discuss.elastic.co/t/5-2-1-elasti-2-4-1/75357)

<div class="topic-metadata">

**Author:** [@Vladimir\_Dyakov](https://discuss.elastic.co/u/Vladimir_Dyakov)\
**Replies:** 30\
**Last updated:** [April 14, 2017, 6:34am UTC](https://discuss.elastic.co/t/5-2-1-elasti-2-4-1/75357 "2017-04-14T06:34:30Z")

</div>

Всех приветствую! Есть 2 параллельно работающих кластера - старый, работающий на версии 2.4.1 и новый на 5.2.1 (ставил 5.0, 5.1, 5.2 версии). Данные на них записываются одинаково, через два output в logstash. Проблема …

---

## [Index parent child relation using Logstash (one to many) Configuration issue](https://discuss.elastic.co/t/index-parent-child-relation-using-logstash-one-to-many-configuration-issue/93517)

<div class="topic-metadata">

**Author:** [@malhotras](https://discuss.elastic.co/u/malhotras)\
**Replies:** 13\
**Last updated:** [August 18, 2017, 7:43am UTC](https://discuss.elastic.co/t/index-parent-child-relation-using-logstash-one-to-many-configuration-issue/93517 "2017-08-18T07:43:51Z")

</div>

I am using parent-child relation between 2 entities. They are fetched from the database where they come from 2 different tables. I use the SQL join statement for them in logstash config file. Details of the config file: …

---

## [Logstash stops running after running for few seconds](https://discuss.elastic.co/t/logstash-stops-running-after-running-for-few-seconds/95765)

<div class="topic-metadata">

**Author:** [@shroh](https://discuss.elastic.co/u/shroh)\
**Replies:** 13\
**Last updated:** [August 9, 2017, 11:06am UTC](https://discuss.elastic.co/t/logstash-stops-running-after-running-for-few-seconds/95765 "2017-08-09T11:06:16Z")

</div>

Hi, My logstash stops running after 4 seconds of starting it, i get this output for systemctl status logstash -l logstash.service - logstash Loaded: loaded (/etc/systemd/system/logstash.service; disabled; vendor prese…

---

## [Logstash : Parsing fails while parsing Json data received through web service like twitter / facebook etc](https://discuss.elastic.co/t/logstash-parsing-fails-while-parsing-json-data-received-through-web-service-like-twitter-facebook-etc/56918)

<div class="topic-metadata">

**Author:** [@Prashant\_Agrawal](https://discuss.elastic.co/u/Prashant_Agrawal)\
**Replies:** 10\
**Last updated:** [August 2, 2016, 11:03am UTC](https://discuss.elastic.co/t/logstash-parsing-fails-while-parsing-json-data-received-through-web-service-like-twitter-facebook-etc/56918 "2016-08-02T11:03:48Z")

</div>

I am receiving the Web service data say from Twitter and logging to file and there after I need to send that data to Logstash so as same can be indexed to Elasticsearch. I am using below config and that is giving jsonpa…

---

## [Module system doesn't exists! when trying to enable system module](https://discuss.elastic.co/t/module-system-doesnt-exists-when-trying-to-enable-system-module/129744)

<div class="topic-metadata">

**Author:** [@Josh\_McDonald](https://discuss.elastic.co/u/Josh_McDonald)\
**Replies:** 10\
**Last updated:** [April 29, 2018, 10:50pm UTC](https://discuss.elastic.co/t/module-system-doesnt-exists-when-trying-to-enable-system-module/129744 "2018-04-29T22:50:35Z")

</div>

I'm trying to get system logs from an Ubuntu VM running the latest version of filebeats (installed via apt-get). When I run sudo ./filebeat modules enable system, I get an error "Module system doesn't exists!". If I run…

---

## [From JSON to Java API and back](https://discuss.elastic.co/t/from-json-to-java-api-and-back/4064)

<div class="topic-metadata">

**Author:** [@paranoiabla](https://discuss.elastic.co/u/paranoiabla)\
**Replies:** 13\
**Last updated:** [March 11, 2011, 12:58pm UTC](https://discuss.elastic.co/t/from-json-to-java-api-and-back/4064 "2011-03-11T12:58:00Z")

</div>

Hi there, Im using the Java API and I want to know what is the best way to convert the SearchResponse object into JSON format. Also If Im using the JSON API and I receive back a JSON response, is there a way to con…

---

## [Fields disappear after refreshing on visualization pages](https://discuss.elastic.co/t/fields-disappear-after-refreshing-on-visualization-pages/86171)

<div class="topic-metadata">

**Author:** [@Singard123](https://discuss.elastic.co/u/Singard123)\
**Replies:** 22\
**Last updated:** [May 26, 2017, 5:07pm UTC](https://discuss.elastic.co/t/fields-disappear-after-refreshing-on-visualization-pages/86171 "2017-05-26T17:07:11Z")

</div>

Kibana version: 4.5.4 Running on logit.io We created a few visualizations based on certain fields. However, after refreshing the page, it reports the following There is a problem with that saved object A field assoc…

---

## [Unassigned Shards, what to do about it](https://discuss.elastic.co/t/unassigned-shards-what-to-do-about-it/192892)

<div class="topic-metadata">

**Author:** [@Moritz\_Kiesewetter](https://discuss.elastic.co/u/Moritz_Kiesewetter)\
**Replies:** 12\
**Last updated:** [July 31, 2019, 11:22am UTC](https://discuss.elastic.co/t/unassigned-shards-what-to-do-about-it/192892 "2019-07-31T11:22:58Z")

</div>

Hello Guys, first off, our Cluster: Master (Kibana) -8GB -Appache Web Server -Does not filter/query Workernode#01/#02 -32GB Ram each -No Kibana Soo my cluster is running about fine, there's just this thing that …

---

## [Parsing the date and sending to ElasticSearch](https://discuss.elastic.co/t/parsing-the-date-and-sending-to-elasticsearch/83883)

<div class="topic-metadata">

**Author:** [@Vedran\_Maricevic](https://discuss.elastic.co/u/Vedran_Maricevic)\
**Replies:** 12\
**Last updated:** [April 28, 2017, 11:06am UTC](https://discuss.elastic.co/t/parsing-the-date-and-sending-to-elasticsearch/83883 "2017-04-28T11:06:22Z")

</div>

Hello everyone, Great to be here :slight\_smile: For hours am trying to parse a file from filebeat and send it to ES. It works, but the date field that is created in ES is set to string, instead of date. I am using (Ma…

---

## [Upgrading cluster 5.2: Out of memory: Kill process](https://discuss.elastic.co/t/upgrading-cluster-5-2-out-of-memory-kill-process/73752)

<div class="topic-metadata">

**Author:** [@maziyar](https://discuss.elastic.co/u/maziyar)\
**Replies:** 9\
**Last updated:** [March 15, 2017, 5:26pm UTC](https://discuss.elastic.co/t/upgrading-cluster-5-2-out-of-memory-kill-process/73752 "2017-03-15T17:26:06Z")

</div>

Hi, I just upgraded my cluster to 5.2 and in the process of moving some shards after restart one of the nodes just dies without any logs. The only thing I could find was this in syslog: Feb 2 20:53:34 es-replicashard…

---

## [Watcher for Reporting shows an SSL Exception in the output](https://discuss.elastic.co/t/watcher-for-reporting-shows-an-ssl-exception-in-the-output/138048)

<div class="topic-metadata">

**Author:** [@swathi](https://discuss.elastic.co/u/swathi)\
**Replies:** 18\
**Last updated:** [August 13, 2018, 5:57pm UTC](https://discuss.elastic.co/t/watcher-for-reporting-shows-an-ssl-exception-in-the-output/138048 "2018-08-13T17:57:16Z")

</div>

Hello, I am trying to create a watcher which generates daily/weekly reports of a dashboard and send that via emails. When the watcher is getting executed, it shows an SSL exception in the output (shown in the picture) …

---

## [TLS Certificate Issue on Elastic cluster](https://discuss.elastic.co/t/tls-certificate-issue-on-elastic-cluster/183303)

<div class="topic-metadata">

**Author:** [@vivektsb](https://discuss.elastic.co/u/vivektsb)\
**Replies:** 12\
**Last updated:** [June 3, 2019, 12:30pm UTC](https://discuss.elastic.co/t/tls-certificate-issue-on-elastic-cluster/183303 "2019-06-03T12:30:43Z")

</div>

Hi, We are trying to form two node ELK 6.8.0 cluster using procedure mentioned in the following link. https://www.elastic.co/guide/en/elasticsearch/reference/6.8/configuring-tls.html#node-certificates Generated certi…

---

## [High CPU usage while bulk indexing](https://discuss.elastic.co/t/high-cpu-usage-while-bulk-indexing/135023)

<div class="topic-metadata">

**Author:** [@motherhubbard](https://discuss.elastic.co/u/motherhubbard)\
**Replies:** 12\
**Last updated:** [August 23, 2018, 7:27pm UTC](https://discuss.elastic.co/t/high-cpu-usage-while-bulk-indexing/135023 "2018-08-23T19:27:36Z")

</div>

We have a 9 box setup (details provided in the Environment section further down). We have a job that uses the bulk write interface to write 100 documents at a time to Elastic. Each document may be up to 1MB in size but …

---

## [Changing time zone format](https://discuss.elastic.co/t/changing-time-zone-format/71775)

<div class="topic-metadata">

**Author:** [@Dan](https://discuss.elastic.co/u/Dan)\
**Replies:** 19\
**Last updated:** [January 20, 2017, 11:52am UTC](https://discuss.elastic.co/t/changing-time-zone-format/71775 "2017-01-20T11:52:02Z")

</div>

i am using jdbc as input and http as output. from jdbc i am getting date as "2017-01-02T12:35:44.000Z" but in my http output date will be accept as "2017-01-02T12:35:44.000+07:00" when i am checking inn database the…

---

## [Installed and configured ElasticSearch (Multi Node) Cluster on CentOS](https://discuss.elastic.co/t/installed-and-configured-elasticsearch-multi-node-cluster-on-centos/33410)

<div class="topic-metadata">

**Author:** [@ananthanaidu](https://discuss.elastic.co/u/ananthanaidu)\
**Replies:** 24\
**Last updated:** [November 10, 2015, 6:45am UTC](https://discuss.elastic.co/t/installed-and-configured-elasticsearch-multi-node-cluster-on-centos/33410 "2015-11-10T06:45:16Z")

</div>

Hello Greetings, I have two queries here, Query1: I have installed ELK with two nodes (node1,node2) and configured in elasticsearch.yml with the same cluster name on both nodes and host name as node1 and node2 re…

---

## [Exiting java.lang.OutOfMemoryError: Java heap space](https://discuss.elastic.co/t/exiting-java-lang-outofmemoryerror-java-heap-space/166926)

<div class="topic-metadata">

**Author:** [@53dd57e6c0d57177c379](https://discuss.elastic.co/u/53dd57e6c0d57177c379)\
**Replies:** 9\
**Last updated:** [February 4, 2019, 6:15pm UTC](https://discuss.elastic.co/t/exiting-java-lang-outofmemoryerror-java-heap-space/166926 "2019-02-04T18:15:29Z")

</div>

\[2019-02-04T12:33:54,521\]\[ERROR\]\[o.e.b.ElasticsearchUncaughtExceptionHandler\] fatal error in thread \[elasticsearch\[8mTx-ra\]\[search\]\[T#7\]\], exiting java.lang.OutOfMemoryError: Java heap space Please help me solve this …

---

## [How to proxy Kibana?](https://discuss.elastic.co/t/how-to-proxy-kibana/39738)

<div class="topic-metadata">

**Author:** [@AthenaInterns](https://discuss.elastic.co/u/AthenaInterns)\
**Replies:** 10\
**Last updated:** [March 7, 2016, 11:54am UTC](https://discuss.elastic.co/t/how-to-proxy-kibana/39738 "2016-03-07T11:54:54Z")

</div>

Hello. I'm having some(a lot of) difficulties, trying to setup a reverse proxy for Kibana. The general idea is that we want to set up a reverse proxy so select customers have access to Kibana. E.g. when customer A goes…

---

## [Failed to create S3 repository with ES 6.0](https://discuss.elastic.co/t/failed-to-create-s3-repository-with-es-6-0/108224)

<div class="topic-metadata">

**Author:** [@outcoldman](https://discuss.elastic.co/u/outcoldman)\
**Replies:** 10\
**Last updated:** [November 20, 2017, 2:16am UTC](https://discuss.elastic.co/t/failed-to-create-s3-repository-with-es-6-0/108224 "2017-11-20T02:16:24Z")

</div>

I used S3 repository with ES 5 fine without any issue. Used curl -s -XPUT 127.0.0.1:9200/\_snapshot/s3 -d "{ \\"type\\": \\"s3\\", \\"settings\\": { \\"bucket\\": \\"BUCKET\_NAME\\", …

---

## [Navigate from Dashboard 1 to Dashboard 2. Is it possible in Kibana?](https://discuss.elastic.co/t/navigate-from-dashboard-1-to-dashboard-2-is-it-possible-in-kibana/27171)

<div class="topic-metadata">

**Author:** [@rkhapre](https://discuss.elastic.co/u/rkhapre)\
**Replies:** 10\
**Last updated:** [August 1, 2016, 2:41pm UTC](https://discuss.elastic.co/t/navigate-from-dashboard-1-to-dashboard-2-is-it-possible-in-kibana/27171 "2016-08-01T14:41:00Z")

</div>

Hi All I have created 2 Dashboards using 2 different indexes Dashboard 1 : Have common data product family Dashboard 2 : Have common data product family Can i navigate from Dashboard 1 to Dashboard 2 to deep down my …

---

## [Scrolling performance](https://discuss.elastic.co/t/scrolling-performance/14560)

<div class="topic-metadata">

**Author:** [@Ivan\_Babrou](https://discuss.elastic.co/u/Ivan_Babrou)\
**Replies:** 18\
**Last updated:** [January 19, 2014, 8:29pm UTC](https://discuss.elastic.co/t/scrolling-performance/14560 "2014-01-19T20:29:01Z")

</div>

I've been trying to dump an index for further reindexing with different sharding settings, but found out that it's almost impossible with large dataset (50m, 7gb in my case). I scroll index with packs of 5000 item…

---

## [Kibana dashboard No result found](https://discuss.elastic.co/t/kibana-dashboard-no-result-found/232173)

<div class="topic-metadata">

**Author:** [@ethical20](https://discuss.elastic.co/u/ethical20)\
**Replies:** 14\
**Last updated:** [May 13, 2020, 5:46pm UTC](https://discuss.elastic.co/t/kibana-dashboard-no-result-found/232173 "2020-05-13T17:46:52Z")

</div>

Hi, I've installed elasticsearch, kibana, on server. Installed Filebeat on ubuntu client. For a reason (couldn't find logstash index, didn't knew it will have filebeat name, forgot about logstash for now) I deleted the…

---

## [Index not rolling over](https://discuss.elastic.co/t/index-not-rolling-over/264843)

<div class="topic-metadata">

**Author:** [@eco](https://discuss.elastic.co/u/eco)\
**Replies:** 15\
**Last updated:** [February 24, 2021, 10:30pm UTC](https://discuss.elastic.co/t/index-not-rolling-over/264843 "2021-02-24T22:30:24Z")

</div>

Hi, I have setup elasticsearch and created the following but the index will not roll over when a limit (size in this case) is reached. Policy { "policy" : { "phases" : { "hot" : { "min\_age" : "0ms"…

---

## [Cant Start Fresh Install of ES 5.0](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360)

<div class="topic-metadata">

**Author:** [@krmathieu](https://discuss.elastic.co/u/krmathieu)\
**Replies:** 11\
**Last updated:** [April 18, 2017, 3:55pm UTC](https://discuss.elastic.co/t/cant-start-fresh-install-of-es-5-0/64360 "2017-04-18T15:55:34Z")

</div>

I spun up a new VirtualBox VM and installed ES 5.0 from yum and when I try to start it I get an error stating: "OpenJDK Server VM Warning: If the number of processors is expected to increase from one, then you should c…

---

## [Elasticsearch snapshot/restore to s3](https://discuss.elastic.co/t/elasticsearch-snapshot-restore-to-s3/330517)

<div class="topic-metadata">

**Author:** [@sraman](https://discuss.elastic.co/u/sraman)\
**Replies:** 30\
**Last updated:** [May 17, 2023, 5:27am UTC](https://discuss.elastic.co/t/elasticsearch-snapshot-restore-to-s3/330517 "2023-05-17T05:27:31Z")

</div>

Hi, I have installed elasticsearch 8.6.2 & kibana 8.6.2 on the same standalone server for testing purpose. Planning to place the data snapshot to S3 and restore, but facing issues while creating the repository(it's not…

---

## [Attempted to send a bulk request to Elasticsearch configured at](https://discuss.elastic.co/t/attempted-to-send-a-bulk-request-to-elasticsearch-configured-at/57671)

<div class="topic-metadata">

**Author:** [@bujar\_metaj](https://discuss.elastic.co/u/bujar_metaj)\
**Replies:** 11\
**Last updated:** [August 10, 2016, 12:31pm UTC](https://discuss.elastic.co/t/attempted-to-send-a-bulk-request-to-elasticsearch-configured-at/57671 "2016-08-10T12:31:11Z")

</div>

hi I have an issue with logstash -\>searchguard (elasticserach) ? works fine without searchguard output { elasticsearch { manage\_template =\> false index =\> "%{\[@metadata\]\[beat\]}-%{+YYYY.MM.dd}" doc…

---

## [Mapper parsing exception - failed to parse field](https://discuss.elastic.co/t/mapper-parsing-exception-failed-to-parse-field/302040)

<div class="topic-metadata">

**Author:** [@Robert777](https://discuss.elastic.co/u/Robert777)\
**Replies:** 9\
**Last updated:** [April 10, 2022, 9:44am UTC](https://discuss.elastic.co/t/mapper-parsing-exception-failed-to-parse-field/302040 "2022-04-10T09:44:23Z")

</div>

Hello, could you please advise what this problem is related to and how to solve it? Below is a snippet of the warning I am getting from logstash. A little situational description, we have a large number of microservice…

[Previous page](https://discuss.elastic.co/top.md?page=31&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=33&per_page=50&period=all)
