# Top

**URL:** https://discuss.elastic.co/top.md?page=33&period=all

[Latest](https://discuss.elastic.co/latest.md) · [Categories](https://discuss.elastic.co/categories.md) · [Tags](https://discuss.elastic.co/tags.md)

**Page:** 34

---

## [How to install ELK scalable stack?](https://discuss.elastic.co/t/how-to-install-elk-scalable-stack/68602)

<div class="topic-metadata">

**Author:** [@wrkilu](https://discuss.elastic.co/u/wrkilu)\
**Replies:** 19\
**Last updated:** [December 16, 2016, 1:20pm UTC](https://discuss.elastic.co/t/how-to-install-elk-scalable-stack/68602 "2016-12-16T13:20:30Z")

</div>

Hi, I need to deploy scalable ELK stack (with further adding nodes), and I didn't find any complete tutorial for this - thats why I'm kindly asking you for help here. I saw some partial descriptions how to do that so I…

---

## [Logstash filter mutate remove\_field inside of an array](https://discuss.elastic.co/t/logstash-filter-mutate-remove-field-inside-of-an-array/168503)

<div class="topic-metadata">

**Author:** [@SuperTomcat1](https://discuss.elastic.co/u/SuperTomcat1)\
**Replies:** 10\
**Last updated:** [February 17, 2019, 1:05am UTC](https://discuss.elastic.co/t/logstash-filter-mutate-remove-field-inside-of-an-array/168503 "2019-02-17T01:05:17Z")

</div>

so i was trying to filter out all references to "volumes.lun-mapping-list" in my json http\_poller input. so this field repeats multiple times but the data is not valuable and its an array inside of the an array so ES do…

---

## [Issue with date format change while reindexing](https://discuss.elastic.co/t/issue-with-date-format-change-while-reindexing/169590)

<div class="topic-metadata">

**Author:** [@meena](https://discuss.elastic.co/u/meena)\
**Replies:** 11\
**Last updated:** [February 28, 2019, 9:12am UTC](https://discuss.elastic.co/t/issue-with-date-format-change-while-reindexing/169590 "2019-02-28T09:12:04Z")

</div>

Hi There, Am new to elastic search and getting the following error while reindexing my data to a new index. I have a change in the format of date field from "yyyy-mm-ddThh:mm:ss.SSSZ" to "yyyy-mm-dd". Could you please h…

---

## [Too many opened files](https://discuss.elastic.co/t/too-many-opened-files/80958)

<div class="topic-metadata">

**Author:** [@sunilmchaudhari](https://discuss.elastic.co/u/sunilmchaudhari)\
**Replies:** 14\
**Last updated:** [April 4, 2017, 7:36am UTC](https://discuss.elastic.co/t/too-many-opened-files/80958 "2017-04-04T07:36:46Z")

</div>

Hi, I have too many files error issue in ES cluster. We are getting below error. 2017-03-30 13:51:34,079\]\[WARN \]\[cluster.action.shard \] \[data-node-1\] \[system1-2017.03.30\]\[2\] received shard failed for \[system1-2017…

---

## [Elasticsearch upgrade from 1.7.1 to 2.3.2 then create index very slow](https://discuss.elastic.co/t/elasticsearch-upgrade-from-1-7-1-to-2-3-2-then-create-index-very-slow/51655)

<div class="topic-metadata">

**Author:** [@tingking23](https://discuss.elastic.co/u/tingking23)\
**Replies:** 35\
**Last updated:** [June 13, 2016, 2:59am UTC](https://discuss.elastic.co/t/elasticsearch-upgrade-from-1-7-1-to-2-3-2-then-create-index-very-slow/51655 "2016-06-13T02:59:22Z")

</div>

when i use the elasticsearch 1.7.1 the java job finished ablout one hour; then i upgreade es to 2.3.2 the java job finished more than three hours. Anyone can help me, thanks very much.(i used the bulk) the java code o…

---

## [How to manage multiline events based on a random field](https://discuss.elastic.co/t/how-to-manage-multiline-events-based-on-a-random-field/43519)

<div class="topic-metadata">

**Author:** [@jpry](https://discuss.elastic.co/u/jpry)\
**Replies:** 23\
**Last updated:** [May 24, 2016, 8:33am UTC](https://discuss.elastic.co/t/how-to-manage-multiline-events-based-on-a-random-field/43519 "2016-05-24T08:33:00Z")

</div>

Hello all, I've been facing a problem related to multiline events lately, and I am needing a little bit of your help for this. My syslog server is sending multi-line events. One single event gathers several lines, and…

---

## [Creating a master node and data node](https://discuss.elastic.co/t/creating-a-master-node-and-data-node/79701)

<div class="topic-metadata">

**Author:** [@tomer](https://discuss.elastic.co/u/tomer)\
**Replies:** 10\
**Last updated:** [March 23, 2017, 12:36pm UTC](https://discuss.elastic.co/t/creating-a-master-node-and-data-node/79701 "2017-03-23T12:36:35Z")

</div>

Hi, Reading the manual I am still uncertain how to make a node as master node and how to make a node as data node (here is the manual I used) In the manual It is written that: To create a standalone master-eligible …

---

## [Kibana exportについて](https://discuss.elastic.co/t/kibana-export/89641)

<div class="topic-metadata">

**Author:** [@kudo](https://discuss.elastic.co/u/kudo)\
**Replies:** 18\
**Last updated:** [August 14, 2017, 1:10am UTC](https://discuss.elastic.co/t/kibana-export/89641 "2017-08-14T01:10:20Z")

</div>

\[Management\] - \[Saved Objects\] を開き、\[Export Everything\]ボタンをクリックすると、 Saved Objects: Not Found となってしまい、Exportが出来ない状態となっております。 Dashboardsとかで、選択してExportは問題なく出来るのですが、上記の\[Export Everything\]が 出来ない状態となっております。 kibana or El…

---

## [Mapping Hive Table Fields to Nested Fields in ElasticSearch](https://discuss.elastic.co/t/mapping-hive-table-fields-to-nested-fields-in-elasticsearch/47389)

<div class="topic-metadata">

**Author:** [@gowthamsadasivam](https://discuss.elastic.co/u/gowthamsadasivam)\
**Replies:** 16\
**Last updated:** [June 30, 2017, 9:35am UTC](https://discuss.elastic.co/t/mapping-hive-table-fields-to-nested-fields-in-elasticsearch/47389 "2017-06-30T09:35:10Z")

</div>

I'm trying to map a field from Hive Table to a Nested Elastic Search Field. Not sure how to achieve that. Here is what my configuration looks like, (1) HIVE TABLE WITH ES SerDe: CREATE EXTERNAL TABLE logs ( id string, …

---

## [Kibana 8.11.0 Failed To Start (Exit Code 1)](https://discuss.elastic.co/t/kibana-8-11-0-failed-to-start-exit-code-1/346893)

<div class="topic-metadata">

**Author:** [@Ethan777100](https://discuss.elastic.co/u/Ethan777100)\
**Replies:** 53\
**Last updated:** [November 13, 2023, 4:53pm UTC](https://discuss.elastic.co/t/kibana-8-11-0-failed-to-start-exit-code-1/346893 "2023-11-13T16:53:10Z")

</div>

I am running a ELK Stack in a local hosted Docker Container that comprises of sub containers of Elasticsearch, Kibana and Logstash service. Setup / config wise, I followed Ali Younges youtube video closely to setup. …

---

## [Elasticsearch installation](https://discuss.elastic.co/t/elasticsearch-installation/285415)

<div class="topic-metadata">

**Author:** [@eugestel](https://discuss.elastic.co/u/eugestel)\
**Replies:** 45\
**Last updated:** [October 8, 2021, 2:08pm UTC](https://discuss.elastic.co/t/elasticsearch-installation/285415 "2021-10-08T14:08:19Z")

</div>

Requesting for help with Elasticsearch. I installed Elasticsearch in my ubuntu server 20.04 but unable to get it to work. The command : systemctl status Elasticsearch.service yielded the following: $ systemctl status…

---

## [Logstash output custom template](https://discuss.elastic.co/t/logstash-output-custom-template/251664)

<div class="topic-metadata">

**Author:** [@venku](https://discuss.elastic.co/u/venku)\
**Replies:** 9\
**Last updated:** [October 12, 2020, 7:20pm UTC](https://discuss.elastic.co/t/logstash-output-custom-template/251664 "2020-10-12T19:20:10Z")

</div>

Hi, I am new to ELK stack. This is my set so far for sending application logs : filebeat -\> redis(dockers) -\> logstash(dockers) -\> ES. My Question is what is the the correct way to setup custom index in logstash output? …

---

## [Dangling Index Imported Leads to Unassigned Shards](https://discuss.elastic.co/t/dangling-index-imported-leads-to-unassigned-shards/101880)

<div class="topic-metadata">

**Author:** [@corona](https://discuss.elastic.co/u/corona)\
**Replies:** 18\
**Last updated:** [October 10, 2017, 6:19pm UTC](https://discuss.elastic.co/t/dangling-index-imported-leads-to-unassigned-shards/101880 "2017-10-10T18:19:44Z")

</div>

Hello, I'm seeing around 1380 shards unassigned after a recent restart of a node in the cluster. This cluster has 20 nodes with 49122 shards with around 17TB of data. We're currently running version 2.4.0. With one node…

---

## [Setting Alerting configuration on Kibana 7.9](https://discuss.elastic.co/t/setting-alerting-configuration-on-kibana-7-9/250530)

<div class="topic-metadata">

**Author:** [@ushma.shah](https://discuss.elastic.co/u/ushma.shah)\
**Replies:** 11\
**Last updated:** [October 2, 2020, 2:53pm UTC](https://discuss.elastic.co/t/setting-alerting-configuration-on-kibana-7-9/250530 "2020-10-02T14:53:38Z")

</div>

I am using basic license for elastic search with on-premises deployment without security. I want to get started with Alerting and Actions in Kibana 7.9. I have set xpack.encryptedSavedObjects.encryptionKey value as pe…

---

## [Logstash service failure ''Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError"](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728)

<div class="topic-metadata">

**Author:** [@soufiane\_adn](https://discuss.elastic.co/u/soufiane_adn)\
**Replies:** 9\
**Last updated:** [May 15, 2020, 1:11pm UTC](https://discuss.elastic.co/t/logstash-service-failure-failed-to-execute-action-action-logstash-create-pipeline-id-main-exception-logstash-configurationerror/232728 "2020-05-15T13:11:38Z")

</div>

Hello, im trying to run logstash as service by systemctl start logstash but i found the following error on log file \[2020-05-15T00:12:10,751\]\[ERROR\]\[logstash.agent \] Failed to execute action {:action=\>LogStas…

---

## [Kibana, Logstash - Couldn't find any Elasticsearch data](https://discuss.elastic.co/t/kibana-logstash-couldnt-find-any-elasticsearch-data/125913)

<div class="topic-metadata">

**Author:** [@Chips](https://discuss.elastic.co/u/Chips)\
**Replies:** 10\
**Last updated:** [May 3, 2018, 10:06pm UTC](https://discuss.elastic.co/t/kibana-logstash-couldnt-find-any-elasticsearch-data/125913 "2018-05-03T22:06:37Z")

</div>

Kibana on the control tab appears an inscription "Couldn't find any Elasticsearch data". \[%D0%A1%D0%BD%D0%B8%D0%BC%D0%BE%D0%BA%20%D1%8D%D0%BA%D1%80%D0%B0%D0%BD%D0%B0%20%D0%BE%D1%82%202018-03-28%2015-40-14\] I decided to…

---

## [ES&Lucene 32GB heap myth or fact?](https://discuss.elastic.co/t/es-lucene-32gb-heap-myth-or-fact/22920)

<div class="topic-metadata">

**Author:** [@Pawel\_Rog](https://discuss.elastic.co/u/Pawel_Rog)\
**Replies:** 9\
**Last updated:** [March 30, 2015, 9:43am UTC](https://discuss.elastic.co/t/es-lucene-32gb-heap-myth-or-fact/22920 "2015-03-30T09:43:47Z")

</div>

Hi everyone, Every time we touch the size of JVM heap for Elasticsearch we can meet indisputable statement "don't let the heap to be bigger than 32GB - this is a magical line". Of course making heap bigger than 32G me…

---

## [ReadTimeout](https://discuss.elastic.co/t/readtimeout/136771)

<div class="topic-metadata">

**Author:** [@adwaitjoshi](https://discuss.elastic.co/u/adwaitjoshi)\
**Replies:** 23\
**Last updated:** [July 14, 2018, 12:59am UTC](https://discuss.elastic.co/t/readtimeout/136771 "2018-07-14T00:59:42Z")

</div>

We are currently sending data to elastic search using a python plugin and suddenly started getting read time out errors on elastic. So i increased the read timeout to 60 seconds. The process ran for 6 hours and failed wi…

---

## [Deleting and creating indexes over time kills index performance](https://discuss.elastic.co/t/deleting-and-creating-indexes-over-time-kills-index-performance/38737)

<div class="topic-metadata">

**Author:** [@haldrich](https://discuss.elastic.co/u/haldrich)\
**Replies:** 23\
**Last updated:** [January 29, 2016, 1:21am UTC](https://discuss.elastic.co/t/deleting-and-creating-indexes-over-time-kills-index-performance/38737 "2016-01-29T01:21:06Z")

</div>

We are using ES 2.1.0, quad core virtual machines, 12 GB ram, SAN disks. We have a process where we will create a new index and when it is done point an alias at it. Then later, we have to make a new index and again w…

---

## [Search not working with mapper-attachment plugin](https://discuss.elastic.co/t/search-not-working-with-mapper-attachment-plugin/28013)

<div class="topic-metadata">

**Author:** [@Sahas\_Sahas](https://discuss.elastic.co/u/Sahas_Sahas)\
**Replies:** 19\
**Last updated:** [August 26, 2015, 1:45pm UTC](https://discuss.elastic.co/t/search-not-working-with-mapper-attachment-plugin/28013 "2015-08-26T13:45:31Z")

</div>

I am using ES 1.7 and have installed mapper-attachment plugin version 2.7.0. I am following the steps from the below URL to understand the basic functionality. http://www.elasticsearch.cn/tutorials/2011/07/18/attachmen…

---

## [Kibana server is not ready yet](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet/322684)

<div class="topic-metadata">

**Author:** [@magen\_lahat](https://discuss.elastic.co/u/magen_lahat)\
**Replies:** 31\
**Last updated:** [February 2, 2023, 9:16pm UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet/322684 "2023-02-02T21:16:29Z")

</div>

hello, im a new user to elasticsearch and hoping to explore it further for my project, So I just installed elasticsearch and kibana on my ubuntu and im getting "Kibana server is not ready yet." after runnig http://loca…

---

## [Create Index Lifecycle Policies to existing index](https://discuss.elastic.co/t/create-index-lifecycle-policies-to-existing-index/290983)

<div class="topic-metadata">

**Author:** [@Aviel\_Bashari](https://discuss.elastic.co/u/Aviel_Bashari)\
**Replies:** 17\
**Last updated:** [December 15, 2021, 3:08pm UTC](https://discuss.elastic.co/t/create-index-lifecycle-policies-to-existing-index/290983 "2021-12-15T15:08:17Z")

</div>

Hi, im trying to add 'Index Lifecycle Policies' to my existing index. my steps: Index management --\> choose my index --\> add lifecycle policy --\> slect logs but i got 'Policy logs is configured for rollover, but ind…

---

## [Winlogbeats not working with SSL configuration to Logstash](https://discuss.elastic.co/t/winlogbeats-not-working-with-ssl-configuration-to-logstash/126502)

<div class="topic-metadata">

**Author:** [@patricktula](https://discuss.elastic.co/u/patricktula)\
**Replies:** 17\
**Last updated:** [April 4, 2018, 3:59am UTC](https://discuss.elastic.co/t/winlogbeats-not-working-with-ssl-configuration-to-logstash/126502 "2018-04-04T03:59:55Z")

</div>

Hi, I need some assistance with my Winlogbeats SSL configuration. My winlogbeats machine sending logs yml config: winlogbeat.event\_logs: - name: Application ignore\_older: 72h - name: Security - name: System …

---

## [Count of docs after \_reindex'ing higher than before](https://discuss.elastic.co/t/count-of-docs-after-reindexing-higher-than-before/116015)

<div class="topic-metadata">

**Author:** [@Kornelia\_Watson](https://discuss.elastic.co/u/Kornelia_Watson)\
**Replies:** 40\
**Last updated:** [January 18, 2018, 3:20pm UTC](https://discuss.elastic.co/t/count-of-docs-after-reindexing-higher-than-before/116015 "2018-01-18T15:20:07Z")

</div>

Hello, I've recently had to reindex all docs due multi type mappings being deprecated. There is one observation that I can't explain... After reindexing (via \_reindex API) I found that new index has more documents tha…

---

## [Unable to start Filebeat 7.9.2 , Failed to start Filebeat sends log files to Logstash or directly to Elasticsearch](https://discuss.elastic.co/t/unable-to-start-filebeat-7-9-2-failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/252928)

<div class="topic-metadata">

**Author:** [@a\_ssuresh](https://discuss.elastic.co/u/a_ssuresh)\
**Replies:** 10\
**Last updated:** [October 28, 2020, 6:58am UTC](https://discuss.elastic.co/t/unable-to-start-filebeat-7-9-2-failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/252928 "2020-10-28T06:58:59Z")

</div>

Hi , I just installed ELK on a server, filebeat agent (ver 7.9.2) on another, OS- CentOS 7 Started elastic, logstash & kibana on a server, but unable to start filebeat agent from another server, where im trying to s…

---

## [Limit of total fields \[1000\] exceeded](https://discuss.elastic.co/t/limit-of-total-fields-1000-exceeded/254747)

<div class="topic-metadata">

**Author:** [@ahmedbrandver](https://discuss.elastic.co/u/ahmedbrandver)\
**Replies:** 17\
**Last updated:** [November 11, 2020, 4:26am UTC](https://discuss.elastic.co/t/limit-of-total-fields-1000-exceeded/254747 "2020-11-11T04:26:36Z")

</div>

I am getting Limit of total fields \[1000\] in index \[products\] has been exceeded. Although total number of properties that is added dynamically is 499. Every where I search is asking me to increase total\_fields length sin…

---

## [Vega Help Infinite extent for field "FIELDNAME": \[Infinity, -Infinity\]](https://discuss.elastic.co/t/vega-help-infinite-extent-for-field-fieldname-infinity-infinity/277485)

<div class="topic-metadata">

**Author:** [@dandcp](https://discuss.elastic.co/u/dandcp)\
**Replies:** 10\
**Last updated:** [July 13, 2021, 4:20pm UTC](https://discuss.elastic.co/t/vega-help-infinite-extent-for-field-fieldname-infinity-infinity/277485 "2021-07-13T16:20:45Z")

</div>

I'm by no means a coder and am trying to do something that I think should be relatively simple. I have an index that has the following fields (plus others): \_source.name", "\_source\['it\_debt\_applies'\]", "\_source\['it\_d…

---

## [Shard relocation storms when cluster disk low](https://discuss.elastic.co/t/shard-relocation-storms-when-cluster-disk-low/136385)

<div class="topic-metadata">

**Author:** [@kenfox](https://discuss.elastic.co/u/kenfox)\
**Replies:** 10\
**Last updated:** [June 26, 2018, 4:01pm UTC](https://discuss.elastic.co/t/shard-relocation-storms-when-cluster-disk-low/136385 "2018-06-26T16:01:07Z")

</div>

We have a 27 data node ES 5.5 cluster with 1.7TB of disk per node. The ES team has created an amazingly easy to use and high performance system. Our cluster normally works beautifully. It ingests over a billion logs per …

---

## [Kibana throwing error "{"statusCode":503,"error":"Service Unavailable","message":"Service Unavailable"}"](https://discuss.elastic.co/t/kibana-throwing-error-statuscode-503-error-service-unavailable-message-service-unavailable/263844)

<div class="topic-metadata">

**Author:** [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)\
**Replies:** 9\
**Last updated:** [February 11, 2021, 4:22pm UTC](https://discuss.elastic.co/t/kibana-throwing-error-statuscode-503-error-service-unavailable-message-service-unavailable/263844 "2021-02-11T16:22:35Z")

</div>

Hi Team, Im using kibana version 6.4.0 and when ever i try to save or create new index im getting 503 error. All the elasticsearch service are up and running. My setup is 3 Master and 3 Data and 1 coordinate Node. My…

---

## [Reindex from Remote not working](https://discuss.elastic.co/t/reindex-from-remote-not-working/69625)

<div class="topic-metadata">

**Author:** [@Thomas\_Doman](https://discuss.elastic.co/u/Thomas_Doman)\
**Replies:** 25\
**Last updated:** [January 16, 2017, 6:56pm UTC](https://discuss.elastic.co/t/reindex-from-remote-not-working/69625 "2017-01-16T18:56:43Z")

</div>

I'm investigating upgrading from our ES 1.7.5 system (running on Windows) to ES 5.1.1. I'm doing some testing with Reindex from Remote to see if I can simply bring my current cluster's data over to a 5.x system. Howeve…

---

## [Cisco ASA Patterns in Logstash 1.5.1](https://discuss.elastic.co/t/cisco-asa-patterns-in-logstash-1-5-1/24661)

<div class="topic-metadata">

**Author:** [@DavidSims](https://discuss.elastic.co/u/DavidSims)\
**Replies:** 9\
**Last updated:** [June 13, 2016, 11:25am UTC](https://discuss.elastic.co/t/cisco-asa-patterns-in-logstash-1-5-1/24661 "2016-06-13T11:25:22Z")

</div>

I have yet to get logstash to parse Cisco ASA logs correctly. I have tried every tutorial a could find and I ALWAYS get \_grokparsefailure. I stripped it all the way down and it seems to hate the patterns. filter { g…

---

## [Installed Elastic-Agent cannot be removed](https://discuss.elastic.co/t/installed-elastic-agent-cannot-be-removed/350473)

<div class="topic-metadata">

**Author:** [@ghuie](https://discuss.elastic.co/u/ghuie)\
**Replies:** 9\
**Last updated:** [January 5, 2024, 6:50pm UTC](https://discuss.elastic.co/t/installed-elastic-agent-cannot-be-removed/350473 "2024-01-05T18:50:54Z")

</div>

So, I have a self-hosted ELK Stack (v. 8.11) in which I've been working for a few weeks. I've configured the certificates using the elasticsearch-certutil util and Elastic + Kibana are working fine. After that I wanted…

---

## [Modifying the Y-axis?](https://discuss.elastic.co/t/modifying-the-y-axis/40444)

<div class="topic-metadata">

**Author:** [@Thien\_Tin\_Lam](https://discuss.elastic.co/u/Thien_Tin_Lam)\
**Replies:** 9\
**Last updated:** [February 12, 2016, 10:45pm UTC](https://discuss.elastic.co/t/modifying-the-y-axis/40444 "2016-02-12T22:45:08Z")

</div>

Hello Recently I tried to do a term search but I want the y-axis to count all the term frequencies in the whole index is this possible ? because I can't modify the x-axis Kind regards T

---

## [The detail meaning of esrally Final score?](https://discuss.elastic.co/t/the-detail-meaning-of-esrally-final-score/57454)

<div class="topic-metadata">

**Author:** [@laoyang360](https://discuss.elastic.co/u/laoyang360)\
**Replies:** 16\
**Last updated:** [August 12, 2016, 1:35pm UTC](https://discuss.elastic.co/t/the-detail-meaning-of-esrally-final-score/57454 "2016-08-12T13:35:34Z")

</div>

Now I running esrally 0.3.2 successfully. And I also get the Final score. I have problem below: Firstly: I think the score contain too many information, But as user I just need the most useful performance information of …

---

## [Compiling elasticsearch for ARM](https://discuss.elastic.co/t/compiling-elasticsearch-for-arm/145553)

<div class="topic-metadata">

**Author:** [@francisaugusto](https://discuss.elastic.co/u/francisaugusto)\
**Replies:** 9\
**Last updated:** [September 4, 2018, 3:21am UTC](https://discuss.elastic.co/t/compiling-elasticsearch-for-arm/145553 "2018-09-04T03:21:51Z")

</div>

Hi, I want to use ELK on an ARM platform running Ubuntu. I started by compiling elasticsearch as instructed here: https://github.com/elastic/elasticsearch After a long time compilation (./gradlew assemble), I didn't ge…

---

## [The filebeat dashboard : No results found](https://discuss.elastic.co/t/the-filebeat-dashboard-no-results-found/89479)

<div class="topic-metadata">

**Author:** [@Amna\_sayed\_ali](https://discuss.elastic.co/u/Amna_sayed_ali)\
**Replies:** 13\
**Last updated:** [June 26, 2017, 10:59am UTC](https://discuss.elastic.co/t/the-filebeat-dashboard-no-results-found/89479 "2017-06-26T10:59:56Z")

</div>

Hello, i have 2 Servers (one is ELK and other is filebeat ) both are Centos 7. i have installed ELK 5.4 "tar installation" on 1st server and filebeat 5.4 "tar installation" on 2nd server. i can see the log index in my…

---

## [Error - XPack Class not found Exception in java](https://discuss.elastic.co/t/error-xpack-class-not-found-exception-in-java/65168)

<div class="topic-metadata">

**Author:** [@wow148](https://discuss.elastic.co/u/wow148)\
**Replies:** 13\
**Last updated:** [December 14, 2016, 8:35am UTC](https://discuss.elastic.co/t/error-xpack-class-not-found-exception-in-java/65168 "2016-12-14T08:35:26Z")

</div>

I got this error please help. Exception in thread "main" java.lang.NoClassDefFoundError: org/elasticsearch/xpack/XPackPlugin at org.elasticsearch.xpack.client.PreBuiltXPackTransportClient.(PreBuiltXPackTransportCli…

---

## [Failed to delete index](https://discuss.elastic.co/t/failed-to-delete-index/88403)

<div class="topic-metadata">

**Author:** [@qin](https://discuss.elastic.co/u/qin)\
**Replies:** 15\
**Last updated:** [June 7, 2017, 3:42am UTC](https://discuss.elastic.co/t/failed-to-delete-index/88403 "2017-06-07T03:42:47Z")

</div>

when in a node delete index, this index and from other nodes synchronization curl -XDELETE http://192.168.31.25:9292/logstash-task-33091-20170531

---

## [Multiline graph over time](https://discuss.elastic.co/t/multiline-graph-over-time/108452)

<div class="topic-metadata">

**Author:** [@joconner](https://discuss.elastic.co/u/joconner)\
**Replies:** 9\
**Last updated:** [November 23, 2017, 12:17am UTC](https://discuss.elastic.co/t/multiline-graph-over-time/108452 "2017-11-23T00:17:39Z")

</div>

I have the following pertinent document properties: ... "properties": { "timestamp": { "type": "date"}, "event": { "type": "text"}, // various \*\_BEGIN/END events "resource\_id": {"type": "text…

---

## [Coerce long to double not working](https://discuss.elastic.co/t/coerce-long-to-double-not-working/36882)

<div class="topic-metadata">

**Author:** [@Benjamin\_Gathmann](https://discuss.elastic.co/u/Benjamin_Gathmann)\
**Replies:** 13\
**Last updated:** [December 11, 2015, 4:19pm UTC](https://discuss.elastic.co/t/coerce-long-to-double-not-working/36882 "2015-12-11T16:19:35Z")

</div>

Hi there, I have problems with importing data because some of my values do not always have the same type. I expected that this would be no big deal due to Elasticsearch's index.mapping.coerce feature. So I went ahead an…

---

## [Field \\"message\\" was indexed without position data; cannot run PhraseQuery](https://discuss.elastic.co/t/field-message-was-indexed-without-position-data-cannot-run-phrasequery/33901)

<div class="topic-metadata">

**Author:** [@PavelPolyakov](https://discuss.elastic.co/u/PavelPolyakov)\
**Replies:** 9\
**Last updated:** [November 8, 2015, 1:15pm UTC](https://discuss.elastic.co/t/field-message-was-indexed-without-position-data-cannot-run-phrasequery/33901 "2015-11-08T13:15:01Z")

</div>

Hi, I have an ELK configuration, which works pretty good, however, when I do some queries like this: message:"text with spaces" I receive the next error: field \\"message\\" was indexed without position data; ca…

---

## [Apply data streams, ILM, Index template through logstash](https://discuss.elastic.co/t/apply-data-streams-ilm-index-template-through-logstash/282666)

<div class="topic-metadata">

**Author:** [@prathamesh7](https://discuss.elastic.co/u/prathamesh7)\
**Replies:** 9\
**Last updated:** [August 30, 2021, 5:52am UTC](https://discuss.elastic.co/t/apply-data-streams-ilm-index-template-through-logstash/282666 "2021-08-30T05:52:51Z")

</div>

Hi Team, I am deploying elasticsearch cluster with latest version i.e 7.14 through automation tool. The current config (v 7.4) is creating daily indices and it is not having data\_stream, ILM policy, index\_template etc.. …

---

## [Logstash memory consumption and swap memory issues](https://discuss.elastic.co/t/logstash-memory-consumption-and-swap-memory-issues/329456)

<div class="topic-metadata">

**Author:** [@Ofek\_Agmon](https://discuss.elastic.co/u/Ofek_Agmon)\
**Replies:** 12\
**Last updated:** [April 9, 2023, 7:26am UTC](https://discuss.elastic.co/t/logstash-memory-consumption-and-swap-memory-issues/329456 "2023-04-09T07:26:56Z")

</div>

Hi all, I've been using logstash version 7.17.8 in docker, and for a while now trying to minimize its memory usage and swap usage, without much success. I have 2 file inputs and one gelf input, and 2 small filters. I …

---

## [Inconsistent results while querying on a index](https://discuss.elastic.co/t/inconsistent-results-while-querying-on-a-index/27636)

<div class="topic-metadata">

**Author:** [@RenuGuru1](https://discuss.elastic.co/u/RenuGuru1)\
**Replies:** 9\
**Last updated:** [August 26, 2015, 1:33pm UTC](https://discuss.elastic.co/t/inconsistent-results-while-querying-on-a-index/27636 "2015-08-26T13:33:13Z")

</div>

We are using elasticsearch 1.6.0 with 6 nodes. We are getting inconsistent results while searching when the same query is requested concurrently, the order of results are changing. Results are entirely different for…

---

## [Elasticsearch index health turned Red!](https://discuss.elastic.co/t/elasticsearch-index-health-turned-red/83805)

<div class="topic-metadata">

**Author:** [@Abhijit\_Paul](https://discuss.elastic.co/u/Abhijit_Paul)\
**Replies:** 12\
**Last updated:** [May 3, 2017, 2:42pm UTC](https://discuss.elastic.co/t/elasticsearch-index-health-turned-red/83805 "2017-05-03T14:42:40Z")

</div>

Hi All, After index got created in elasticsearch few hours after health of that index turned Red !!! During my Observation few suspected items are: item1: Shard Allocation Failed item2: org.apache.lucene.index.Corrup…

---

## [Logs Do Not Appear In APM, Although Correlation Info Is Present](https://discuss.elastic.co/t/logs-do-not-appear-in-apm-although-correlation-info-is-present/289720)

<div class="topic-metadata">

**Author:** [@Brandon\_Liles](https://discuss.elastic.co/u/Brandon_Liles)\
**Replies:** 13\
**Last updated:** [December 8, 2021, 1:55pm UTC](https://discuss.elastic.co/t/logs-do-not-appear-in-apm-although-correlation-info-is-present/289720 "2021-12-08T13:55:14Z")

</div>

Using version 7.15.2 of Elasticsearch, Kibana and APM. I have APM configured and can see transactions/traces. I have Serilog configured with the Elasticsearch sink and I am using the EcsTextFormatter. When I go to Logs \>…

---

## [Elasticsearch refuses to run](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945)

<div class="topic-metadata">

**Author:** [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Replies:** 21\
**Last updated:** [September 20, 2018, 12:34pm UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945 "2018-09-20T12:34:32Z")

</div>

I've installed the .tar.gz package on a Rhel7.5 instance on Amazon Web Services with a RAM of 1GB and volume of 10GB but when I run it with this command "./bin/elasticsearch" I get this error despite reducing the heap si…

---

## [SSL Certificate issues](https://discuss.elastic.co/t/ssl-certificate-issues/347390)

<div class="topic-metadata">

**Author:** [@nvanalphen](https://discuss.elastic.co/u/nvanalphen)\
**Replies:** 12\
**Last updated:** [November 23, 2023, 8:14am UTC](https://discuss.elastic.co/t/ssl-certificate-issues/347390 "2023-11-23T08:14:56Z")

</div>

I am trying to set up a server to evaluate and determine if/how we can use this solution. Unfortunately I am going mad trying to set it up. I have been trying, searching, reading and trying again for over a week now and…

---

## [Failed to load settings from \[elasticsearch.yml\]](https://discuss.elastic.co/t/failed-to-load-settings-from-elasticsearch-yml/245391)

<div class="topic-metadata">

**Author:** [@Kailas](https://discuss.elastic.co/u/Kailas)\
**Replies:** 9\
**Last updated:** [August 20, 2020, 11:43am UTC](https://discuss.elastic.co/t/failed-to-load-settings-from-elasticsearch-yml/245391 "2020-08-20T11:43:29Z")

</div>

I am getting the following exception . I have followed this link https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-advanced-node-scheduling.html#k8s-define-elasticsearch-nodes-roles root@k8smaster elastic\]# ku l…

---

## [Insert longitude and latitude to logstash config file](https://discuss.elastic.co/t/insert-longitude-and-latitude-to-logstash-config-file/107615)

<div class="topic-metadata">

**Author:** [@ahmedcharef](https://discuss.elastic.co/u/ahmedcharef)\
**Replies:** 21\
**Last updated:** [November 20, 2017, 6:41am UTC](https://discuss.elastic.co/t/insert-longitude-and-latitude-to-logstash-config-file/107615 "2017-11-20T06:41:06Z")

</div>

Hello, I have CSV file with two geolocation columns: cell\_easting cell\_northing 26.1541 66.48703 26.161 66.49312 26.166 66.49182 I would like to insert them as a markers into a map Here my config file: \> input …

[Previous page](https://discuss.elastic.co/top.md?page=32&per_page=50&period=all)

[Next page](https://discuss.elastic.co/top.md?page=34&per_page=50&period=all)
